Search found 5 matches

by dustyFrog
Thu Feb 27, 2020 13:59
Forum: Mod Releases
Topic: [Mod] Mobs Redo [1.52] [mobs]
Replies: 1979
Views: 360888

Re: [Mod] Mobs Redo [1.50] [mobs]

@TenPlus1 I might have solved the problem. I did not notice that in my local git repo the Minetest master branch was active instead of the latest stable release. I have reinstalled Minetest. Right after having loaded my savegame I noticed a sheep jumping within a tree. I went closer to inspect the s...
by dustyFrog
Thu Feb 27, 2020 13:26
Forum: Mod Releases
Topic: [Mod] Mobs Redo [1.52] [mobs]
Replies: 1979
Views: 360888

Re: [Mod] Mobs Redo [1.50] [mobs]

@TenPlus1 setvelocity is just an alias for set_velocity - understood AsyncErr: ServerThread::run Lua: Runtime error from mod 'default' in callback luaentity_Step(): /home/dustyfrog/.minetest/mods/mobs/api.lua:239: attempt to index a nil value stack traceback: /home/dustyfrog/.minetest/mods/mobs/api....
by dustyFrog
Thu Feb 27, 2020 08:33
Forum: Mod Releases
Topic: [Mod] Mobs Redo [1.52] [mobs]
Replies: 1979
Views: 360888

Re: [Mod] Mobs Redo [1.50] [mobs]

@TenPlus1 I do not know what is happening. Due to the error message I suspect that an animal (I don't know where) is trying to jump, which somehow triggers the crash. I have checked line 993 (former 989) in the updated mobs/api.lua: and self:get_velocity() > 0.5 According to Minetest's lua_api.txt t...
by dustyFrog
Wed Feb 26, 2020 22:01
Forum: Mod Releases
Topic: [Mod] Mobs Redo [1.52] [mobs]
Replies: 1979
Views: 360888

Re: [Mod] Mobs Redo [1.50] [mobs]

@TenPlus1
Thank you for your quick reply. I have just downloaded and tested mobs_redo including your latest commit 62bd960e38. Unfortunately, the game crashed again with the 2nd error message from my previous post.
by dustyFrog
Wed Feb 26, 2020 10:15
Forum: Mod Releases
Topic: [Mod] Mobs Redo [1.52] [mobs]
Replies: 1979
Views: 360888

Re: [Mod] Mobs Redo [1.50] [mobs]

I am experiencing random crashes from the mobs api on Minetest 5.2.0-dev-e8a8185 (Linux) AsyncErr: ServerThread::run Lua: Runtime error from mod 'default' in callback luaentity_Step(): /home/dustyfrog/.minetest/mods/mobs/api.lua:251: attempt to index local 'v' (a nil value) stack traceback: /home/du...