Search found 313 matches

by qwrwed
Thu Jul 25, 2013 22:37
Forum: Mod Releases
Topic: [Mod] Plasma Screen TV [20130728] [plasmascreen]
Replies: 9
Views: 9591

[Mod] Plasma Screen TV [20130728] [plasmascreen]

http://www.mediafire.com/convkey/27bb/5n7509x76o01xdc4g.jpg This mod adds a decorative 2x3 plasma TV and stand to Minetest. It has a "flipping through channels" texture provided by VanessaE. Crafting: glass coal_lump glass steel_ingot copper_ingot steel_ingot glass glass glass or 2 Homede...
by qwrwed
Thu Jul 25, 2013 11:41
Forum: WIP Mods
Topic: placing nodes with on_construct
Replies: 9
Views: 1417

How do I place a node (with facedir) on_construct?
(see first post for more details)
by qwrwed
Wed Jul 24, 2013 18:43
Forum: WIP Mods
Topic: placing nodes with on_construct
Replies: 9
Views: 1417

(previous problem solved) Another problem: when I place screen5, screen4 appears to the left of it as planned, but instead of appearing to the right, screen6 appears in place of screen5. Here is the code: after_place_node = function(pos,placer,itemstack) local param2 = minetest.get_node(pos).param2 ...
by qwrwed
Wed Jul 24, 2013 16:44
Forum: WIP Mods
Topic: placing nodes with on_construct
Replies: 9
Views: 1417

I get this error: 17:42:54: ERROR[main]: ServerError: LuaError: error: ...cuments\minetest-0.4.7\bin\..\mods\plasmascreen\init.lua:146: calling 'get_node' on bad self (table expected, got userdata) The definition with the after_place_node is this: minetest.register_node("plasmascreen:screen5&qu...
by qwrwed
Wed Jul 24, 2013 16:39
Forum: WIP Mods
Topic: placing nodes with on_construct
Replies: 9
Views: 1417

Thanks webdesigner and PilzAdam, I will try that. Sokomine, I did that after making the first 6 nodes (it seemed simpler than using set_node) but I found that even when using a 32x48 texture, it just reverted to 6 16x16 textures. As for animation, I'm not that good with textures (maybe I will ask Va...
by qwrwed
Wed Jul 24, 2013 15:24
Forum: WIP Mods
Topic: placing nodes with on_construct
Replies: 9
Views: 1417

placing nodes with on_construct

I am going to try and place 6 nodes with only one placed by the player, but I don't know how to use on_construct to place nodes. Right now I am using after_place_node, but that only works for adding a second node because there is no placer to activate the "after_place_node" function for an...
by qwrwed
Wed Jul 24, 2013 14:38
Forum: Modding Discussion
Topic: Post your modding questions here
Replies: 4208
Views: 379867

How do I use add_node or set_node to create other nodes? i am making a plasma screen TV mod which has 6 nodes, arranged like this: 1 2 3 4 5 6 5 is the node that is placed, and when the player places it the other 5 nodes should generate. However, I don't know how to do this, and looking in the code ...
by qwrwed
Wed Jul 24, 2013 09:36
Forum: Mod Releases
Topic: [Mod] NonCubic Blocks Mod [1.4] [noncubic]
Replies: 111
Views: 42375

Bas080 wrote: I'm continuing the development of this mod. The git is at https://github.com/bas080/noncubic. I tried the link but it is broken. It would be nice if this mod could adapt it's shapes to any block type. sorry i didn't reply sooner. It's in my simple modpack too together with stairsplus....
by qwrwed
Tue Jul 23, 2013 19:47
Forum: Servers
Topic: Redcrab's server
Replies: 5031
Views: 670393

(muhehe)
by qwrwed
Tue Jul 23, 2013 19:10
Forum: Minetest-related projects
Topic: [Old]Node Box Editor [0.9.2]
Replies: 444
Views: 93640

On XP, I downloaded the 0.5 zip file and extracted from it, then extracted from that file, then clicked the .exe file, and I got an error message saying cg.dll was not found. After downloading thta, cgD3D9.dll was not found, and after downloading that, I got an error message - not saying that anothe...
by qwrwed
Tue Jul 23, 2013 17:32
Forum: Minetest-related projects
Topic: [Old]Node Box Editor [0.9.2]
Replies: 444
Views: 93640

Hey rubenwardy! I made a bash script that automatically compiles your node box generator in your desktop. Please tell me what you think. Code: #!/bin/bash echo "" echo "********************************************" echo "* *" echo "* The-NodeBox-Generator Compiler...
by qwrwed
Tue Jul 23, 2013 16:17
Forum: Mod Releases
Topic: [Mod] Lights+ [12112013] [lightsplus]
Replies: 46
Views: 20212

Uploaded to Github
by qwrwed
Sat Jul 20, 2013 18:36
Forum: Mod Releases
Topic: [Mod] Technic [0.4.16-dev] [technic]
Replies: 1551
Views: 522793

I'm having the same problem as before trying to add conversion of MV to LV to the setup I mentioned earlier. At the moment it goes: HV solar arrays -> switching station -> HV battery box -> HV-MV supply converter -> switching station -> MV battery box -> MV-LV supply converter -> switching station -...
by qwrwed
Sat Jul 20, 2013 16:43
Forum: Mod Releases
Topic: [Mod] Technic [0.4.16-dev] [technic]
Replies: 1551
Views: 522793

Yes, I am trying to convert HV (yellow wires) to MV (black wires). They are set up as in the screenshot, but I don't know how to convert HV power to MV power. Edit: Thanks, I will try adding a switching station. Edit2: Extended the MV wires, placed a switching station between the supply converter an...
by qwrwed
Sat Jul 20, 2013 15:21
Forum: Mod Releases
Topic: [Mod] Technic [0.4.16-dev] [technic]
Replies: 1551
Views: 522793

How does the supply converter work? I've been looking through the sorce code and all I've gathered is that the higher voltage goes above and the lower voltage goes below. Now it is unpowered, so how do I power it so that the MV battery box has power? http://www.mediafire.com/convkey/bffe/esllewldo77...
by qwrwed
Fri Jul 19, 2013 15:16
Forum: WIP Mods
Topic: Watergone [V0.2] By Switch5681
Replies: 12
Views: 4126

I have reuploaded this mod to Mediafire in case anyone wants to download it. It still seems to work in 0.4.7.
http://www.mediafire.com/download/4zcb8 ... ergone.zip
by qwrwed
Tue Jul 16, 2013 14:51
Forum: Mod Releases
Topic: [Mod] Lights+ [12112013] [lightsplus]
Replies: 46
Views: 20212

I have - I had to in order to alias them. It might seem like it doesn't do anything, but it just means that if you switch from newlights to lightsplus, there won't be any unknown blocks and they will work exactly the same. (I also added it because I liked the idea/appearance and it is more convenien...
by qwrwed
Mon Jul 15, 2013 16:08
Forum: Mod Releases
Topic: [Mod] Lights+ [12112013] [lightsplus]
Replies: 46
Views: 20212

Thanks, webdesigner :)
LionsDen, I have added your lights to the mod and aliased them (any lights from your modification will be changed to the lights in this mod which are exactly the same apart from the name). By the way, so you don't have to keep using he/she, I'm a he.
by qwrwed
Sun Jul 14, 2013 19:50
Forum: Mod Releases
Topic: [Mod] Lights+ [12112013] [lightsplus]
Replies: 46
Views: 20212

Reuploaded to Mediafire with gold lights.
by qwrwed
Sat Jul 13, 2013 20:03
Forum: Mod Releases
Topic: [mod] Hills [grassblock]
Replies: 20
Views: 11892

I agree - at least nodeboxes (usually) fit in with a cubic world though.
by qwrwed
Sat Jul 13, 2013 17:31
Forum: Mod Releases
Topic: [mod] Hills [grassblock]
Replies: 20
Views: 11892

Reuploaded to mediafire, non-cubic grass slopes added
by qwrwed
Thu Jul 04, 2013 20:04
Forum: Servers
Topic: Redcrab's server
Replies: 5031
Views: 670393

I won't be able to come to the party (I live in the GMT time zone, so I will be asleep during it).
by qwrwed
Fri Jun 07, 2013 19:12
Forum: Maps
Topic: [Map] Aperture science (based on P0RTAL)
Replies: 13
Views: 5394

If you create a "worldmods" folder and put all of those mods into it, people will not have to download every one - they will all be there. I posted a download link to a folder called 'aperture mods'. You don't need to post a seperate download; create a folder called "worldmods" ...
by qwrwed
Sun May 19, 2013 12:26
Forum: Maps
Topic: [Map] Aperture science (based on P0RTAL)
Replies: 13
Views: 5394

If you create a "worldmods" folder and put all of those mods into it, people will not have to download every one - they will all be there.
by qwrwed
Sun May 19, 2013 11:46
Forum: WIP Mods
Topic: (SOLVED)Sound problem with my mod
Replies: 3
Views: 701

Thanks. I knew there was going to be a simple fix. Can a moderator close this topic?