Page 2 of 2

Posted: Sun Apr 08, 2012 17:32
by RabbiBob
Family is over for Easter Dinner. Will get back to you later.

Basically you've got to pass the port from the router and point it right at the IP of the server.

For example, my router is and my server is on my internal network. I have to tell the router to pass all port 3000 UDP traffic from the Internet to (and then make sure the server at isn't blocking that port as well).

Posted: Sun Apr 08, 2012 17:36
by mauvebic
allright, with the wilan in access point mode, everything is on the same network (at least) :-)


Posted: Sun Apr 08, 2012 22:15
by RabbiBob
Another test to know if it's your iptables or your router requires another computer on your internal network: try to connect to the server at Port 30000. If it fails, then it's your server and most likely the firewall.


Random thought: Did you restart your iptables after the changes and you still can't connect?

/etc/rc.d/init.d/iptables restart

If so.....


We may be convoluting things.

Your screenshot shows "192.168.2.x" as being the available IP range from your router's config page. You said above that your IP is "", but I suspect it is "". To clear this up, get the IP of your server. Arch linux should spit it out with the following command:

>ip a


If you have a typical home setup, you'll have a cable or dsl wire that goes into a cable or dsl modem. From there, you most likely have a router connected to the modem via an Ethernet cable. From there, your computer is connected to the router by another Ethernet cable (or wi-fi).

You usually do not make changes to the modem. It just runs and does its job. It usually has its own IP address that is 1) an internal IP address and 2) different than your router's IP address.

Your router may or may not see the modem's IP (yours may be seeing it from what I'm reading), but we shouldn't really care about it. Your screenshot looks like you've done this properly. If TCP\UDP is an option, you can set that as well and cover both types (Calinou says it is UDP, so we'll can take that as truth or set the value to cover it all).

Regardless, now your router is set to pass port traffic destined for port 30000 onward to If your router has logging, you actually should see requests go through if people are trying to connect from the internet (you'll have to work with someone actively to see if they generate traffic).

So we'll assume that port 30000 is making it through. If iptables is on, you'll need to let it pass through. I have little experience with this specifically and could only suggest googling "ip tables port forwarding". The premise is exactly the same as what you did to the router: allow port 30000 to pass through the firewall.

If you get this set up and the server is running, it'll accept a connection.

That's about as much blind help I can give, I hope it helps out.

Posted: Mon Apr 09, 2012 03:50
by mauvebic
Ive tried everything:
router port forwarding (fail), then set it as access point which meant the router and all hosts were on the modem's network.
then i setup port forwarding on the modem (fail). Then i enable IP passthrough so my host would have the public IP (fail). Both the routers' and the modems' firewalls were disable.

I think this is an Arch issue. VLC remote and VLC web interface haven't worked in three weeks either, something about socket permissions being denied. I filed a bug on that so ill check it out.

Thanks anyways :-) ill post back if/when i get it to work :-)

Posted: Thu Apr 12, 2012 20:17
by mauvebic
I was able to connect to my server using a laptop, i think it should work now :-)