[FIXED] Server not announcing to servers.minetest.net

pengnuin
New member
 
Posts: 9
Joined: Sat Dec 23, 2017 18:39

[FIXED] Server not announcing to servers.minetest.net

by pengnuin » Thu Dec 28, 2017 03:16

Hello folks,
I've been fooling around with database backends for hours on end and decided I'd like to try announcements. However, the server list apparently keeps telling my server that it is a teapot!

Code: Select all
2017-12-28 04:13:04: ERROR[CurlFetch]: servers.minetest.net/announce not found (HTTP response code said error) (response code 418)


I'm probably missing something really obvious here. Any suggestions?

EDIT: I kept the server running for a while after adjusting the curl_timeout parameter in minetest.conf up to 10000. Server announces properly now, yay!
Last edited by pengnuin on Thu Dec 28, 2017 12:55, edited 2 times in total.
 

User avatar
Festus1965
Member
 
Posts: 1098
Joined: Sun Jan 03, 2016 11:58
Location: Thailand - Chiang Mai (+5-6h to MEZ)
In-game: Thomas Explorer Thailand

Re: Announcing to servers.minetest.net response [b]code 418[

by Festus1965 » Thu Dec 28, 2017 04:13

I had this this morning also. 3 times see red announcement ... maybe they was not reachable for a few minutes. But long time now now problem and people come in also.

edit: nice for you - seams my code was different at the end, see here now: ERROR[CurlFetch]: servers.minetest.net/announce not found (HTTP response code said error) (response code 500)

but anyway, thanks, I try your solution
Last edited by Festus1965 on Thu Dec 28, 2017 22:51, edited 2 times in total.
Server: still up, see some gamer - but there is a new 1st important thread "climate change" for me.
 

pengnuin
New member
 
Posts: 9
Joined: Sat Dec 23, 2017 18:39

Re: Announcing to servers.minetest.net

by pengnuin » Thu Dec 28, 2017 08:50

Weird that it worked for you - It's still giving me that exact message, however.
 

User avatar
Festus1965
Member
 
Posts: 1098
Joined: Sun Jan 03, 2016 11:58
Location: Thailand - Chiang Mai (+5-6h to MEZ)
In-game: Thomas Explorer Thailand

Re: [FIXED] Server not announcing to servers.minetest.net

by Festus1965 » Mon Jan 01, 2018 03:42

Hello penguin,

I just helped another old minetest friend with this issue Failure 418 at server announce.

He has two servers inside the same sub domain in a private address area (like me) but he has only one dyndns address what (i guess) is "connected" to the first server, and successful announced.
As he wanted to use the same dyndns address for the second server, he is getting an 418 Failure.


first to that: HTTP-Statuscode
This is a list of Hypertext Transfer Protocol (HTTP) response status codes. Status codes are issued by a server in response to a browser's request made to the server. ...


So I guess our Client Minetestserver, asks via http at servers.minetest.net to register his server. 418 then tells fail.
Fail with code 418 means already that HAD a connection, but the server denys to register, whatever reason.



maybe problems :
servers.minetest.net is denying to register a 2nd or more servers on the same dyndns, even with different ports.
or
the 2nd server is not getting back the connection open to register the server, as the dyndns address is for the 1st server.

offered solutions to check out:
a 2nd dyndns address for the 2nd server and use this in minetest.conf (no other changes, just keep other Port)
and / or
check how the 2nd server is allowed to connect out (to announce and keep the port getting answers back.)


So at me, with 2 servers, both successful announcing servers have each an own dyndns address and there is NAT used, they can connect themselves successful to INTERNET, means they get back THERE own requests.


So far, this might be an hint what is wrong at you, and I will post the result, when I get the answer myself.
Server: still up, see some gamer - but there is a new 1st important thread "climate change" for me.
 

pengnuin
New member
 
Posts: 9
Joined: Sat Dec 23, 2017 18:39

Re: [FIXED] Server not announcing to servers.minetest.net

by pengnuin » Wed Jan 03, 2018 07:08

Thanks for the detailed reply, Festus, and a happy new year :)

Most of what you posted seems to check out - but I doubt that is an issue in my case, since I use a subdomain on my TLD for the minetest server. There is only a web server on that same domain - or IP, for that matter.
However, I was restarting the server several times during configuration, so that may have caused problems as the server list could have had the servers info in cache still as it came up again and tried to announce.

Luckily, it worked in my case (without me actually changing anything except for "curl_timeout") - but if we can find out what the issue actually is and write a post in order to help others who might encounter the problem, I'll be happy to do some further testing as well.
 


Return to Servers



Who is online

Users browsing this forum: No registered users and 3 guests