Setting up a Minetest Server on Raspberry PI

Posts: 252
Joined: Sat Jul 25, 2015 19:54
In-game: DoyleChris

Setting up a Minetest Server on Raspberry PI

by DoyleChris » Wed Jan 02, 2019 01:00

So i got Minetest Server installed (4.15) i ran it by running minetest --server --worldname Test, and it started and ran fine. And i was able to connect to it.
I have a server (4.17.1) running on my laptop, so i copied the mods folder and worlds folder to /home/pi/.minetest/, and under worlds folder i have Server world folder.
But when i go to run it with minetest --server -- worldname Server i get this error.

Code: Select all
2019-01-01 19:47:28: [Main]: Using world specified by --worldname on the command line
2019-01-01 19:47:28: WARNING[Main]: NodeDefManager: Ignoring CONTENT_IGNORE redefinition
2019-01-01 19:47:28: ERROR[Main]: ModError: Failed to load and run script from /home/pi/.minetest/mods/unified_inventory/init.lua:
2019-01-01 19:47:28: ERROR[Main]: /home/pi/.minetest/mods/unified_inventory/init.lua:40: attempt to index field 'settings' (a nil value)
2019-01-01 19:47:28: ERROR[Main]: stack traceback:
2019-01-01 19:47:28: ERROR[Main]:    /home/pi/.minetest/mods/unified_inventory/init.lua:40: in main chunk

So i have started shutting off the mods one by one when they show up like the one above. But i keep getting the same error everytime just a different mod.

Any help would be great.

Posts: 309
Joined: Mon Aug 20, 2018 00:44
Location: Earth

Michael Eh?
Posts: 391
Joined: Sun Jan 01, 2012 17:21

Re: Setting up a Minetest Server on Raspberry PI

by Michael Eh? » Sat Jan 05, 2019 22:20

I know that Regulus Mars Survive server runs on Raspberry Pi3 okay. One quirk is write permissions with minetest log file (I think) on the OS on Raspberry Pi. At least that is what archfan who runs the server said in chat.

Return to Servers

Who is online

Users browsing this forum: No registered users and 15 guests