Page 51 of 59

Re: VanessaE's Creative Server [git]

Posted: Tue Jan 06, 2015 00:17
by kittykat3331
VanessaE wrote:Interact granted.
Thanks! :)

Re: VanessaE's Creative Server [git]

Posted: Sat Jan 17, 2015 18:43
by VanessaE
Update: I've moved the server's regular restart time to 0800 UTC, 3:00am EST, as the server's quiet times have shifted again. This change affects all of my Minetest server instances.

Re: VanessaE's Creative Server [git]

Posted: Sun Jan 18, 2015 00:21
by Inocudom
Has Dreambuilder been updated on this server yet so that the infrastructure mod won't crash the server anymore?

Re: VanessaE's Creative Server [git]

Posted: Sun Jan 18, 2015 00:35
by VanessaE
It has been updated, yes. That update will go into effect at the next restart (as above, unless someone does it sooner).

Re: VanessaE's Creative Server [git]

Posted: Thu Jan 22, 2015 02:32
by VanessaE
This server's config has been updated such that it now requires 0.4.11 or newer to connect. If you are using 0.4.10 or earlier, the server will reject your connection. I did this to curb uses of outdated clients that can't properly render all of the media and drawtypes that are in use on this server.

Re: VanessaE's Creative Server [git]

Posted: Thu Jan 22, 2015 20:20
by Michael Eh?
0.4.11 craps out trying to connect...
ERROR[MeshUpdateThread]: Waiting for texture disable_img.png timed out.

In fact, 0.4.11 for windows either 32 or 64 crashes on my windows 7.1 Enterprise even in single player mode. It's either not render SOME media types or NONE at all. :( 0.4.11 isn't stable yet folks.

Re: VanessaE's Creative Server [git]

Posted: Thu Jan 22, 2015 20:26
by VanessaE
Michael: try sfan5's latest build (this applies to all Windows users on my servers): https://forum.minetest.net/viewtopic.php?p=168490#p168490

Direct links to those:
32 bit: https://sfan5.pf-control.de/minetest-builds/latest.php?b=minetest
64 bit: https://sfan5.pf-control.de/minetest-builds/latest.php?b=minetest_64

Android users:
try celeron55's build: https://forum.minetest.net/viewtopic.php?p=167371
...or try sapier's latest build: http://www.fileconvoy.com/dfl.php?id=g9c63a08b33eb932899961019369bd677d164a74aa

These are all built from recent git and are more stable than 0.4.11-release, thanks to a number of bugfixes and performance improvements that went in after.

Linux desktop users: you know what to do ;-)

Re: VanessaE's Creative Server [git]

Posted: Fri Jan 23, 2015 01:40
by Michael Eh?
Stan5 version crashes as well. :/
debug said really nothing ....
-------------
Separator
-------------

Irrlicht log: Irrlicht Engine version 1.8.1
Irrlicht log: Microsoft Windows 7 Enterprise Edition Service Pack 1 (Build 7601)
Irrlicht log: Using renderer: OpenGL 2.0.0
Irrlicht log: Intel 965/963 Graphics Media Accelerator: Intel
Irrlicht log: OpenGL driver version is 1.2 or better.
Irrlicht log: GLSL version: 1.1
Irrlicht log: Resizing window (800 600)
20:32:54: ACTION[main]: Client: Contacting remote server "http://192.99.11.10/creative-survival-media/"
20:32:54: ERROR[CurlFetchThread]: http://192.99.11.10/creative-survival-media/index.mth not found (HTTP response code said error) (response code 404)
Irrlicht log: PNG warning: Malformed iTXt chunk
Irrlicht log: PNG warning: Malformed iTXt chunk
Irrlicht log: PNG warning: Malformed iTXt chunk
Irrlicht log: PNG warning: Interlace handling should be turned on when using png_read_image
20:33:46: ERROR[CurlFetchThread]: http://192.99.11.10/creative-survival-m ... c_base.png not found (HTTP response code said error) (response code 404)
20:33:46: ERROR[CurlFetchThread]: http://192.99.11.10/creative-survival-m ... se_inv.png not found (HTTP response code said error) (response code 404)
Irrlicht log: PNG warning: Interlace handling should be turned on when using png_read_image
Irrlicht log: PNG warning: Interlace handling should be turned on when using png_read_image
20:35:35: ERROR[main]: generateImage(): Could not load image "door_steel.png" while building texture
20:35:35: ERROR[main]: generateImage(): Creating a dummy image for "door_steel.png"
20:35:35: ERROR[main]: generateImage(): Could not load image "door_steel.png" while building texture
20:35:35: ERROR[main]: generateImage(): Creating a dummy image for "door_steel.png"
Font size: 6 14

The font size seems off.. usually it's 8 17

Re: VanessaE's Creative Server [git]

Posted: Fri Jan 23, 2015 05:26
by VanessaE
MichaelEh, can you try adding: enable_mesh_cache = false to your minetest.conf (or if it's there and set to true, then change it to false) and see if that helps, please?

All users, please set that in your minetest.conf anyway, whether it fixes MichaelEh's issue or not. :-)

Most folks won't notice a performance impact, and it will reduce RAM usage by about 800 MB. Most users (who aren't using a texture pack) should find themselves able to play using less than 1.5 GB of RAM with this setting.

Happy building!

Re: VanessaE's Creative Server [git]

Posted: Fri Jan 23, 2015 22:22
by Michael Eh?
it didn't ... Windows says there is a problem with core program which what it did when I did a singleplayer world. It gets on to the server with hand greyed out then crashes with nothing else than blue sky. :P

Looks like some issues with 0.4.11 still exist.

Re: VanessaE's Creative Server [git]

Posted: Sat Jan 24, 2015 20:14
by Michael Eh?
okay I had 0.4.11 temporarily up and running in singleplayer mode... using Compatibility mode set to XP sp3 but it eventually crashed and wouldn't connect to Creative nor load Big Sight map. So much for that. Now onto trying previous versions to see where it gone wrong. Funny 0.4.10 didn't need to run compatibility mode at all under Win 7.1 Enterprise.

Re: VanessaE's Creative Server [git]

Posted: Sun Jan 25, 2015 18:08
by Michael Eh?
I tried 0.4.11 on my old XP sp3 netbook. It loaded the server which showed me where I was but couldn't do anything including F3,F5, inv to use home function nor 't' to talk. Maybe 0.4.12 will correct the problem but I'm out of luck for now.

Re: VanessaE's Creative Server [git]

Posted: Sun Jan 25, 2015 20:41
by VanessaE
That is just so strange, I don't understand why it isn't working for you.

Re: VanessaE's Creative Server [git]

Posted: Mon Jan 26, 2015 20:12
by Michael Eh?
This happened before with forced to update to your servers. Ended up for another version number change before I was able to log on again. Annoying. I don't find the .mtl to be worth it but faster load times are good that is when it works at all.

Re: VanessaE's Creative Server [git]

Posted: Thu Jan 29, 2015 13:09
by Tmanyo
For some reason when I get on your server I can only stay on for 5 minutes at the most before my application stops working or it stops responding. It is only with this server too. Is there an explanation? I put the thing into the conf. file but that allowed me to get on but not to stay on.

Re: VanessaE's Creative Server [git]

Posted: Sun Feb 22, 2015 16:56
by EdShouldBeInBed
Oh great admin who dwells in Waynesville, might the humble EdShdBInBed have interact?

Re: VanessaE's Creative Server [git]

Posted: Sun Feb 22, 2015 17:31
by VanessaE
Heh.. interact already granted :)

Re: VanessaE's Creative Server [git]

Posted: Sun Feb 22, 2015 17:33
by ExeterDad
EdShouldBeInBed wrote:Oh great admin who dwells in Waynesville, might the humble EdShdBInBed have interact?
LOL!

Re: VanessaE's Creative Server [git]

Posted: Mon Feb 23, 2015 10:46
by EdShouldBeInBed
VanessaE wrote:Heh.. interact already granted :)
Yes, the great and good cheepie kindly did so. Thank you for not smiting me, great one.

Re: VanessaE's Creative Server [git]

Posted: Tue Feb 24, 2015 04:24
by doyousketch2
Hiya!

Your map has too many megapixels! so I split it with ImageMagick.

convert -crop 4500x4500 Creative_World.png tile%d.png

Easier to view that way :)

Re: VanessaE's Creative Server [git]

Posted: Tue Feb 24, 2015 04:25
by VanessaE
Glad to see you're still around :D

Re: VanessaE's Creative Server [git]

Posted: Wed Feb 25, 2015 20:16
by 12Me21
How long do backups usually take? It's 3:21 and the server isn't showing up on the list.

Re: VanessaE's Creative Server [git]

Posted: Wed Feb 25, 2015 22:06
by VanessaE
I took the servers down as a precaution, due to what appears to be a hardware problem on the new machine I moved everything to a few days ago. I've made off-site backups, so data has been lost (hopefully).

I have just gotten off the phone with my host about it, and they've agreed to schedule a repair immediately.

Re: VanessaE's Creative Server [git]

Posted: Thu Feb 26, 2015 08:26
by VanessaE
All Minetest servers are up and running again, and no data was lost. Feel free to log in and resume playing normally. :-)

IRC, webchat, and all other services on the machine have also been restored.

Sorry for the downtime folks.

Note: this particular world is still experiencing an engine bug that causes timeouts and/or flat player skins. This is not related to the cause of the downtime.

Re: VanessaE's Creative Server [git]

Posted: Sat Feb 28, 2015 00:12
by doyousketch2
Cool. Had you ever thought of adding voice-chat to your server?

I believe I read that your server runs on Debian?
If so, there's an easy package called: mumble-server

Then everyone could log in with a client from - http://sourceforge.net/projects/mumble
'prolly most Linux users could do something like this: sudo apt-get install mumble
Debian users can simply add the 'mumble' package from Synaptic.

Or if on Android - https://play.google.com/store/apps/deta ... mbleclient

I use it all the time while playing Tanki with my kid. It's great.