[Mod] X-Decor [git] [xdecor]

User avatar
Napiophelios
Member
 
Posts: 810
Joined: Mon Jul 07, 2014 01:14
GitHub: Napiophelios
IRC: Nappi
In-game: Nappi

Re: [Mod] X-Decor [git] [xdecor]

by Napiophelios » Sun May 22, 2016 17:27

Haven't tested it, but open the handlers folder,
then open the registration.lua file
and add:

def.light_source = def.light_source

to the function xdecor.register(name, def) at line 45.


EDIT:

also add:

light_source = def.light_source,

to minetest.register_node at line 256
of the workbench.lua file.

seems to work for me.
 

bark
Member
 
Posts: 35
Joined: Thu Sep 24, 2015 13:25
In-game: bark
 

bark
Member
 
Posts: 35
Joined: Thu Sep 24, 2015 13:25
In-game: bark

Re: [Mod] X-Decor [git] [xdecor]

by bark » Thu May 26, 2016 17:03

Warning to server admins running xdecor: https://github.com/minetest-mods/xdecor/issues/48

I temporarily solved the issue by commenting out the right-click function on node xdecor:chair in xdecor/nodes.lua.
 

bark
Member
 
Posts: 35
Joined: Thu Sep 24, 2015 13:25
In-game: bark

Re: [Mod] X-Decor [git] [xdecor]

by bark » Tue May 31, 2016 21:02

I'm missing yet another node. xdecor:stone_tile_stair

Got some code to get it back?
 

FrancMacon
New member
 
Posts: 1
Joined: Fri Jul 22, 2016 00:18
In-game: FrancMacon

Re: [Mod] X-Decor [git] [xdecor]

by FrancMacon » Sun Jul 24, 2016 04:28

160724072556.png
(448.18 KiB) Not downloaded yet


Via colorize
Attachments
xdecor_cushions.tar.gz
(2.32 KiB) Downloaded 22 times
 

User avatar
addi
Member
 
Posts: 614
Joined: Thu Sep 20, 2012 03:16
Location: Black-Forest, Germany

Re: [Mod] X-Decor [git] [xdecor]

by addi » Mon Jul 25, 2016 06:49

Hi,
is there a way I can register nodes for use with the saw of Workbench?
 

User avatar
RHR
Member
 
Posts: 214
Joined: Mon Jan 27, 2014 20:07
GitHub: RHRhino

Re: [Mod] X-Decor [git] [xdecor]

by RHR » Mon Jul 25, 2016 08:59

addi wrote:Hi,
is there a way I can register nodes for use with the saw of Workbench?

Sure addi, just change the general registration of them in workbench.lua
e.g. if you want to add straw from the farming mod then add or def.name == "farming:straw" like shown in the code below

Code: Select all
local nodes = {}
for node, def in pairs(minetest.registered_nodes) do
   if (def.drawtype == "normal" or def.drawtype:find("glass")) and
         (def.groups.cracky or def.groups.choppy) and not
         def.on_construct and not def.after_place_node and not
         def.after_place_node and not def.on_rightclick and not
         def.on_blast and not def.allow_metadata_inventory_take and not
         (def.groups.not_in_creative_inventory == 1) and not
         def.groups.wool and not def.description:find("Ore") and
         def.description and def.description ~= "" and def.light_source == 0
         or def.name == "farming:straw"
         then       nodes[#nodes+1] = node
   end
end
 

User avatar
Krock
Developer
 
Posts: 3644
Joined: Thu Oct 03, 2013 07:48
Location: Switzerland
GitHub: SmallJoker

Re: [Mod] X-Decor [git] [xdecor]

by Krock » Mon Jul 25, 2016 09:08

RHR: Be careful with these checks, for example
Code: Select all
not def.description:find("Ore")

will not work when intllib is activated. It will also not work when a mod is loaded after xdecor, thus you have to put the whole thing into minetest.after or add all mods to your depends.txt.
Mod Search Engine - All my mods
Donations --> paramat
Also check out the DuckDuckGo mod search bang: !mtmod <keyword here>
 

User avatar
RHR
Member
 
Posts: 214
Joined: Mon Jan 27, 2014 20:07
GitHub: RHRhino

Re: [Mod] X-Decor [git] [xdecor]

by RHR » Mon Jul 25, 2016 11:04

Krock wrote:RHR: Be careful with these checks, for example
Code: Select all
not def.description:find("Ore")

will not work when intllib is activated. It will also not work when a mod is loaded after xdecor, thus you have to put the whole thing into minetest.after or add all mods to your depends.txt.


Krock: These checks were already part of jp's xdecor mod. I just added the one "or" line, as example to allow another node to be registered for the workbench.
 

User avatar
addi
Member
 
Posts: 614
Joined: Thu Sep 20, 2012 03:16
Location: Black-Forest, Germany

Re: [Mod] X-Decor [git] [xdecor]

by addi » Mon Jul 25, 2016 13:17

Uhm OK thanks so far. I thought something like minetest.register_stair()...
I created an issue about this: https://github.com/minetest-mods/xdecor/issues/56
I also found out, that there are hundreds of nodes registered for that saw that doesn't make logically and from looking of the textures sense.
 

User avatar
azekill_DIABLO
Member
 
Posts: 5563
Joined: Wed Oct 29, 2014 20:05
Location: Pixelator
GitHub: azekillDIABLO
In-game: azekill_DIABLO

Re: [Mod] X-Decor [git] [xdecor]

by azekill_DIABLO » Mon Jul 25, 2016 13:50

it's even cutting spawners and mesecons :D
Code: Select all
Hi, my username is azekill_DIABLO and i'm an exelent bug-maker(yeah...i know...i have a bad reputation)

My Mods and Stuff | Voxellar 1.9 | VoxBox on GITHUB | M.I.L.A Monster engine
Check my website and give feedback!

Want to create MILA mobs? CL!CK
 

KCoombes
Member
 
Posts: 328
Joined: Thu Jun 11, 2015 23:19
Location: SW Florida, USA
In-game: Knatt or Rudilyn

Re: [Mod] X-Decor [git] [xdecor]

by KCoombes » Sat Aug 27, 2016 21:18

Any fix for this:

Code: Select all
2016-08-27 17:04:24: WARNING[Main]: Undeclared global variable "xpanes" accessed at ...sktop\minetest-0.4.14-win32\bin\..\mods\xdecor/nodes.lua:4
2016-08-27 17:04:24: ERROR[Main]: ModError: Failed to load and run script from C:\Users\User\Desktop\minetest-0.4.14-win32\bin\..\mods\xdecor\init.lua:
2016-08-27 17:04:24: ERROR[Main]: ...sktop\minetest-0.4.14-win32\bin\..\mods\xdecor/nodes.lua:4: attempt to index global 'xpanes' (a nil value)
2016-08-27 17:04:24: ERROR[Main]: stack traceback:
2016-08-27 17:04:24: ERROR[Main]:    ...sktop\minetest-0.4.14-win32\bin\..\mods\xdecor/nodes.lua:4: in function 'register_pane'
2016-08-27 17:04:24: ERROR[Main]:    ...sktop\minetest-0.4.14-win32\bin\..\mods\xdecor/nodes.lua:18: in main chunk
 

User avatar
Napiophelios
Member
 
Posts: 810
Joined: Mon Jul 07, 2014 01:14
GitHub: Napiophelios
IRC: Nappi
In-game: Nappi

Re: [Mod] X-Decor [git] [xdecor]

by Napiophelios » Sun Aug 28, 2016 04:57

I downloaded the latest Minetest game, the latest xdecor mod,
and the latest windows build by Krock; and I am not getting any errors.
 

KCoombes
Member
 
Posts: 328
Joined: Thu Jun 11, 2015 23:19
Location: SW Florida, USA
In-game: Knatt or Rudilyn

Re: [Mod] X-Decor [git] [xdecor]

by KCoombes » Sun Aug 28, 2016 09:13

Napiophelios wrote:I downloaded the latest Minetest game, the latest xdecor mod,
and the latest windows build by Krock; and I am not getting any errors.


I'm using sfan5's stable 04.14-win32 build with a fresh copy (yesterday) of xdecor in Minetest_game - could the build be the problem?
 

User avatar
Krock
Developer
 
Posts: 3644
Joined: Thu Oct 03, 2013 07:48
Location: Switzerland
GitHub: SmallJoker

Re: [Mod] X-Decor [git] [xdecor]

by Krock » Sun Aug 28, 2016 09:55

KCoombes wrote:could the build be the problem?

Better sue Trump for this problem because it has absolutely nothing to do with the build.
Your error log tells me that it can't find the xpanes API function. If there is a copy of xpanes in your mods directory, remove it. Then also remove the subgame minetest_game and re-download it.
Mod Search Engine - All my mods
Donations --> paramat
Also check out the DuckDuckGo mod search bang: !mtmod <keyword here>
 

KCoombes
Member
 
Posts: 328
Joined: Thu Jun 11, 2015 23:19
Location: SW Florida, USA
In-game: Knatt or Rudilyn

Re: [Mod] X-Decor [git] [xdecor]

by KCoombes » Sun Aug 28, 2016 10:20

Krock wrote:
KCoombes wrote:could the build be the problem?

Better sue Trump for this problem because it has absolutely nothing to do with the build.
Your error log tells me that it can't find the xpanes API function. If there is a copy of xpanes in your mods directory, remove it. Then also remove the subgame minetest_game and re-download it.


Ok, fresh copy of Minetest_game installed, xpanes removed - now this error:

Code: Select all
2016-08-28 06:18:03: ERROR[Main]: ModError: Failed to load and run script from C:\Users\User\Desktop\minetest-0.4.14-win32\bin\..\games\minetest_game\mods\default\init.lua:
2016-08-28 06:18:03: ERROR[Main]: ...win32\bin\..\games\minetest_game\mods\default/mapgen.lua:1471: attempt to call field 'get_mapgen_setting' (a nil value)
2016-08-28 06:18:03: ERROR[Main]: stack traceback:
2016-08-28 06:18:03: ERROR[Main]:    ...win32\bin\..\games\minetest_game\mods\default/mapgen.lua:1471: in main chunk
2016-08-28 06:18:03: ERROR[Main]:    [C]: in function 'dofile'
2016-08-28 06:18:03: ERROR[Main]:    ...4-win32\bin\..\games\minetest_game\mods\default\init.lua:45: in main chunk
 

User avatar
azekill_DIABLO
Member
 
Posts: 5563
Joined: Wed Oct 29, 2014 20:05
Location: Pixelator
GitHub: azekillDIABLO
In-game: azekill_DIABLO

Re: [Mod] X-Decor [git] [xdecor]

by azekill_DIABLO » Sun Aug 28, 2016 12:34

wat is your minetest conf?
Code: Select all
Hi, my username is azekill_DIABLO and i'm an exelent bug-maker(yeah...i know...i have a bad reputation)

My Mods and Stuff | Voxellar 1.9 | VoxBox on GITHUB | M.I.L.A Monster engine
Check my website and give feedback!

Want to create MILA mobs? CL!CK
 

KCoombes
Member
 
Posts: 328
Joined: Thu Jun 11, 2015 23:19
Location: SW Florida, USA
In-game: Knatt or Rudilyn

Re: [Mod] X-Decor [git] [xdecor]

by KCoombes » Sun Aug 28, 2016 13:40

azekill_DIABLO wrote:wat is your minetest conf?


Code: Select all
maintab_LAST = singleplayer
menu_last_game = minetest
name = Knatt
remote_port = 30000
server_dedicated = false
public_serverlist = true
enable_shaders = true
free_move = false
noclip = false
mainmenu_last_selected_world = 6
selected_world_path = C:\Users\User\Desktop\minetest-0.4.14-win32\bin\..\worlds\xdecor
wieldview_node_tiles = false
wieldview_update_time = 2
fixed_map_seed = 8204518463
mg_name = v7
mg_flags = trees,caves,light,nodungeons
world_config_selected_mod = 301
fast_move = true
anisotropic_filter = false
bilinear_filter = false
generate_normalmaps = true
mip_map = false
trilinear_filter = false
video_driver = opengl
remove_far_mobs = true
remove_items = 300
creative_mode = false
enable_damage = true
server_announce = false
cinematic = false
connected_glass = true
mainmenu_last_selected_TP = 1
texture_path =
time_speed = 72
map_generation_limit = 20000
debug_log_level = verbose
enable_fog = false
show_debug = true
enable_minimap = true
minimap_shape_round = true
port = 30000
wanted_fps = 60
fps_max = 120
default_privs = interact,shout,teleport,fly,noclip,fast
viewing_range = 40
screenW = 1419
screenH = 725
leaves_style = simple
deprecated_lua_api_handling = log
cloud_height = 240
mod_profiling = false
detailed_profiling = true
dedicated_server_step = 0.2
 

User avatar
Napiophelios
Member
 
Posts: 810
Joined: Mon Jul 07, 2014 01:14
GitHub: Napiophelios
IRC: Nappi
In-game: Nappi

Re: [Mod] X-Decor [git] [xdecor]

by Napiophelios » Sun Aug 28, 2016 15:51

KCoombes, I got the same default mapgen error using the stable build,
I had to update to the latest dev version of the MT engine to get past it.

don't remove the xpanes mod, xdecor wont be available ingame.
just make sure you don't have a duplicate of xpanes in your common mods folder
 

KCoombes
Member
 
Posts: 328
Joined: Thu Jun 11, 2015 23:19
Location: SW Florida, USA
In-game: Knatt or Rudilyn

Re: [Mod] X-Decor [git] [xdecor]

by KCoombes » Sun Aug 28, 2016 19:04

Yep, that fixed it, although I did remove xpanes from the mods folder, as it is included in minetest_game/mods already.
 

User avatar
azekill_DIABLO
Member
 
Posts: 5563
Joined: Wed Oct 29, 2014 20:05
Location: Pixelator
GitHub: azekillDIABLO
In-game: azekill_DIABLO

Re: [Mod] X-Decor [git] [xdecor]

by azekill_DIABLO » Mon Aug 29, 2016 14:22

and your mineteste.conf is perfectly normal :D
Code: Select all
Hi, my username is azekill_DIABLO and i'm an exelent bug-maker(yeah...i know...i have a bad reputation)

My Mods and Stuff | Voxellar 1.9 | VoxBox on GITHUB | M.I.L.A Monster engine
Check my website and give feedback!

Want to create MILA mobs? CL!CK
 

User avatar
Wuzzy
Member
 
Posts: 2558
Joined: Mon Sep 24, 2012 15:01
GitHub: Wuzzy2
IRC: Wuzzy
In-game: Wuzzy

Re: [Mod] X-Decor [git] [xdecor]

by Wuzzy » Tue Sep 06, 2016 05:29

Expected to see a lightweight decoration mod. Was disappointed. Your mod is anything BUT “lightweight”:
- Full blown chess game (WTF?)
- Very heavyweight gameplay changes: Enchantment table, Ender chest (jeez, please try to avoid Minecraft slang), Work bench, apparently even a mechanism system which I don't understand yet (sadly, there is no manual)
- Crafting guide
- Beehive?!

Don't get me wrong: This mod includes many great gameplay ideas and has a couple of nice-looking and simple new decorations. I like the style. But for people who just want the decorations they do not neccessarily want the gameplay stuff as well.

The formspec design you used throughout the is great. It is simple to use and well-designed. This is how formspecs should generally be done. I appreciate the effort you put into these because I know how much a pain in the ass it is to only get a single form to work with all widgets aligned properly, etc.

About the mod design:
I suggest to strictly seperate the functional part from the decorational part, except for the things which change gameplay insignificantly.
I would especially like to see the crafting guide in a seperate mod. Looks like a nice rework of zcg to me. It's not as useful as Unified Inventory but still better than nothing. Why does the arrow go into the wrong direction? ;-)

I see you already released the workbench mod seperately, but for some reason you still have included it in xdecor. :-(

There's a serious bug in this mod: You used paramtype="light" for many nodes, even “solid” ones. I bet you misunderstood what this paramtype means. A side-effect of this is that it will cause light to propagate THROUGH the node, so if you place a torch behind a stone tile (for example), it glows! I am sure this is not intended. You need this paramtype for nodeboxes usually but for normal cubes you should only use this paramtype if you really want light to go through (like for leaves or glass). First I thought this attribute is only set for the runestone (this is actually pretty interesting and worth keeping) but after a quick check I notice this is set for pretty much every node.
I'm creating MineClone 2, a Minecraft clone for Minetest.
I made the Help modpack, adding in-game help to Minetest.
 

User avatar
mahmutelmas06
Member
 
Posts: 366
Joined: Mon Mar 02, 2015 13:10
GitHub: mahmutelmas06
IRC: mahmutelmas06
In-game: masum

Re: [Mod] X-Decor [git] [xdecor]

by mahmutelmas06 » Tue Sep 06, 2016 09:32

As i know the developer of this mod "JP" left the minetest.
There is also seperated crafting guide viewtopic.php?f=11&t=14088
My Mods:

Beverage
 

User avatar
everamzah
Member
 
Posts: 490
Joined: Thu Jan 29, 2015 00:47
GitHub: everamzah
IRC: everamzah
In-game: everamzah

Re: [Mod] X-Decor [git] [xdecor]

by everamzah » Tue Sep 06, 2016 12:27

This is the best mod ever, and is perfect in every way.

That said, I always wondered why light behind stone tiles was so bright. Ha!

This mod was transferred over to minetest-mods organization on GitHub, headed by sofar. You'd do well to submit PRs there, I think. You raise fine points, though I'd never been bothered by simply commenting out certain dofile() lines.

Cheers.
 

twoelk
Member
 
Posts: 1111
Joined: Fri Apr 19, 2013 16:19
Location: northern Germany

Re: [Mod] X-Decor [git] [xdecor]

by twoelk » Tue Sep 06, 2016 15:01

indeed jp made standalone versions of some of the xdecor mods
such as the Work Bench, Enchanting and as stated before the Crafting Guide.
.....and when he began it was pretty lightweight; but then again compared to Home Decor plus More Blocks...
 

PreviousNext

Return to Mod Releases



Who is online

Users browsing this forum: Yahoo [Bot] and 7 guests