Page 1 of 1

[mod] More advanced area protection [tyrant_denaid] [1.3]

PostPosted: Mon Jul 06, 2015 14:37
by orwell
This mod is now dependent of the tyrant mod, which i split from it to provide unified area protection checking. Nothing changed regarding area setup and handling, all old areas are kept.
------------------
This mod is an advanced area management and protection tool. It is not only restricting on build protection.

Administrators (denaid_admin privilege) can create and edit areas, their bounds and their owner. The owner is then able to:
-prohibit players from entering his area
-stop players from building in his area
-prohibit griefing and spamming(any type of inventory interaction) inside his area
These restrictions are managed in rulesets that can apply to specific players or to all players. Of course, the owner and admins are still able to bypass the restrictions.

Further area owners can:
-disable monster spawning in his area (target mod must support this, as I know, no one does.)
-disable PvP in his area (0.4.13 only)
This is handled area-wide.

Areas can intersect, a priority number is used to determine which area is more important. This is okay because that number can only be edited by admins. self-protected areas will have a fixed priority. I think implementing a parent-child relation is not useful.
(the priority number is a feature of tyrant, but denaid is the only integration that actively uses it, most other mods just keep a fixed priority. see their code or documentation)

self-protection has been removed, an alternate solution can be found with tyrant_claim. If anyone wishes, I can reinclude it into the code, just ask inside this thread.

The non-admin stuff should be self-explaining.
See readme for further explanation.

License: WTFPL

Depends on:
tyrant (https://github.com/orwell96/tyrant/archive/master.zip)

Download: https://github.com/orwell96/tyrant_denaid/archive/master.zip
Github: https://github.com/orwell96/tyrant_denaid

For those who are not happy with it:
denaid_1_3.zip
Latest version of denaid before the switch to tyrant was done. still includes self-protection. if you are not happy with tyrant-denaid, go back to this.
(15.4 KiB) Downloaded 51 times


Remove the '-master' suffix on mod folders after extracting!

Re: [mod] More advanced area protection [denaid]

PostPosted: Mon Jul 06, 2015 23:20
by Niebieski
Well done orwell. I didn't test it though. I think PVP protection is a good idea.
Good luck.

Re: [mod] More advanced area protection [denaid]

PostPosted: Tue Jul 07, 2015 00:24
by Dragonop
This mods looks like if you ruled your own communist country. Kinda cool tough.

Re: [mod] More advanced area protection [denaid]

PostPosted: Wed Jul 08, 2015 20:00
by Diamond knight
maybe also a pvp alowwed area for an arena on a server that u can only pvp in arenas

Re: [mod] More advanced area protection [denaid]

PostPosted: Thu Jul 30, 2015 13:18
by orwell
EDIT: This post is outdated, see below.

Actually I need help.
I just can't find a way to make players receive no damage from other players while still receiving damage from monsters.
A simple way would be to make players completely invulnerable.

If someone has an idea how to implement, please post. In the meantime, PvP protection will remain unimplemented.

Re: [mod] More advanced area protection [denaid]

PostPosted: Mon Aug 10, 2015 12:52
by orwell
In latest development version, register_on_punchplayer was integrated. Callbacks can return true if no damage should be dealt. That is what i will use. I will push a new version soon with the API and PvP-Protection enabled IF register_on_punchplayer exists. (for the ones that compiled minetest on their own from github)
Looking forward for Minetest version 0.4.13 (please release it soon....)
lua_api.txt wrote:minetest.register_on_punchplayer(func(player, hitter, time_from_last_punch, tool_capabilities, dir, damage))`
* Called when a player is punched
...
* should return `true` to prevent the default damage mechanism


EDIT: Now it's out! Will work in 0.4.13 or later

Re: [mod] More advanced area protection [denaid]

PostPosted: Fri Sep 18, 2015 20:34
by swordpaint12
Nice mod, just downloaded the latest version. Looks great, I can hardly wait to try it! I've been looking for a protection mod a while now, but this afternoon I looked seriously, not just on the side of what I was doing. Thank you for putting time into this!

Re: [mod] More advanced area protection [denaid] [1.3]

PostPosted: Thu Nov 26, 2015 10:33
by orwell
celeron55 wrote:(in Forum information and guidelines)
also post a release notice in the topic.


read this recently. will do that now.
Hello, World! There is a new version.

Re: [mod] More advanced area protection [denaid] [1.3]

PostPosted: Fri Nov 27, 2015 23:24
by luizrpgluiz
anti pvp is not working even in the most current version of minetest, I leave turned on the pvp in minetest.conf

Re: [mod] More advanced area protection [denaid] [1.3]

PostPosted: Sat Nov 28, 2015 22:23
by orwell
It is working.
Please check that you:
- created an area around your spawn point (to see if it is configured properly, see if the bottom left corner of the screen shows the name of that area)
- created a ruleset that allows all players to at least enter this area (don't forget this step, it could cause unwanted results when players join!)
- un-ticked the pvp checkbox.
Then it should work.
If you don't know how to do the things I described, see the readme.txt. To administer areas, you need to have the denaid_admin and denaid_bypass privileges. (denaid_bypass to ensure you do not bug around when you get thrown out of the spawn area)

Re: [mod] More advanced area protection [denaid] [1.3]

PostPosted: Tue May 24, 2016 16:47
by sofar
This mod crashes with 0.4.14 somehow when pipeworks is used. See:

https://forum.minetest.net/viewtopic.php?f=11&t=2155&p=218598#p218560

- what is the license of this code?
- can you use github?

Re: [mod] More advanced area protection [denaid] [1.3]

PostPosted: Wed May 25, 2016 10:07
by orwell
Lejo wrote:I update the denaid mod and now it works fine.
Thanks a lot


sofar wrote:- what is the license of this code?
- can you use github?

1. whoops, WTFPL
2. yes, i will move all my mods to github soon(TM)

I will post tyrant, denaid's successor, probably this weekend. tyrant tries to unify different independent protection mods into one framework. I will write further stuff on it when I post it.

Re: [mod] More advanced area protection [tyrant_denaid] [1.3

PostPosted: Wed Oct 12, 2016 10:28
by Lejo
I had on my server two problems with your new tyrant_denaid mod:
-If I want to set a ruleset the server crashes.
-If I punch a player the server crashes Here the Error:
Image

Please help me I need the mod.

Re: [mod] More advanced area protection [tyrant_denaid] [1.3

PostPosted: Thu Oct 13, 2016 10:03
by orwell
Sorry, i'm busy ATM. Next week.

Re: [mod] More advanced area protection [tyrant_denaid] [1.3

PostPosted: Sun Oct 16, 2016 14:11
by orwell
Second problem fixed, the error lies in 'tyrant'
Please re-download tyrant.
and, can you post the error log from the first error, if it still appears?

Re: [mod] More advanced area protection [tyrant_denaid] [1.3

PostPosted: Mon Oct 17, 2016 15:26
by Lejo
orwell wrote:Second problem fixed, the error lies in 'tyrant'
Please re-download tyrant.
and, can you post the error log from the first error, if it still appears?

Here is the second Error:
Image
It is only if I want to set a Ruleset and if it is a new map.

I hope it is to fix to. :)

Re: [mod] More advanced area protection [tyrant_denaid] [1.3

PostPosted: Mon Oct 17, 2016 18:30
by orwell
just my fault (both errors). of course it is to fix. thx for pointing this out, i wonder why this never showed up to me...
this time you need to update tyrant-denaid.

Re: [mod] More advanced area protection [tyrant_denaid] [1.3

PostPosted: Wed Oct 19, 2016 14:03
by Lejo
The first Error appears still.
The Name of the Area is:
Code: Select all
Get Down

The id is:
Code: Select all
29

Can the Problem be the name of my area?
Here the Error:
Image

Please help me.

Re: [mod] More advanced area protection [tyrant_denaid] [1.3

PostPosted: Wed Oct 19, 2016 17:21
by orwell
No, it can't. did you really update tyrant-denaid from github?
Maybe try the zip included in the first post, with this it should work.

Re: [mod] More advanced area protection [tyrant_denaid] [1.3

PostPosted: Wed Oct 19, 2016 17:46
by Lejo
Yes I really update it, so it is a other Error.

Re: [mod] More advanced area protection [tyrant_denaid] [1.3

PostPosted: Thu Oct 20, 2016 11:30
by orwell
Lejo wrote:Yes I really update it, so it is a other Error.

You're right. Same line, but different error. This time it should work. I named the function parameter 'player' but i should have called it 'pname'.
Please re-download tyrant_denaid.

Re: [mod] More advanced area protection [tyrant_denaid] [1.3

PostPosted: Sat Oct 22, 2016 17:28
by Lejo
Now all works thanks a lot.