[Mod] Enchanting [git] [enchanting]

Post Reply
User avatar
jp
Member
Posts: 798
Joined: Wed Dec 18, 2013 09:03
GitHub: kilbith
Location: France

[Mod] Enchanting [git] [enchanting]

by jp » Post

Enchanting

A mod adding a Minecraft-inspired Enchantment Table.

3 enchants are proposed for the default tools, and 2 enchants for the armors from 3D Armor.

You can also easily register your own enchanted tools or tweak the enchants.

This mod is originating from X-Decor (license : GPLv3).

Depends : default.
Recommends : 3d_armor.

Image Download | Github

Image Image
Last edited by jp on Mon Feb 29, 2016 18:39, edited 10 times in total.

User avatar
MineYoshi
Member
Posts: 5373
Joined: Wed Jul 08, 2015 13:20
Contact:

Re: [Mod] Enchanting [enchanting]

by MineYoshi » Post

Wow , the mod looks great, maybe i can include it in my new server!
Oi

User avatar
firefox
Member
Posts: 1583
Joined: Wed Jan 14, 2015 07:34
In-game: Red_Fox
Location: Xanadu

Re: [Mod] Enchanting [git] [enchanting]

by firefox » Post

eeehhhh sugoi!

i will include it in my subgame
(whenever i finish the basics and get to add other mods ...)
=(^.^)= nyan~

User avatar
RickMcFarley
Member
Posts: 10
Joined: Mon Dec 23, 2013 11:51

Re: [Mod] Enchanting [git] [enchanting]

by RickMcFarley » Post

This is great! Thanks!

User avatar
Minetestforfun
Member
Posts: 940
Joined: Tue Aug 05, 2014 14:09
GitHub: MinetestForFun
IRC: MinetestForFun
In-game: MinetestForFun
Location: On earth
Contact:

Re: [Mod] Enchanting [git] [enchanting]

by Minetestforfun » Post

Happy to see this mod splitted from xdecor modpack, great job !

User avatar
LazerRay
Member
Posts: 147
Joined: Sun Jul 27, 2014 01:32
GitHub: LazerRay

Re: [Mod] Enchanting [git] [enchanting]

by LazerRay » Post

I'm getting a bug were enchanted armor from 3D-Armor is not rendering properly on the player, instead it comes out as a solid purple blob.

User avatar
jp
Member
Posts: 798
Joined: Wed Dec 18, 2013 09:03
GitHub: kilbith
Location: France

Re: [Mod] Enchanting [git] [enchanting]

by jp » Post

Screenshot please ? It might be an engine or 3d_armor bug.

KCoombes
Member
Posts: 412
Joined: Thu Jun 11, 2015 23:19
In-game: Knatt
Location: SW Florida, USA

Re: [Mod] Enchanting [git] [enchanting]

by KCoombes » Post

Are shields included?

User avatar
jp
Member
Posts: 798
Joined: Wed Dec 18, 2013 09:03
GitHub: kilbith
Location: France

Re: [Mod] Enchanting [git] [enchanting]

by jp » Post

KCoombes wrote:Are shields included?
No, these are not supported.

User avatar
LazerRay
Member
Posts: 147
Joined: Sun Jul 27, 2014 01:32
GitHub: LazerRay

Re: [Mod] Enchanting [git] [enchanting]

by LazerRay » Post

Here are screenshots of the rendering bug I reported:

Default Steel Armor (No enchants)
Image


Same Steel Armor after enchanting
Image

You can see the error message in the second screenshot of what might be happening

User avatar
jp
Member
Posts: 798
Joined: Wed Dec 18, 2013 09:03
GitHub: kilbith
Location: France

Re: [Mod] Enchanting [git] [enchanting]

by jp » Post

Try updating your copy of 3d_armor. Seems outdated.

kosmonautik
Member
Posts: 31
Joined: Fri Jun 24, 2016 10:40
In-game: kosmonautik
Location: Czech Republic
Contact:

Re: [Mod] Enchanting [git] [enchanting]

by kosmonautik » Post

Hello,
I use a 1.4.13 minetest version and it doesn't work. Minetest writes a lua error.

Thanks, kosmonautik

kniffo80
New member
Posts: 2
Joined: Mon Nov 28, 2016 13:08
GitHub: kniffo80

Re: [Mod] Enchanting [git] [enchanting]

by kniffo80 » Post

Same for me. Getting the following error on 0.14.4 Server (Debian):

Code: Select all

2016-12-11 09:32:47: ERROR[Main]: ModError: Failed to load and run script from /root/.minetest/mods/enchanting/init.lua:
2016-12-11 09:32:47: ERROR[Main]: /root/.minetest/mods/enchanting/init.lua:44: attempt to call field 'colorize' (a nil value)
2016-12-11 09:32:47: ERROR[Main]: stack traceback:
2016-12-11 09:32:47: ERROR[Main]: 	/root/.minetest/mods/enchanting/init.lua:44: in function 'get_tooltip'
2016-12-11 09:32:47: ERROR[Main]: 	/root/.minetest/mods/enchanting/init.lua:268: in function 'register_tools'
2016-12-11 09:32:47: ERROR[Main]: 	/root/.minetest/mods/enchanting/init.lua:309: in main chunk

User avatar
Napiophelios
Member
Posts: 1019
Joined: Mon Jul 07, 2014 01:14
GitHub: Napiophelios
IRC: Nappi
In-game: Nappi

Re: [Mod] Enchanting [git] [enchanting]

by Napiophelios » Post

You need to update to the latest dev build of Minetest engine

User avatar
pithy
Member
Posts: 251
Joined: Wed Apr 13, 2016 17:34
GitHub: pithydon

Re: [Mod] Enchanting [git] [enchanting]

by pithy » Post

kosmonautik wrote:Hello,
I use a 1.4.13 minetest version and it doesn't work. Minetest writes a lua error.

Thanks, kosmonautik
kniffo80 wrote:Same for me. Getting the following error on 0.14.4 Server (Debian):

Code: Select all

2016-12-11 09:32:47: ERROR[Main]: ModError: Failed to load and run script from /root/.minetest/mods/enchanting/init.lua:
2016-12-11 09:32:47: ERROR[Main]: /root/.minetest/mods/enchanting/init.lua:44: attempt to call field 'colorize' (a nil value)
2016-12-11 09:32:47: ERROR[Main]: stack traceback:
2016-12-11 09:32:47: ERROR[Main]: 	/root/.minetest/mods/enchanting/init.lua:44: in function 'get_tooltip'
2016-12-11 09:32:47: ERROR[Main]: 	/root/.minetest/mods/enchanting/init.lua:268: in function 'register_tools'
2016-12-11 09:32:47: ERROR[Main]: 	/root/.minetest/mods/enchanting/init.lua:309: in main chunk
Time travelers can avoid a lot of bugs by only using software from one time.

kniffo80
New member
Posts: 2
Joined: Mon Nov 28, 2016 13:08
GitHub: kniffo80

Re: [Mod] Enchanting [git] [enchanting]

by kniffo80 » Post

pithy wrote:
kosmonautik wrote:Hello,
I use a 1.4.13 minetest version and it doesn't work. Minetest writes a lua error.

Thanks, kosmonautik
kniffo80 wrote:Same for me. Getting the following error on 0.14.4 Server (Debian):

Code: Select all

2016-12-11 09:32:47: ERROR[Main]: ModError: Failed to load and run script from /root/.minetest/mods/enchanting/init.lua:
2016-12-11 09:32:47: ERROR[Main]: /root/.minetest/mods/enchanting/init.lua:44: attempt to call field 'colorize' (a nil value)
2016-12-11 09:32:47: ERROR[Main]: stack traceback:
2016-12-11 09:32:47: ERROR[Main]: 	/root/.minetest/mods/enchanting/init.lua:44: in function 'get_tooltip'
2016-12-11 09:32:47: ERROR[Main]: 	/root/.minetest/mods/enchanting/init.lua:268: in function 'register_tools'
2016-12-11 09:32:47: ERROR[Main]: 	/root/.minetest/mods/enchanting/init.lua:309: in main chunk
Time travelers can avoid a lot of bugs by only using software from one time.
Hmmm ... explain please ;)

User avatar
pithy
Member
Posts: 251
Joined: Wed Apr 13, 2016 17:34
GitHub: pithydon

Re: [Mod] Enchanting [git] [enchanting]

by pithy » Post

kniffo80 wrote:Hmmm ... explain please ;)
It is common for software from deferent times to not work well together.

They must be time travelers to have versions 1.4.13 and 0.14.4 of minetest.

User avatar
Miniontoby
Member
Posts: 436
Joined: Fri Mar 01, 2019 19:25
IRC: Miniontoby
In-game: Miniontoby
Location: The Netherlands

Re: [Mod] Enchanting [git] [enchanting]

by Miniontoby » Post

Cool mod. Please upload to content.minetest.net So that we can simpler download it in minetest 5.0 versions.
My English isn't very good because I'm Dutch ---- Check my mod "Doorbell" Vote your gang

Post Reply

Who is online

Users browsing this forum: techniX and 3 guests