[Mod] Item magnet and in-world node drops [item_drop]

User avatar
texmex
Member
Posts: 1752
Joined: Mon Jul 11, 2016 21:08
GitHub: tacotexmex
In-game: tacotexmex

Re: [Mod] Item magnet and in-world node drops [item_drop]

by texmex » Post

Excellent, let's mark it as fixed for now.
Mods | Support Mesehub: bc1qluuests9rxmlnvpjrhsnyjg9ucwy6z3r0y3srw

User avatar
FreeGamers
Member
Posts: 641
Joined: Sat May 25, 2019 00:15
GitHub: is proprietary I use NotABug
Location: United States
Contact:

Re: [Mod] Item magnet and in-world node drops [item_drop]

by FreeGamers » Post

A user reported on my server that they could not obtain clay with a shovel. So I tried it with an admin account with creative privs and it worked fine.

But when I log in with a test user account with standard MT privs, clay lumps cannot be obtained when this mod is enabled. Can anyone else reproduce this or verify?

User avatar
texmex
Member
Posts: 1752
Joined: Mon Jul 11, 2016 21:08
GitHub: tacotexmex
In-game: tacotexmex

Re: [Mod] Item magnet and in-world node drops [item_drop]

by texmex » Post

Are you using the latest version?
Mods | Support Mesehub: bc1qluuests9rxmlnvpjrhsnyjg9ucwy6z3r0y3srw

User avatar
FreeGamers
Member
Posts: 641
Joined: Sat May 25, 2019 00:15
GitHub: is proprietary I use NotABug
Location: United States
Contact:

Re: [Mod] Item magnet and in-world node drops [item_drop]

by FreeGamers » Post

texmex wrote:Are you using the latest version?
I was using the previous version. I updated to the latest and we're all good. Clay is dropping from clay blocks with a standard user. Thanks for mentioning the update. I need to start following git repositories and push updates to my server somehow.

User avatar
Clyde
Member
Posts: 148
Joined: Sat Jul 30, 2016 14:23
GitHub: acmgit
In-game: clyde

Re: [Mod] Item magnet and in-world node drops [item_drop]

by Clyde » Post

Hello,
i was testing the mod on my server, but

Code: Select all

2020-03-05 23:26:36: ERROR[Main]: ServerError: AsyncErr: environment_Step: Runtime error from mod '' in callback environment_Step(): /usr/local/share/minetest/builtin/game/item.lua:22: attempt to index local 'img1' (a nil value)
2020-03-05 23:26:36: ERROR[Main]: stack traceback:
2020-03-05 23:26:36: ERROR[Main]: 	/usr/local/share/minetest/builtin/game/item.lua:22: in function 'inventorycube'
2020-03-05 23:26:36: ERROR[Main]: 	...l/share/minetest/games/Smalltech/mods/item_drop/init.lua:124: in function 'collect_item'
2020-03-05 23:26:36: ERROR[Main]: 	...l/share/minetest/games/Smalltech/mods/item_drop/init.lua:292: in function 'pickupfunc'
2020-03-05 23:26:36: ERROR[Main]: 	...l/share/minetest/games/Smalltech/mods/item_drop/init.lua:317: in function 'func'
2020-03-05 23:26:36: ERROR[Main]: 	/usr/local/share/minetest/builtin/common/after.lua:20: in function </usr/local/share/minetest/builtin/common/after.lua:5>
2020-03-05 23:26:36: ERROR[Main]: 	/usr/local/share/minetest/builtin/game/register.lua:429: in function </usr/local/share/minetest/builtin/game/register.lua:413>
2020-03-05 23:26:36: ERROR[Main]: stack traceback:
I use the last git-version of MT.
Greetings, Clyde.

User avatar
texmex
Member
Posts: 1752
Joined: Mon Jul 11, 2016 21:08
GitHub: tacotexmex
In-game: tacotexmex

Re: [Mod] Item magnet and in-world node drops [item_drop]

by texmex » Post

Looks like it’s due to the particle effect. It’s been flaky before. I’ll look into it.
Mods | Support Mesehub: bc1qluuests9rxmlnvpjrhsnyjg9ucwy6z3r0y3srw

User avatar
Hybrid Dog
Member
Posts: 2768
Joined: Thu Nov 01, 2012 12:46
GitHub: HybridDog

Re: [Mod] Item magnet and in-world node drops [item_drop]

by Hybrid Dog » Post

The first parameter passed to minetest.inventorycube is nil. ("attempt to index local 'img1' (a nil value)")
https://github.com/minetest/minetest/bl ... ua#L18-L25
img1 is top from there:
https://github.com/minetest-mods/item_d ... t.lua#L124
Either tiles[1] or tiles[1].name (if tiles[1] is a table) is nil.

‮‪‮
‮‪‮
‮‪‮
‮‪‮
‮‪‮
‮‪‮
‮‪‮
‮‪‮
‮‪

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests