[Modpack] Display Modpack [1.3] [display_modpack]

Thomas-S
Member
 
Posts: 110
Joined: Sun Sep 06, 2015 12:23
Location: Bavaria, Germany
GitHub: Thomas--S
IRC: Thomas-S
In-game: Thomas-S

Re: [Modpack] Display Modpack [1.2] [display_modpack]

by Thomas-S » Wed Mar 06, 2019 10:26

As far as I can see, minetest.is_player() utilizes ObjectRef:is_player() internally.
 

User avatar
Pyrollo
Member
 
Posts: 334
Joined: Mon Jan 08, 2018 15:14
Location: Paris
GitHub: pyrollo
In-game: Naj

Re: [Modpack] Display Modpack [1.2] [display_modpack]

by Pyrollo » Wed Mar 06, 2019 11:00

jas wrote:Is `minetest.is_player' separate from `ObjectRef:is_player'?


I guess so.
[ Display Modpack ] - [ Digiterms ] - [ Crater MG ] - [ LATE ]
 

Thomas-S
Member
 
Posts: 110
Joined: Sun Sep 06, 2015 12:23
Location: Bavaria, Germany
GitHub: Thomas--S
IRC: Thomas-S
In-game: Thomas-S

Re: [Modpack] Display Modpack [1.2] [display_modpack]

by Thomas-S » Fri Mar 08, 2019 08:14

According to the ContentDB, this mod contains non-free media. (https://content.minetest.net/packages/P ... y_modpack/)

Is this still true?

As far as I know, the non-free font got replaced with the metro font.
 

User avatar
Pyrollo
Member
 
Posts: 334
Joined: Mon Jan 08, 2018 15:14
Location: Paris
GitHub: pyrollo
In-game: Naj

Re: [Modpack] Display Modpack [1.2] [display_modpack]

by Pyrollo » Fri Mar 08, 2019 09:41

You are right, non free media have been removed a while ago and replaced by CC licensed ones.
[ Display Modpack ] - [ Digiterms ] - [ Crater MG ] - [ LATE ]
 

User avatar
BirgitLachner
Member
 
Posts: 382
Joined: Thu May 05, 2016 10:18
In-game: Bibs

Re: [Modpack] Display Modpack [1.2] [display_modpack]

by BirgitLachner » Fri Mar 08, 2019 16:10

Thank you for all the attempts to help me. I guess it's another problem. Because I noticed now that when loading the server there is another message, which surely has something to do with it:

ERROR[Main]: The following mods could not be found: "display_lib" "font_lib"


I did not find any reason for that message. At world.mt the mods are activated and I don't see any missing part of the Display-Mod, the file in the Display Modpack Folder are the same.

What is a bit strange ... every time I leave the world, I get the same error message, when trying to change the font.

2019-03-08 18:59:27: ERROR[Main]: ServerError: AsyncErr: ServerThread::run Lua: Runtime error from mod 'font_api' in callback on_leaveplayer(): ...st/bin/../mods/display_modpack/font_api/fontform.lua:24: attempt to call field 'is_player' (a nil value)
2019-03-08 18:59:27: ERROR[Main]: stack traceback:
2019-03-08 18:59:27: ERROR[Main]: ...st/bin/../mods/display_modpack/font_api/fontform.lua:24: in function '?'
2019-03-08 18:59:27: ERROR[Main]: /minetest/bin/../builtin/game/register.lua:412: in function </minetest/bin/../builtin/game/register.lua:392>


Birgit
 

User avatar
Pyrollo
Member
 
Posts: 334
Joined: Mon Jan 08, 2018 15:14
Location: Paris
GitHub: pyrollo
In-game: Naj

Re: [Modpack] Display Modpack [1.2] [display_modpack]

by Pyrollo » Sat Mar 09, 2019 17:39

BirgitLachner wrote:
ERROR[Main]: The following mods could not be found: "display_lib" "font_lib"


display_lib and font_lib are old names of display_api and font_api. I guess you have this message because of remaining lines in your world.mt file that refer to these old names. This is not a problem and you can get rid of this error by removing load_mod_display_lib and load_mod_font_lib lines from the world.mt file.

BirgitLachner wrote:
2019-03-08 18:59:27: ERROR[Main]: ServerError: AsyncErr: ServerThread::run Lua: Runtime error from mod 'font_api' in callback on_leaveplayer(): ...st/bin/../mods/display_modpack/font_api/fontform.lua:24: attempt to call field 'is_player' (a nil value)
2019-03-08 18:59:27: ERROR[Main]: stack traceback:
2019-03-08 18:59:27: ERROR[Main]: ...st/bin/../mods/display_modpack/font_api/fontform.lua:24: in function '?'
2019-03-08 18:59:27: ERROR[Main]: /minetest/bin/../builtin/game/register.lua:412: in function </minetest/bin/../builtin/game/register.lua:392>


You can see here the error is about font_api (and not anymore font_lib). That is the current name of the mod.

I don't know what to say except : be sure to use the last version of display_modpack (did you get it from git or from contentdb ? or other ?) and be sure to use at least 0.4.17.1 version of Minetest (exact vesion number is displayed in the "credits" tab of the main menu).
[ Display Modpack ] - [ Digiterms ] - [ Crater MG ] - [ LATE ]
 

User avatar
Pyrollo
Member
 
Posts: 334
Joined: Mon Jan 08, 2018 15:14
Location: Paris
GitHub: pyrollo
In-game: Naj

Re: [Modpack] Display Modpack [1.3] [display_modpack]

by Pyrollo » Sat Mar 09, 2019 21:33

Version 1.3 - Upside down and round and round
Display API now takes benefit of the new Minetest 5.0 ObjectRef:set_rotation method :
Now display nodes can be rotated in any possible ways!

Image


Three conditions to make this work :

  • Use Minetest 5
  • Update Display Modpack to version 1.3
  • Disable "display_rotation_restriction" setting (Mods/display_api)
Attachments
screenshot_20190309_221829.png
(287.93 KiB) Not downloaded yet
Last edited by Pyrollo on Sun May 26, 2019 14:40, edited 1 time in total.
[ Display Modpack ] - [ Digiterms ] - [ Crater MG ] - [ LATE ]
 

User avatar
thomasthespacefox
Member
 
Posts: 94
Joined: Sun Aug 02, 2015 15:00
GitHub: ThomasTheSpaceFox
IRC: ThomasJaguar1212
In-game: thomasthespacefox

Re: [Modpack] Display Modpack [1.3] [display_modpack]

by thomasthespacefox » Wed May 15, 2019 21:07

Pyrollo wrote:Version 1.3 - Upside down and round and round
Display API now takes benefit of the new Minetest 5.0 ObjectRef:set_rotation method :
Now display nodes can be rotated in any possible ways!

Image


Three conditions to make this work :

  • Use Minetest 5
  • Update Display Modpack to version 1.3
  • Disable "display_rotation_restriction" setting (Mods/display_api)


Its not on ContentDB yet. newest version there is 1.2
 

User avatar
Pyrollo
Member
 
Posts: 334
Joined: Mon Jan 08, 2018 15:14
Location: Paris
GitHub: pyrollo
In-game: Naj

Re: [Modpack] Display Modpack [1.3] [display_modpack]

by Pyrollo » Thu May 16, 2019 09:35

thomasthespacefox wrote:Its not on ContentDB yet. newest version there is 1.2


New 1.3.1 release added, waiting for approval.
[ Display Modpack ] - [ Digiterms ] - [ Crater MG ] - [ LATE ]
 

User avatar
uwu
Member
 
Posts: 24
Joined: Sun Jan 21, 2018 15:01

Re: [Modpack] Display Modpack [1.3] [display_modpack]

by uwu » Sun May 26, 2019 13:32

Pyrollo wrote:IMPORTANT: If you use Minetest version 5.0 or above, disable the setting display_rotate_restriction and enjoy rotation of display nodes in every direction.


I couldn't find this setting, where is it?
 

User avatar
Pyrollo
Member
 
Posts: 334
Joined: Mon Jan 08, 2018 15:14
Location: Paris
GitHub: pyrollo
In-game: Naj

Re: [Modpack] Display Modpack [1.3] [display_modpack]

by Pyrollo » Sun May 26, 2019 14:37

Sorry, this setting is no more required since 1.3.1.

Edit: edited posts accordingly.
[ Display Modpack ] - [ Digiterms ] - [ Crater MG ] - [ LATE ]
 

User avatar
Yvanhoe
Member
 
Posts: 131
Joined: Fri Jul 05, 2019 03:18
Location: Japan

Re: [Modpack] Display Modpack [1.3] [display_modpack]

by Yvanhoe » Sat Aug 17, 2019 14:54

Just a small heads up: the link to the Old Wizard font repository is broken in the first post, it should be: https://github.com/pyrollo/font_oldwizard
 

User avatar
Pyrollo
Member
 
Posts: 334
Joined: Mon Jan 08, 2018 15:14
Location: Paris
GitHub: pyrollo
In-game: Naj
 

bennovb
New member
 
Posts: 2
Joined: Tue Nov 19, 2019 22:00

Re: [Modpack] Display Modpack [1.3] [display_modpack]

by bennovb » Tue Nov 19, 2019 22:12

Why do i keep getting this errormessage about init.lua missing?


Code: Select all
2019-11-19 22:55:42: ERROR[Main]: ModError: Failed to load and run script from C:\Minetest\bin\..\mods\display_modpack\display_modpack\init.lua:
2019-11-19 22:55:42: ERROR[Main]: C:\Minetest\bin\..\mods\display_modpack\display_modpack\init.lua: No such file or directory
2019-11-19 22:55:42: ERROR[Main]: Kijk in debug.txt voor details.
2019-11-19 22:55:42: ACTION[Main]: Server: Shutting down


Using on Windows 10
fresh install of;
- minetest-5.1.0-win64
- Display Modpack [1.3]
 

User avatar
Nathan.S
Member
 
Posts: 969
Joined: Wed Sep 24, 2014 17:47
Location: Bigsby Texas
GitHub: NathanSalapat
IRC: NathanS21
In-game: NathanS21

Re: [Modpack] Display Modpack [1.3] [display_modpack]

by Nathan.S » Wed Nov 20, 2019 04:00

Looks like you have your modpack in an extra folder. There should be no display_modpack folder in the display_modpack folder. You might want to download a fresh copy of the mod_pack.
I record Minetest videos, Mod reviews, Modding tutorials, and Lets plays.
Check out my website, and brand new Minetest Modding Course
 

bennovb
New member
 
Posts: 2
Joined: Tue Nov 19, 2019 22:00

Re: [Modpack] Display Modpack [1.3] [display_modpack]

by bennovb » Wed Nov 20, 2019 14:52

Nathan.S wrote:Looks like you have your modpack in an extra folder. There should be no display_modpack folder in the display_modpack folder. You might want to download a fresh copy of the mod_pack.


Looks like your right!
As a novice user i didn't understand at first, but your advice was very helpful, thanks.

I unpacked (moved) each individual mod to the modsfolder and now it works fine,
 

User avatar
Pyrollo
Member
 
Posts: 334
Joined: Mon Jan 08, 2018 15:14
Location: Paris
GitHub: pyrollo
In-game: Naj

Re: [Modpack] Display Modpack [1.3] [display_modpack]

by Pyrollo » Wed Nov 20, 2019 15:09

You can do that but the simpliest way is to unpack display_modpack folder into your mod folder.
The problem was having a second display_modpack folder in the display_modpack folder.
[ Display Modpack ] - [ Digiterms ] - [ Crater MG ] - [ LATE ]
 

Previous

Return to Mod Releases



Who is online

Users browsing this forum: No registered users and 7 guests