[Mod] Pipeworks [git] [pipeworks]

User avatar
VanessaE
Moderator
 
Posts: 4117
Joined: Sun Apr 01, 2012 12:38
Location: Waynesville, NC
GitHub: VanessaE
IRC: VanessaE
In-game: VanessaE

Re: [Mod] Pipeworks [git] [pipeworks]

by VanessaE » Sun Jan 14, 2018 21:39

Make sure your mod depends on pipeworks (as in put it in depends.txt), then just call pipeworks' functions normally, none of that rawget() stuff.
You might like some of my stuff: Plantlife ~ More Trees ~ Home Decor ~ Pipeworks ~ HDX Textures (16-512px)
 

Joseph13
Member
 
Posts: 148
Joined: Tue Dec 06, 2016 05:35
In-game: Joseph

Re: [Mod] Pipeworks [git] [pipeworks]

by Joseph13 » Fri Jan 19, 2018 17:50

When I try to play a world with the mod enabled it says that devices.lua attempted to index global ‘screwdriver’( a nil value). Probably an outdated problem? I’m running the latest 0.5 build. Any ideas? @VenessaE
I love Hobby Drones! They are awesome! Also I love FPV rc cars!!!
 

Mineminer
Member
 
Posts: 58
Joined: Mon Mar 05, 2018 04:05

Re: [Mod] Pipeworks [git] [pipeworks]

by Mineminer » Wed Mar 07, 2018 04:51

Why is my 0.4.16 server not booting up properly with regards to Pipeworks? I had triple checked the naming closely on the file and have everything enabled for that world in question (as far I can tell).

Here is the error output...
Code: Select all
06.03 23:58:49 [Server] ERROR[Main .../.minetest/mods/pipeworks/init.lua:140: in main chunk
06.03 23:58:49 [Server] ERROR[Main [C]: in function 'dofile'
06.03 23:58:49 [Server] ERROR[Main .../.minetest/mods/pipeworks/compat-chests.lua:94: in main chunk
06.03 23:58:49 [Server] ERROR[Main ...sr/bin/../share/minetest/builtin/common/misc_helpers.lua:590: in function 'copy'
06.03 23:58:49 [Server] ERROR[Main stack traceback:
06.03 23:58:49 [Server] ERROR[Main ...sr/bin/../share/minetest/builtin/common/misc_helpers.lua:590: table index is nil
06.03 23:58:49 [Server] ERROR[Main ModError: Failed to load and run script from /.minetest/mods/pipeworks/init.lua:


Please do let me know why this particular mod only is having problems booting up? I can confirm that others are booting up properly as shown below...
Code: Select all
06.03 23:58:49 [Server] INFO [MOD] Protector Redo loaded   0
06.03 23:58:49 [Server] INFO [Protector] pvp_protect is disabled   0
06.03 23:58:49 [Server] INFO [OK] Mesecons


Thanks in advance!
 

User avatar
VanessaE
Moderator
 
Posts: 4117
Joined: Sun Apr 01, 2012 12:38
Location: Waynesville, NC
GitHub: VanessaE
IRC: VanessaE
In-game: VanessaE

Re: [Mod] Pipeworks [git] [pipeworks]

by VanessaE » Wed Mar 07, 2018 09:24

You forgot the first part of the error, so I can't tell what went wrong.
You might like some of my stuff: Plantlife ~ More Trees ~ Home Decor ~ Pipeworks ~ HDX Textures (16-512px)
 

User avatar
RSLRedstonier
Member
 
Posts: 422
Joined: Wed May 10, 2017 21:00
Location: some were in middle earth
GitHub: RSL-Redstonier
In-game: RSLRedstonier

Re: [Mod] Pipeworks [git] [pipeworks]

by RSLRedstonier » Wed Mar 07, 2018 15:16

have you changed any of the code as pipeworks is a fairly complicated mod and it would be easy to accidently break if you don't know what your doing
"A programmer is just a tool which converts caffeine into code"

try out my skytest mod always being updated!
https://forum.minetest.net/viewtopic.php?f=9&t=17568
 

Mineminer
Member
 
Posts: 58
Joined: Mon Mar 05, 2018 04:05

Re: [Mod] Pipeworks [git] [pipeworks]

by Mineminer » Wed Mar 07, 2018 17:15

VanessaE wrote:You forgot the first part of the error, so I can't tell what went wrong.

Here is the whole between start and shut down...

Code: Select all
06.03 23:58:49 [Server] ERROR[Main .../.minetest/mods/pipeworks/init.lua:140: in main chunk
06.03 23:58:49 [Server] ERROR[Main [C]: in function 'dofile'
06.03 23:58:49 [Server] ERROR[Main .../.minetest/mods/pipeworks/compat-chests.lua:94: in main chunk
06.03 23:58:49 [Server] ERROR[Main ...sr/bin/../share/minetest/builtin/common/misc_helpers.lua:590: in function 'copy'
06.03 23:58:49 [Server] ERROR[Main stack traceback:
06.03 23:58:49 [Server] ERROR[Main ...sr/bin/../share/minetest/builtin/common/misc_helpers.lua:590: table index is nil
06.03 23:58:49 [Server] ERROR[Main ModError: Failed to load and run script from /.minetest/mods/pipeworks/init.lua:
06.03 23:58:49 [Server] INFO [MOD] Protector Redo loaded   0
06.03 23:58:49 [Server] INFO [Protector] pvp_protect is disabled   0
06.03 23:58:49 [Server] INFO [OK] Mesecons
06.03 23:58:49 [Server] WARNING[Main [xban] Unable to load database: /.minetest/worlds/world/xban.db: No such file or directory
06.03 23:58:49 [Server] WARNING[Main NodeDefManager: Ignoring CONTENT_IGNORE redefinition
06.03 23:58:49 [Server] Main Using world specified by --worldname on the command line


RSLRedstonier wrote:have you changed any of the code as pipeworks is a fairly complicated mod and it would be easy to accidently break if you don't know what your doing


No I installed it by unzipping the zip file and renaming the folder to "pipeworks" and of course enabling it for the world.
 

User avatar
VanessaE
Moderator
 
Posts: 4117
Joined: Sun Apr 01, 2012 12:38
Location: Waynesville, NC
GitHub: VanessaE
IRC: VanessaE
In-game: VanessaE

Re: [Mod] Pipeworks [git] [pipeworks]

by VanessaE » Wed Mar 07, 2018 17:35

That's not all of it. Not only does Minetest print a some other startup stuff before mods are actually loaded, the first line of the error text would normally tell just what failed (at least it would give a filename and a line number to look at). Maybe run Minetest from a terminal and paste the entire contents here. Sometimes debug.txt doesn't catch everything.

All of that aside, Pipeworks is known to run just fine in 0.4.16, but if you can, you should fetch Minetest engine from its git repository, and build/install from the backport-0.4 branch. That's generally regarded as stable, and recommended by Minetest developers, as there have been many bug fixes committed to there since 0.4.16-release. Don't forget to update minetest_game as well (also from the backport-0.4 branch).
You might like some of my stuff: Plantlife ~ More Trees ~ Home Decor ~ Pipeworks ~ HDX Textures (16-512px)
 

Mineminer
Member
 
Posts: 58
Joined: Mon Mar 05, 2018 04:05

Re: [Mod] Pipeworks [git] [pipeworks]

by Mineminer » Wed Mar 07, 2018 18:09

VanessaE wrote:That's not all of it. Not only does Minetest print a some other startup stuff before mods are actually loaded, the first line of the error text would normally tell just what failed (at least it would give a filename and a line number to look at). Maybe run Minetest from a terminal and paste the entire contents here. Sometimes debug.txt doesn't catch everything.


Here is the RAW output https://pastebin.com/ysVHhrAS itself, maybe that will help alongside of the console output. It's the last one down of the latest booting cycle.

(This forum is being stupid and won't let me post the actual file so I just pasted it in PasteBin)
 

User avatar
VanessaE
Moderator
 
Posts: 4117
Joined: Sun Apr 01, 2012 12:38
Location: Waynesville, NC
GitHub: VanessaE
IRC: VanessaE
In-game: VanessaE

Re: [Mod] Pipeworks [git] [pipeworks]

by VanessaE » Wed Mar 07, 2018 19:06

Odd, the bit I was interested in was there in your pastes, I just didn't see it because your logs were reversed (oldest output first). I'm at a loss to explain the crash. However...um... what is multicraft? is that some other subgame? And why is this all under /home/minecraft?
You might like some of my stuff: Plantlife ~ More Trees ~ Home Decor ~ Pipeworks ~ HDX Textures (16-512px)
 

Mineminer
Member
 
Posts: 58
Joined: Mon Mar 05, 2018 04:05

Re: [Mod] Pipeworks [git] [pipeworks]

by Mineminer » Wed Mar 07, 2018 19:10

VanessaE wrote:Odd, the bit I was interested in was there in your pastes, I just didn't see it because your logs were reversed (oldest output first). I'm at a loss to explain the crash. However...um... what is multicraft? is that some other subgame? And why is this all under /home/minecraft?


Well because the host and I was concerned about me being able to manage the server remotely. They had worked to get the Minetest instance to be able to operate on the Multicraft's control panel in a generic sense. That way I can view the console, edit files, and other basic operations without having to SSHing in or having to contact them.
 

Mineminer
Member
 
Posts: 58
Joined: Mon Mar 05, 2018 04:05

Re: [Mod] Pipeworks [git] [pipeworks]

by Mineminer » Wed Mar 07, 2018 22:53

VanessaE wrote:Odd, the bit I was interested in was there in your pastes, I just didn't see it because your logs were reversed (oldest output first). I'm at a loss to explain the crash. However...um... what is multicraft? is that some other subgame? And why is this all under /home/minecraft?


The provider had figured out why the server having the issue... They said...

the mod wants the linux server locale to be "en_US.UTF-8" or similar.


I never honestly seen this requirement. :(
 

User avatar
VanessaE
Moderator
 
Posts: 4117
Joined: Sun Apr 01, 2012 12:38
Location: Waynesville, NC
GitHub: VanessaE
IRC: VanessaE
In-game: VanessaE

Re: [Mod] Pipeworks [git] [pipeworks]

by VanessaE » Wed Mar 07, 2018 22:58

Minetest mods do not have any concept of locale, let alone Pipeworks. More likely it was the engine that needed it.
You might like some of my stuff: Plantlife ~ More Trees ~ Home Decor ~ Pipeworks ~ HDX Textures (16-512px)
 

Mineminer
Member
 
Posts: 58
Joined: Mon Mar 05, 2018 04:05

Re: [Mod] Pipeworks [git] [pipeworks]

by Mineminer » Wed Mar 07, 2018 23:43

VanessaE wrote:Minetest mods do not have any concept of locale, let alone Pipeworks. More likely it was the engine that needed it.


Ahh I see, must been a "component" that needed it that didn't "kick into gears" until I tried using Pipeworks. Given that the Minetest instance worked before I added the mods and it.
 

Dubfiance
New member
 
Posts: 1
Joined: Fri Apr 06, 2018 18:19
IRC: Dubfiance
In-game: Dubfiance

Re: [Mod] Pipeworks [git] [pipeworks]

by Dubfiance » Fri Apr 06, 2018 18:30

I cant get this to work I get:

Code: Select all
2018-04-06 11:14:32: ERROR[Main]: Irrlicht: Switch to fullscreen: The graphics mode is not supported.
2018-04-06 11:14:44: ERROR[Main]: The following mods could not be found: "beacon_master" "monorail"
2018-04-06 11:14:44: WARNING[Main]: NodeDefManager: Ignoring CONTENT_IGNORE redefinition
2018-04-06 11:14:44: WARNING[Main]: Field "tile_images": Deprecated; new name is "tiles".
2018-04-06 11:14:44: WARNING[Main]: Field "light_propagates": Deprecated; determined from paramtype
2018-04-06 11:14:44: WARNING[Main]: Undeclared global variable "HUD_ENABLE_HUNGER" accessed at ...s\common\Minetest\bin\..\mods\hud_hunger\hud/builtin.lua:41
2018-04-06 11:14:44: WARNING[Main]: Node 'light_source' value exceeds maximum, limiting to maximum: beacon:bluebeam
2018-04-06 11:14:44: WARNING[Main]: Node 'light_source' value exceeds maximum, limiting to maximum: beacon:redbeam
2018-04-06 11:14:44: WARNING[Main]: Node 'light_source' value exceeds maximum, limiting to maximum: beacon:greenbeam
2018-04-06 11:14:44: WARNING[Main]: Node 'light_source' value exceeds maximum, limiting to maximum: beacon:purplebeam
2018-04-06 11:14:44: ERROR[Main]: ModError: Failed to load and run script from C:\Program Files (x86)\Steam\steamapps\common\Minetest\bin\..\mods\pipeworks\init.lua:
2018-04-06 11:14:44: ERROR[Main]: ...s\common\Minetest\bin\..\builtin\common\misc_helpers.lua:590: table index is nil
2018-04-06 11:14:44: ERROR[Main]: stack traceback:
2018-04-06 11:14:44: ERROR[Main]:    ...s\common\Minetest\bin\..\builtin\common\misc_helpers.lua:590: in function 'copy'
2018-04-06 11:14:44: ERROR[Main]:    ...\common\Minetest\bin\..\mods\pipeworks/compat-chests.lua:94: in main chunk
2018-04-06 11:14:44: ERROR[Main]:    [C]: in function 'dofile'
2018-04-06 11:14:44: ERROR[Main]:    ...steamapps\common\Minetest\bin\..\mods\pipeworks\init.lua:140: in main chunk
2018-04-06 11:14:44: ERROR[Main]: Check debug.txt for details.


I have the Mese mods enabled.
 

mcalex
New member
 
Posts: 1
Joined: Mon Apr 23, 2018 08:03
 

Previous

Return to Mod Releases



Who is online

Users browsing this forum: No registered users and 6 guests