[Mod] Craft Guide Mod Renewed [cgmr]

vktRus
Member
 
Posts: 67
Joined: Wed May 01, 2013 07:23

by vktRus » Mon May 06, 2013 14:28

Ubuntu 12.04 LTS, minetestc55 0.4.6
From this site:
launchpad.net/~minetestdevs/+archive/stable?field.series_filter=precise
Maybe creative mode ON?
I am set creative mode OFF.
Last edited by vktRus on Mon May 06, 2013 14:29, edited 1 time in total.
 

deivan
Member
 
Posts: 452
Joined: Fri Feb 15, 2013 10:16
Location: Brazil. :D

by deivan » Mon May 06, 2013 14:29

I started a new game, copied from the download link the mod and the library (domb). All working with the ladder in the first test. Maybe you have a old version of the mod, please, download again.
-*-
A fault version of the mod...
Download from here:
http://www.novoseusadosinformatica.com.br/arq/minetest/DOM-modpak-cgmr.zip
http://www.novoseusadosinformatica.com.br/arq/minetest/DOM-modpak-domb.zip
Last edited by deivan on Mon May 06, 2013 14:33, edited 1 time in total.
 

vktRus
Member
 
Posts: 67
Joined: Wed May 01, 2013 07:23

by vktRus » Mon May 06, 2013 14:32

I am use DOM [DOM-modpack-all]
Version 20130422.
My server 217.112.36.179
Last edited by vktRus on Mon May 06, 2013 14:33, edited 1 time in total.
 

deivan
Member
 
Posts: 452
Joined: Fri Feb 15, 2013 10:16
Location: Brazil. :D

by deivan » Mon May 06, 2013 14:33

Hum... Maybe this version have a fault, I will check. Thanks.
Is it, problem solved. Please, test again.
Last edited by deivan on Mon May 06, 2013 14:36, edited 1 time in total.
 

deivan
Member
 
Posts: 452
Joined: Fri Feb 15, 2013 10:16
Location: Brazil. :D

by deivan » Mon May 06, 2013 15:57

All mods updated today. Including the modpack-all.
 

vktRus
Member
 
Posts: 67
Joined: Wed May 01, 2013 07:23

by vktRus » Mon May 06, 2013 16:20

I am redownload. Don't work.
Sorry, but i am install original Craft guid. Nice work.
 

deivan
Member
 
Posts: 452
Joined: Fri Feb 15, 2013 10:16
Location: Brazil. :D

by deivan » Mon May 06, 2013 17:13

Strange... No fails?
 

vktRus
Member
 
Posts: 67
Joined: Wed May 01, 2013 07:23

by vktRus » Mon May 06, 2013 17:21

No errors.
Do a project on github.com
Last edited by vktRus on Mon May 06, 2013 17:23, edited 1 time in total.
 

deivan
Member
 
Posts: 452
Joined: Fri Feb 15, 2013 10:16
Location: Brazil. :D

by deivan » Mon May 06, 2013 17:27

A project in the github.com don't help me to solve this bug... You don't see any recipe but don't have errors, correct?
Last edited by deivan on Mon May 06, 2013 17:28, edited 1 time in total.
 

sapier
Developer
 
Posts: 763
Joined: Tue Aug 16, 2011 18:17

by sapier » Mon May 06, 2013 18:01

Ok I assume this is more correct thread for error reports.

Current (20130506) main post version of cgmr and domb
minetest-0.4.6 stable
only minetest_game and common mods (not quite sure which version)

result --> not even opening craftguide menu on rightclick
DON'T mention coding style!
(c) sapier all rights reserved
 

deivan
Member
 
Posts: 452
Joined: Fri Feb 15, 2013 10:16
Location: Brazil. :D

by deivan » Mon May 06, 2013 18:07

Is a game engine bug... I think. Sometimes happen. Try get the item back and add again to the same place.
 

deivan
Member
 
Posts: 452
Joined: Fri Feb 15, 2013 10:16
Location: Brazil. :D

by deivan » Mon May 06, 2013 19:56

I have the same issue with the windows version running with the wine, I will search the cause of it. Working...
 

vktRus
Member
 
Posts: 67
Joined: Wed May 01, 2013 07:23

by vktRus » Mon May 06, 2013 19:59

Guys, make a one stable version, pls )
 

deivan
Member
 
Posts: 452
Joined: Fri Feb 15, 2013 10:16
Location: Brazil. :D

by deivan » Mon May 06, 2013 20:12

Well, last time I start translating things and my stable versions become a unstable version... Sorry, but I am working to find the problem and solve it. Don't worry, a stable versions is ready ASAP.
 

deivan
Member
 
Posts: 452
Joined: Fri Feb 15, 2013 10:16
Location: Brazil. :D

by deivan » Mon May 06, 2013 20:57

Ok, problem found and already solved, I need some time to make a dual version (compatible with Windows and GNU Linux versions of the game). I update soon.
 

deivan
Member
 
Posts: 452
Joined: Fri Feb 15, 2013 10:16
Location: Brazil. :D

by deivan » Mon May 06, 2013 21:21

Ok, new version in the download server. Ready for test.
 

deivan
Member
 
Posts: 452
Joined: Fri Feb 15, 2013 10:16
Location: Brazil. :D

by deivan » Tue May 07, 2013 00:05

After many tests I don't am capable to reproduce the fail reported by sapier (dont see the formspec from the node) then I make a blind workaround, now every time you click or punch the pc the formspec is generated again, I don't have side effects here then I think this solve this case without create another case.

Then today I solved two bugs:
1) Forspec don't is loading from sapier (but I don't know if will work to him, I waiting for a return)
2) Don't load of recipes in other versions. Here is working, anyway I tested in the windows old but 4.6 version and don't is working, then I added a extra code do cover other options. I need someone who have the problem testing it to.

Anyway thanks, every report of problem is a possibility to make a better mod. ;)
Last edited by deivan on Tue May 07, 2013 00:06, edited 1 time in total.
 

vktRus
Member
 
Posts: 67
Joined: Wed May 01, 2013 07:23
 

sapier
Developer
 
Posts: 763
Joined: Tue Aug 16, 2011 18:17

by sapier » Tue May 07, 2013 18:52

sorry still doesn't work for me
DON'T mention coding style!
(c) sapier all rights reserved
 

vktRus
Member
 
Posts: 67
Joined: Wed May 01, 2013 07:23
 

deivan
Member
 
Posts: 452
Joined: Fri Feb 15, 2013 10:16
Location: Brazil. :D

by deivan » Tue May 07, 2013 22:10

Sapier, if don't show the menu at the first time and you get the item back and deploy again and don't see the menu. Give some punches. For each try a new form is generated then I don't know how is possible in your game the menu never appear. Maybe a 64bits specific problem with some of my vars? I don't know, I need more data about your version of the game or a copy of it but if is a 64 bits don't will work here ( I have a 686 kernel). :-/
 

vktRus
Member
 
Posts: 67
Joined: Wed May 01, 2013 07:23

by vktRus » Wed May 08, 2013 14:40

Server crush:

Code: Select all
18:14:16: ERROR[main]: ServerEnvironment::deactivateFarObjects(): id=437 m_static_exists=true but static data doesn't actually exist in (-7,1,-7)
WARNING: StaticObjectList::remove(): id=437 not found
18:14:16: ERROR[main]: ServerEnvironment::deactivateFarObjects(): id=440 m_static_exists=true but static data doesn't actually exist in (-7,1,-8)
WARNING: StaticObjectList::remove(): id=440 not found
18:14:16: ERROR[main]: ServerEnvironment::deactivateFarObjects(): id=441 m_static_exists=true but static data doesn't actually exist in (-8,1,-7)
WARNING: StaticObjectList::remove(): id=441 not found
18:14:16: ERROR[main]: ServerEnvironment::deactivateFarObjects(): id=442 m_static_exists=true but static data doesn't actually exist in (-8,1,-7)
WARNING: StaticObjectList::remove(): id=442 not found
18:14:16: ERROR[main]: ServerEnvironment::deactivateFarObjects(): id=444 m_static_exists=true but static data doesn't actually exist in (-7,1,-7)
WARNING: StaticObjectList::remove(): id=444 not found
18:14:16: ERROR[main]: ServerEnvironment::deactivateFarObjects(): id=447 m_static_exists=true but static data doesn't actually exist in (-8,1,-7)
WARNING: StaticObjectList::remove(): id=447 not found
18:14:16: ERROR[main]: ServerEnvironment::deactivateFarObjects(): id=448 m_static_exists=true but static data doesn't actually exist in (-8,1,-7)
WARNING: StaticObjectList::remove(): id=448 not found
18:14:16: ERROR[main]: ServerEnvironment::deactivateFarObjects(): id=450 m_static_exists=true but static data doesn't actually exist in (-7,1,-8)
WARNING: StaticObjectList::remove(): id=450 not found
18:14:16: ERROR[main]: ServerEnvironment::deactivateFarObjects(): id=451 m_static_exists=true but static data doesn't actually exist in (-7,1,-7)
WARNING: StaticObjectList::remove(): id=451 not found
18:14:16: ERROR[main]: ERROR: An unhandled exception occurred: ServerError: LuaError: error: ...inetest/.minetest/mods/minetest/DOM/cgmr/rotinas.lua:295: attempt to concatenate global 'local_receita_nome'
 (a nil value)
18:14:16: ERROR[main]: stack traceback:

In thread b6d17700:
/build/buildd/minetestc55-201305062007/src/main.cpp:2024: int main(int, char**): Assertion '0' failed.
Debug stacks:
DEBUG STACK FOR THREAD b6d17700:
#0  int main(int, char**)
(Leftover data: #1  Dedicated server branch)
(Leftover data: #2  virtual void ServerMap::save(ModifiedState))
(Leftover data: #3  virtual void ServerMap::saveBlock(MapBlock*))
(Leftover data: #4  void ItemStack::serialize(std::ostream&) const)
 

deivan
Member
 
Posts: 452
Joined: Fri Feb 15, 2013 10:16
Location: Brazil. :D

by deivan » Wed May 08, 2013 19:37

The line 295, don't have reference to this var in the current version. I regenerated all my downloads in the server now...
Try download again and say to me if is working now.

Waiting...
Last edited by deivan on Wed May 08, 2013 19:37, edited 1 time in total.
 

vktRus
Member
 
Posts: 67
Joined: Wed May 01, 2013 07:23

by vktRus » Thu May 09, 2013 22:15

Code: Select all
02:12:28: ERROR[main]: ERROR: An unhandled exception occurred: ServerError: LuaError: error: ...netest/.minetest/mods/minetest/DOM/watch/rotinas.lua:134: attempt to index a nil value
02:12:28: ERROR[main]: stack traceback:

In thread b6d86700:
/build/buildd/minetestc55-201305062007/src/main.cpp:2024: int main(int, char**): Assertion '0' failed.
Debug stacks:
DEBUG STACK FOR THREAD b6d86700:
#0  int main(int, char**)
(Leftover data: #1  Dedicated server branch)
(Leftover data: #2  virtual void ServerMap::save(ModifiedState))
(Leftover data: #3  virtual void ServerMap::saveBlock(MapBlock*))
 

deivan
Member
 
Posts: 452
Joined: Fri Feb 15, 2013 10:16
Location: Brazil. :D

by deivan » Thu May 09, 2013 22:43

Ok, 134. I will check it.

Ops, this fail is occurring in another mod, the watch, I will check it.
Last edited by deivan on Thu May 09, 2013 22:45, edited 1 time in total.
 

PreviousNext

Return to Mod Releases



Who is online

Users browsing this forum: No registered users and 11 guests