Page 1 of 6

[Mod] Experimental mapgen [mg]

PostPosted: Sat Sep 21, 2013 16:26
by Nore

mg - Experimental Mapgen



A custom Lua-mapgen, with biomes, caves, villages, cliffs and ore generation.
Biomes:
  • Ocean
  • Dry grasslands
  • Wet grasslands
  • Forest
  • Jungle
  • Savanna
  • Desert
  • Tundra
  • Taiga
  • Beach
To use, enable the mod before playing a world for the first time (do not use it in an already used world).
Github repo: https://github.com/minetest-mods/mg
Screenshots:
+ Click to open!

PostPosted: Sat Sep 21, 2013 17:17
by jin_xi
very nice!

PostPosted: Sat Sep 21, 2013 17:21
by mauvebic
along with blockmen's wasteland mod, these would all make awesome biomes for the default mapgen (which could use some more biomes) :-)

PostPosted: Sat Sep 21, 2013 20:06
by philipbenr
I get this error:

Code: Select all
13:03:09: ERROR[main]: Failed to load and run script from
13:03:09: ERROR[main]: C:\Users\----\Game Data\minetest-0.4.7 - Copy\bin\..\mods\mg\init.lua:
13:03:09: ERROR[main]: ...\Game Data\minetest-0.4.7 - Copy\bin\..\mods\mg\init.lua:4: attempt to call field 'register_on_mapgen_init' (a nil value)
13:03:09: ERROR[main]: stack traceback:
13:03:09: ERROR[main]:     ...\Game Data\minetest-0.4.7 - Copy\bin\..\mods\mg\init.lua:4: in main chunk
13:03:09: ERROR[main]: =======END OF ERROR FROM LUA ========


I run windows and I have a fairly new version of 0.4.7 from minetest github.

I want this so bad!!

PS: +100

PostPosted: Sat Sep 21, 2013 20:38
by PilzAdam
philipbenr wrote:I get this error:

Code: Select all
13:03:09: ERROR[main]: Failed to load and run script from
13:03:09: ERROR[main]: C:\Users\----\Game Data\minetest-0.4.7 - Copy\bin\..\mods\mg\init.lua:
13:03:09: ERROR[main]: ...\Game Data\minetest-0.4.7 - Copy\bin\..\mods\mg\init.lua:4: attempt to call field 'register_on_mapgen_init' (a nil value)
13:03:09: ERROR[main]: stack traceback:
13:03:09: ERROR[main]:     ...\Game Data\minetest-0.4.7 - Copy\bin\..\mods\mg\init.lua:4: in main chunk
13:03:09: ERROR[main]: =======END OF ERROR FROM LUA ========


I run windows and I have a fairly new version of 0.4.7 from minetest github.

I want this so bad!!

PS: +100

Your Minetest version is outdated.

PostPosted: Sat Sep 21, 2013 21:37
by philipbenr
I can. This is soooooo awesome. I love this mod, and will use for a long time to come.

PostPosted: Sat Sep 21, 2013 22:10
by sfan5
Quick Update:
  • Wells added to Villages
I also reworked the building spawn code because it was broken
Image

PostPosted: Sun Sep 22, 2013 00:31
by paramat
Wow you even created flat areas for villages, i will have to study how you did this.
Good to see you include savanna and a dry grass texture, i just added both to slabrealm mod. Your biome system is similar to the slabrealm one:

Image

Hybrid Dog wrote:↓primitive, but fast, river system↓

Nice, how did you generate it, is it at sea level?

PostPosted: Sun Sep 22, 2013 01:25
by Inocudom
paramat wrote:Wow you even created flat areas for villages, i will have to study how you did this.
Good to see you include savanna and a dry grass texture, i just added both to slabrealm mod. Your biome system is similar to the slabrealm one:

http://i.imgur.com/ZOt7zx0.gif

Hybrid Dog wrote:↓primitive, but fast, river system↓

Nice, how did you generate it, is it at sea level?


The way I look at it, Hybrid Dog, paramat, and Nore could work together.

PostPosted: Sun Sep 22, 2013 02:39
by paramat
We already do by reading each others code :)

PostPosted: Sun Sep 22, 2013 05:09
by Nore
paramat, I looked at your biome map to create mine ;)
Moreover, I finally fixed the caves (the problem was that coordinates were floating-point). So that means: no more buggy caves and shadows, so caves are near the surface again.

PostPosted: Sun Sep 22, 2013 07:14
by paramat
Cool :) I look forward to trying this mapgen in 0.4.8 stable. I realised this must be the flattening and smoothing-of-transition methods you have mentioned before.

PostPosted: Sun Sep 22, 2013 07:17
by Nore
Not exactly, but not for from it (the thing I had done was too slow and a bit buggy).

PostPosted: Sun Sep 22, 2013 07:24
by sfan5
Pinetrees incoming!
Image

PostPosted: Sun Sep 22, 2013 07:25
by paramat
Best pines i've seen, now you can have taiga and tundra biomes and have all 8 biomes.

PostPosted: Sun Sep 22, 2013 07:33
by Nore
Now pines generate in taiga biomes, and have snow on the top!

PostPosted: Sun Sep 22, 2013 08:17
by paramat
There's a new screenshot in the first post of the snowy pines, they are sooo beautiful, i have a 'thing' for snowy landscapes (and north European black metal of course).

PostPosted: Sun Sep 22, 2013 08:26
by sfan5
paramat wrote:There's a new screenshot in the first post

I made that screenshot :)

PostPosted: Sun Sep 22, 2013 09:17
by Nore
We need builders for the villages:
* the buildings should not be too big
* they should use default materials

Building ideas:
- Forge
- Inn
- Church
- Library
- Several house types
- etc.

PostPosted: Sun Sep 22, 2013 09:59
by sfan5
New Screenshot in the first post!
Image
New Buildings:
* More houses
* Fountains
* Cotton fields

PostPosted: Sun Sep 22, 2013 10:43
by Sokomine
Nore wrote:We need builders for the villages:

It would be great to have a place to exchange schematics of houses in the new, compact .mts format.

PostPosted: Sun Sep 22, 2013 11:50
by aron1263
PilzAdam wrote:
philipbenr wrote:I get this error:
Code: Select all
13:03:09: ERROR[main]: Failed to load and run script from
13:03:09: ERROR[main]: C:\Users\----\Game Data\minetest-0.4.7 - Copy\bin\..\mods\mg\init.lua:
13:03:09: ERROR[main]: ...\Game Data\minetest-0.4.7 - Copy\bin\..\mods\mg\init.lua:4: attempt to call field 'register_on_mapgen_init' (a nil value)
13:03:09: ERROR[main]: stack traceback:
13:03:09: ERROR[main]:     ...\Game Data\minetest-0.4.7 - Copy\bin\..\mods\mg\init.lua:4: in main chunk
13:03:09: ERROR[main]: =======END OF ERROR FROM LUA ========
I run windows and I have a fairly new version of 0.4.7 from minetest github.
I want this so bad!!
PS: +100
Your Minetest version is outdated.
Im also having that error but i have the new version of minetest.

PostPosted: Sun Sep 22, 2013 11:57
by sfan5
aron1263 wrote:
PilzAdam wrote:
philipbenr wrote:I get this error:
Code: Select all
13:03:09: ERROR[main]: Failed to load and run script from
13:03:09: ERROR[main]: C:\Users\----\Game Data\minetest-0.4.7 - Copy\bin\..\mods\mg\init.lua:
13:03:09: ERROR[main]: ...\Game Data\minetest-0.4.7 - Copy\bin\..\mods\mg\init.lua:4: attempt to call field 'register_on_mapgen_init' (a nil value)
13:03:09: ERROR[main]: stack traceback:
13:03:09: ERROR[main]:     ...\Game Data\minetest-0.4.7 - Copy\bin\..\mods\mg\init.lua:4: in main chunk
13:03:09: ERROR[main]: =======END OF ERROR FROM LUA ========
I run windows and I have a fairly new version of 0.4.7 from minetest github.
I want this so bad!!
PS: +100
Your Minetest version is outdated.
Im also having that error but i have the new version of minetest.

You need a newer version of Minetest.
Try my or Fess builds

PostPosted: Sun Sep 22, 2013 13:43
by Nore
The villages are now much better: instead of being a bunch of buildings thrown together, there are roads, etc. Moreover, the villages are bigger.

PostPosted: Sun Sep 22, 2013 14:00
by sfan5
Like this
Image
(Screenshot by BlockMen)
or this
Image
(Screenshot by me)