[Modpack] Creatures MOB-Engine [2.3.1] [cme]

dethegeek
New member
 
Posts: 6
Joined: Sat Feb 22, 2014 18:58

by dethegeek » Sat Mar 15, 2014 16:04

Hi

I could not follow this topic since some time. ( For reference : https://forum.minetest.net/viewtopic.php?pid=131202#p131202 )

I'll try the latest version of your mod and report back if this solves my issue. Thanks for your work.

For your information I'm using the latest release of minetest : 0.4.9 stable

Sorry for the soooo long delay.
 

4aiman
Member
 
Posts: 1208
Joined: Mon Jul 30, 2012 05:47

by 4aiman » Sat Mar 15, 2014 17:03

heavy gale wrote:Why are the creatures blinking (light white and grey)?

I'm not sure, how it's now, but back in the 0.4.5 days these was caused by the "same mesh=same light level" approach. So if one mob was in the shadows/underwater then all others which shared the same mesh started to blink or went dark grey...
 

dethegeek
New member
 
Posts: 6
Joined: Sat Feb 22, 2014 18:58

by dethegeek » Sun Mar 16, 2014 12:52

Hi

I just give a try with version 1.1 beta.

The sheeps are funny :D

The bug I had with 1.0 is still there. I observed it with sheeps. I found they are lots of sheeps in a very small and delimited area. This seems happen when I'm moving with free mode enabled (I'm the administrator of my server).

If I logon during the night, the framerate is below 4 FPS even when I stay in a house. I did not tried to go out, because I did not wanted to be killed. The game is unplayable and I could not protect myself agains zombies and ghosts.

I'll create a new world to do some tests need.ed.

I also noticed there are some sheeps in caves, and sometimes they are black, probabli due to the same bug described earlier.
 

Sokomine
Member
 
Posts: 3956
Joined: Sun Sep 09, 2012 17:31
GitHub: Sokomine

by Sokomine » Sun Mar 16, 2014 12:59

dethegeek wrote:I also noticed there are some sheeps in caves, and sometimes they are black, probabli due to the same bug described earlier.

Perhaps those in caves fell down there. As for the black sheep: They might be stuck in blocks. Try to dig those blocks (most of the time it's dirt), and they'll turn white again.

I observed an "invasion" of sheep as well. There where quite a lot roaming around even after a short time.

And: There needs to be a way to sheer them without causing panic to the poor sheep!
A list of my mods can be found here.
 

User avatar
BlockMen
Developer
 
Posts: 768
Joined: Fri Mar 01, 2013 17:24
Location: Germany
GitHub: BlockMen

by BlockMen » Sun Mar 16, 2014 14:16

Since i have no idea yet why it cotinues to spawn that much mobs i cant fix it right now, sorry.
Here a "mod" that removes at least all creatures mobs in the world (if you cant use /clearobjects for some reason)
Attachments
remove_creatures.zip
(3.54 KiB) Downloaded 69 times
Last edited by BlockMen on Sun Mar 16, 2014 14:17, edited 1 time in total.
 

Sokomine
Member
 
Posts: 3956
Joined: Sun Sep 09, 2012 17:31
GitHub: Sokomine

by Sokomine » Sun Mar 16, 2014 18:54

Btw, real black sheep might be something new. Most mobs mobs do have sheep of some kind...but none has a black one :-) I don't want those crazy thrown-in-a-pot-with-dye-sheep from Minecraft. Just the usual colors that come naturally with sheep :-)
A list of my mods can be found here.
 

User avatar
Jordach
Member
 
Posts: 4523
Joined: Mon Oct 03, 2011 17:58
Location: Blender Scene
GitHub: Jordach
IRC: Jordach
In-game: Jordach

by Jordach » Sun Mar 16, 2014 20:24

Sometimes the server crashes when the ghosts punches someone,
Code: Select all
20:17:00: ACTION[ServerThread]: Player Angels_den punched by LuaEntitySAO at (56.6735,4.98,-62.9891), damage 1 HP
20:17:00: ACTION[ServerThread]: Player shadowzone punched by LuaEntitySAO at (-28.1919,2.5,-24.209), damage 1 HP
20:17:02: ACTION[ServerThread]: Angels_den leaves game. List of players: Jordach Daven shadowzone Doctor twoelk
20:17:02: ACTION[ServerThread]: Jordach leaves game. List of players: Daven shadowzone Doctor twoelk
20:17:02: ERROR[main]: ServerError: ...\bin\..\games\minetest_game\mods\creatures/ghost.lua:280: attempt to index local 'p' (a nil value)
20:17:02: ERROR[main]: stack traceback:
20:17:02: ERROR[main]:     ...\bin\..\games\minetest_game\mods\creatures/ghost.lua:280: in function <...\bin\..\games\minetest_game\mods\creatures/ghost.lua:119>
viewtopic.php?f=10&t=19056 Solar Plains Dev Server
 

4aiman
Member
 
Posts: 1208
Joined: Mon Jul 30, 2012 05:47

by 4aiman » Sun Mar 16, 2014 21:11

Sokomine wrote:I don't want those crazy thrown-in-a-pot-with-dye-sheep from Minecraft.

Actually there's ~15% chance for a black sheep to spawn naturally...

Jordach wrote:Sometimes the server crashes when the ghosts punches someone,

Isn't that because you've left and the mod tried to getpos() of your player?
Try to get hurt and then Ctrl+C your client to confirm.
 

User avatar
Jordach
Member
 
Posts: 4523
Joined: Mon Oct 03, 2011 17:58
Location: Blender Scene
GitHub: Jordach
IRC: Jordach
In-game: Jordach

by Jordach » Sun Mar 16, 2014 23:40

4aiman wrote:
Sokomine wrote:I don't want those crazy thrown-in-a-pot-with-dye-sheep from Minecraft.

Actually there's ~15% chance for a black sheep to spawn naturally...

Jordach wrote:Sometimes the server crashes when the ghosts punches someone,

Isn't that because you've left and the mod tried to getpos() of your player?
Try to get hurt and then Ctrl+C your client to confirm.
Angel left the game AFTER being punched by the ghost, so it does appear to be something else.
viewtopic.php?f=10&t=19056 Solar Plains Dev Server
 

4aiman
Member
 
Posts: 1208
Joined: Mon Jul 30, 2012 05:47

by 4aiman » Mon Mar 17, 2014 05:53

Jordach wrote:Angel left the game AFTER being punched by the ghost, so it does appear to be something else.

Message about leaving doesn't show the exact moment I leave even in singleplayer. And Angel had logged out just 2 seconds after was punched.
Server lags + Lua execution speed + ping time could've make server think that one is still online even if one doesn't for 2 seconds.

I'm not the one to tell a developer anything regarding any code written for or used with MT.
I just had this kind of problems when was working on my version of tnt (although that was around a year ago). And when tnt punched me I was getting this kind of error and then was kicked out.

Anyway, there' should be a check for that "p" variable not being nil.
 

lyghtkruz
New member
 
Posts: 2
Joined: Mon Mar 17, 2014 01:33

by lyghtkruz » Mon Mar 17, 2014 18:08

I took a look at the code, but I'm not too familiar with the method which you are using to spawn the creatures. When I had the issue with the sheep spawning, it was because I set fast mode on and flying mode. This was on a server which is normally set to survival mode. My son was lost and I was flying around looking for him to help him get back. It doesn't appear that the limit is actually being used for some reason. You may try to keep an internal count and check for the limit prior to calling the 'spawn' function and a safety check in the spawn function.
 

User avatar
Topywo
Member
 
Posts: 1721
Joined: Fri May 18, 2012 20:27

by Topywo » Mon Mar 17, 2014 19:48

lyghtkruz wrote:My son was lost and I was flying around looking for him to help him get back.


Pressing the key F5 gives your coordinates up left of the screen.
 

lyghtkruz
New member
 
Posts: 2
Joined: Mon Mar 17, 2014 01:33

by lyghtkruz » Wed Mar 19, 2014 10:24

Topywo wrote:
lyghtkruz wrote:My son was lost and I was flying around looking for him to help him get back.


Pressing the key F5 gives your coordinates up left of the screen.


Thanks, but that wasn't the issue. I don't want to go completely off topic here or anything, but my son is 4 (: and he dug himself underground and got lost without another pickaxe. I was looking for his name so I could go dig him out. I did come up with a teleport mod which helps now in that situation.
 

dethegeek
New member
 
Posts: 6
Joined: Sat Feb 22, 2014 18:58

by dethegeek » Sun Mar 23, 2014 08:36

Hi

I wonder if the mod is affected by another. Will try on a new world without other plugin than Creatures.

I tried to understand the code of remove_creatures, without success. Are the creatures spawned saved somewhere to be re-spawned when someone is near of them ?

lyghtkruz wrote: When I had the issue with the sheep spawning, it was because I set fast mode on and flying mode. This was on a server which is normally set to survival mode.


The flying mode may be the cause of my bug..

EDIT : On a new world with only Creatures mod v1.0 (not 1.1) I cannot reproduce the issue I described. I also tried to move fast with fly mode without success. There are only a few creatures spawned, enough to make the game freaky :)
Last edited by dethegeek on Sun Mar 23, 2014 10:51, edited 1 time in total.
 

Josh
Member
 
Posts: 1146
Joined: Fri Jun 29, 2012 23:11
Location: Victoria, Australia

by Josh » Mon Mar 24, 2014 01:32

This is a good mod Blockmen, maybe you could add more animals? also the sheep needs to drop something like a leg of lamb when you kill it. Also you can't replenish your health bar with the rotten flesh in the "Better HUD" mod that you made, it would be good if that could be done also :)
 

Matsetes
Member
 
Posts: 70
Joined: Tue Sep 11, 2012 23:36

by Matsetes » Thu Mar 27, 2014 22:36

I had some crashes and the client said that there is a problem with the line 323 of sheep.lua, which is the one for the jump of the sheep...
Can anyone tell me what I have to do?
 

sawik
Member
 
Posts: 16
Joined: Sun Jan 12, 2014 18:11
Location: Poland
GitHub: Sawiq
In-game: Sawik

by sawik » Fri Mar 28, 2014 08:40

Hi guys! Did someone try to add line_of_sight() function to this mod? It would by nice if the creatures cannot see through walls...
 

User avatar
LuxAtheris
Member
 
Posts: 169
Joined: Fri Oct 25, 2013 00:54
Location: Aether

by LuxAtheris » Fri Mar 28, 2014 10:42

sawik wrote:Hi guys! Did someone try to add line_of_sight() function to this mod? It would by nice if the creatures cannot see through walls...

+1 for this guy over here.
Believe you can and you’re halfway there.
 

rcthomas93
Member
 
Posts: 22
Joined: Mon Apr 22, 2013 03:09

by rcthomas93 » Fri Apr 04, 2014 00:45

Is there any way I could have a spawner that will spawn more than one zombie at a time? For instance, place one spawner, and that spawner will make sure there are always x amount of zombies in the area? Or just have it spawn x amount and disappear?
 

RavonTUS
Member
 
Posts: 11
Joined: Mon Nov 11, 2013 18:02

by RavonTUS » Fri Apr 04, 2014 02:18

Greetings,

Can you tell me which "wool" dependancy this needs?

-Ravon
 

User avatar
LuxAtheris
Member
 
Posts: 169
Joined: Fri Oct 25, 2013 00:54
Location: Aether

by LuxAtheris » Fri Apr 04, 2014 06:58

RavonTUS wrote:Greetings,

Can you tell me which "wool" dependancy this needs?

-Ravon

The default one.
Believe you can and you’re halfway there.
 

User avatar
CraigyDavi
Member
 
Posts: 582
Joined: Sat Aug 10, 2013 13:08
Location: Hampshire, UK
GitHub: davisonio
IRC: davisonio
In-game: CraigyDavi

by CraigyDavi » Fri Apr 04, 2014 14:45

RavonTUS wrote:Greetings,

Can you tell me which "wool" dependancy this needs?

-Ravon

It is probably already installed. It's in minetest_game.
 

Matsetes
Member
 
Posts: 70
Joined: Tue Sep 11, 2012 23:36

by Matsetes » Mon Apr 07, 2014 06:47

I had TOO MUCH crashes and the client said that there is a problem with the line 323 of sheep.lua, which is the one for the jump of the sheep...
Can anyone tell me what I have to do?
I like very much your mod but I cannot play that way
 

User avatar
BlockMen
Developer
 
Posts: 768
Joined: Fri Mar 01, 2013 17:24
Location: Germany
GitHub: BlockMen

by BlockMen » Mon Apr 07, 2014 10:31

Matsetes wrote:I had TOO MUCH crashes and the client said that there is a problem with the line 323 of sheep.lua, which is the one for the jump of the sheep...
Can anyone tell me what I have to do?
I like very much your mod but I cannot play that way


I will post an update next time, but until then not using the mod is the best way to prevent crashes i guess.
 

User avatar
JPRuehmann
Member
 
Posts: 334
Joined: Fri Mar 21, 2014 21:40
Location: Germany

by JPRuehmann » Tue Apr 08, 2014 10:25

Hello
I love your mod.
but sometimes my Server chrashes with this error.

23:38:34: ERROR[main]: ServerError: /home/ruehmann/.minetest/mods/creatures/init.lua:73: attempt to index a nil value
23:38:34: ERROR[main]: stack traceback:
23:38:34: ERROR[main]: /home/ruehmann/.minetest/mods/creatures/init.lua:73: in function 'find_mates'
23:38:34: ERROR[main]: /home/ruehmann/.minetest/mods/creatures/init.lua:20: in function 'spawn'
23:38:34: ERROR[main]: /home/ruehmann/.minetest/mods/creatures/spawn.lua:61: in function </home/ruehmann/.minetest/mods/creatures/spawn.lua:37>

What´s up?
Thanks,
JPR
 

PreviousNext

Return to Mod Releases



Who is online

Users browsing this forum: D00Med, Google [Bot] and 1 guest