[Mod] Mobs Redo [1.53] [mobs]

User avatar
PolySaken
Member
Posts: 652
Joined: Thu Nov 09, 2017 05:18
GitHub: PolySaken-I-Am
In-game: PolySaken
Location: Wānaka, Aotearoa
Contact:

Re: [Mod] Mobs Redo [1.41] [mobs]

by PolySaken » Post

works fine with 0.4.16

Ypheus
New member
Posts: 1
Joined: Thu Mar 29, 2018 08:11

Re: [Mod] Mobs Redo [1.41] [mobs]

by Ypheus » Post

Hi everyone,

I'm new to Minetest and english is not my mother tongue, sorry for any mistake.

I've been using "mobs redo" for two weeks now.

I searched but did not find how to change the explosion radius, neither the timer before explosion. I read this (https://antummt.github.io/mod-mobs_redo/api.html), but still can't find how.

Can you help me please ?

Thanks !

User avatar
Dokimi
Member
Posts: 190
Joined: Mon Sep 19, 2016 03:52
GitHub: DokimiCU

Re: [Mod] Mobs Redo [1.41] [mobs]

by Dokimi » Post

I just added a new mod that uses Mobs Redo, if anyone is interested.

Mobs War.

Turns Minetest into a hellishly terrifying war zone. Can be a lot of fun.

Astrobe
Member
Posts: 325
Joined: Sun Apr 01, 2018 10:46

Re: [Mod] Mobs Redo [1.41] [mobs]

by Astrobe » Post

Mobs that don't take water damage have a tendency of taking baths too often. One thing I made to fix that is to given them 0.1 water damage and floor() the actual damage (this step might not necessary if the engine already does that - I was too lazy to actually check).

holli
Member
Posts: 15
Joined: Sat Mar 31, 2018 20:04
In-game: holli
Location: Lower Saxony, Germany
Contact:

Re: [Mod] Mobs Redo [1.41] [mobs]

by holli » Post

Hi there,

I am using Mobs Redo the first time today on a 0.4.16 server @lubuntu 16.10.4 amd64 and I get very often crashes with this crash message:

Code: Select all

018-04-02 21:18:07: ERROR[Main]: ServerError: AsyncErr: ServerThread::run Lua: Runtime error from mod 'mobs_animal' in callback LuaABM::trigger(): /usr/share/minetest/mods/mobs_redo/api.lua:3107: attempt to index field 'collisionbox' (a nil value)
2018-04-02 21:18:07: ERROR[Main]: stack traceback:
2018-04-02 21:18:07: ERROR[Main]: 	/usr/share/minetest/mods/mobs_redo/api.lua:3107: in function </usr/share/minetest/mods/mobs_redo/api.lua:3027>
All my other mods are listed here:

Code: Select all

2018-04-02 21:11:08: WARNING[Main]: Mod name conflict detected: "farming"
2018-04-02 21:11:08: WARNING[Main]: Will not load: /usr/share/minetest/games/minetest_game/mods/farming
2018-04-02 21:11:08: WARNING[Main]: Overridden by: /usr/share/minetest/mods/farming
2018-04-02 21:11:08: WARNING[Main]: NodeDefManager: Ignoring CONTENT_IGNORE redefinition
2018-04-02 21:11:08: ACTION[Main]: hb.register_hudbar: health
2018-04-02 21:11:08: ACTION[Main]: hb.register_hudbar: breath
2018-04-02 21:11:08: ACTION[Main]: hb.register_hudbar: sprint
2018-04-02 21:11:08: ACTION[Main]: MOD: loading animal resources mod ...
2018-04-02 21:11:08: WARNING[Main]: Undeclared global variable "weapons_spacer" accessed at ...imals_modpack_minimal-2.5.0/animal_resources/weapons.lua:15
2018-04-02 21:11:08: WARNING[Main]: Undeclared global variable "element" accessed at ...imals_modpack_minimal-2.5.0/animal_resources/weapons.lua:466
2018-04-02 21:11:08: ACTION[Main]: MOD: animal resources mod 0.0.1 loaded.
2018-04-02 21:11:08: WARNING[Main]: Undeclared global variable "adv_spawning" accessed at ...mods/animals_modpack_minimal-2.5.0/adv_spawning/init.lua:13
2018-04-02 21:11:08: WARNING[Main]: WARNING: minetest.setting_* functions are deprecated.  Use methods on the minetest.settings object.
2018-04-02 21:11:08: WARNING[Main]: WARNING: minetest.setting_* functions are deprecated.  Use methods on the minetest.settings object.
2018-04-02 21:11:08: ACTION[Main]: Advanced spawning mod version 0.0.13 loaded
2018-04-02 21:11:08: ACTION[Main]: MOD: mobf loading ...
2018-04-02 21:11:08: ACTION[Main]: 	registering pattern dont_move
2018-04-02 21:11:08: ACTION[Main]: 	registering pattern run_and_jump_low
2018-04-02 21:11:08: ACTION[Main]: 	registering pattern stop_and_go
2018-04-02 21:11:08: ACTION[Main]: 	registering pattern swim_pattern1
2018-04-02 21:11:08: ACTION[Main]: 	registering pattern swim_pattern2
2018-04-02 21:11:08: ACTION[Main]: 	registering pattern flight_pattern1
2018-04-02 21:11:08: ACTION[Main]: MOD: mob framework mod 2.5.0 loaded
2018-04-02 21:11:08: ACTION[Main]: MOD: mobf_settings mod           version 1.9.0 loaded
2018-04-02 21:11:08: ACTION[Main]: MOD: Loading mob_environments mod ...
2018-04-02 21:11:08: ACTION[Main]: MOD: mob_environments mod 0.0.1 loaded.
2018-04-02 21:11:08: ACTION[Main]: MOD: mob_miner mod loading ...
2018-04-02 21:11:08: ACTION[Main]: 	adding mob miner
2018-04-02 21:11:08: ACTION[Main]: MOD: mob_miner mod                version 0.1.1 loaded
2018-04-02 21:11:08: ACTION[Main]: MOD: mob_guard mod loading ...
2018-04-02 21:11:08: ACTION[Main]: 	adding mob guard
2018-04-02 21:11:08: ACTION[Main]: MOD: mob_guard mod                version 0.2.1 loaded
2018-04-02 21:11:08: ACTION[Main]: MOD: mob_archer mod loading ...
2018-04-02 21:11:08: ACTION[Main]: 	adding mob archer
2018-04-02 21:11:08: ACTION[Main]: MOD: mob_archer mod                version 0.2.1 loaded
2018-04-02 21:11:08: ACTION[Main]: MOD: animalmaterials loading ...
2018-04-02 21:11:08: ACTION[Main]: MOD: animalmaterials mod version 0.1.3 loaded
2018-04-02 21:11:08: ACTION[Main]: MOD: mob_ostrich mod loading ...
2018-04-02 21:11:08: ACTION[Main]: ADV_SPAWNING: registering spawner "ostrich_m_spawner_1"
2018-04-02 21:11:08: ACTION[Main]: ADV_SPAWNING: now handling: 1 spawner definitions
2018-04-02 21:11:08: ACTION[Main]: ADV_SPAWNING: registering spawner "ostrich_f_spawner_1"
2018-04-02 21:11:08: ACTION[Main]: ADV_SPAWNING: now handling: 2 spawner definitions
2018-04-02 21:11:08: ACTION[Main]: 	adding mob ostrich_m
2018-04-02 21:11:08: ACTION[Main]: 	adding mob ostrich_f
2018-04-02 21:11:08: ACTION[Main]: MOD: mob_ostrich mod            version 0.2.0 loaded
2018-04-02 21:11:08: WARNING[Main]: Not registering alias, item with same name is already defined: mushroom:brown_natural -> flowers:mushroom_fertile_brown
2018-04-02 21:11:08: WARNING[Main]: Not registering alias, item with same name is already defined: mushroom:red_natural -> flowers:mushroom_fertile_red
2018-04-02 21:11:09: ACTION[Main]: [MOD] Mobs Redo loaded
2018-04-02 21:11:09: WARNING[Main]: WARNING: minetest.setting_* functions are deprecated.  Use methods on the minetest.settings object.
2018-04-02 21:11:09: WARNING[Main]: WARNING: minetest.setting_* functions are deprecated.  Use methods on the minetest.settings object.
2018-04-02 21:11:09: WARNING[Main]: Not registering alias, item with same name is already defined: bushes:blueberry -> farming:blueberries
2018-04-02 21:11:09: WARNING[Main]: Not registering alias, item with same name is already defined: bushes:raspberry -> farming:raspberries
2018-04-02 21:11:09: WARNING[Main]: 3d_armor_ui: Mod loaded but unused.
2018-04-02 21:11:09: WARNING[Main]: 3d_armor_ip: Mod loaded but unused.
2018-04-02 21:11:09: ACTION[Main]: MOD: mob_npc mod loading ...
2018-04-02 21:11:09: ACTION[Main]: ADV_SPAWNING: registering spawner "npc_trader_spawner_1"
2018-04-02 21:11:09: ACTION[Main]: ADV_SPAWNING: now handling: 3 spawner definitions
2018-04-02 21:11:09: ACTION[Main]: 	adding mob npc_trader
2018-04-02 21:11:09: ACTION[Main]: 	adding mob npc
2018-04-02 21:11:09: ACTION[Main]: MOD: mob_npc mod                version 0.2.1 loaded
2018-04-02 21:11:09: ACTION[Main]: hb.register_hudbar: satiation
2018-04-02 21:11:09: WARNING[Main]: WARNING: minetest.setting_* functions are deprecated.  Use methods on the minetest.settings object.
2018-04-02 21:11:09: WARNING[Main]: Not registering alias, item with same name is already defined: mobs:bunny -> mobs_mc:rabbit
2018-04-02 21:11:09: WARNING[Main]: Not registering alias, item with same name is already defined: mobs_animal:cow -> mobs_mc:cow
2018-04-02 21:11:09: WARNING[Main]: Not registering alias, item with same name is already defined: mobs:kitten -> mobs_mc:ocelot
2018-04-02 21:11:09: WARNING[Main]: Not registering alias, item with same name is already defined: mobs:spider -> mobs_mc:spider
2018-04-02 21:11:10: ACTION[Main]:         .__               __                   __   
2018-04-02 21:11:10: ACTION[Main]:   _____ |__| ____   _____/  |_  ____   _______/  |_ 
2018-04-02 21:11:10: ACTION[Main]:  /     \|  |/    \_/ __ \   __\/ __ \ /  ___/\   __\
2018-04-02 21:11:10: ACTION[Main]: |  Y Y  \  |   |  \  ___/|  | \  ___/ \___ \  |  |  
2018-04-02 21:11:10: ACTION[Main]: |__|_|  /__|___|  /\___  >__|  \___  >____  > |__|  
2018-04-02 21:11:10: ACTION[Main]:       \/        \/     \/          \/     \/        
2018-04-02 21:11:10: ACTION[Main]: World at [/var/games/minetest-server/.minetest/worlds/world]
2018-04-02 21:11:10: ACTION[Main]: Server for gameid="minetest" listening on 192.168.7.250:30000.
I am using a minimal edition of Animals Modpack 2.5.0, only for traders, archers, miners and ostriches (to ride them with the traders saddle) simultanous with Mods Redo. Eventually this could be the reason. I'll check this out and post the result hrer for you.

Thanks for help,

Holli

holli
Member
Posts: 15
Joined: Sat Mar 31, 2018 20:04
In-game: holli
Location: Lower Saxony, Germany
Contact:

Re: [Mod] Mobs Redo [1.41] [mobs]

by holli » Post

Rehi,

I am back again to tell you, that minetest already crashes without the Animal Modpack 2.5 mods. The crash message stays the same:

Code: Select all

2018-04-02 21:41:57: ERROR[Main]: ServerError: AsyncErr: ServerThread::run Lua: Runtime error from mod 'mobs_animal' in callback LuaABM::trigger(): /usr/share/minetest/mods/mobs_redo/api.lua:3107: attempt to index field 'collisionbox' (a nil value)
2018-04-02 21:41:57: ERROR[Main]: stack traceback:
2018-04-02 21:41:57: ERROR[Main]: 	/usr/share/minetest/mods/mobs_redo/api.lua:3107: in function </usr/share/minetest/mods/mobs_redo/api.lua:3027>
Please help me out... :-/ ...thanks!

Holli

User avatar
TenPlus1
Member
Posts: 2879
Joined: Mon Jul 29, 2013 13:38
GitHub: tenplus1

Re: [Mod] Mobs Redo [1.41] [mobs]

by TenPlus1 » Post

holli: it sounds like you have a registered mob that uses the mob redo api and doesn't have the collisionbox set for the mob entity, so I'll add a fallback in the api that should stop this happening.

holli
Member
Posts: 15
Joined: Sat Mar 31, 2018 20:04
In-game: holli
Location: Lower Saxony, Germany
Contact:

Re: [Mod] Mobs Redo [1.41] [mobs]

by holli » Post

Hi TenPlus1,

thanks for your support and your really quick reply!

Holli

PS: You call back if the patch is downloadable? 8-D

ektor
Member
Posts: 78
Joined: Sat Sep 24, 2016 11:59
IRC: dtarcz
In-game: ektor
Contact:

how to make mobs spawn less?

by ektor » Post

Hello.

I want to make mobs spawn less to have better performance.
How can I do this setting ?

I try to modify the spawner.lua file and change the interval to 120, but it seems to have no incidence.

And I don't understand how works the code to include in the minetest.conf: the mob chance and area numbers.
Vive Minetest!

User avatar
TenPlus1
Member
Posts: 2879
Joined: Mon Jul 29, 2013 13:38
GitHub: tenplus1

Re: [Mod] Mobs Redo [1.41] [mobs]

by TenPlus1 » Post

ektor: in minetest.conf you could add this line to spawn less mobs (higher the number, less mobs):

mob_chance_multiplier = 2.0

ektor
Member
Posts: 78
Joined: Sat Sep 24, 2016 11:59
IRC: dtarcz
In-game: ektor
Contact:

Re: [Mod] Mobs Redo [1.41] [mobs]

by ektor » Post

great, I'll try tonight, when server not busy.
thanks TenPlus1.
Vive Minetest!

holli
Member
Posts: 15
Joined: Sat Mar 31, 2018 20:04
In-game: holli
Location: Lower Saxony, Germany
Contact:

Re: [Mod] Mobs Redo [1.41] [mobs]

by holli » Post

Ah, nice hint, TenPlus1! :-D In the world on my server were to much mobs too...

Astrobe
Member
Posts: 325
Joined: Sun Apr 01, 2018 10:46

Re: [Mod] Mobs Redo [1.41] [mobs]

by Astrobe » Post

There's an exploit with vehicles: when you're in a cart or in a boat, you are invulnerable because the aggressor hits your vehicle that has no HP so nothing happens. The solution I've found to this is to add a chance of dismounting the player.

This makes for instance sharks quite scary when you're crossing seas, because if you are dismounted your boat will carry on without you (not to mention there's a pair of large jaws after you). If you react quick enough you can mount it again right away, but it's wiser to make two or three boats just in case.

Chibi ghost
Member
Posts: 845
Joined: Fri Jan 08, 2016 21:17
In-game: Ghost

Re: [Mod] Mobs Redo [1.41] [mobs]

by Chibi ghost » Post

I have a problem it's the penguins they have a bad habit of swimming through solid areas like walls or the ground
also, I'm not sure if it's a you problem or a blert2112 viewtopic.php?f=9&t=12652
problem but since I updated the mob's api the fish fly through the air unless they get tangled up in the trees shame really as it was the only fish mod I liked
Image
anyway that's enough of me moaning I love the new changes now the farm animals are not escaping

User avatar
TenPlus1
Member
Posts: 2879
Joined: Mon Jul 29, 2013 13:38
GitHub: tenplus1

Re: [Mod] Mobs Redo [1.41] [mobs]

by TenPlus1 » Post

Chibi: I tested fish for a while and noticed them swimming slowly up and down on occasion, but on a server that has lag issues they have a tendency to glide out of the water so I've disabled the up.down movement for flying and swimming mobs (for now).

Update: Added smooth rotation to mobs thanks to ThomasMonroe.

barbach
New member
Posts: 3
Joined: Mon Apr 23, 2018 19:29

Re: [Mod] Mobs Redo [1.41] [mobs]

by barbach » Post

Hi there, I cannot use this mod on my server (Debian).
Here's the error message :

2018-04-23 19:21:18: ERROR[Main]: ModError: Failed to load and run script from /***/mods/mobs_redo-master/init.lua:
2018-04-23 19:21:18: ERROR[Main]: /***/mods/mobs_redo-master/api.lua:27: attempt to index field 'settings' (a nil value)
2018-04-23 19:21:18: ERROR[Main]: stack traceback:
2018-04-23 19:21:18: ERROR[Main]: /***/mods/mobs_redo-master/api.lua:27: in main chunk
2018-04-23 19:21:18: ERROR[Main]: [C]: in function 'dofile'
2018-04-23 19:21:18: ERROR[Main]: /***/mods/mobs_redo-master/init.lua:5: in main chunk

Mobs redo is the only mod enabled, I just wanted to see if the server could lauch properly.

User avatar
cHyper
Member
Posts: 904
Joined: Fri May 06, 2011 08:49
GitHub: cHyper-0815OL
IRC: cHyper cHyper_de
In-game: cHyper cHyper_0815
Location: Austria
Contact:

Re: [Mod] Mobs Redo [1.41] [mobs]

by cHyper » Post

barbach wrote:Hi there, I cannot use this mod on my server (Debian).
Here's the error message :

2018-04-23 19:21:18: ERROR[Main]: ModError: Failed to load and run script from /***/mods/mobs_redo-master/init.lua:
2018-04-23 19:21:18: ERROR[Main]: /***/mods/mobs_redo-master/api.lua:27: attempt to index field 'settings' (a nil value)
2018-04-23 19:21:18: ERROR[Main]: stack traceback:
2018-04-23 19:21:18: ERROR[Main]: /***/mods/mobs_redo-master/api.lua:27: in main chunk
2018-04-23 19:21:18: ERROR[Main]: [C]: in function 'dofile'
2018-04-23 19:21:18: ERROR[Main]: /***/mods/mobs_redo-master/init.lua:5: in main chunk

Mobs redo is the only mod enabled, I just wanted to see if the server could lauch properly.
remove the -master and then it will work!!!!

User avatar
TenPlus1
Member
Posts: 2879
Joined: Mon Jul 29, 2013 13:38
GitHub: tenplus1

Re: [Mod] Mobs Redo [1.41] [mobs]

by TenPlus1 » Post

barbach: make sure you are running Minetest 0.4.16 for the new settings function.

barbach
New member
Posts: 3
Joined: Mon Apr 23, 2018 19:29

Re: [Mod] Mobs Redo [1.41] [mobs]

by barbach » Post

Yup seems like I'm running minetest 4.15...
I'll try to install 4.16 and see if it works thanks

Chibi ghost
Member
Posts: 845
Joined: Fri Jan 08, 2016 21:17
In-game: Ghost

Re: [Mod] Mobs Redo [1.41] [mobs]

by Chibi ghost » Post

updated the monster mobs and I encountered a dungeon master and it's new fireball


halp

barbach
New member
Posts: 3
Joined: Mon Apr 23, 2018 19:29

Re: [Mod] Mobs Redo [1.41] [mobs]

by barbach » Post

Updated to 4.16 and it's working well.
Just one weird thing : I can't use shears on sheeps...

User avatar
Lone_Wolf
Member
Posts: 2410
Joined: Sun Apr 09, 2017 05:50
GitHub: LoneWolfHT
IRC: Lone_Wolf or LoneWolfHT
In-game: Lone_Wolf
Location: Not there, THERE!

Re: [Mod] Mobs Redo [1.41] [mobs]

by Lone_Wolf » Post

barbach wrote:Updated to 4.16 and it's working well.
Just one weird thing : I can't use shears on sheeps...
They need to be tamed I think

Chibi ghost
Member
Posts: 845
Joined: Fri Jan 08, 2016 21:17
In-game: Ghost

Re: [Mod] Mobs Redo [1.41] [mobs]

by Chibi ghost » Post

if you don't want to tame them kill them and get one wool block
upside you get the muton as well so extra food is good

User avatar
Hamlet
Member
Posts: 765
Joined: Sat Jul 29, 2017 21:09
IRC: H4mlet
In-game: Hamlet
Location: Lombardy, Italy

Re: [Mod] Mobs Redo [1.41] [mobs]

by Hamlet » Post

Is there a way to avoid mobs/npcs entering the "attack" state if the target isn't in their line of sight?
I'm testing some npcs/mobs and I've noticed that they look even for mobs that they couldn't normally see, for example a monster in a cave under them or a mob in a tunnel separated by a stone wall.

It's weird to see them get stuck in front of a wall, or running in circles because of an underground mob.
My repositories: Codeberg.org | My ContentDB's page | I'm on PureOS with XFCE

User avatar
TenPlus1
Member
Posts: 2879
Joined: Mon Jul 29, 2013 13:38
GitHub: tenplus1

Re: [Mod] Mobs Redo [1.41] [mobs]

by TenPlus1 » Post

Hamlet - Mobs Redo API has been updated and this issue has been fixed :)

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests