[Mod] Simple Mobs [mobs]

OwenBean
Member
 
Posts: 17
Joined: Sun Sep 09, 2012 22:25

by OwenBean » Tue Sep 18, 2012 11:24

Yea agreed the DM (or something like the DM) would rock. Although one of the main things with the DMs for me was the fact that they would disappear after a while when I came back to their cave. (Must have fallen into the lava or something? idk..) but that sucked.

But yea I updated to the latest dev version and I'm getting the same 'on_step' error as others - particularly on my server. I too am on windows.

Hope this helps.
 

User avatar
sdzen
Member
 
Posts: 1170
Joined: Fri Aug 05, 2011 22:33
Location: Paradise (your not allowed)

by sdzen » Tue Sep 18, 2012 22:05

hello just a small suggestion replace "local mobs = {}" with "mobs = {}" on the first line I was playing with my skulls and had to do that to make it work when separating the folders :D
[h]Zen S.D.[/h] The next generation of tranquility!
malheureusement mon français n'est pas bon :<
Owner of the Zelo's
In game name: MuadTralk, spdtainted, sdzen, sd zen, sdzeno
 

User avatar
sfan5
Moderator
 
Posts: 3816
Joined: Wed Aug 24, 2011 09:44
Location: Germany
GitHub: sfan5
IRC: sfan5

by sfan5 » Wed Sep 19, 2012 05:32

irksomeduck wrote:
Code: Select all
...
14:05:48: VERBOSE[main]: error_message = ModError: Failed to load and run C:\Users\Lewis\Desktop\Minetest 0.4.3\bin\..\mods\minetest\PilzAdam-mobs-4151fe2\init.lua
14:05:48: VERBOSE[main]: Check debug.txt for details.
...


This is not helpful, paste debug.txt not the Console Output
Mods: Mesecons | WorldEdit | Nuke & Minetest builds for Windows (32-bit & 64-bit)
 

User avatar
PilzAdam
Member
 
Posts: 4026
Joined: Fri Jul 20, 2012 16:19
Location: Germany
GitHub: PilzAdam
IRC: PilzAdam
 

User avatar
sfan5
Moderator
 
Posts: 3816
Joined: Wed Aug 24, 2011 09:44
Location: Germany
GitHub: sfan5
IRC: sfan5

by sfan5 » Wed Sep 19, 2012 16:43

Nice!
I've missed the Oerkki
Mods: Mesecons | WorldEdit | Nuke & Minetest builds for Windows (32-bit & 64-bit)
 

User avatar
PilzAdam
Member
 
Posts: 4026
Joined: Fri Jul 20, 2012 16:19
Location: Germany
GitHub: PilzAdam
IRC: PilzAdam

by PilzAdam » Wed Sep 19, 2012 17:26

I need new textures for the sheep (resolution: 20x32). I realy cant draw (see my attempt in textures/mobs_sheep_old.png).
I also need new texutures for the dirt, stone and sand monster.
 

Josh
Member
 
Posts: 1146
Joined: Fri Jun 29, 2012 23:11
Location: Victoria, Australia

by Josh » Thu Sep 20, 2012 03:12

Do you need the old sheep texture? Plus i would like to see some new textures for the Oerkii the original ones look scary.
 

Josh
Member
 
Posts: 1146
Joined: Fri Jun 29, 2012 23:11
Location: Victoria, Australia

by Josh » Thu Sep 20, 2012 03:56

Hey PilzAdam you said you needed some new textures for the mobs so i wen't ahead and did some!
I have only done the texture's for the stone, sand and dirt monster. Here is the download link
https://dl.dropbox.com/u/102401091/textures.zip
If you like them tell me. They may be a bit ugly but they sort of give the old retro feel.
 

User avatar
Topywo
Member
 
Posts: 1721
Joined: Fri May 18, 2012 20:27

by Topywo » Thu Sep 20, 2012 07:53

I was curious about your and Josh textures so I extracted them and looked at the png. Then I decided to see them 'live'. Unfortunately I got this error. I used the download: PilzAdam-mobs-b687ddf

The error in debug.txt is:

09:30:31: ERROR[main]: ServerError: LuaError: error running function 'on_step': attempt to index a number value
09:30:31: ERROR[main]: stack traceback:

09:30:32: VERBOSE[main]: error_message = ServerError: LuaError: error running function 'on_step': attempt to index a number value
09:30:32: VERBOSE[main]: stack traceback:

As far as I good see on the png files I don't think your textures need (much) improvement. I like the idea that they have the same color as their spawning material. Maybe the dirt monster needs more 'camouflage' and the stone monster less 'mossy'.

Josh, your monsters look nice, but still very similar too the originals. You could consider making them completely different. Good you're making textures!

edit: the usual typo's
Last edited by Topywo on Thu Sep 20, 2012 07:54, edited 1 time in total.
 

User avatar
PilzAdam
Member
 
Posts: 4026
Joined: Fri Jul 20, 2012 16:19
Location: Germany
GitHub: PilzAdam
IRC: PilzAdam

by PilzAdam » Thu Sep 20, 2012 09:56

Topywo wrote:Josh, your monsters look nice, but still very similar too the originals. You could consider making them completely different. Good you're making textures!

+1
 

cornernote
Member
 
Posts: 844
Joined: Wed Jul 11, 2012 15:02

by cornernote » Thu Sep 20, 2012 23:41

now that i have a version that runs this, finally got a chance to have a play and give some feedback.

1) this is awesome

2) the monsters seem really hard (random) to kill. they only have 1 hp, and i may have to hit them 50 times to do a damage. i assume better weapons give a better kill chance. can the monsters have 10hp, and each hit does ~1 damage? That way i know there is about 10 hits to kill one. when i get a better weapon, it could take 2hp per hit, etc.

3) i think someone mentioned it before, but being able to push them back a little would be good. maybe every 2nd or 3rd hit pushes them back a tad.
 

Josh
Member
 
Posts: 1146
Joined: Fri Jun 29, 2012 23:11
Location: Victoria, Australia

by Josh » Fri Sep 21, 2012 03:59

Topywo wrote:I was curious about your and Josh textures so I extracted them and looked at the png. Then I decided to see them 'live'. Unfortunately I got this error. I used the download: PilzAdam-mobs-b687ddf

The error in debug.txt is:

09:30:31: ERROR[main]: ServerError: LuaError: error running function 'on_step': attempt to index a number value
09:30:31: ERROR[main]: stack traceback:

09:30:32: VERBOSE[main]: error_message = ServerError: LuaError: error running function 'on_step': attempt to index a number value
09:30:32: VERBOSE[main]: stack traceback:

As far as I good see on the png files I don't think your textures need (much) improvement. I like the idea that they have the same color as their spawning material. Maybe the dirt monster needs more 'camouflage' and the stone monster less 'mossy'.

Josh, your monsters look nice, but still very similar too the originals. You could consider making them completely different. Good you're making textures!

edit: the usual typo's


Thank's for the feedback Topywo. Glad you liked them.
Last edited by Josh on Fri Sep 21, 2012 04:01, edited 1 time in total.
 

Josh
Member
 
Posts: 1146
Joined: Fri Jun 29, 2012 23:11
Location: Victoria, Australia

by Josh » Fri Sep 21, 2012 04:46

I have made some new texture's. Topywo suggested i could make them a bit different from there original texture's so i did. This download only includes sand & dirt monster here it is. https://dl.dropbox.com/u/102401091/textures2.zip
This time they have a camoflauge on them. Check it out & see what you think.
 

User avatar
Calinou
Moderator
 
Posts: 3156
Joined: Mon Aug 01, 2011 14:26
Location: Troyes, France
GitHub: Calinou
IRC: Calinou
In-game: Calinou

by Calinou » Fri Sep 21, 2012 08:40

cornernote wrote:now that i have a version that runs this, finally got a chance to have a play and give some feedback.

1) this is awesome

2) the monsters seem really hard (random) to kill. they only have 1 hp, and i may have to hit them 50 times to do a damage. i assume better weapons give a better kill chance. can the monsters have 10hp, and each hit does ~1 damage? That way i know there is about 10 hits to kill one. when i get a better weapon, it could take 2hp per hit, etc.

3) i think someone mentioned it before, but being able to push them back a little would be good. maybe every 2nd or 3rd hit pushes them back a tad.


They have more than 1hp... Note stone monsters are resistant to hands and wooden swords.
 

User avatar
PilzAdam
Member
 
Posts: 4026
Joined: Fri Jul 20, 2012 16:19
Location: Germany
GitHub: PilzAdam
IRC: PilzAdam

by PilzAdam » Fri Sep 21, 2012 10:39

Josh wrote:I have made some new texture's. Topywo suggested i could make them a bit different from there original texture's so i did. This download only includes sand & dirt monster here it is. https://dl.dropbox.com/u/102401091/textures2.zip
This time they have a camoflauge on them. Check it out & see what you think.

Dont just make them a "bit" different. Make them completly different. The textures from me are just the player textures with some dirt/sand/mossycobble looking.
 

User avatar
PilzAdam
Member
 
Posts: 4026
Joined: Fri Jul 20, 2012 16:19
Location: Germany
GitHub: PilzAdam
IRC: PilzAdam
 

fgr
Member
 
Posts: 86
Joined: Mon Sep 17, 2012 08:22

by fgr » Fri Sep 21, 2012 20:41

here is another bug:

Code: Select all
22:38:58: ERROR[main]: ...test/games/minetest_game/mods/pilzadam_mobs/init.lua:1: attempt to concatenate a nil value
22:38:58: ERROR[main]: stack traceback:
22:38:58: ERROR[main]:  ...test/games/minetest_game/mods/pilzadam_mobs/init.lua:1: in main chunk
22:38:58: ERROR[main]: =======END OF ERROR FROM LUA ========
22:38:58: ERROR[main]: Server: Failed to load and run /usr/share/minetest/games/minetest_game/mods/pilzadam_mobs/init.lua
22:38:58: ERROR[main]: ERROR: An unhandled exception occurred: ModError: Failed to load and run /usr/share/minetest/games/minetest_game/mods/pilzadam_mobs/init.lua

In thread 7fdf0808c740:
/build/buildd/minetestc55-0.4.3/src/main.cpp:1741: int main(int, char**): Assertion '0' failed.
Debug stacks:
DEBUG STACK FOR THREAD 7fdf0808c740:
#0  int main(int, char**)
(Leftover data: #1  Dedicated server branch)
(Leftover data: #2  void ItemStack::deSerialize(std::istream&, IItemDefManager*))
Aborted (core dumped)
 

Josh
Member
 
Posts: 1146
Joined: Fri Jun 29, 2012 23:11
Location: Victoria, Australia

by Josh » Sat Sep 22, 2012 03:03

PilzAdam wrote:
Josh wrote:I have made some new texture's. Topywo suggested i could make them a bit different from there original texture's so i did. This download only includes sand & dirt monster here it is. https://dl.dropbox.com/u/102401091/textures2.zip
This time they have a camoflauge on them. Check it out & see what you think.

Dont just make them a "bit" different. Make them completly different. The textures from me are just the player textures with some dirt/sand/mossycobble looking.


Im gonna stick a picture of a gun on the bad mobs so it looks like there holding a gun. Would that be cool?
 

cornernote
Member
 
Posts: 844
Joined: Wed Jul 11, 2012 15:02

by cornernote » Sat Sep 22, 2012 03:04

i'd rather see them holding a melee weapon, like a mace or a club or something
 

User avatar
Feorth
Member
 
Posts: 27
Joined: Sat Sep 08, 2012 00:06
Location: Brazil

by Feorth » Sat Sep 22, 2012 05:05

I've been using this mod for a while and today a noticed that a dirt mob was acting a little strange, like it was going straight in one direction and didn't stop even when i started to hit it. When i killed the mob that happened:
Image
And the empty node kept moving... That's not really an issue i just wanted to let you know.
Cheers
Last edited by Feorth on Sat Sep 22, 2012 16:32, edited 1 time in total.
 

User avatar
PilzAdam
Member
 
Posts: 4026
Joined: Fri Jul 20, 2012 16:19
Location: Germany
GitHub: PilzAdam
IRC: PilzAdam

by PilzAdam » Sat Sep 22, 2012 08:50

fgr wrote:here is another bug:

Code: Select all
22:38:58: ERROR[main]: ...test/games/minetest_game/mods/pilzadam_mobs/init.lua:1: attempt to concatenate a nil value
22:38:58: ERROR[main]: stack traceback:
22:38:58: ERROR[main]:  ...test/games/minetest_game/mods/pilzadam_mobs/init.lua:1: in main chunk
22:38:58: ERROR[main]: =======END OF ERROR FROM LUA ========
22:38:58: ERROR[main]: Server: Failed to load and run /usr/share/minetest/games/minetest_game/mods/pilzadam_mobs/init.lua
22:38:58: ERROR[main]: ERROR: An unhandled exception occurred: ModError: Failed to load and run /usr/share/minetest/games/minetest_game/mods/pilzadam_mobs/init.lua

In thread 7fdf0808c740:
/build/buildd/minetestc55-0.4.3/src/main.cpp:1741: int main(int, char**): Assertion '0' failed.
Debug stacks:
DEBUG STACK FOR THREAD 7fdf0808c740:
#0  int main(int, char**)
(Leftover data: #1  Dedicated server branch)
(Leftover data: #2  void ItemStack::deSerialize(std::istream&, IItemDefManager*))
Aborted (core dumped)

Rename the mod folder from "pilzadam_mobs" to "mobs".
 

User avatar
PilzAdam
Member
 
Posts: 4026
Joined: Fri Jul 20, 2012 16:19
Location: Germany
GitHub: PilzAdam
IRC: PilzAdam

by PilzAdam » Sat Sep 22, 2012 08:52

Josh wrote:
PilzAdam wrote:
Josh wrote:I have made some new texture's. Topywo suggested i could make them a bit different from there original texture's so i did. This download only includes sand & dirt monster here it is. https://dl.dropbox.com/u/102401091/textures2.zip
This time they have a camoflauge on them. Check it out & see what you think.

Dont just make them a "bit" different. Make them completly different. The textures from me are just the player textures with some dirt/sand/mossycobble looking.


Im gonna stick a picture of a gun on the bad mobs so it looks like there holding a gun. Would that be cool?

Guns are too modern. They should be misshapen, ugly and slimy monsters.
 

User avatar
PilzAdam
Member
 
Posts: 4026
Joined: Fri Jul 20, 2012 16:19
Location: Germany
GitHub: PilzAdam
IRC: PilzAdam

by PilzAdam » Sat Sep 22, 2012 08:53

Feorth wrote:I've been using this mod for a while and today a noticed that a dirt mob was acting a little strange, like it was going straight in one direction and didn't stop even when i started to hit it. When i killed the mob that happened:
Image
And the empty node kept moving... That's not really an issue i just wanted to let you know.
Cheers

The image seems to be broken but i know this bug. Sometimes the Minetest engine stops to handle entities. Then they just keep going, cant die and dont react on rigthtclicks.
 

fgr
Member
 
Posts: 86
Joined: Mon Sep 17, 2012 08:22

by fgr » Sat Sep 22, 2012 13:04

i got this error after renaming it to mobs:

Code: Select all
15:02:10: ACTION[ServerThread]: eythen joins game. List of players: eythen
15:02:14: ERROR[main]: ERROR: An unhandled exception occurred: ServerError: LuaError: error running function 'on_step': attempt to index a number value
15:02:14: ERROR[main]: stack traceback:

In thread 7f82a19e6740:
/build/buildd/minetestc55-0.4.3/src/main.cpp:1741: int main(int, char**): Assertion '0' failed.
Debug stacks:
DEBUG STACK FOR THREAD 7f82a19e6740:
#0  int main(int, char**)
(Leftover data: #1  Dedicated server branch)
(Leftover data: #2  virtual void ServerMap::save(ModifiedState))
(Leftover data: #3  virtual void ServerMap::saveBlock(MapBlock*))
(Leftover data: #4  void ItemStack::serialize(std::ostream&) const)
Aborted (core dumped)


after deleting the mobs dir i get this error:

Code: Select all
15:05:48: ERROR[ServerThread]: LuaEntity name "mobs:oerkki" not defined
15:05:48: ERROR[ServerThread]: LuaEntity name "mobs:stone_monster" not defined
15:05:48: ERROR[ServerThread]: LuaEntity name "mobs:oerkki" not defined
15:05:48: ERROR[ServerThread]: LuaEntity name "mobs:rat" not defined
15:05:48: ERROR[ServerThread]: LuaEntity name "mobs:oerkki" not defined
15:05:48: ERROR[ServerThread]: LuaEntity name "mobs:oerkki" not defined
15:05:50: ERROR[ServerThread]: LuaEntity name "mobs:dungeon_master" not defined
15:05:52: ERROR[ServerThread]: LuaEntity name "mobs:oerkki" not defined
15:05:52: ERROR[ServerThread]: LuaEntity name "mobs:rat" not defined
15:05:52: ERROR[ServerThread]: LuaEntity name "mobs:dungeon_master" not defined
15:05:52: ERROR[ServerThread]: LuaEntity name "mobs:oerkki" not defined


how can i remove the mobs in the map due the mod isnt working properly?
Last edited by fgr on Sat Sep 22, 2012 13:25, edited 1 time in total.
 

User avatar
PilzAdam
Member
 
Posts: 4026
Joined: Fri Jul 20, 2012 16:19
Location: Germany
GitHub: PilzAdam
IRC: PilzAdam

by PilzAdam » Sat Sep 22, 2012 13:13

fgr wrote:i got this error after renaming it to mobs:

Code: Select all
15:02:10: ACTION[ServerThread]: eythen joins game. List of players: eythen
15:02:14: ERROR[main]: ERROR: An unhandled exception occurred: ServerError: LuaError: error running function 'on_step': attempt to index a number value
15:02:14: ERROR[main]: stack traceback:

In thread 7f82a19e6740:
/build/buildd/minetestc55-0.4.3/src/main.cpp:1741: int main(int, char**): Assertion '0' failed.
Debug stacks:
DEBUG STACK FOR THREAD 7f82a19e6740:
#0  int main(int, char**)
(Leftover data: #1  Dedicated server branch)
(Leftover data: #2  virtual void ServerMap::save(ModifiedState))
(Leftover data: #3  virtual void ServerMap::saveBlock(MapBlock*))
(Leftover data: #4  void ItemStack::serialize(std::ostream&) const)
Aborted (core dumped)


after deleting the mobs dir i get this error:

Code: Select all
15:05:48: ERROR[ServerThread]: LuaEntity name "mobs:oerkki" not defined
15:05:48: ERROR[ServerThread]: LuaEntity name "mobs:stone_monster" not defined
15:05:48: ERROR[ServerThread]: LuaEntity name "mobs:oerkki" not defined
15:05:48: ERROR[ServerThread]: LuaEntity name "mobs:rat" not defined
15:05:48: ERROR[ServerThread]: LuaEntity name "mobs:oerkki" not defined
15:05:48: ERROR[ServerThread]: LuaEntity name "mobs:oerkki" not defined
15:05:50: ERROR[ServerThread]: LuaEntity name "mobs:dungeon_master" not defined
15:05:52: ERROR[ServerThread]: LuaEntity name "mobs:oerkki" not defined
15:05:52: ERROR[ServerThread]: LuaEntity name "mobs:rat" not defined
15:05:52: ERROR[ServerThread]: LuaEntity name "mobs:dungeon_master" not defined
15:05:52: ERROR[ServerThread]: LuaEntity name "mobs:oerkki" not defined

There is a error in the windows build so the first error only occurs in windows. If you want to remove all the old mobs after deleting the mod use
Code: Select all
/clearobjects

This will delete all entities.
 

PreviousNext

Return to Old Mods



Who is online

Users browsing this forum: MSN [Bot] and 2 guests