[Mod] Simple Mobs [mobs]

sysedit
Member
 
Posts: 27
Joined: Sun Aug 12, 2012 10:53

by sysedit » Sun Sep 23, 2012 10:15

Hello PilzAdam,

nice changes upstream, I especially like that the sheeps are now
drowning. What I think needs tuning is the sheep sound.
It occurs quite too often.

Also the enemies give me damage even when they are not touching me. Sort like a harming aura. I think it would be more reallistic for them to not harm you if they can not reach you.

Another thing I noticed was that often times when I kill a sheep,
a puff of smoke will appear and the sheep is still there.

Thank you for your good work.
 

User avatar
PilzAdam
Member
 
Posts: 4026
Joined: Fri Jul 20, 2012 16:19
Location: Germany
GitHub: PilzAdam
IRC: PilzAdam

by PilzAdam » Sun Sep 23, 2012 10:24

sysedit wrote:Another thing I noticed was that often times when I kill a sheep,
a puff of smoke will appear and the sheep is still there.

Thats an engine bug.
 

User avatar
sdzen
Member
 
Posts: 1170
Joined: Fri Aug 05, 2011 22:33
Location: Paradise (your not allowed)

by sdzen » Tue Sep 25, 2012 23:25

PilzAdam wrote:
fgr wrote:i got this error after renaming it to mobs:

Code: Select all
15:02:10: ACTION[ServerThread]: eythen joins game. List of players: eythen
15:02:14: ERROR[main]: ERROR: An unhandled exception occurred: ServerError: LuaError: error running function 'on_step': attempt to index a number value
15:02:14: ERROR[main]: stack traceback:

In thread 7f82a19e6740:
/build/buildd/minetestc55-0.4.3/src/main.cpp:1741: int main(int, char**): Assertion '0' failed.
Debug stacks:
DEBUG STACK FOR THREAD 7f82a19e6740:
#0  int main(int, char**)
(Leftover data: #1  Dedicated server branch)
(Leftover data: #2  virtual void ServerMap::save(ModifiedState))
(Leftover data: #3  virtual void ServerMap::saveBlock(MapBlock*))
(Leftover data: #4  void ItemStack::serialize(std::ostream&) const)
Aborted (core dumped)


There is a error in the windows build so the first error only occurs in windows. If you want to remove all the old mobs after deleting the mod use

that about what i get only on line 98 and it says attempted to compare number with nil btw it was on linux :P
Last edited by sdzen on Tue Sep 25, 2012 23:27, edited 1 time in total.
[h]Zen S.D.[/h] The next generation of tranquility!
malheureusement mon français n'est pas bon :<
Owner of the Zelo's
In game name: MuadTralk, spdtainted, sdzen, sd zen, sdzeno
 

User avatar
PilzAdam
Member
 
Posts: 4026
Joined: Fri Jul 20, 2012 16:19
Location: Germany
GitHub: PilzAdam
IRC: PilzAdam

by PilzAdam » Wed Sep 26, 2012 14:36

sdzen wrote:
PilzAdam wrote:
fgr wrote:i got this error after renaming it to mobs:

Code: Select all
15:02:10: ACTION[ServerThread]: eythen joins game. List of players: eythen
15:02:14: ERROR[main]: ERROR: An unhandled exception occurred: ServerError: LuaError: error running function 'on_step': attempt to index a number value
15:02:14: ERROR[main]: stack traceback:

In thread 7f82a19e6740:
/build/buildd/minetestc55-0.4.3/src/main.cpp:1741: int main(int, char**): Assertion '0' failed.
Debug stacks:
DEBUG STACK FOR THREAD 7f82a19e6740:
#0  int main(int, char**)
(Leftover data: #1  Dedicated server branch)
(Leftover data: #2  virtual void ServerMap::save(ModifiedState))
(Leftover data: #3  virtual void ServerMap::saveBlock(MapBlock*))
(Leftover data: #4  void ItemStack::serialize(std::ostream&) const)
Aborted (core dumped)


There is a error in the windows build so the first error only occurs in windows. If you want to remove all the old mobs after deleting the mod use

that about what i get only on line 98 and it says attempted to compare number with nil btw it was on linux :P

Ive tested it myself on windows and everything works fine.
The only possiblity i see is, that the people who get this error dont have a later version than 0.4.3
 

User avatar
sdzen
Member
 
Posts: 1170
Joined: Fri Aug 05, 2011 22:33
Location: Paradise (your not allowed)

by sdzen » Wed Sep 26, 2012 16:16

PilzAdam wrote:The only possiblity i see is, that the people who get this error dont have a later version than 0.4.3

I was running the latest development version from git
[h]Zen S.D.[/h] The next generation of tranquility!
malheureusement mon français n'est pas bon :<
Owner of the Zelo's
In game name: MuadTralk, spdtainted, sdzen, sd zen, sdzeno
 

sysedit
Member
 
Posts: 27
Joined: Sun Aug 12, 2012 10:53

by sysedit » Wed Sep 26, 2012 17:48

Hello,

due to a malloc my server keeps crashing. Whose fault is it?
Mobs or mintests?

19:23:49: ERROR[ServerThread]: ERROR: An unhandled exception occurred: std::bad_alloc

In thread b65ffb70:
/home/henry/system/games/minetest/src/server.cpp:152: virtual void* ServerThread::Thread(): Assertion '0' failed.
Debug stacks:
DEBUG STACK FOR THREAD b65ffb70:
#0 virtual void* ServerThread::Thread()
(Leftover data: #1 void Server::AsyncRunStep())
(Leftover data: #2 virtual void ServerEnvironment::step(float))
(Leftover data: #3 void ItemStack::deSerialize(std::istream&, IItemDefManager*))
(Leftover data: #4 void ItemStack::serialize(std::ostream&) const)
(Leftover data: #5 void ServerMap::loadBlock(std::string*, v3s16, MapSector*, bool))
DEBUG STACK FOR THREAD b77216d0:
#0 int main(int, char**)
#1 Dedicated server branch
#2 void dedicated_server_loop(Server&, bool&)
(Leftover data: #3 void Server::step(float))
Aborted
 

User avatar
Jordach
Member
 
Posts: 4523
Joined: Mon Oct 03, 2011 17:58
Location: Blender Scene
GitHub: Jordach
IRC: Jordach
In-game: Jordach

by Jordach » Wed Sep 26, 2012 17:49

Out of memory.
viewtopic.php?f=10&t=19056 Solar Plains Dev Server
 

sapier
Developer
 
Posts: 763
Joined: Tue Aug 16, 2011 18:17

by sapier » Wed Sep 26, 2012 19:54

no this is the acceleration bug github issue 229 .... I'm telling about in mobf thread for some time ,-)
DON'T mention coding style!
(c) sapier all rights reserved
 

User avatar
GJH105775
Member
 
Posts: 106
Joined: Thu Sep 27, 2012 16:11
Location: Ohio, USA

by GJH105775 » Thu Sep 27, 2012 17:03

OwenBean wrote:Sorry - I get a failed to run init.lua


change the mod's folder name it works everytime for me
Check out my mod xtrablocks, has some different types of marble that you can build with or mine at different depths

I am not here regularly as I just kind of pop in and out. If you want to find me I'll be on quadcopterforum.com helping with multirotor builds and spending other's money haha.

http://i10.photobucket.com/albums/a119/ ... hicons.jpg
 

stormrider2
Member
 
Posts: 83
Joined: Thu Jun 02, 2011 21:13

by stormrider2 » Thu Sep 27, 2012 23:57

Code: Select all
20:28:00: ERROR[main]: ERROR: An unhandled exception occurred: ServerError: LuaE
rror: error running function 'on_step': attempt to index a number value
20:28:00: ERROR[main]: stack traceback:

In thread 1f54:
/home/celeron55/mtbuild/celeron55-minetest-4a11323/src/main.cpp:1741: main: Asse
rtion '0' failed.
Debug stacks:
DEBUG STACK FOR THREAD 1f54:
#0  main
(Leftover data: #1  Dedicated server branch)
(Leftover data: #2  save)
(Leftover data: #3  saveBlock)


I have this error and I am running the latest dev version.
 

Jonathan
 

by Jonathan » Fri Sep 28, 2012 01:39

PilzAdam,


I have the error - "ServerError: LuaError: error running function ‘on_step’: attempt to index a number value" and I tried the following versions:
minetest-0.4.3-4a11323-meta_set_nodedef-win32
minetest-0.4.3-win32

Do you use minetest on Linux? If so, this might be a Windows issue and not a Linux issue.
 

User avatar
Calinou
Moderator
 
Posts: 3156
Joined: Mon Aug 01, 2011 14:26
Location: Troyes, France
GitHub: Calinou
IRC: Calinou
In-game: Calinou

by Calinou » Fri Sep 28, 2012 09:04

Jonathan wrote:PilzAdam,


I have the error - "ServerError: LuaError: error running function ‘on_step’: attempt to index a number value" and I tried the following versions:
minetest-0.4.3-4a11323-meta_set_nodedef-win32
minetest-0.4.3-win32

Do you use minetest on Linux? If so, this might be a Windows issue and not a Linux issue.


You need the latest Git - both are outdated (compared to Git) and do not work with Simple Mobs.
 

User avatar
PilzAdam
Member
 
Posts: 4026
Joined: Fri Jul 20, 2012 16:19
Location: Germany
GitHub: PilzAdam
IRC: PilzAdam

by PilzAdam » Fri Sep 28, 2012 12:45

Jonathan wrote:PilzAdam,


I have the error - "ServerError: LuaError: error running function ‘on_step’: attempt to index a number value" and I tried the following versions:
minetest-0.4.3-4a11323-meta_set_nodedef-win32
minetest-0.4.3-win32

Do you use minetest on Linux? If so, this might be a Windows issue and not a Linux issue.

With latest version for win it worked for me.
 

stormrider2
Member
 
Posts: 83
Joined: Thu Jun 02, 2011 21:13

by stormrider2 » Fri Sep 28, 2012 15:31

I tried the latest windows version and it still did not work. Can you release a bug fix?
 

User avatar
PilzAdam
Member
 
Posts: 4026
Joined: Fri Jul 20, 2012 16:19
Location: Germany
GitHub: PilzAdam
IRC: PilzAdam

by PilzAdam » Fri Sep 28, 2012 15:54

stormrider2 wrote:I tried the latest windows version and it still did not work. Can you release a bug fix?

I cant reproduce this bug, so I cant fix it.
 

Jonathan
 

by Jonathan » Fri Sep 28, 2012 16:13

Calinou wrote:
Jonathan wrote:PilzAdam,


I have the error - "ServerError: LuaError: error running function ‘on_step’: attempt to index a number value" and I tried the following versions:
minetest-0.4.3-4a11323-meta_set_nodedef-win32
minetest-0.4.3-win32

Do you use minetest on Linux? If so, this might be a Windows issue and not a Linux issue.


You need the latest Git - both are outdated (compared to Git) and do not work with Simple Mobs.


What is "Git" and where can I get the latest one?

Thanks,
Jonathan
 

User avatar
PilzAdam
Member
 
Posts: 4026
Joined: Fri Jul 20, 2012 16:19
Location: Germany
GitHub: PilzAdam
IRC: PilzAdam

by PilzAdam » Fri Sep 28, 2012 16:15

Jonathan wrote:
Calinou wrote:
Jonathan wrote:PilzAdam,


I have the error - "ServerError: LuaError: error running function ‘on_step’: attempt to index a number value" and I tried the following versions:
minetest-0.4.3-4a11323-meta_set_nodedef-win32
minetest-0.4.3-win32

Do you use minetest on Linux? If so, this might be a Windows issue and not a Linux issue.


You need the latest Git - both are outdated (compared to Git) and do not work with Simple Mobs.


What is "Git" and where can I get the latest one?

Thanks,
Jonathan

GitHub is a website that contains code of projects. Minetest is one of the ~2 million. projects there. You can get it here: https://github.com/celeron55/minetest

EDIT: There are over 3,862,506 repositories (projects).
Last edited by PilzAdam on Fri Sep 28, 2012 16:16, edited 1 time in total.
 

Jonathan
 

by Jonathan » Sat Sep 29, 2012 01:40

PilzAdam wrote:
Jonathan wrote:
Calinou wrote:
You need the latest Git - both are outdated (compared to Git) and do not work with Simple Mobs.


What is "Git" and where can I get the latest one?

Thanks,
Jonathan

GitHub is a website that contains code of projects. Minetest is one of the ~2 million. projects there. You can get it here: https://github.com/celeron55/minetest

EDIT: There are over 3,862,506 repositories (projects).


Is there somewhere I can get the latest exe file? I don't want to try to figure out how to build the executable with the files on Git.
 

cornernote
Member
 
Posts: 844
Joined: Wed Jul 11, 2012 15:02
 

Jonathan
 

by Jonathan » Sat Sep 29, 2012 14:23

cornernote wrote:sfan5 has builds of the latest versions for windows:
http://minetest.net/forum/viewtopic.php?id=1523

direct download link:
http://sfan.sf.funpic.de/minetest-builds/c55/minetest-0.4.3-9696ed3-win32.7z


After downloading this version I still got the error - "ServerError: LuaError: error running function ‘on_step’: attempt to index a number value".

Just to let you know I don't get this error until I am in the game playing it. I almost wonder if it tends to happen when I am around a hostile mob, but that does not seem to always be the case. Additionally, I am using 64bit Windows 7.

Below are some of the last lines in the debug file.
Code: Select all
10:05:44: INFO[main]: ServerMap: Written: 0 sector metadata files, 3 block files, 148 blocks in memory.
10:05:44: INFO[main]: ServerMap: Blocks modified by:
10:05:44: INFO[main]:   deactivateFarObjects: Static data changed considerably...: 1
10:05:44: INFO[main]:   setNodeNoCheck, setNodeNoCheck, setNode, setNode: 1
10:05:44: INFO[main]:   setNodeNoCheck, setNodeNoCheck, setNodeNoCheck: 1
10:05:44: INFO[main]: ServerMap: Saved map to C:\Users\Jonathan\Documents\Minetest\MinetestLatestVersion\bin\..\worlds\Jonathan's Earth
10:05:44: INFO[main]: RollbackManager::~RollbackManager()
10:05:44: INFO[main]: RollbackManager::flush()
10:05:44: INFO[main]: Server: Deinitializing scripting
10:05:44: INFO[main]: BanManager: saving to C:\Users\Jonathan\Documents\Minetest\MinetestLatestVersion\bin\..\worlds\Jonathan's Earth\ipban.txt
10:05:44: ERROR[main]: ServerError: LuaError: error running function 'on_step': attempt to index a number value
10:05:44: ERROR[main]: stack traceback:
10:05:44: INFO[main]: Searching worlds...
10:05:44: INFO[main]:   In C:\Users\Jonathan\Documents\Minetest\MinetestLatestVersion\bin\..\worlds:
10:05:44: INFO[main]: Jonathan's Earth
10:05:44: INFO[main]: 1 found.
10:05:44: INFO[main]: Waiting for other menus
10:05:44: INFO[main]: Waited for other menus
10:05:44: VERBOSE[main]: error_message = ServerError: LuaError: error running function 'on_step': attempt to index a number value
10:05:44: VERBOSE[main]: stack traceback:
10:05:44: INFO[main]: Created main menu
10:05:44: INFO[main]: locale has been set to:English_United States.1252
10:05:44: INFO[main]: locale has been set to:C
 

User avatar
PilzAdam
Member
 
Posts: 4026
Joined: Fri Jul 20, 2012 16:19
Location: Germany
GitHub: PilzAdam
IRC: PilzAdam

by PilzAdam » Sat Sep 29, 2012 14:32

The error occurs when a mob hist a player. For some reason a fix in object:punch() function dont work on some computers.
It works for me on linux and windows.
 

stormrider2
Member
 
Posts: 83
Joined: Thu Jun 02, 2011 21:13

by stormrider2 » Mon Oct 01, 2012 02:45

Maybe I can provide a bug fix? I'm a amateur programmer.
 

User avatar
PilzAdam
Member
 
Posts: 4026
Joined: Fri Jul 20, 2012 16:19
Location: Germany
GitHub: PilzAdam
IRC: PilzAdam

by PilzAdam » Mon Oct 01, 2012 06:37

PilzAdam wrote:The error occurs when a mob hist a player. For some reason a fix in object:punch() function dont work on some computers.
It works for me on linux and windows.

My friend (he had the same bug before) tested it with latest build from sfan5 and it works perfectly.
 

User avatar
GJH105775
Member
 
Posts: 106
Joined: Thu Sep 27, 2012 16:11
Location: Ohio, USA

by GJH105775 » Mon Oct 01, 2012 12:55

I would love for them to look more blocky.
Check out my mod xtrablocks, has some different types of marble that you can build with or mine at different depths

I am not here regularly as I just kind of pop in and out. If you want to find me I'll be on quadcopterforum.com helping with multirotor builds and spending other's money haha.

http://i10.photobucket.com/albums/a119/ ... hicons.jpg
 

User avatar
PilzAdam
Member
 
Posts: 4026
Joined: Fri Jul 20, 2012 16:19
Location: Germany
GitHub: PilzAdam
IRC: PilzAdam

by PilzAdam » Mon Oct 01, 2012 14:32

GJH105775 wrote:I would love for them to look more blocky.

If you or someone else could give me textures i will gladly add them.
 

PreviousNext

Return to Old Mods



Who is online

Users browsing this forum: No registered users and 4 guests