Minetest mapserver

User avatar
Miniontoby
Member
 
Posts: 263
Joined: Fri Mar 01, 2019 19:25
Location: The Netherlands
In-game: Miniontoby

Re: Minetest mapserver

by Miniontoby » Sun Jul 28, 2019 12:11

I think that ip doesn't go work
My English isn't very good because I'm Dutch ---- Check my mod "Doorbell"
 

User avatar
Miniontoby
Member
 
Posts: 263
Joined: Fri Mar 01, 2019 19:25
Location: The Netherlands
In-game: Miniontoby

Re: Minetest mapserver

by Miniontoby » Sun Jul 28, 2019 12:13

Check the real mod name you did gave the mod and set that modname at secure.http_mods setting
My English isn't very good because I'm Dutch ---- Check my mod "Doorbell"
 

DoyleChris
Member
 
Posts: 252
Joined: Sat Jul 25, 2015 19:54
In-game: DoyleChris

Re: Minetest mapserver

by DoyleChris » Sun Jul 28, 2019 12:19

I tried both mapserver and mapserver_mod in minetest.conf and world.mt it still throws the error.

Also added ability for admins, to be able to teleport players.
 

User avatar
Miniontoby
Member
 
Posts: 263
Joined: Fri Mar 01, 2019 19:25
Location: The Netherlands
In-game: Miniontoby

Re: Minetest mapserver

by Miniontoby » Sun Jul 28, 2019 12:25

Do you have set on the mapserver mod in world.mt ?
My English isn't very good because I'm Dutch ---- Check my mod "Doorbell"
 

BuckarooBanzay
Member
 
Posts: 319
Joined: Tue Apr 24, 2018 05:58
Location: Switzerland
GitHub: thomasrudin-mt
In-game: BuckarooBanzai

Re: Minetest mapserver

by BuckarooBanzay » Sun Jul 28, 2019 13:07

Code: Select all
secure.http_mods = mapserver_mod
mapserver.url = http://192.168.1.1501:8080
mapserver.key = JHtYOPtiQbOjhxoK


Two issues:

Can you post the entire debug output from minetest?
 

DoyleChris
Member
 
Posts: 252
Joined: Sat Jul 25, 2015 19:54
In-game: DoyleChris
 

DoyleChris
Member
 
Posts: 252
Joined: Sat Jul 25, 2015 19:54
In-game: DoyleChris

Re: Minetest mapserver

by DoyleChris » Sun Jul 28, 2019 15:38

This is the first couple of lines of the server debug.

Code: Select all
2019-07-28 08:12:47: [Main]: Using world specified by --worldname on the command line
2019-07-28 08:12:47: ERROR[Main]: The following mods could not be found: "mapserver_mod"
2019-07-28 08:12:47: WARNING[Main]: 3d_armor_ip: Mod loaded but unused.
2019-07-28 08:12:48: ACTION[Main]: [MOD] Mobs Redo loaded
2019-07-28 08:12:48: WARNING[Main]: /!\ You are using old auth file backend. This backend is deprecated and will be removed in a future release /!\
2019-07-28 08:12:48: WARNING[Main]: Switching to SQLite3 is advised, please read http://wiki.minetest.net/Database_backends.
2019-07-28 08:12:48: ACTION[Main]: World at [/media/christopher/700GB/minetest/bin/../worlds/Server_50]
2019-07-28 08:12:48: ACTION[Main]: Server for gameid="minetest" listening on 0.0.0.0:30000.
2019-07-28 08:13:16: ACTION[Server]: Dad [192.168.1.211] joins game.
2019-07-28 08:13:16: ACTION[Server]: Dad joins game. List of players: Dad
2019-07-28 08:19:15: ACTION[Server]: Dad leaves game. List of players:
2019-07-28 10:39:50: ACTION[Server]: Joseph [174.100.94.182] joins game.
2019-07-28 10:39:50: ACTION[Server]: Joseph joins game. List of players: Joseph
2019-07-28 10:42:04: ACTION[Server]: Server::ProcessData(): PacketError: what=Reading outside packet (offset: 0, packet size: 1)
2019-07-28 10:42:15: ACTION[Server]: Joseph digs default:sand at (-102,-7,-1956)
2019-07-28 10:42:16: ACTION[Server]: Joseph digs default:sand at (-102,-8,-1956)
2019-07-28 10:42:17: ACTION[Server]: Joseph places node default:aspen_wood at (-102,-7,-1956)
2019-07-28 10:42:28: ACTION[Server]: Joseph digs default:aspen_wood at (-102,-7,-1956)
2019-07-28 10:42:57: ACTION[Server]: Joseph digs default:sand at (-102,-7,-1957)
2019-07-28 10:42:58: ACTION[Server]: Joseph digs default:sand at (-102,-8,-1957)
2019-07-28 10:43:04: ACTION[Server]: Joseph places node default:aspen_wood at (-102,-7,-1956)
 

DoyleChris
Member
 
Posts: 252
Joined: Sat Jul 25, 2015 19:54
In-game: DoyleChris

Re: Minetest mapserver

by DoyleChris » Sun Jul 28, 2019 15:45

well i did some changes and this is what i got now.

Code: Select all
2019-07-28 11:44:11: [Main]: Using world specified by --worldname on the command line
2019-07-28 11:44:11: WARNING[Main]: 3d_armor_ip: Mod loaded but unused.
2019-07-28 11:44:12: ACTION[Main]: [MOD] Mobs Redo loaded
2019-07-28 11:44:13: WARNING[Main]: /!\ You are using old auth file backend. This backend is deprecated and will be removed in a future release /!\
2019-07-28 11:44:13: WARNING[Main]: Switching to SQLite3 is advised, please read http://wiki.minetest.net/Database_backends.
2019-07-28 11:44:13: ACTION[Main]: World at [/media/christopher/700GB/minetest/bin/../worlds/Server_50]
2019-07-28 11:44:13: ACTION[Main]: Server for gameid="minetest" listening on 0.0.0.0:30000.
 

User avatar
Miniontoby
Member
 
Posts: 263
Joined: Fri Mar 01, 2019 19:25
Location: The Netherlands
In-game: Miniontoby

Re: Minetest mapserver

by Miniontoby » Mon Jul 29, 2019 12:47

I run mapserver.exe

And My minetest server with this log
Code: Select all
... (here come some )
2019-07-29 14:42:59: ACTION[Main]: World at [/home/pi/snap/minetest/820/.minetest/worlds/server]
2019-07-29 14:42:59: ACTION[Main]: Server for gameid="minetest" listening on 0.0.0.0:30000.
2019-07-29 14:51:34: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:51:36: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:51:39: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:51:41: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:51:43: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:51:45: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:51:47: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:51:49: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:51:52: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:51:54: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:51:56: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:51:58: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:52:00: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:52:02: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:52:05: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:52:07: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:52:09: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:52:11: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:52:13: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:52:15: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:52:18: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:52:20: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:52:22: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:52:24: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:52:26: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:52:28: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:52:31: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:52:33: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest


My minetest.conf like this
Code: Select all
secure.http_mods = mapserver
mapserver.url = http://192.168.1.151:8080
mapserver.key = QEeiIUfaRwlBLfXd

P.s. my Mapserver url is my (laptop) IP

And this works.

Image
Attachments
Screenshot_2019-07-29-14-55-59.png
Screenshot
(444.92 KiB) Not downloaded yet
Last edited by Miniontoby on Tue Jul 30, 2019 08:23, edited 2 times in total.
My English isn't very good because I'm Dutch ---- Check my mod "Doorbell"
 

DoyleChris
Member
 
Posts: 252
Joined: Sat Jul 25, 2015 19:54
In-game: DoyleChris

Re: Minetest mapserver

by DoyleChris » Tue Jul 30, 2019 00:45

What is this.

mapserver.enable_crafting
 

User avatar
Miniontoby
Member
 
Posts: 263
Joined: Fri Mar 01, 2019 19:25
Location: The Netherlands
In-game: Miniontoby

Re: Minetest mapserver

by Miniontoby » Tue Jul 30, 2019 08:16

That is a setting and I forget something to post in serverlog. But I will add it later
My English isn't very good because I'm Dutch ---- Check my mod "Doorbell"
 

BuckarooBanzay
Member
 
Posts: 319
Joined: Tue Apr 24, 2018 05:58
Location: Switzerland
GitHub: thomasrudin-mt
In-game: BuckarooBanzai

Re: Minetest mapserver

by BuckarooBanzay » Tue Jul 30, 2019 17:40

DoyleChris wrote:What is this.

mapserver.enable_crafting


See: https://github.com/minetest-tools/mapse ... bridge-mod

Code: Select all
If you want to enable craftable mapobjects (poi, labels, trainblocks, etc) you can enable the setting in your minetest.conf (defaults to false)
 

Rafi59
Member
 
Posts: 12
Joined: Tue May 22, 2018 10:31
Location: France
GitHub: Rafi594
IRC: Rafi59
In-game: Rafi59

Re: Minetest mapserver

by Rafi59 » Tue Aug 06, 2019 18:53

Initial rendering is finished on my map but I don't see the smartshop on the map maybe my version is not good ? (https://rafi59.codelib.re/git/Axinite/smartshop)
 

BuckarooBanzay
Member
 
Posts: 319
Joined: Tue Apr 24, 2018 05:58
Location: Switzerland
GitHub: thomasrudin-mt
In-game: BuckarooBanzai

Re: Minetest mapserver

by BuckarooBanzay » Sun Aug 11, 2019 17:14

Rafi59 wrote:Initial rendering is finished on my map but I don't see the smartshop on the map maybe my version is not good ? (https://rafi59.codelib.re/git/Axinite/smartshop)



Sorry for the lag :)

Seems to be an issue on my server too, i opened an issue in the mapserver repo:
https://github.com/minetest-tools/mapserver/issues/48

I never noticed because we use the fancyvendors more...

Thx for reporting
 

jakebriggs
New member
 
Posts: 1
Joined: Sun Oct 06, 2019 20:30

Re: Minetest mapserver

by jakebriggs » Mon Dec 02, 2019 01:16

I have a weird issue, the mapserver runs and initial rendering completes, but when I connect I get nothing - a blank screen, apart from some UI elements. There are 2 errors in the web browser console though and I think the call to ws://redacted:8080/api/ws is the issue.
Code: Select all
Source map error: Error: request failed with status 404
Resource URL: http://redacted:8080/css/bootstrap.min.css
Source Map URL: bootstrap.min.css.map


and

Code: Select all
The connection to ws://redacted:8080/api/ws was interrupted while the page was loading. WebSocketChannel.js:32:13


Image

The full logs from the server are here but I can't see anything obvious in them:

Code: Select all
jake@redacted:/var/games/minetest-server/.minetest/worlds/world$ sudo ./mapserver-linux-x86_64
INFO[0000] Starting mapserver                            version=3.0.0
INFO[0000] Migrating database                            filename=map.sqlite prefix=sqlite-db
INFO[0000] Migration completed                           elapsed=506.103551ms prefix=sqlite-db
INFO[0000] Loading default colors                        filename=/colors.txt prefix=colormapping size=704276 useLocal=false
INFO[0000] Loaded default colors                         count=16109
INFO[0000] Migrating database                            filename=mapserver.sqlite prefix=mapobjectdb.sqlite
INFO[0000] Migration completed                           elapsed=26.319796ms prefix=mapobjectdb.sqlite
INFO[0000] Starting http server                          port=8080 webdev=false
INFO[0000] Starting initial rendering job               
^TINFO[0022] Initial rendering                             elapsed=21.670126547s mapblocks=5044 progress%=0 tiles=202
INFO[0039] Initial rendering                             elapsed=17.649924268s mapblocks=4970 progress%=3 tiles=254
INFO[0054] Initial rendering                             elapsed=14.352038823s mapblocks=4446 progress%=6 tiles=232
INFO[0070] Initial rendering                             elapsed=15.851774846s mapblocks=4591 progress%=10 tiles=267
INFO[0083] Initial rendering                             elapsed=13.761146197s mapblocks=4606 progress%=13 tiles=216
INFO[0097] Initial rendering                             elapsed=13.742259122s mapblocks=4406 progress%=17 tiles=214
INFO[0115] Initial rendering                             elapsed=17.869077152s mapblocks=5301 progress%=20 tiles=316
INFO[0138] Initial rendering                             elapsed=22.865410705s mapblocks=5090 progress%=23 tiles=350
INFO[0158] Initial rendering                             elapsed=20.494052799s mapblocks=4793 progress%=27 tiles=303
INFO[0182] Initial rendering                             elapsed=23.909590745s mapblocks=4728 progress%=30 tiles=446
INFO[0201] Initial rendering                             elapsed=19.029038995s mapblocks=5374 progress%=34 tiles=346
INFO[0219] Initial rendering                             elapsed=18.121476666s mapblocks=5420 progress%=37 tiles=300
INFO[0235] Initial rendering                             elapsed=15.313777358s mapblocks=4294 progress%=41 tiles=258
INFO[0255] Initial rendering                             elapsed=20.289591735s mapblocks=5436 progress%=44 tiles=353
INFO[0273] Initial rendering                             elapsed=17.952355636s mapblocks=4444 progress%=47 tiles=306
INFO[0296] Initial rendering                             elapsed=22.515469318s mapblocks=5061 progress%=51 tiles=385
INFO[0316] Initial rendering                             elapsed=20.231217634s mapblocks=4964 progress%=54 tiles=339
INFO[0334] Initial rendering                             elapsed=17.804159943s mapblocks=4636 progress%=58 tiles=287
INFO[0355] Initial rendering                             elapsed=21.419019221s mapblocks=5679 progress%=61 tiles=358
INFO[0371] Initial rendering                             elapsed=16.308660227s mapblocks=4446 progress%=64 tiles=243
INFO[0391] Initial rendering                             elapsed=19.223415514s mapblocks=5959 progress%=68 tiles=290
INFO[0413] Initial rendering                             elapsed=22.428884951s mapblocks=4273 progress%=71 tiles=376
INFO[0432] Initial rendering                             elapsed=18.647383849s mapblocks=5443 progress%=75 tiles=287
INFO[0450] Initial rendering                             elapsed=18.883572621s mapblocks=5437 progress%=78 tiles=281
INFO[0471] Initial rendering                             elapsed=20.261465729s mapblocks=4783 progress%=82 tiles=340
INFO[0491] Initial rendering                             elapsed=20.551858592s mapblocks=4898 progress%=85 tiles=337
INFO[0508] Initial rendering                             elapsed=16.498716029s mapblocks=5128 progress%=88 tiles=276
INFO[0531] Initial rendering                             elapsed=23.09628202s mapblocks=5199 progress%=92 tiles=415
INFO[0551] Initial rendering                             elapsed=20.573754685s mapblocks=5386 progress%=95 tiles=389
INFO[0559] Initial rendering                             elapsed=7.857432814s mapblocks=1714 progress%=99 tiles=182
INFO[0559] initial rendering complete                   
INFO[0559] Starting incremental rendering job            LastMtime=1575247790
^[[A^[[A^C
jake@redacted:/var/games/minetest-server/.minetest/worlds/world$
jake@redacted:/var/games/minetest-server/.minetest/worlds/world$
jake@redacted:/var/games/minetest-server/.minetest/worlds/world$
jake@redacted:/var/games/minetest-server/.minetest/worlds/world$ sudo ./mapserver-linux-x86_64
INFO[0000] Starting mapserver                            version=3.0.0
INFO[0000] Loading default colors                        filename=/colors.txt prefix=colormapping size=704276 useLocal=false
INFO[0000] Loaded default colors                         count=16109
INFO[0000] Migrating database                            filename=mapserver.sqlite prefix=mapobjectdb.sqlite
INFO[0000] Migration completed                           elapsed=2.378155ms prefix=mapobjectdb.sqlite
INFO[0000] Starting http server                          port=8080 webdev=false
INFO[0000] Starting incremental rendering job            LastMtime=1575247790
 

User avatar
Miniontoby
Member
 
Posts: 263
Joined: Fri Mar 01, 2019 19:25
Location: The Netherlands
In-game: Miniontoby

Re: Minetest mapserver

by Miniontoby » Mon Dec 02, 2019 13:18

That last thing you did in the log is what you need to do (run it in the server folder.) and by me it does work, but I have git-be20dff27e4e9ad65b8fb0bbf6d3222eb594ab63 version of the mapper
My English isn't very good because I'm Dutch ---- Check my mod "Doorbell"
 

BuckarooBanzay
Member
 
Posts: 319
Joined: Tue Apr 24, 2018 05:58
Location: Switzerland
GitHub: thomasrudin-mt
In-game: BuckarooBanzai

Re: Minetest mapserver

by BuckarooBanzay » Mon Dec 02, 2019 16:53

jakebriggs wrote:I have a weird issue, the mapserver runs and initial rendering completes, but when I connect I get nothing - a blank screen, apart from some UI elements. There are 2 errors in the web browser console though and I think the call to ws://redacted:8080/api/ws is the issue.
Code: Select all
Source map error: Error: request failed with status 404
Resource URL: http://redacted:8080/css/bootstrap.min.css
Source Map URL: bootstrap.min.css.map



The first error in the console is a missing bootstrap debug asset, ironically that only fails if you open the developer console :)
The second is probably the previous websocket connection before you refreshed the site.
You can ignore both safely ;)

Did you try to zoom in into the grey stuff? (with the + button on the upper left or the scroll wheel on the mouse)
Is this a new/empty world?
If not, can you share the
Code: Select all
mapserver.json
with the configured layers?

I made a pre-release for the new mapserver with a frontend rewrite, maybe you can give that a try:
https://github.com/minetest-mapserver/m ... .0.0-alpha

Rafi59 wrote:Initial rendering is finished on my map but I don't see the smartshop on the map maybe my version is not good ? (https://rafi59.codelib.re/git/Axinite/smartshop)


This should be fixed in the new version too (https://github.com/minetest-mapserver/m ... /issues/48)

Miniontoby wrote:That last thing you did in the log is what you need to do (run it in the server folder.) and by me it does work, but I have git-be20dff27e4e9ad65b8fb0bbf6d3222eb594ab63 version of the mapper


Where did you get that version from? I thought i properly tagged the releases with 3.0, 3.1, etc... :O
 

User avatar
Miniontoby
Member
 
Posts: 263
Joined: Fri Mar 01, 2019 19:25
Location: The Netherlands
In-game: Miniontoby

Re: Minetest mapserver

by Miniontoby » Tue Dec 03, 2019 12:58

BuckarooBanzay wrote:
Miniontoby wrote:That last thing you did in the log is what you need to do (run it in the server folder.) and by me it does work, but I have git-be20dff27e4e9ad65b8fb0bbf6d3222eb594ab63 version of the mapper


Where did you get that version from? I thought i properly tagged the releases with 3.0, 3.1, etc... :O


I don't know how I get that version, but I am happy that it is working (p.s. I have run it on my raspberry pi, so I have one of the linux versions).
My English isn't very good because I'm Dutch ---- Check my mod "Doorbell"
 

User avatar
Festus1965
Member
 
Posts: 974
Joined: Sun Jan 03, 2016 11:58
Location: Thailand - Chiang Mai (+5-6h to MEZ)
In-game: Thomas Explorer

Re: Minetest mapserver

by Festus1965 » Sat Dec 07, 2019 11:02

Code: Select all
..
2019-12-07 13:59:25: WARNING[Server]: [monitoring] globalstep took 77141 us in mod mesecons
..
What could cause this ? (Even put mapserver = false lat restart as I don't see gamer on map)
Server: still up, see some gamer - but there is a new 1st important thread "climate change" for me. Something I know since 1992 - had seen the melting glacier in Switzerland.
 

Previous

Return to Minetest-related projects



Who is online

Users browsing this forum: No registered users and 1 guest