Omicron - prerelease 0.7 "Tweaky Update"

User avatar
cHyper
Member
 
Posts: 842
Joined: Fri May 06, 2011 08:49
Location: Austria
GitHub: cHyper-0815OL
IRC: cHyper
In-game: cHyper cHyper_0815

Re: Omicron - prerelease 0.7 "Tweaky Update"

by cHyper » Thu Jul 25, 2019 18:15

i use mint linux and when i compile the game with cmake or make the game start shortly and then it crash and do nothing? what should i do to run it under linux?

Image

error: message:

could not find DOXYGEN ??

sudo apt-get build-dep glfw ------------------>>>> where do i get glfw ?????????

which linux distribution does this game do his best job?? maybe i switch the os system!!
Attachments
Bildschirmfoto vom 2019-07-25 20-18-57.png
(234.84 KiB) Not downloaded yet
 

User avatar
azekill_DIABLO
Member
 
Posts: 7488
Joined: Wed Oct 29, 2014 20:05
Location: OMICRON
GitHub: azekillDIABLO
In-game: azekill_DIABLO

Re: Omicron - prerelease 0.7 "Tweaky Update"

by azekill_DIABLO » Mon Jul 29, 2019 16:13

cHyper wrote:i use mint linux and when i compile the game with cmake or make the game start shortly and then it crash and do nothing? what should i do to run it under linux?

Image

error: message:

could not find DOXYGEN ??

sudo apt-get build-dep glfw ------------------>>>> where do i get glfw ?????????

which linux distribution does this game do his best job?? maybe i switch the os system!!

I'm so sorry for taking that long to reply, I had a lot of stuff to do away from my PC.

ABOUT THE CRASH:
lone_wolf suffers the same issue as you. I'm working on it and I couldn't guess what wasn't working out until you pointed out something related to GLFW and Doxygen :D thanks!

ABOUT GLFW:
you might need to use the command sudo apt-get install cmake xorg-dev libglu1-mesa-dev to get the good deps for GLFW. Then if you still can't install GLFW (which is one pesky library) here's what you can do instead:

short method: sudo apt-get install libglfw3-dev
else use:

  1. Add the following line to /etc/apt/sources.list
  2. Then execute these commands
      sudo apt-get update
      sudo apt-get install libglfw3
      sudo apt-get install libglfw3-dev

ABOUT OS CONCERNS:
AntiX seems to work just fine... but don't change! It's entirely my fault if I can't get the game to work on your PC! Don't disturb your config, I'm sure if fine and reliable!
 

User avatar
azekill_DIABLO
Member
 
Posts: 7488
Joined: Wed Oct 29, 2014 20:05
Location: OMICRON
GitHub: azekillDIABLO
In-game: azekill_DIABLO

Re: Omicron - prerelease 0.7 "Tweaky Update"

by azekill_DIABLO » Mon Jul 29, 2019 16:43

I was testing on my nano-laptop and it can't run craft so yeah, I think it's fair to say it's my laptop which is quite bad. And old.

Honestly I'd love to be able to try run it on another linux to understand wth is wrong.

Also DOXYGEN is pretty much useless, it's optional don't worry, I don't have it on my PC either.
 

User avatar
cHyper
Member
 
Posts: 842
Joined: Fri May 06, 2011 08:49
Location: Austria
GitHub: cHyper-0815OL
IRC: cHyper
In-game: cHyper cHyper_0815

Re: Omicron - prerelease 0.7 "Tweaky Update"

by cHyper » Tue Aug 06, 2019 11:05

After adding a folder called "world" the game runs smooth and well done.
Thanks for fixing the issue. great game so far, whats the next features you will add with the next milestone-release?
 

User avatar
azekill_DIABLO
Member
 
Posts: 7488
Joined: Wed Oct 29, 2014 20:05
Location: OMICRON
GitHub: azekillDIABLO
In-game: azekill_DIABLO

Re: Omicron - prerelease 0.7 "Tweaky Update"

by azekill_DIABLO » Thu Aug 22, 2019 13:39

That's nice to hear. Next feature are: light system, chunk render issue fixing on the run, tree leaves
 

Previous

Return to Minetest-related projects



Who is online

Users browsing this forum: No registered users and 4 guests