Minetest mapserver

User avatar
Miniontoby
Member
Posts: 416
Joined: Fri Mar 01, 2019 19:25
IRC: Miniontoby
In-game: Miniontoby
Location: The Netherlands

Re: Minetest mapserver

by Miniontoby » Post

I think that ip doesn't go work
My English isn't very good because I'm Dutch ---- Check my mod "Doorbell" Vote your gang

User avatar
Miniontoby
Member
Posts: 416
Joined: Fri Mar 01, 2019 19:25
IRC: Miniontoby
In-game: Miniontoby
Location: The Netherlands

Re: Minetest mapserver

by Miniontoby » Post

Check the real mod name you did gave the mod and set that modname at secure.http_mods setting
My English isn't very good because I'm Dutch ---- Check my mod "Doorbell" Vote your gang

DoyleChris
Member
Posts: 253
Joined: Sat Jul 25, 2015 19:54
In-game: DoyleChris

Re: Minetest mapserver

by DoyleChris » Post

I tried both mapserver and mapserver_mod in minetest.conf and world.mt it still throws the error.

Also added ability for admins, to be able to teleport players.

User avatar
Miniontoby
Member
Posts: 416
Joined: Fri Mar 01, 2019 19:25
IRC: Miniontoby
In-game: Miniontoby
Location: The Netherlands

Re: Minetest mapserver

by Miniontoby » Post

Do you have set on the mapserver mod in world.mt ?
My English isn't very good because I'm Dutch ---- Check my mod "Doorbell" Vote your gang

User avatar
BuckarooBanzay
Member
Posts: 374
Joined: Tue Apr 24, 2018 05:58
GitHub: BuckarooBanzay
IRC: BuckarooBanzai
In-game: BuckarooBanzai

Re: Minetest mapserver

by BuckarooBanzay » Post

Code: Select all

secure.http_mods = mapserver_mod
mapserver.url = http://192.168.1.1501:8080
mapserver.key = JHtYOPtiQbOjhxoK
Two issues: Can you post the entire debug output from minetest?

DoyleChris
Member
Posts: 253
Joined: Sat Jul 25, 2015 19:54
In-game: DoyleChris

Re: Minetest mapserver

by DoyleChris » Post

sorry its 192.168.1.150

DoyleChris
Member
Posts: 253
Joined: Sat Jul 25, 2015 19:54
In-game: DoyleChris

Re: Minetest mapserver

by DoyleChris » Post

This is the first couple of lines of the server debug.

Code: Select all

2019-07-28 08:12:47: [Main]: Using world specified by --worldname on the command line
2019-07-28 08:12:47: ERROR[Main]: The following mods could not be found: "mapserver_mod"
2019-07-28 08:12:47: WARNING[Main]: 3d_armor_ip: Mod loaded but unused.
2019-07-28 08:12:48: ACTION[Main]: [MOD] Mobs Redo loaded
2019-07-28 08:12:48: WARNING[Main]: /!\ You are using old auth file backend. This backend is deprecated and will be removed in a future release /!\
2019-07-28 08:12:48: WARNING[Main]: Switching to SQLite3 is advised, please read http://wiki.minetest.net/Database_backends.
2019-07-28 08:12:48: ACTION[Main]: World at [/media/christopher/700GB/minetest/bin/../worlds/Server_50]
2019-07-28 08:12:48: ACTION[Main]: Server for gameid="minetest" listening on 0.0.0.0:30000.
2019-07-28 08:13:16: ACTION[Server]: Dad [192.168.1.211] joins game. 
2019-07-28 08:13:16: ACTION[Server]: Dad joins game. List of players: Dad
2019-07-28 08:19:15: ACTION[Server]: Dad leaves game. List of players: 
2019-07-28 10:39:50: ACTION[Server]: Joseph [174.100.94.182] joins game. 
2019-07-28 10:39:50: ACTION[Server]: Joseph joins game. List of players: Joseph
2019-07-28 10:42:04: ACTION[Server]: Server::ProcessData(): PacketError: what=Reading outside packet (offset: 0, packet size: 1)
2019-07-28 10:42:15: ACTION[Server]: Joseph digs default:sand at (-102,-7,-1956)
2019-07-28 10:42:16: ACTION[Server]: Joseph digs default:sand at (-102,-8,-1956)
2019-07-28 10:42:17: ACTION[Server]: Joseph places node default:aspen_wood at (-102,-7,-1956)
2019-07-28 10:42:28: ACTION[Server]: Joseph digs default:aspen_wood at (-102,-7,-1956)
2019-07-28 10:42:57: ACTION[Server]: Joseph digs default:sand at (-102,-7,-1957)
2019-07-28 10:42:58: ACTION[Server]: Joseph digs default:sand at (-102,-8,-1957)
2019-07-28 10:43:04: ACTION[Server]: Joseph places node default:aspen_wood at (-102,-7,-1956)

DoyleChris
Member
Posts: 253
Joined: Sat Jul 25, 2015 19:54
In-game: DoyleChris

Re: Minetest mapserver

by DoyleChris » Post

well i did some changes and this is what i got now.

Code: Select all

2019-07-28 11:44:11: [Main]: Using world specified by --worldname on the command line
2019-07-28 11:44:11: WARNING[Main]: 3d_armor_ip: Mod loaded but unused.
2019-07-28 11:44:12: ACTION[Main]: [MOD] Mobs Redo loaded
2019-07-28 11:44:13: WARNING[Main]: /!\ You are using old auth file backend. This backend is deprecated and will be removed in a future release /!\
2019-07-28 11:44:13: WARNING[Main]: Switching to SQLite3 is advised, please read http://wiki.minetest.net/Database_backends.
2019-07-28 11:44:13: ACTION[Main]: World at [/media/christopher/700GB/minetest/bin/../worlds/Server_50]
2019-07-28 11:44:13: ACTION[Main]: Server for gameid="minetest" listening on 0.0.0.0:30000.

User avatar
Miniontoby
Member
Posts: 416
Joined: Fri Mar 01, 2019 19:25
IRC: Miniontoby
In-game: Miniontoby
Location: The Netherlands

Re: Minetest mapserver

by Miniontoby » Post

I run mapserver.exe

And My minetest server with this log

Code: Select all

... (here come some )
2019-07-29 14:42:59: ACTION[Main]: World at [/home/pi/snap/minetest/820/.minetest/worlds/server]
2019-07-29 14:42:59: ACTION[Main]: Server for gameid="minetest" listening on 0.0.0.0:30000.
2019-07-29 14:51:34: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:51:36: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:51:39: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:51:41: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:51:43: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:51:45: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:51:47: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:51:49: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:51:52: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:51:54: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:51:56: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:51:58: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:52:00: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:52:02: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:52:05: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:52:07: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:52:09: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:52:11: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:52:13: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:52:15: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:52:18: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:52:20: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:52:22: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:52:24: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:52:26: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:52:28: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:52:31: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
2019-07-29 14:52:33: ACTION[Server]: Mod performs HTTP request with URL http://192.168.1.151:8080/api/minetest
My minetest.conf like this

Code: Select all

secure.http_mods = mapserver
mapserver.url = http://192.168.1.151:8080
mapserver.key = QEeiIUfaRwlBLfXd

P.s. my Mapserver url is my (laptop) IP

And this works.

Image
Attachments
Screenshot_2019-07-29-14-55-59.png
Screenshot
(444.92 KiB) Not downloaded yet
Last edited by Miniontoby on Tue Jul 30, 2019 08:23, edited 2 times in total.
My English isn't very good because I'm Dutch ---- Check my mod "Doorbell" Vote your gang

DoyleChris
Member
Posts: 253
Joined: Sat Jul 25, 2015 19:54
In-game: DoyleChris

Re: Minetest mapserver

by DoyleChris » Post

What is this.

mapserver.enable_crafting

User avatar
Miniontoby
Member
Posts: 416
Joined: Fri Mar 01, 2019 19:25
IRC: Miniontoby
In-game: Miniontoby
Location: The Netherlands

Re: Minetest mapserver

by Miniontoby » Post

That is a setting and I forget something to post in serverlog. But I will add it later
My English isn't very good because I'm Dutch ---- Check my mod "Doorbell" Vote your gang

User avatar
BuckarooBanzay
Member
Posts: 374
Joined: Tue Apr 24, 2018 05:58
GitHub: BuckarooBanzay
IRC: BuckarooBanzai
In-game: BuckarooBanzai

Re: Minetest mapserver

by BuckarooBanzay » Post

DoyleChris wrote:What is this.

mapserver.enable_crafting
See: https://github.com/minetest-tools/mapse ... bridge-mod

Code: Select all

If you want to enable craftable mapobjects (poi, labels, trainblocks, etc) you can enable the setting in your minetest.conf (defaults to false)

Rafi59
Member
Posts: 15
Joined: Tue May 22, 2018 10:31
GitHub: Rafi594
IRC: Rafi59
In-game: Rafi59
Location: France
Contact:

Re: Minetest mapserver

by Rafi59 » Post

Initial rendering is finished on my map but I don't see the smartshop on the map maybe my version is not good ? (https://rafi59.codelib.re/git/Axinite/smartshop)

User avatar
BuckarooBanzay
Member
Posts: 374
Joined: Tue Apr 24, 2018 05:58
GitHub: BuckarooBanzay
IRC: BuckarooBanzai
In-game: BuckarooBanzai

Re: Minetest mapserver

by BuckarooBanzay » Post

Rafi59 wrote:Initial rendering is finished on my map but I don't see the smartshop on the map maybe my version is not good ? (https://rafi59.codelib.re/git/Axinite/smartshop)

Sorry for the lag :)

Seems to be an issue on my server too, i opened an issue in the mapserver repo:
https://github.com/minetest-tools/mapserver/issues/48

I never noticed because we use the fancyvendors more...

Thx for reporting

jakebriggs
New member
Posts: 4
Joined: Sun Oct 06, 2019 20:30

Re: Minetest mapserver

by jakebriggs » Post

I have a weird issue, the mapserver runs and initial rendering completes, but when I connect I get nothing - a blank screen, apart from some UI elements. There are 2 errors in the web browser console though and I think the call to ws://redacted:8080/api/ws is the issue.

Code: Select all

Source map error: Error: request failed with status 404
Resource URL: http://redacted:8080/css/bootstrap.min.css
Source Map URL: bootstrap.min.css.map
and

Code: Select all

The connection to ws://redacted:8080/api/ws was interrupted while the page was loading. WebSocketChannel.js:32:13
Image

The full logs from the server are here but I can't see anything obvious in them:

Code: Select all

jake@redacted:/var/games/minetest-server/.minetest/worlds/world$ sudo ./mapserver-linux-x86_64 
INFO[0000] Starting mapserver                            version=3.0.0
INFO[0000] Migrating database                            filename=map.sqlite prefix=sqlite-db
INFO[0000] Migration completed                           elapsed=506.103551ms prefix=sqlite-db
INFO[0000] Loading default colors                        filename=/colors.txt prefix=colormapping size=704276 useLocal=false
INFO[0000] Loaded default colors                         count=16109
INFO[0000] Migrating database                            filename=mapserver.sqlite prefix=mapobjectdb.sqlite
INFO[0000] Migration completed                           elapsed=26.319796ms prefix=mapobjectdb.sqlite
INFO[0000] Starting http server                          port=8080 webdev=false
INFO[0000] Starting initial rendering job               
^TINFO[0022] Initial rendering                             elapsed=21.670126547s mapblocks=5044 progress%=0 tiles=202
INFO[0039] Initial rendering                             elapsed=17.649924268s mapblocks=4970 progress%=3 tiles=254
INFO[0054] Initial rendering                             elapsed=14.352038823s mapblocks=4446 progress%=6 tiles=232
INFO[0070] Initial rendering                             elapsed=15.851774846s mapblocks=4591 progress%=10 tiles=267
INFO[0083] Initial rendering                             elapsed=13.761146197s mapblocks=4606 progress%=13 tiles=216
INFO[0097] Initial rendering                             elapsed=13.742259122s mapblocks=4406 progress%=17 tiles=214
INFO[0115] Initial rendering                             elapsed=17.869077152s mapblocks=5301 progress%=20 tiles=316
INFO[0138] Initial rendering                             elapsed=22.865410705s mapblocks=5090 progress%=23 tiles=350
INFO[0158] Initial rendering                             elapsed=20.494052799s mapblocks=4793 progress%=27 tiles=303
INFO[0182] Initial rendering                             elapsed=23.909590745s mapblocks=4728 progress%=30 tiles=446
INFO[0201] Initial rendering                             elapsed=19.029038995s mapblocks=5374 progress%=34 tiles=346
INFO[0219] Initial rendering                             elapsed=18.121476666s mapblocks=5420 progress%=37 tiles=300
INFO[0235] Initial rendering                             elapsed=15.313777358s mapblocks=4294 progress%=41 tiles=258
INFO[0255] Initial rendering                             elapsed=20.289591735s mapblocks=5436 progress%=44 tiles=353
INFO[0273] Initial rendering                             elapsed=17.952355636s mapblocks=4444 progress%=47 tiles=306
INFO[0296] Initial rendering                             elapsed=22.515469318s mapblocks=5061 progress%=51 tiles=385
INFO[0316] Initial rendering                             elapsed=20.231217634s mapblocks=4964 progress%=54 tiles=339
INFO[0334] Initial rendering                             elapsed=17.804159943s mapblocks=4636 progress%=58 tiles=287
INFO[0355] Initial rendering                             elapsed=21.419019221s mapblocks=5679 progress%=61 tiles=358
INFO[0371] Initial rendering                             elapsed=16.308660227s mapblocks=4446 progress%=64 tiles=243
INFO[0391] Initial rendering                             elapsed=19.223415514s mapblocks=5959 progress%=68 tiles=290
INFO[0413] Initial rendering                             elapsed=22.428884951s mapblocks=4273 progress%=71 tiles=376
INFO[0432] Initial rendering                             elapsed=18.647383849s mapblocks=5443 progress%=75 tiles=287
INFO[0450] Initial rendering                             elapsed=18.883572621s mapblocks=5437 progress%=78 tiles=281
INFO[0471] Initial rendering                             elapsed=20.261465729s mapblocks=4783 progress%=82 tiles=340
INFO[0491] Initial rendering                             elapsed=20.551858592s mapblocks=4898 progress%=85 tiles=337
INFO[0508] Initial rendering                             elapsed=16.498716029s mapblocks=5128 progress%=88 tiles=276
INFO[0531] Initial rendering                             elapsed=23.09628202s mapblocks=5199 progress%=92 tiles=415
INFO[0551] Initial rendering                             elapsed=20.573754685s mapblocks=5386 progress%=95 tiles=389
INFO[0559] Initial rendering                             elapsed=7.857432814s mapblocks=1714 progress%=99 tiles=182
INFO[0559] initial rendering complete                   
INFO[0559] Starting incremental rendering job            LastMtime=1575247790
^[[A^[[A^C
jake@redacted:/var/games/minetest-server/.minetest/worlds/world$ 
jake@redacted:/var/games/minetest-server/.minetest/worlds/world$ 
jake@redacted:/var/games/minetest-server/.minetest/worlds/world$ 
jake@redacted:/var/games/minetest-server/.minetest/worlds/world$ sudo ./mapserver-linux-x86_64 
INFO[0000] Starting mapserver                            version=3.0.0
INFO[0000] Loading default colors                        filename=/colors.txt prefix=colormapping size=704276 useLocal=false
INFO[0000] Loaded default colors                         count=16109
INFO[0000] Migrating database                            filename=mapserver.sqlite prefix=mapobjectdb.sqlite
INFO[0000] Migration completed                           elapsed=2.378155ms prefix=mapobjectdb.sqlite
INFO[0000] Starting http server                          port=8080 webdev=false
INFO[0000] Starting incremental rendering job            LastMtime=1575247790

User avatar
Miniontoby
Member
Posts: 416
Joined: Fri Mar 01, 2019 19:25
IRC: Miniontoby
In-game: Miniontoby
Location: The Netherlands

Re: Minetest mapserver

by Miniontoby » Post

That last thing you did in the log is what you need to do (run it in the server folder.) and by me it does work, but I have git-be20dff27e4e9ad65b8fb0bbf6d3222eb594ab63 version of the mapper
My English isn't very good because I'm Dutch ---- Check my mod "Doorbell" Vote your gang

User avatar
BuckarooBanzay
Member
Posts: 374
Joined: Tue Apr 24, 2018 05:58
GitHub: BuckarooBanzay
IRC: BuckarooBanzai
In-game: BuckarooBanzai

Re: Minetest mapserver

by BuckarooBanzay » Post

jakebriggs wrote:I have a weird issue, the mapserver runs and initial rendering completes, but when I connect I get nothing - a blank screen, apart from some UI elements. There are 2 errors in the web browser console though and I think the call to ws://redacted:8080/api/ws is the issue.

Code: Select all

Source map error: Error: request failed with status 404
Resource URL: http://redacted:8080/css/bootstrap.min.css
Source Map URL: bootstrap.min.css.map
The first error in the console is a missing bootstrap debug asset, ironically that only fails if you open the developer console :)
The second is probably the previous websocket connection before you refreshed the site.
You can ignore both safely ;)

Did you try to zoom in into the grey stuff? (with the + button on the upper left or the scroll wheel on the mouse)
Is this a new/empty world?
If not, can you share the

Code: Select all

mapserver.json
with the configured layers?

I made a pre-release for the new mapserver with a frontend rewrite, maybe you can give that a try:
https://github.com/minetest-mapserver/m ... .0.0-alpha
Rafi59 wrote:Initial rendering is finished on my map but I don't see the smartshop on the map maybe my version is not good ? (https://rafi59.codelib.re/git/Axinite/smartshop)
This should be fixed in the new version too (https://github.com/minetest-mapserver/m ... /issues/48)
Miniontoby wrote:That last thing you did in the log is what you need to do (run it in the server folder.) and by me it does work, but I have git-be20dff27e4e9ad65b8fb0bbf6d3222eb594ab63 version of the mapper
Where did you get that version from? I thought i properly tagged the releases with 3.0, 3.1, etc... :O

User avatar
Miniontoby
Member
Posts: 416
Joined: Fri Mar 01, 2019 19:25
IRC: Miniontoby
In-game: Miniontoby
Location: The Netherlands

Re: Minetest mapserver

by Miniontoby » Post

BuckarooBanzay wrote:
Miniontoby wrote:That last thing you did in the log is what you need to do (run it in the server folder.) and by me it does work, but I have git-be20dff27e4e9ad65b8fb0bbf6d3222eb594ab63 version of the mapper
Where did you get that version from? I thought i properly tagged the releases with 3.0, 3.1, etc... :O
I don't know how I get that version, but I am happy that it is working (p.s. I have run it on my raspberry pi, so I have one of the linux versions).
My English isn't very good because I'm Dutch ---- Check my mod "Doorbell" Vote your gang

User avatar
Festus1965
Member
Posts: 1339
Joined: Sun Jan 03, 2016 11:58
In-game: Thomas Explorer Thailand
Location: Thailand - Chiang Mai (+5-6h to MEZ)
Contact:

Re: Minetest mapserver

by Festus1965 » Post

Code: Select all

..
2019-12-07 13:59:25: WARNING[Server]: [monitoring] globalstep took 77141 us in mod mesecons
..
What could cause this ? (Even put mapserver = false last restart, as I don't see gamer on map)
Last edited by Festus1965 on Mon Dec 16, 2019 01:39, edited 1 time in total.

User avatar
BuckarooBanzay
Member
Posts: 374
Joined: Tue Apr 24, 2018 05:58
GitHub: BuckarooBanzay
IRC: BuckarooBanzai
In-game: BuckarooBanzai

Re: Minetest mapserver

by BuckarooBanzay » Post

Release 4.0.0

Changes:
  • complete frontend overhaul
  • bones mapobject fix
  • smartshop fixes
Download: https://github.com/minetest-mapserver/m ... /tag/4.0.0

jakebriggs
New member
Posts: 4
Joined: Sun Oct 06, 2019 20:30

Re: Minetest mapserver

by jakebriggs » Post

BuckarooBanzay wrote:
jakebriggs wrote:I have a weird issue, the mapserver runs and initial rendering completes, but when I connect I get nothing - a blank screen, apart from some UI elements. There are 2 errors in the web browser console though and I think the call to ws://redacted:8080/api/ws is the issue.

Code: Select all

Source map error: Error: request failed with status 404
Resource URL: http://redacted:8080/css/bootstrap.min.css
Source Map URL: bootstrap.min.css.map
The first error in the console is a missing bootstrap debug asset, ironically that only fails if you open the developer console :)
The second is probably the previous websocket connection before you refreshed the site.
You can ignore both safely ;)

Did you try to zoom in into the grey stuff? (with the + button on the upper left or the scroll wheel on the mouse)
Is this a new/empty world?
If not, can you share the

Code: Select all

mapserver.json
with the configured layers?

I made a pre-release for the new mapserver with a frontend rewrite, maybe you can give that a try:
https://github.com/minetest-mapserver/m ... .0.0-alpha
Well life got in the way and I forgot all about this, but I recently tried again with your newer 4.0.0 release and I have the same issue. I checked a bunch of the png's in the mapserver.tile directory, and they all seem to just be transparent and empty - running identify on them outputs:

Code: Select all

./mapserver.tiles/1/12/-19/-10.png PNG 256x256 256x256+0+0 8-bit sRGB 820B 0.000u 0:00.000
- but i haven't checked all of them. (EDIT: I loaded all the tiles up in shotwell which identified 4500ish of them as being duplicate images and the other 8 or so are just mostly transparent with one white splodge in them)

Here is the log from running it for the first time:

Code: Select all

11:55:18 0 jake@beastie ~/worldthing/world $ ./mapserver-linux-x86_64 
INFO[0000] Starting mapserver                            version=git-b777635c6a11396a594130be2c29ac71462664ed
INFO[0000] Loading colors                                filename=/colors/vanessa.txt prefix=colormapping size=1335774 useLocal=false
INFO[0000] Loading colors                                filename=/colors/advtrains.txt prefix=colormapping size=497 useLocal=false
INFO[0000] Loading colors                                filename=/colors/scifi_nodes.txt prefix=colormapping size=1315 useLocal=false
INFO[0000] Loading colors                                filename=/colors/custom.txt prefix=colormapping size=375 useLocal=false
INFO[0000] Migrating database                            filename=mapserver.sqlite prefix=mapobjectdb.sqlite
INFO[0000] Migration completed                           elapsed=16.267671ms prefix=mapobjectdb.sqlite
INFO[0000] Starting http server                          port=8080 webdev=false
INFO[0000] Starting initial rendering job               
INFO[0002] Initial rendering                             elapsed=2.069645122s mapblocks=5044 progress%=0 tiles=202
INFO[0004] Initial rendering                             elapsed=2.260720977s mapblocks=4970 progress%=3 tiles=254
INFO[0006] Initial rendering                             elapsed=1.928039702s mapblocks=4446 progress%=6 tiles=232
INFO[0008] Initial rendering                             elapsed=2.073872266s mapblocks=4591 progress%=10 tiles=267
INFO[0010] Initial rendering                             elapsed=1.947169613s mapblocks=4606 progress%=13 tiles=216
INFO[0012] Initial rendering                             elapsed=1.916494441s mapblocks=4406 progress%=17 tiles=214
INFO[0014] Initial rendering                             elapsed=2.340691914s mapblocks=5301 progress%=20 tiles=316
INFO[0017] Initial rendering                             elapsed=2.503800208s mapblocks=5090 progress%=23 tiles=350
INFO[0019] Initial rendering                             elapsed=2.42664345s mapblocks=4793 progress%=27 tiles=303
INFO[0022] Initial rendering                             elapsed=2.821516871s mapblocks=4728 progress%=30 tiles=446
INFO[0024] Initial rendering                             elapsed=2.44666468s mapblocks=5374 progress%=34 tiles=346
INFO[0027] Initial rendering                             elapsed=2.364993792s mapblocks=5420 progress%=37 tiles=300
INFO[0029] Initial rendering                             elapsed=1.979034139s mapblocks=4294 progress%=41 tiles=258
INFO[0031] Initial rendering                             elapsed=2.57300362s mapblocks=5436 progress%=44 tiles=353
INFO[0034] Initial rendering                             elapsed=2.362186266s mapblocks=4444 progress%=47 tiles=306
INFO[0036] Initial rendering                             elapsed=2.635591124s mapblocks=5061 progress%=51 tiles=385
INFO[0039] Initial rendering                             elapsed=2.503530202s mapblocks=4964 progress%=54 tiles=339
INFO[0041] Initial rendering                             elapsed=2.398512754s mapblocks=4636 progress%=58 tiles=287
INFO[0044] Initial rendering                             elapsed=2.694344923s mapblocks=5679 progress%=61 tiles=358
INFO[0046] Initial rendering                             elapsed=2.010511194s mapblocks=4446 progress%=64 tiles=243
INFO[0048] Initial rendering                             elapsed=2.618650423s mapblocks=5959 progress%=68 tiles=290
INFO[0051] Initial rendering                             elapsed=2.606451817s mapblocks=4273 progress%=71 tiles=376
INFO[0054] Initial rendering                             elapsed=2.497019404s mapblocks=5443 progress%=75 tiles=287
INFO[0056] Initial rendering                             elapsed=2.402826289s mapblocks=5437 progress%=78 tiles=281
INFO[0058] Initial rendering                             elapsed=2.471665847s mapblocks=4783 progress%=82 tiles=340
INFO[0061] Initial rendering                             elapsed=2.773443323s mapblocks=4898 progress%=85 tiles=337
INFO[0063] Initial rendering                             elapsed=2.242036957s mapblocks=5128 progress%=88 tiles=276
INFO[0066] Initial rendering                             elapsed=2.816434327s mapblocks=5199 progress%=92 tiles=415
INFO[0069] Initial rendering                             elapsed=2.606083053s mapblocks=5386 progress%=95 tiles=389
INFO[0070] Initial rendering                             elapsed=1.070083708s mapblocks=1714 progress%=99 tiles=182
INFO[0070] initial rendering complete                   
INFO[0070] Starting incremental rendering job            LastMtime=1580079321
Finally, here is the mapserver.json:

Code: Select all

{
	"configversion": 1,
	"port": 8080,
	"enableprometheus": true,
	"enablerendering": true,
	"enablesearch": true,
	"enableinitialrendering": true,
	"enabletransparency": false,
	"enablemediarepository": false,
	"webdev": false,
	"webapi": {
		"enablemapblock": false,
		"secretkey": "iwMXHDZfTTvMEFRe"
	},
	"layers": [
		{
			"id": 0,
			"name": "Ground",
			"from": -1,
			"to": 10
		},
		{
			"id": 1,
			"name": "Sky",
			"from": 11,
			"to": 24
		}
	],
	"renderingfetchlimit": 10000,
	"renderingjobs": 4,
	"renderingqueue": 100,
	"mapobjects": {
		"areas": true,
		"bones": true,
		"protector": true,
		"xpprotector": true,
		"privprotector": true,
		"technic_quarry": true,
		"technic_switch": true,
		"technic_anchor": true,
		"technic_reactor": true,
		"luacontroller": true,
		"digiterms": true,
		"digilines": true,
		"travelnet": true,
		"mapserver_player": true,
		"mapserver_poi": true,
		"mapserver_label": true,
		"mapserver_trainline": true,
		"mapserver_border": true,
		"tileserverlegacy": true,
		"mission": true,
		"jumpdrive": true,
		"smartshop": true,
		"fancyvend": true,
		"atm": true,
		"train": true,
		"trainsignal": true,
		"minecart": false,
		"locator": false
	},
	"mapblockaccessor": {
		"expiretime": "15s",
		"purgetime": "30s",
		"maxitems": 500
	},
	"defaultoverlays": [
		"mapserver_poi",
		"mapserver_label",
		"mapserver_player"
	]
}

User avatar
BuckarooBanzay
Member
Posts: 374
Joined: Tue Apr 24, 2018 05:58
GitHub: BuckarooBanzay
IRC: BuckarooBanzai
In-game: BuckarooBanzai

Re: Minetest mapserver

by BuckarooBanzay » Post

@jakebriggs can you pack the world and your mapserver-binary and send it to me if possible, i don't think i can debug/reproduce it like this... :/

jakebriggs
New member
Posts: 4
Joined: Sun Oct 06, 2019 20:30

Re: Minetest mapserver

by jakebriggs » Post

Here is a tar gz of my entire world folder:

https://drive.google.com/open?id=1ur0kX ... CZwPTZmlrT

User avatar
BuckarooBanzay
Member
Posts: 374
Joined: Tue Apr 24, 2018 05:58
GitHub: BuckarooBanzay
IRC: BuckarooBanzai
In-game: BuckarooBanzai

Re: Minetest mapserver

by BuckarooBanzay » Post

jakebriggs wrote:Here is a tar gz of my entire world folder:

https://drive.google.com/open?id=1ur0kX ... CZwPTZmlrT
Got it! The colors for all the mineclone nodes are missing :D

Copy the file from https://raw.githubusercontent.com/minet ... clone2.txt into your world-folder and rename it to "colors.txt".

The mapserver will pick them up and render it properly:

Image

jakebriggs
New member
Posts: 4
Joined: Sun Oct 06, 2019 20:30

Re: Minetest mapserver

by jakebriggs » Post

Thank you so much!

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests