Node Box Editor [0.9.2]

User avatar
rubenwardy
Moderator
 
Posts: 5863
Joined: Tue Jun 12, 2012 18:11
Location: United Kingdom
GitHub: rubenwardy
IRC: rubenwardy
In-game: rubenwardy

by rubenwardy » Sun Apr 28, 2013 16:30

Evergreen wrote:I said, when I go to copy the code it makes after modeling the node, it crashes. Everything else works fine.


No idea why. At what point?

  • Clicking File>Export>something
  • clicking the text field
  • pressing ctrl+a or highlighting
  • pressing ctrl+c
 

User avatar
Evergreen
Member
 
Posts: 2135
Joined: Sun Jan 06, 2013 01:22
Location: A forest in the midwest
GitHub: 4Evergreen4
IRC: EvergreenTree
In-game: Evergreen

by Evergreen » Sun Apr 28, 2013 16:34

rubenwardy wrote:
Evergreen wrote:I said, when I go to copy the code it makes after modeling the node, it crashes. Everything else works fine.


No idea why. At what point?

  • Clicking File>Export>something
  • clicking the text field
  • pressing ctrl+a or highlighting
  • pressing ctrl+c

It's the highlighting that causes it to crash. I start to highlight, it starts to highlight, but then it just crashes. :/
Back from the dead!
 

User avatar
rubenwardy
Moderator
 
Posts: 5863
Joined: Tue Jun 12, 2012 18:11
Location: United Kingdom
GitHub: rubenwardy
IRC: rubenwardy
In-game: rubenwardy

by rubenwardy » Sun Apr 28, 2013 16:42

Must be something wrong with Irrlicht.
The text field is not updated once it is made.

Are there any rendering anomalies?
Last edited by rubenwardy on Sun Apr 28, 2013 18:29, edited 1 time in total.
 

User avatar
rubenwardy
Moderator
 
Posts: 5863
Joined: Tue Jun 12, 2012 18:11
Location: United Kingdom
GitHub: rubenwardy
IRC: rubenwardy
In-game: rubenwardy

by rubenwardy » Sun Apr 28, 2013 16:43

sfan5 wrote:Can't build it:
Code: Select all
/usr/bin/ld: /usr/lib/gcc/x86_64-linux-gnu/4.7/../../../x86_64-linux-gnu/libIrrlicht.a(CIrrDeviceLinux.o): undefined reference to symbol 'XF86VidModeGetGamma'
/usr/bin/ld: note: 'XF86VidModeGetGamma' is defined in DSO /usr/lib/x86_64-linux-gnu/libXxf86vm.so.1 so try adding it to the linker command line
/usr/lib/x86_64-linux-gnu/libXxf86vm.so.1: could not read symbols: Invalid operation
collect2: error: ld returned 1 exit status


That is nothing to do with this project, looks like something to do with Irrlicht.

EDIT: A quick search gives me this: http://irrlicht.sourceforge.net/forum/viewtopic.php?f=1&t=48491
I think there is a small bug in the Irrlicht cmake script, or maybe in this project's
Last edited by rubenwardy on Sun Apr 28, 2013 16:45, edited 1 time in total.
 

User avatar
rubenwardy
Moderator
 
Posts: 5863
Joined: Tue Jun 12, 2012 18:11
Location: United Kingdom
GitHub: rubenwardy
IRC: rubenwardy
In-game: rubenwardy

by rubenwardy » Mon May 06, 2013 13:11

[h]0.2 Released![/h]

Features:

  • 16 pixel snapping
  • bug fixes

Download for Windows
Last edited by rubenwardy on Mon May 06, 2013 13:32, edited 1 time in total.
 

User avatar
Traxie21
Member
 
Posts: 753
Joined: Mon Dec 31, 2012 10:48
Location: McKinney, Texas U.S.A.

by Traxie21 » Mon May 06, 2013 13:19

Awesome! Can the snapping be disabled? Is there a grid?

</awayfromhome>
 

User avatar
rubenwardy
Moderator
 
Posts: 5863
Joined: Tue Jun 12, 2012 18:11
Location: United Kingdom
GitHub: rubenwardy
IRC: rubenwardy
In-game: rubenwardy

by rubenwardy » Mon May 06, 2013 13:26

In the edit menu you can turn it off.

You can also turn off the "limit to node size", so you can make a nodebox bigger than a node.

There is no visible grid. The node boxes can only be set to a place on the 16 pixel grid when it is enabled (ie: You can not resize them to anywhere else)
Last edited by rubenwardy on Mon May 06, 2013 14:28, edited 1 time in total.
 

User avatar
Traxie21
Member
 
Posts: 753
Joined: Mon Dec 31, 2012 10:48
Location: McKinney, Texas U.S.A.

by Traxie21 » Mon May 06, 2013 13:29

Evergreen, if you have MT installed on linux, download the source of Nodebox generator, extract and cd to it and type make. Then you should be able to run the excecutable in the directory.
 

User avatar
Evergreen
Member
 
Posts: 2135
Joined: Sun Jan 06, 2013 01:22
Location: A forest in the midwest
GitHub: 4Evergreen4
IRC: EvergreenTree
In-game: Evergreen

by Evergreen » Mon May 06, 2013 13:34

I think my problem is, when I select too much of the exported node code, it crashes. I might be able to copy it piece by piece, or if necessary, by hand.
Back from the dead!
 

User avatar
Traxie21
Member
 
Posts: 753
Joined: Mon Dec 31, 2012 10:48
Location: McKinney, Texas U.S.A.

by Traxie21 » Mon May 06, 2013 13:54

Evergreen, CTRL+A should select all the code, then CTRL+C will copy it.
 

User avatar
Evergreen
Member
 
Posts: 2135
Joined: Sun Jan 06, 2013 01:22
Location: A forest in the midwest
GitHub: 4Evergreen4
IRC: EvergreenTree
In-game: Evergreen

by Evergreen » Mon May 06, 2013 15:30

Traxie21 wrote:Evergreen, CTRL+A should select all the code, then CTRL+C will copy it.

Oh, it works now. Thanks.
Back from the dead!
 

User avatar
12Me21
Member
 
Posts: 873
Joined: Tue Mar 05, 2013 00:36
Location: (Ignore all of my posts before 2018)
GitHub: 12Me21

by 12Me21 » Mon May 06, 2013 19:16

Image
Last edited by 12Me21 on Mon May 06, 2013 19:17, edited 1 time in total.
Shoutouts to Simpleflips
 

User avatar
rubenwardy
Moderator
 
Posts: 5863
Joined: Tue Jun 12, 2012 18:11
Location: United Kingdom
GitHub: rubenwardy
IRC: rubenwardy
In-game: rubenwardy

by rubenwardy » Tue May 07, 2013 10:08

That is because you are running a debug version.

I made sure that I built in release mode, so I do not know what happened.
 

User avatar
Evergreen
Member
 
Posts: 2135
Joined: Sun Jan 06, 2013 01:22
Location: A forest in the midwest
GitHub: 4Evergreen4
IRC: EvergreenTree
In-game: Evergreen

by Evergreen » Tue May 07, 2013 12:29

I have the latest git (after you released 0.2) and there isn't 16px snapping. Or is 16px snapping only for windows?
Back from the dead!
 

User avatar
sfan5
Moderator
 
Posts: 3816
Joined: Wed Aug 24, 2011 09:44
Location: Germany
GitHub: sfan5
IRC: sfan5

by sfan5 » Tue May 07, 2013 14:13

rubenwardy wrote:
sfan5 wrote:Can't build it:
Code: Select all
/usr/bin/ld: /usr/lib/gcc/x86_64-linux-gnu/4.7/../../../x86_64-linux-gnu/libIrrlicht.a(CIrrDeviceLinux.o): undefined reference to symbol 'XF86VidModeGetGamma'
/usr/bin/ld: note: 'XF86VidModeGetGamma' is defined in DSO /usr/lib/x86_64-linux-gnu/libXxf86vm.so.1 so try adding it to the linker command line
/usr/lib/x86_64-linux-gnu/libXxf86vm.so.1: could not read symbols: Invalid operation
collect2: error: ld returned 1 exit status


That is nothing to do with this project, looks like something to do with Irrlicht.

EDIT: A quick search gives me this: http://irrlicht.sourceforge.net/forum/viewtopic.php?f=1&t=48491
I think there is a small bug in the Irrlicht cmake script, or maybe in this project's

Thanks! That fixed the problem
Mods: Mesecons | WorldEdit | Nuke & Minetest builds for Windows (32-bit & 64-bit)
 

User avatar
rubenwardy
Moderator
 
Posts: 5863
Joined: Tue Jun 12, 2012 18:11
Location: United Kingdom
GitHub: rubenwardy
IRC: rubenwardy
In-game: rubenwardy

by rubenwardy » Tue May 07, 2013 16:01

Evergreen wrote:I have the latest git (after you released 0.2) and there isn't 16px snapping. Or is 16px snapping only for windows?


Snapping is on all versions.

What happens is when you move a side, It can only be moved to a 16px boundary. If it is not on one, it goes to the nearest one.

Make sure Edit > Snapping is ticked (no reason why it should not be), if it is the untick it and tick it again. If not, just tick it.
 

User avatar
Evergreen
Member
 
Posts: 2135
Joined: Sun Jan 06, 2013 01:22
Location: A forest in the midwest
GitHub: 4Evergreen4
IRC: EvergreenTree
In-game: Evergreen

by Evergreen » Tue May 07, 2013 16:18

Tried it, but it certainly doesn't feel like it is snapping at all.
Back from the dead!
 

User avatar
rubenwardy
Moderator
 
Posts: 5863
Joined: Tue Jun 12, 2012 18:11
Location: United Kingdom
GitHub: rubenwardy
IRC: rubenwardy
In-game: rubenwardy

by rubenwardy » Tue May 07, 2013 16:29

Evergreen wrote:Tried it, but it certainly doesn't feel like it is snapping at all.


Try resizing the node in the top right view. If you look at the grass in the background, the edge should be on the edge of a pixel.
 

User avatar
Excalibur Zero
Member
 
Posts: 142
Joined: Tue Apr 02, 2013 19:45
Location: United States
GitHub: ExcaliburZero

by Excalibur Zero » Tue May 07, 2013 20:46

12Me21 wrote:Image

I am having the same problem. Does anyone know how to fix it?
 

User avatar
12Me21
Member
 
Posts: 873
Joined: Tue Mar 05, 2013 00:36
Location: (Ignore all of my posts before 2018)
GitHub: 12Me21

by 12Me21 » Tue May 07, 2013 20:51

On one of my computers it says that and on my other computer it says "NodeBoxGen.exe is not a valid win32 application"
Shoutouts to Simpleflips
 

User avatar
Jordach
Member
 
Posts: 4523
Joined: Mon Oct 03, 2011 17:58
Location: Blender Scene
GitHub: Jordach
IRC: Jordach
In-game: Jordach

by Jordach » Wed May 08, 2013 02:53

Excalibur Zero wrote:
12Me21 wrote:Image

I am having the same problem. Does anyone know how to fix it?
Download Microsoft Visual C++ 2012 Redist.
viewtopic.php?f=10&t=19056 Solar Plains Dev Server
 

User avatar
sfan5
Moderator
 
Posts: 3816
Joined: Wed Aug 24, 2011 09:44
Location: Germany
GitHub: sfan5
IRC: sfan5

by sfan5 » Wed May 08, 2013 05:35

For all people on linux that have the same problem as me:
After the "cmake ." step:
Open CMakeFiles/NodeBoxGenerator.dir/link.txt in an editor and add -lXxf86vm
and you're done, now "make" and it should compile
Last edited by sfan5 on Wed May 08, 2013 15:41, edited 1 time in total.
Mods: Mesecons | WorldEdit | Nuke & Minetest builds for Windows (32-bit & 64-bit)
 

User avatar
Traxie21
Member
 
Posts: 753
Joined: Mon Dec 31, 2012 10:48
Location: McKinney, Texas U.S.A.

by Traxie21 » Wed May 08, 2013 12:21

Funny, I didnt even need to cmake.
I just typed 'make'

OS: Ubuntu 12.04 (I'll update eventually. 13.04 has font issues)
 

User avatar
kaeza
Moderator
 
Posts: 2162
Joined: Thu Oct 18, 2012 05:00
Location: Montevideo, Uruguay
GitHub: kaeza
IRC: kaeza diemartin blaaaaargh
In-game: kaeza

by kaeza » Wed May 08, 2013 13:15

Traxie21 wrote:Funny, I didnt even need to cmake.
I just typed 'make'

OS: Ubuntu 12.04 (I'll update eventually. 13.04 has font issues)

The plain Makefile is very basic; it was made to test it in my machine when there was no Makefile. If it does not works for others is of no convern.
Glad it worked for you though :)
Your signature is not the place for a blog post. Please keep it as concise as possible. Thank you!

Check out my stuff! | Donations greatly appreciated! PayPal
 

User avatar
rubenwardy
Moderator
 
Posts: 5863
Joined: Tue Jun 12, 2012 18:11
Location: United Kingdom
GitHub: rubenwardy
IRC: rubenwardy
In-game: rubenwardy

by rubenwardy » Wed May 08, 2013 14:48

sfan5 wrote:For all people on linux that have the same problem as me:
After the "cmake ." step:
Open CMakeFiles/NodeBoxGenerator.dir/link.txt in an editor and add -lXxf86vm
and you're done, now "make" and it should compile


Thank you for the help.
I will try and add a way to automate this.
Last edited by rubenwardy on Fri May 10, 2013 11:03, edited 1 time in total.
 

PreviousNext

Return to Minetest-related projects



Who is online

Users browsing this forum: No registered users and 2 guests