Page 7 of 11

Re: [Game]/[World] Tutorial [1.8.0]

PostPosted: Tue Dec 08, 2015 22:56
by Wuzzy
Okay, I have made a quick test with a fresh build of Minetest.

It seems to work so far and the lighting is correct, too. Thanks for taking your time again. There is still one problem remaining:
One of the entities does not spawn when loading the world.

+ Spoiler

+ Spoiler

If you manage to fix this problem, I think I will just pull in your changes into the Tutorial. If not, I might try to work it out on my own, but don't expect too much. xD

When I release version 1.9.0, I will keep version 1.8.0 around for a while for compability reasons, since you said that your changes are incompatible with Minetest 0.4.13.

Re: [Game]/[World] Tutorial [1.8.0]

PostPosted: Sat Jan 09, 2016 05:50
by sofar

I spotted this:

Code: Select all
./games/tutorial/mods/default/textures/default_dirt.png: PNG image data, 16 x 16, 8-bit/color RGB, interlaced

Can you convert this to non-interlaced? It may give some irrlicht versions problems rendering.

Re: [Game]/[World] Tutorial [1.8.0]

PostPosted: Fri Jan 15, 2016 18:16
by mine_el
How do i change the language from English to another translated language (e.g. German)?

Re: [Game]/[World] Tutorial [1.8.0]

PostPosted: Sun Jan 17, 2016 21:52
by Wuzzy
Currently, only English and German are available, other languages are not available or only partially translated.

First, try to set your system language to the desired language first. If this does not work, you can modify minetest.conf, the Minetest configuration file.

On GNU/Linux and Mac OS X you find this file in $HOME/.minetest/minetest.conf. On Windows it is in <Your Minetest folder>/minetest.conf.

Open this file with a text editor and search for the line starting with “language”. If it is present, change it to “language = <code>”. Replace “<code>” with the language code. For German it is “de”.
If the line is not present, you have to add it. Example for German:

Code: Select all
language = de

This changes the language of Minetest to German and (hopefully) for Tutorial as well.

At all others:
Be assured I still read your posts. I am currently just not in the mood to update Tutorial. Hopefully I'll do it sooner or later.

Re: [Game]/[World] Tutorial [1.8.0]

PostPosted: Mon Jan 18, 2016 12:49
by mine_el
Thank you Wuzzy, editing the configuration file worked.

Re: [Game]/[World] Tutorial [1.8.0]

PostPosted: Mon Jan 18, 2016 21:22
by BBmine

I wish I had this when I first started Minetest!

Re: [Game]/[World] Tutorial [1.8.0]

PostPosted: Tue Jan 26, 2016 18:44
by mine_el
Here is a rough but complete greek translation of the tutorial.

In order to use it:

1. Install the tutorial.
2. Edit minetest.conf and add the following line:
Code: Select all
language = el

2. Unzip the attached file (requires 7zip). This creates into a "mods" folder.
3. Copy-paste the above folder into YourMinetestFolder/games/tutorial.

Version 1.8.1 released! Version 2.0.0 released!

PostPosted: Sat Feb 13, 2016 22:16
by Wuzzy
Tutorial updates released!
Download links in first post.

I have split the Tutorial for now into two versions. The current recommended version for newbies is 1.8.1, you can safely ignore other versions (for now).

Changelog for 1.8.1 (for Minetest 0.4.13):
  • Dutch translation (thanks!)
  • Partial Greek translation (thanks!)
  • Fix bad texture problem reported by sofar
  • Other bugfixes for bugs introduced by Minetest 0.4.13

The Greek translation by mine_el is not complete or has mistakes. There are some signs and strings which appear untranslated in the game. I leave it in the responsibility to mine_el to fix this.

Perhaps more interestingly for developers, I simutanously release version 2.0.0. I don't recommend this version to newbies because it is “impossible” to set up right now. This is intended as a preview (but it is still 100% usable) for next Minetest version and perhaps even more “ready” to be included into Minetest than previous versions. This version only works with the latest developer version Minetest. The biggest change is that it merges world and subgame to save disk space. And it works, the compressed archive requires only ca. 0.797 MiB of disk space! There is no world bundled anymore. You have to first generate the world by clicking “new”. Sorry for the hassle, but I do this to hopefully make things easiers to developers, should they ever decide to ship Tutorial with Minetest.

Changelog for 2.0.0:
  • All the changes in 1.8.1 (but new translations are outdated again, except German)
  • Added minimap explanation (at the end of the jumping section)
  • Added explanation of Cinematic Mode (in spawn room)
  • Added brief explanation of listrings (shift-click in inventory) (in smelting section)
  • Added demonstration of bouncy blocks (in special blocks section)
  • The crafting section now has nice pictures hanging on the wall, showing examples of crafting
  • Update some texts which have become outdated for 0.4.13
  • Short simple helper texts in main menu. They are temporary until a better solution has been found.
  • Tutorial World and Tutorial subgame got merged. The Tutorial World is now automatically generated when you create a new world. Huge thanks to Ferk! (I have also managed to fix all issues I had with Ferk's code before)
  • Bugfixes of bugs introduced by Minetest 0.4.13
  • Bugfix: When your first spawn with Creative Mode enabled, you spawned in the death tower, instead of the spawn room

Screenshot of crafting example:

(Note about version numbering scheme: first number = major architectual changes. second number = new features. third number: bugfixes and/or translation updates only)

Sadly, radar does not seem to work at all for Tutorial World. Everything is fully green, no matter which height. These are bad conditions to teach some radar examples like in a maze which has been suggested previously. So all I can do is write some theory and encourage the player to try it out in a subgame. :-/

+ Information for translators

Version 1.8.2 released! Version 2.0.1 released!

PostPosted: Sun Feb 14, 2016 13:11
by Wuzzy
Minor bugfix update, versions 1.8.2 and 2.0.1 are released today.

This (hopefully) fixes issues with the language not being set correctly on Windows systems (for both versions). This is the only change.

Re: [Game]/[World] Tutorial [1.8.2]/[2.0.1]

PostPosted: Mon Feb 15, 2016 00:32
by sofar
Could you change this subgame such that it overrides the mapgen, copies the tutorial world mapblocks from a schematic and then spawns the player in it? You obviously want to force mapgen to singlenode as well.

This will help with the problem of having need to both the map and the subgame, and you could distribute this as a single subgame only.

Re: [Game]/[World] Tutorial [1.8.2]/[2.0.1]

PostPosted: Mon Feb 15, 2016 01:01
by sofar
sofar wrote:Could you change this subgame such that it overrides the mapgen, copies the tutorial world mapblocks from a schematic and then spawns the player in it? You obviously want to force mapgen to singlenode as well.

This will help with the problem of having need to both the map and the subgame, and you could distribute this as a single subgame only.

oy, I should have totally read the 2.0 release notes... lol

Re: [Game]/[World] Tutorial [1.8.2]/[2.0.1]

PostPosted: Thu Feb 25, 2016 12:51
by addi
If I try to git-clone I get the following error message:
also access this link via browser its horrible slowly.

Is there an alternative git link?

Re: [Game]/[World] Tutorial [1.8.2]/[2.0.1]

PostPosted: Thu Feb 25, 2016 18:10
by Wuzzy
This URL leads to a webpage, not a git repository. The repository URLs are listed on the webpage itself.

Re: [Game]/[World] Tutorial [1.8.2]/[2.0.1]

PostPosted: Thu Feb 25, 2016 18:37
by addi
ahh that \w\ made the difference. the odd thing is also leads to the website but its a correct git repo too O.o

Re: [Game]/[World] Tutorial [1.8.2]/[2.0.1]

PostPosted: Fri Feb 26, 2016 10:34
by addi
In the Pointing section sign 2 tells me, there should somewhere lay a special tool to reach the apples. I cannot find it. Does it realy exist? Im using the git version from branch mapgen.

Re: [Game]/[World] Tutorial [1.8.2]/[2.0.1]

PostPosted: Fri Feb 26, 2016 11:02
by Wuzzy
Yes, it exists. It is on one of the table in the same section, in front of the “Pointing (2)” sign. It is called “apple snatcher”.
I thought the sign was pretty unambigious on that. :-(
If there is nothing on the table you may have already collected it or something.
If not, restart the Tutorial by deleting the world and creating a new one and playing that one. Remember that from version 2.0.0 onward you can't use Tutorial World from previous versions anymore, you have to *create* the world first.

Re: [Game]/[World] Tutorial [1.8.2]/[2.0.1]

PostPosted: Fri Feb 26, 2016 16:42
by addi
Sorry, I created three times a new tutorial world, but there was never a apple snatcher on the tables :-(
The Minetest version is the very latest, built this morning.
(389.8 KiB) Not downloaded yet

edit: the table to the entry of the Item, Tools crafting, smelting house is also empty.
But all in all the tutorial is really great :)

Re: [Game]/[World] Tutorial [1.8.2]/[2.0.1]

PostPosted: Sat Feb 27, 2016 03:05
by Wuzzy
Oops, you are right. Entities do not spawn anymore except near the player spawn. :(

It must have happened with a new Minetest commit, maybe there was some change which broke the tutorial again.
Also, I noticed some other issues. It seems there is still work to do. xD

Anyways, you are playing the developer version, expeect bugs.
You can always play the tutorial of the 1 series (1.8.2 currently) on Minetest 0.4.13.

Re: [Game]/[World] Tutorial [1.8.2]/[2.0.1]

PostPosted: Sat Feb 27, 2016 03:10
by addi
Its not about myself to play it, its because I want to share tutorial within my installer builds. But as long as it does not work correctly ill not put it into the installer.

Developer release 2.1.0

PostPosted: Sun Mar 13, 2016 01:38
by Wuzzy
I release the developer version 2.1.0 of the tutorial today to fix some bugs seen in the developer version of Minetest. Remember: This version is for the developer version of Minetest only! The current recommended Tutorial version for newbies is currently still 1.8.2 (because you are not a newbie if you just compiled Minetest ;-) ). Changelog:

  • Clone creative inventory from Minetest Game
  • Use 16×16 textures for all items
  • Tutorial now can be played with mod security enabled.
  • Commands to save tutorial map and entities are disabled when tutorial is not trusted
  • Fix broken water textures
  • Clean up bad overlappings in formspecs; texts should now work in small resolutions as well
  • Minor refactoring and textures cleanup

There is is now an issue that prevents saving the map even if the tutorial mod is trusted. I need to save a schematic with minetest.save_schematic, but Minetest complains that I may not save in the mod folder since this function takes a file name. So I used minetest.request_insecure_environment but it seems this does NOT return any function from the minetest table. I get stuff like os but not minetest.
It seems the problem here is that minetest.request_insecure_environment does not give me a table with the minetest functions like minetest.save_schematic. IMO minetest.request_insecure_environment must also give access to “insecure” minetest functions, otherwise it is pretty limited. I guess there's an issue for that already.
Because of this, this is an issue I can not fix as long the insecure environment is incomplete.
However, this bug is not serious since it does not break playing the tutorial.

Sadly, I did not manage to fix the bug regarding missing items. I have no idea why it is broken and I might need some help here.
I have already looked into the mapgen code. The problem seems to lie somehow around the load_entities_area function.
I tested if the function at least reaches the minetest.add_item function. It does so for all items! This means the cause does probably not lie in incorrectly chosen bounding boxes or something like that.
I also tested the return value of this, it was always non-nil, so it must be correct (hopefully).
So Minetest returns a non-nil item for all added items, yet some of them do not actually appear in the world!

Also I made an observation: Items near the spawn appear, but not items far away from the spawn. There seems to be a “cut” in the Z axis from which the items do not appear anymore. The strange thing is, why did it stop working with the new Minetest? I have the feeling that this bug is not caused by Tutorial, but I can't know for sure.

At least I have figured out a hack that adding the items with a 5-second delay would work. But I did not commit this, because this is a very bad hack and it is likely to be unreliable.
If someone wants to try to debug it, here's the relevant mapgen source code (as of now): ... mapgen.lua

I hope I have given you enough information for the brave people who want to debug this. :-)

Lastly, a few weeks ago I have officially posted an issue on GitHub to add the tutorial to Minetest.
It's has been a heated debate so far, read more here:

Re: [Game]/[World] Tutorial [1.8.2]/[2.1.0]

PostPosted: Thu Apr 28, 2016 14:54
by cesarpachon
hi! having lot of fun learning how you implemented this nice mod! now I am trying to modify the castle, but I can't figure out how to remove the protection of the nodes. I already changed in all the mods the immortal group from 1 to nil, but it seems not having effect neither with existing nor new blocks (I can't destroy them). may you explain me what additional mechanism is involved in the protection of the nodes?
(PD. just read the github issue and can't resist to comment there..)

Re: [Game]/[World] Tutorial [1.8.2]/[2.1.0]

PostPosted: Thu Apr 28, 2016 15:14
by Don
cesarpachon - Try removing the immortal group.

I read your comment on github. Totally agree with you. The end user should be the focus for any project. No matter how well you make a game if it isn't what people want then it will fail. One issue with Minetest is there is a lot of different things to learn. Trial and error is a great way to frustrate users. A tutorial like this is the answer for getting new players and keeping them.

Wuzzy - Keep up the great work! You seem to have a great understanding of what players need.

Re: [Game]/[World] Tutorial [1.8.2]/[2.1.0]

PostPosted: Thu Apr 28, 2016 19:01
by Wuzzy
cesarpachon: Most blocks in Tutorial World are indestructible by normal means. When I need to edit the world, I use a mod called “admin_tools” (or so) which contains a special tool which is able to remove any node.

About the groups:
Removing immortal or setting it to nil won't work in most cases. There is no “protection” in itself on the node, it's really just using the groups system. For a block to be minable at all, it also needs to be one of the group of your digging tools. For the hand, that would be oddly_breakable_by_hand. If you just remove immortal for, let's say, reinforced wall, it still needs at least one group of your mining tool.

Maybe I can make it more straightforward to remove blocks in Creative Mode in the following Tutorial, the current solution was mostly just made for me.

Translation for Spanish

PostPosted: Mon May 02, 2016 07:04
by Godo
Hi, Wuzzy, pleased to meet you at last (it has taken me two days to find a computer whose IP was not registered as a spammer, which seems to be the case with my home PC, and to find a question that I can answer to get past the anti-robot bouncer).

I am what you are looking for: a total newbie (I don't even know yet what the name of a player in multiplayer mode is, I just found out that the version after 1.0.10 is 1.0.11 or something like that, and I still have doubts about whether roses have spines), who had no idea how Minetest (or Minecraft, for that matter) worked, and who is willing to provide you with feedback about your amazing tutorial.

First things first: congratulations on a subperb idea flawlessly carried out. I doubt I will ever be able to craft something as beautiful and useful as your tutorial. I haven't got past the first corner yet, but just by translating it into Spanish I have learned an awful lot about how Minetest works. If there ever is an official tutorial I hope it is based on yours.

As for feedback, I disagree with some comments I came across regarding too long explanations. They are exactly what I was looking for! There is some very useful help in the wiki (, but it does not give as much basic information as your tutorial, and in fact the first time I tried to follow those instructions I ended up in really deep water, both metaphorically and literally (there must be a corpse out there somewhere).

As for suggestions for improvement, and taking into account that I still haven't really explored your tutorial, I miss two things: one explanation about whether it is possible to crawl along a tunnel which is less than 2 blocks high, which I think I can't do, and some information about where to find recipes for crafting things, as well as a more obvious (for you, not for a genuine newbie like me) explanation about where to mine for raw materials. That is the one thing which I think it is not possible to do in your tutorial, apart from getting out of the castle, isn't it?

Below is a link where you can download my translation from. I hereby give you the right to include it in your distribution so that it is available for anyone who needs it. I am not sure about a few terms yet, but it is legible and grammatically correct. By the way, I would include in the template.txt file which is supposed to facilitate new translations a warning about not changing anything in the original English text, because I did, and it took me quite a while to find out why it wasn't working.

I found a couple of mistakes in the signs (that's why I had changed some things), like a mention to 13 gold coins instead of 14, or the other way round, I can't remember now).

One other thing: "dough" is the English word for a mixture of flour and water, I think in your tutorial you mention that you can craft dough into bread, but unless you have previously had to mix the flour and water, maybe you need to change that word (we would not have these problems if we could mine for potatoes in Minetest, they need only be put into an oven for a while, and also they are more nutritious than cereal). I am surprised no one seems to have thought of this, given that potatoes grow underground, probably there weren't any Irish people in the developers team.

Re: [Game]/[World] Tutorial [1.8.2]/[2.1.0]

PostPosted: Thu May 19, 2016 04:25
by wilkgr76
Shift-clicking within the inventory? i.e. shift-clicking to/from chests/furnaces/crafting grid/etc.

Does that exist in the tutorial?