[GAME] [SERVER] Post-Apocalyptic World [aftermath][v1.3]

User avatar
maikerumine
Member
Posts: 1366
Joined: Mon Aug 04, 2014 14:27
GitHub: maikerumine
In-game: maikerumine

Re: [GAME] [SERVER] Post-Apocalyptic World [aftermath][v1.3]

by maikerumine » Post

Server is on ver 0.5 I guess...
Extreme Survival Minetest-->viewtopic.php?f=10&t=12959

Triandra
New member
Posts: 7
Joined: Mon Mar 02, 2020 18:32

Re: [GAME] [SERVER] Post-Apocalyptic World [aftermath][v1.3]

by Triandra » Post

Ok, so I've had a closer look at the game myself - though I must add, I have absolutely no experience with programming/coding. The origin of recieving damage while damage is actually turned off is the 3d armour mod. So I've made myself a game version without it, just for building/creative mode and it's working great :) I've also added some lines from BlockMen's original Wasteland to farming, to make the dirt turn to dirt with grass when in contact with normal water. (I'm about to build an oasis^^) Now I just need to think of a way to add the radiation as a factor, so you don't have a green meadow right next toxic water or mud.
@goats Ok, thanks for the info - i guess most mob mods are a bit bugged. Well, I'd say in this case it somehow adds to the game, because it is kind of creepy and totally fits the atmosphere. And yes, I am using the 0.5 version. However, it is working totally fine now. When I've got some time, I'll have another look at the 3d armour mod. Maybe I find something. If not - well without recieving damage there's no real need for armour, so I'm fine with having two game versions: One for building and one for playing.
@maikerumine It was probably the mud, as I was totally new to the game and didn't know how it looked like, so I was probably heading straight to it... Now I know villages are often surrounded by it.

By the way, what is the best block to shield yourself and your settlements from the radiation? Maybe you could introduce lead blocks that are craftable from the more_ores (?) lead lumps and stone as the ultimate radiation blocker?
In a story I made up I also came up with a device creating a force field that is blocking radiation while using it as an energy source to build up said force field. If you set up more of these generators you can build a cupola shielding your entire village and also cleansing it of radiation. Well, it's probably a bit too complicated for minetest...

VernaMcguire
New member
Posts: 2
Joined: Wed Apr 29, 2020 14:45

Re: [GAME] [SERVER] Post-Apocalyptic World [aftermath][v1.3]

by VernaMcguire » Post

Thanks for sharing the game, very nice. I can still use the free game mod on https://hapmod.com/ to play.

User avatar
Talkless
Member
Posts: 11
Joined: Sun Nov 04, 2012 09:04

Re: [GAME] [SERVER] Post-Apocalyptic World [aftermath][v1.3]

by Talkless » Post

Looks like this game does not work on 5.3?

Code: Select all

2020-07-26 16:36:48: [Main]: Using world specified by --worldname on the command line
2020-07-26 16:36:48: [Main]: Using game specified by --gameid on the command line
2020-07-26 16:36:48: WARNING[Main]: [xban] Unable to load database: /var/games/minetest-server/.minetest/worlds/aftermath/xban.db: No such file or directory
2020-07-26 16:36:48: ACTION[Main]: hb.register_hudbar: health
2020-07-26 16:36:48: ACTION[Main]: hb.register_hudbar: breath
2020-07-26 16:36:48: ACTION[Main]: hb.register_hudbar: sprint
2020-07-26 16:36:48: ERROR[Main]: Invalid field inventory_image (expected string got table).
2020-07-26 16:36:48: ERROR[Main]: stack traceback:
2020-07-26 16:36:48: ERROR[Main]:       [C]: in function 'register_item_raw'
2020-07-26 16:36:48: ERROR[Main]:       /usr/share/games/minetest/builtin/game/register.lua:182: in function 'register_item'
2020-07-26 16:36:48: ERROR[Main]:       /usr/share/games/minetest/builtin/game/register.lua:208: in function 'register_node'
2020-07-26 16:36:48: ERROR[Main]:       /opt/minetest/aftermath/mods/scifi_nodes/init.lua:429: in main chunk
2020-07-26 16:36:48: ACTION[Main]: Server: Shutting down
2020-07-26 16:36:48: ERROR[Main]: ModError: Failed to load and run script from /opt/minetest/aftermath/mods/mobs_redo/init.lua:
2020-07-26 16:36:48: ERROR[Main]: Unknown node: fire:basic_flame
2020-07-26 16:36:48: ERROR[Main]: stack traceback:
2020-07-26 16:36:48: ERROR[Main]:       [C]: in function 'get_content_id'
2020-07-26 16:36:48: ERROR[Main]:       /opt/minetest/aftermath/mods/mobs_redo/api.lua:2656: in main chunk
2020-07-26 16:36:48: ERROR[Main]:       [C]: in function 'dofile'
2020-07-26 16:36:48: ERROR[Main]:       /opt/minetest/aftermath/mods/mobs_redo/init.lua:5: in main chunk

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests