Petit bug bien gonflant...

French
User avatar
shiva
Member
 
Posts: 108
Joined: Tue Sep 16, 2014 22:00
Location: En Bretagne :-)
In-game: shiva35

Petit bug bien gonflant...

by shiva » Fri Nov 11, 2016 18:29

Slt à tous,
Vous avez déjà vu ce bug concernant l’utilisation d'une houe :
Code: Select all
2016-11-11 19:04:53: ERROR[Main]: ServerError: Lua: Runtime error from mod 'farming' in callback item_OnUse(): ...-dev/bin/../games/minetest_game/mods/farming/api.lua:94: attempt to call field 'hoe_on_use' (a nil value)
2016-11-11 19:04:53: ERROR[Main]: stack traceback:
2016-11-11 19:04:53: ERROR[Main]:    ...-dev/bin/../games/minetest_game/mods/farming/api.lua:94: in function <...-dev/bin/../games/minetest_game/mods/farming/api.lua:93>

J'utilise la dernière version en 0.4.14 et la dernière version de "minetest_game"
Donc dès l'utilisation de l'outil le serveur crash direct...
 

User avatar
Onyx
Member
 
Posts: 113
Joined: Fri Sep 25, 2015 08:36
Location: Steinheim-NodesNation
In-game: onyx58

Re: Petit bug bien gonflant...

by Onyx » Fri Nov 11, 2016 18:56

Bonsoir Shiva,

N'aurais-tu pas le mod "farming_plus" d'installé également ?
Je crois me souvenir que ce bug est assez ancien, pourtant il avait été fixé, étrange...
Pour le moment, je ne peux pas t'aider, je n'ai en plus pas expérimenté cette situation, si ça devait continuer, je te suggère de poster ce debug dans le forum "Bugs and Problems", tu ne devrais pas tarder à avoir une réponse.
"Science sans conscience n'est que ruine de l'âme."
-----------------------------------------------------------------------------------------
Steinheim NodesNation : steinheim-minetest.servegame.com Pt : 28000
 

User avatar
shiva
Member
 
Posts: 108
Joined: Tue Sep 16, 2014 22:00
Location: En Bretagne :-)
In-game: shiva35

Re: Petit bug bien gonflant...

by shiva » Sun Nov 13, 2016 09:15

Slt Onyx,
Oui en effet j'ai bien le plugin "famring_plus". Je viens de le désactiver et le problème ne se présente plus.
Dommage quand même de se passer de ce plugin... En tout cas plus de crash. Merci pour l'info
 

User avatar
Onyx
Member
 
Posts: 113
Joined: Fri Sep 25, 2015 08:36
Location: Steinheim-NodesNation
In-game: onyx58

Re: Petit bug bien gonflant...

by Onyx » Sun Nov 13, 2016 11:20

Bonjour Shiva,

Je viens de me rappeler que nous utilisons le fork de HybridDog pour farming_plus, essaye-le pour voir si les crashes continuent.

> https://github.com/HybridDog/farming_plus
"Science sans conscience n'est que ruine de l'âme."
-----------------------------------------------------------------------------------------
Steinheim NodesNation : steinheim-minetest.servegame.com Pt : 28000
 

User avatar
shiva
Member
 
Posts: 108
Joined: Tue Sep 16, 2014 22:00
Location: En Bretagne :-)
In-game: shiva35

Re: Petit bug bien gonflant...

by shiva » Sun Nov 13, 2016 12:43

Je viens de tester et je me retrouve avec cette erreur :
Code: Select all
2016-11-13 13:42:16: ERROR[Main]: ModError: Failed to load and run script from /home/minetest/minetest-0.4.14/bin/../mods/farming_plus/init.lua:
2016-11-13 13:42:16: ERROR[Main]: ...st/minetest-0.4.14/bin/../mods/farming_plus/init.lua:5: [farming_plus] some field(s) already exist
2016-11-13 13:42:16: ERROR[Main]: stack traceback:
2016-11-13 13:42:16: ERROR[Main]:       [C]: in function 'error'
2016-11-13 13:42:16: ERROR[Main]:       ...st/minetest-0.4.14/bin/../mods/farming_plus/init.lua:5: in main chunk
 

User avatar
Onyx
Member
 
Posts: 113
Joined: Fri Sep 25, 2015 08:36
Location: Steinheim-NodesNation
In-game: onyx58

Re: Petit bug bien gonflant...

by Onyx » Sun Nov 13, 2016 18:25

Ah mince ! Je ne comprends pas pourquoi tu as cette ligne d'erreur...
Bon, je ne vois qu'une alternative à ton problème dans l'immédiat, essayer le mod "farming" de tenplus1 en espérant que ça fonctionne cette fois, il contient les mêmes choses que "farming_plus" mais ajoute d'autres cultures.
Tiens-moi au courant.

> https://github.com/tenplus1/farming
"Science sans conscience n'est que ruine de l'âme."
-----------------------------------------------------------------------------------------
Steinheim NodesNation : steinheim-minetest.servegame.com Pt : 28000
 

User avatar
shiva
Member
 
Posts: 108
Joined: Tue Sep 16, 2014 22:00
Location: En Bretagne :-)
In-game: shiva35

Re: Petit bug bien gonflant...

by shiva » Mon Nov 14, 2016 07:48

Je viens de récupérer et tester celui de tenplus1 et là tout est ok.
Merci à toi
 


Return to Français



Who is online

Users browsing this forum: No registered users and 2 guests