[SOLVED] How to compile minetest with luajit 2.1-beta?

Posts: 58
Joined: Wed Aug 03, 2016 08:09
GitHub: SlackCoyote
In-game: SlackCoyote

[SOLVED] How to compile minetest with luajit 2.1-beta?

by Reedych » Mon May 07, 2018 14:42

I want to host a server on Raspberry PI 3. I use devuan ascii (debian stretch with systemd removed) arm64. So because of arm64 architecture used I need 2.1. But at end it prints a lot errors of type "undefined reference to `lua*****`":
Code: Select all
CMakeFiles/minetestserver.dir/script/lua_api/l_object.cpp.o: In function `ObjectRef::l_get_entity_name(lua_State*)':
l_object.cpp:(.text+0x364c): undefined reference to `luaL_checktype'
l_object.cpp:(.text+0x365c): undefined reference to `luaL_checkudata'
l_object.cpp:(.text+0x372c): undefined reference to `lua_pushstring'
l_object.cpp:(.text+0x3784): undefined reference to `luaL_typerror'

So where to dig/sniff?

P.s. and the build.sh:
Code: Select all
cd minetest
rm -rf build
mkdir build
cd build

cmake .. \
-DIRRLICHT_SOURCE_DIR=../../irrlicht \
-DLUA_INCLUDE_DIR=../../luajit/src/ \
Slackware64 14.2, MT 0.4.16. My best mod.

Return to General Discussion

Who is online

Users browsing this forum: No registered users and 6 guests