Page 1 of 1

[Blender] Weird rendering of faces being behind transparent.

PostPosted: Thu May 09, 2019 18:30
by Andrey01
I`ve made the car windows are transparent (enabled 'Transparency' parameter) and if I increase the opacity value from 0 in Gimp of the car texture in Blender some faces are being behind the windows get looked transparent dependently of the camera location, they as if disappear inside the car:
Image

Who does know what causes it?

Re: [Blender] Weird rendering of faces being behind transpar

PostPosted: Fri May 10, 2019 10:36
by runs
Probably a normals issue. You have to recalculate them.

1) Save your model to test.

2) In edit mode, press 'A' to select all, or what you want.

3) Search in the menu Mesh for the 'Recalculate normals outside' option, or inside.


Then your faces turn, but in the other side will be transparent maybe. A solution: To solidify. Use the 'Solidifier' Modifier to create a double sided mesh.

Re: [Blender] Weird rendering of faces being behind transpar

PostPosted: Sun May 12, 2019 15:20
by Andrey01
Thanks, I will try that.

Re: [Blender] Weird rendering of faces being behind transpar

PostPosted: Fri Jun 21, 2019 09:45
by Andrey01
runs wrote:Probably a normals issue. You have to recalculate them.

1) Save your model to test.

2) In edit mode, press 'A' to select all, or what you want.

3) Search in the menu Mesh for the 'Recalculate normals outside' option, or inside.


Then your faces turn, but in the other side will be transparent maybe. A solution: To solidify. Use the 'Solidifier' Modifier to create a double sided mesh.

Now it doesn`t work with a bus model. I`m trying to calculate outside and inside normals:
Image

https://ufile.io/oi3hfhb7
https://ufile.io/gfbbmwsa

Re: [Blender] Weird rendering of faces being behind transpar

PostPosted: Fri Jun 21, 2019 18:53
by TumeniNodes
remember that MT does not handle transparency in a complete and proper manner. You are always going to have some issues/glitches when not using 100% transparency.
i.e. it may look fine from one direction, but from another, objects behind the trans will also seem to disappear. This is still found in the issues section in the repo, though I forget the # to link to and do not feel like diving into issue-lake atm

Re: [Blender] Weird rendering of faces being behind transpar

PostPosted: Sat Jun 22, 2019 17:05
by Andrey01
TumeniNodes wrote:remember that MT does not handle transparency in a complete and proper manner. You are always going to have some issues/glitches when not using 100% transparency.
i.e. it may look fine from one direction, but from another, objects behind the trans will also seem to disappear. This is still found in the issues section in the repo, though I forget the # to link to and do not feel like diving into issue-lake atm

But the problem is that it happens even in blender. However, it works with my car (I created separate object with those faces and then united that with the car). There are only the floor and the wall displayed in the bus, but not dispalyed the steering wheel and the seat.
Image

Re: [Blender] Weird rendering of faces being behind transpar

PostPosted: Sat Jun 22, 2019 22:15
by TumeniNodes
Ah, I thought you were referring to it's rendering in MT.
Have you tried https://blenderartists.org/c/support ?

Re: [Blender] Weird rendering of faces being behind transpar

PostPosted: Sun Jun 23, 2019 17:07
by Andrey01
TumeniNodes wrote:Ah, I thought you were referring to it's rendering in MT.
Have you tried https://blenderartists.org/c/support ?

Wow, there`s even whole blender forum? Thanks!

Re: [Blender] Weird rendering of faces being behind transpar

PostPosted: Mon Jun 24, 2019 07:59
by sirrobzeroone
edit: My bad, I squinted a bit harder and can see your using blender render :)

so cycles render info not relevant sorry