Page 1 of 1

how to update minetest to 0.4.17 in LXDE?

PostPosted: Sat May 11, 2019 13:54
by piet
I have a problem i have installed the travelnet mod but he says that i most update my minetest to 0.4.17 i have LXDE but i have see that you cant update minetest to 0.4.17 in LXDE please i need help!

Re: how to update minetest to 0.4.17 in LXDE?

PostPosted: Sat May 11, 2019 14:13
by Hybrid Dog
Have you looked at the downloads page yet? https://www.minetest.net/downloads/
That page should explain how to install or update minetest.
If you use apt, the PPA could work: https://code.launchpad.net/~minetestdev ... ly-builds/

Re: how to update minetest to 0.4.17 in LXDE?

PostPosted: Sat May 11, 2019 15:18
by piet
Hybrid Dog wrote:Have you looked at the downloads page yet? https://www.minetest.net/downloads/
That page should explain how to install or update minetest.
If you use apt, the PPA could work: https://code.launchpad.net/~minetestdev ... ly-builds/

I have already look in downloads there is it not and i dont know what for codes i most type

Re: how to update minetest to 0.4.17 in LXDE?

PostPosted: Sat May 11, 2019 15:23
by piet
piet wrote:
Hybrid Dog wrote:Have you looked at the downloads page yet? https://www.minetest.net/downloads/
That page should explain how to install or update minetest.
If you use apt, the PPA could work: https://code.launchpad.net/~minetestdev ... ly-builds/

I have already look in downloads there is it not and i dont know what for codes i most type

i was thinking and i was opening the page i have typed the commands but my minetest is still 0.4.16

Re: how to update minetest to 0.4.17 in LXDE?

PostPosted: Sun May 12, 2019 06:43
by angus-parvis
After you added PPA and did sudo apt-get update, to download new minetest package you have to type:
Code: Select all
sudo apt-get upgrade

Re: how to update minetest to 0.4.17 in LXDE?

PostPosted: Sun May 12, 2019 07:16
by piet
angus-parvis wrote:After you added PPA and did sudo apt-get update, to download new minetest package you have to type:
Code: Select all
sudo apt-get upgrade

Its still minetest 0.4.16

Re: how to update minetest to 0.4.17 in LXDE?

PostPosted: Sun May 12, 2019 07:29
by piet
i have try it again on my terminal and he says that there is an error with a broken pipe

Re: how to update minetest to 0.4.17 in LXDE?

PostPosted: Sun May 12, 2019 10:16
by piet
Its to late my terminal has a broken pipe.

Re: how to update minetest to 0.4.17 in LXDE?

PostPosted: Tue May 14, 2019 08:29
by dawgdoc
piet wrote:I have a problem i have installed the travelnet mod but he says that i most update my minetest to 0.4.17 i have LXDE but i have see that you cant update minetest to 0.4.17 in LXDE please i need help!

LXDE is a desktop environment that will run on top of many different Linux distributions.

Are you running LXDE on Ubuntu (Lubuntu), Fedora, or what other distribution? What version number of your distribution are you on?

The PPA is used for Ubuntu based distributions; Ubuntu, Kubuntu, LinuxMint, Zorin, Elementary OS, etc. It is of no use for Debian, Fedora, Arch, OpenSuse, etc.

Re: how to update minetest to 0.4.17 in LXDE?

PostPosted: Fri Jun 07, 2019 12:14
by Miniontoby
Try it with "snap" check https://snapcraft.io/minetest

Re: how to update minetest to 0.4.17 in LXDE?

PostPosted: Fri Jun 07, 2019 18:38
by Krock
Late to the party. Assuming Lubuntu as distro. FYI LXDE can be installed on any distribution.
There's how you'd do it with the stable PPA. Even on Debian you can use them, but it will be a bit tricky.

1) Open a terminal
2) sudo add-apt-repository ppa:minetestdevs/stable
3) sudo apt update
If Minetest is already installed, update it:
4) sudo apt install --only-upgrade minetest
Otherwise, install it:
4) sudo apt install minetest

Source: https://launchpad.net/~minetestdevs/+ar ... ntu/stable
This will work for sure. Please post error logs or a description or what's not working if you still have troubles.

PS: This will install 5.0.1, not 0.4.17 since that version is already outdated.