What's the deal with the forums lately?

Post Reply
User avatar
sorcerykid
Member
Posts: 1537
Joined: Fri Aug 26, 2016 15:36
GitHub: sorcerykid
In-game: Nemo
Location: Illinois, USA

What's the deal with the forums lately?

by sorcerykid » Post

Does anyone know what's going on? I've been getting errors for the past few weeks, and pages take extraordinarily long to load. At first I thought it might've just been a glitch, but then I checked IRC and several others have mentioned the forums being inaccessible or slow.

Image

Image

Image

User avatar
v-rob
Developer
Posts: 828
Joined: Thu Mar 24, 2016 03:19
GitHub: v-rob
IRC: v-rob
Location: Right behind you.

Re: What's the deal with the forums lately?

by v-rob » Post

I've also had a situation where the CSS wasn't fully loaded, leading to a very basic view.

I think it might have something to do with this:
Index Page wrote:In total there are 617 users online :: 8 registered, 0 hidden and 609 guests (based on users active over the past 5 minutes)
My guess is that a majority of those are bots since this number barely changes.
GUI Core Developer | My Best Mods: Bridger - Slats - Stained Glass | To contact me, send a PM

ShadMOrdre
Member
Posts: 755
Joined: Mon Dec 29, 2014 08:07
GitHub: ShadMOrdre
In-game: shadmordre
Location: USA

Re: What's the deal with the forums lately?

by ShadMOrdre » Post

With most of the world at home, I'd say it's more likely do to heavy internet traffic, worldwide.

Preferential treatment to the big tech websites. And perhaps a not as good as it could / should be server hosting up the site....
MY MODS: lib_ecology lib_materials lib_clouds lib_node_shapes ---- Inspired By: Open Source Virtual World Simulator Opensimulator.

User avatar
Linuxdirk
Member
Posts: 2731
Joined: Wed Sep 17, 2014 11:21
In-game: Linuxdirk
Location: Germany
Contact:

Re: What's the deal with the forums lately?

by Linuxdirk » Post

v-rob wrote:I've also had a situation where the CSS wasn't fully loaded, leading to a very basic view.
That’s just a side effect of the super slow response times. It just loads and loads and loads and at one time the browser runs into timeout and skips loading.

During the last few weeks it feels like the forum was moved to a Raspberry Pi for home hosting with low bandwidth.

User avatar
sorcerykid
Member
Posts: 1537
Joined: Fri Aug 26, 2016 15:36
GitHub: sorcerykid
In-game: Nemo
Location: Illinois, USA

Re: What's the deal with the forums lately?

by sorcerykid » Post

Linuxdirk wrote: During the last few weeks it feels like the forum was moved to a Raspberry Pi for home hosting with low bandwidth.
Interesting, as I made almost that exact same comment in chat the other day:)

Code: Select all

2020-04-01 12:04:14: ACTION[Server]: CHAT: <Nemo> i think celeron55 needs a better webhost, or else he's running on a raspberry pi

User avatar
Linuxdirk
Member
Posts: 2731
Joined: Wed Sep 17, 2014 11:21
In-game: Linuxdirk
Location: Germany
Contact:

Re: What's the deal with the forums lately?

by Linuxdirk » Post

sorcerykid wrote:Interesting, as I made almost that exact same comment in chat the other day:)

Code: Select all

2020-04-01 12:04:14: ACTION[Server]: CHAT: <Nemo> i think celeron55 needs a better webhost, or else he's running on a raspberry pi
Ha! :) Nice coincidence. Seems like you also have experience with running a Pi for hosting publicly available dynamic web sites :D

User avatar
Hume2
Member
Posts: 631
Joined: Tue Jun 19, 2018 08:24
GitHub: Hume2
In-game: Hume2
Location: Czech Republic

Re: What's the deal with the forums lately?

by Hume2 » Post

I have the same problem too.
If you lack the reality, go on a trip or find a job.

BlueTangs Rock
Member
Posts: 159
Joined: Sun Jul 10, 2016 05:00
Location: Under Le' Sea

Re: What's the deal with the forums lately?

by BlueTangs Rock » Post

This situation was happening to me as well for the last month or two, with the most recent instance happening a few days ago. I thought it was just an internet connection issue on my side or something, lol.
Look at that, a signiture box! To bad I have nothing to put in i-... Wait...

User avatar
Oil_boi
Member
Posts: 139
Joined: Mon Jan 28, 2019 13:12
GitHub: oilboi
IRC: oilboi
In-game: oilboi
Contact:

Re: What's the deal with the forums lately?

by Oil_boi » Post

It's extremely annoying :(
I like to make mods :D
I also made a patreon!

User avatar
rubenwardy
Moderator
Posts: 6424
Joined: Tue Jun 12, 2012 18:11
GitHub: rubenwardy
IRC: rubenwardy
In-game: rubenwardy
Location: United Kingdom
Contact:

Re: What's the deal with the forums lately?

by rubenwardy » Post

There are hardware issues, possibly related to the record breaking number of views recently. celeron55 is on it

User avatar
pampogokiraly
Member
Posts: 248
Joined: Wed Jan 08, 2020 22:21
In-game: i_love_mesecon

Re: What's the deal with the forums lately?

by pampogokiraly » Post

rubenwardy wrote:There are hardware issues, possibly related to the record breaking number of views recently. celeron55 is on it
Sounds good because this is getting really annoying.
My mod (a bit old) request: Better enchant. My second mod: Old Broken Castle nodes. Search for aab01 to find my mods!

User avatar
sorcerykid
Member
Posts: 1537
Joined: Fri Aug 26, 2016 15:36
GitHub: sorcerykid
In-game: Nemo
Location: Illinois, USA

Re: What's the deal with the forums lately?

by sorcerykid » Post

It looks like it may have been fixed. Or else it's just super good luck, because the page loads are blazingly fast now.

Edit: It was working fine for several hours, but maybe that was an anomaly. Who knows.
Last edited by sorcerykid on Mon Apr 06, 2020 18:08, edited 1 time in total.

User avatar
Linuxdirk
Member
Posts: 2731
Joined: Wed Sep 17, 2014 11:21
In-game: Linuxdirk
Location: Germany
Contact:

Re: What's the deal with the forums lately?

by Linuxdirk » Post

sorcerykid wrote:It looks like it may have been fixed. Or else it's just super good luck, because the page loads are blazingly fast now.
I load the forums in the background and come back after a few minutes to perform any action (or reload because internal server errors) and then do something else for a few minutes to wait for the page to load (or run into another internal server error)

This is far from being fixed.

User avatar
Captcha
New member
Posts: 9
Joined: Mon Apr 06, 2020 14:00
IRC: Captcha
In-game: Captcha

Re: What's the deal with the forums lately?

by Captcha » Post

sorcerykid wrote:Does anyone know what's going on? I've been getting errors for the past few weeks, and pages take extraordinarily long to load. At first, I thought it might've just been a glitch, but then I checked IRC and several others have mentioned the forums being inaccessible or slow.

Image

Image

Image
The site is really slow for me, I've spent more than 4 minutes waiting for the index to load.

He should change his web host.... this is real slow and I got several times the bad gateway error...
Not the best lua coder

Professional name sniper


Working on an in-game CAPTCHA for minetest and trying to make his own "game" (sub game of minetest) to learn some more lua.

User avatar
Hume2
Member
Posts: 631
Joined: Tue Jun 19, 2018 08:24
GitHub: Hume2
In-game: Hume2
Location: Czech Republic

Re: What's the deal with the forums lately?

by Hume2 » Post

This might help :D
Image
Attachments
Figure_3.png
(31.41 KiB) Not downloaded yet
If you lack the reality, go on a trip or find a job.

BlueTangs Rock
Member
Posts: 159
Joined: Sun Jul 10, 2016 05:00
Location: Under Le' Sea

Re: What's the deal with the forums lately?

by BlueTangs Rock » Post

Hume2 wrote:This might help :D
Image
Is the horizontal axis the number of days and the vertical axis the number of forum crashes?
Look at that, a signiture box! To bad I have nothing to put in i-... Wait...

User avatar
Hume2
Member
Posts: 631
Joined: Tue Jun 19, 2018 08:24
GitHub: Hume2
In-game: Hume2
Location: Czech Republic

Re: What's the deal with the forums lately?

by Hume2 » Post

BlueTangs Rock wrote:
Hume2 wrote:This might help :D
Image
Is the horizontal axis the number of days and the vertical axis the number of forum crashes?
It's the number of tries to access the forum.
If you lack the reality, go on a trip or find a job.

User avatar
Linuxdirk
Member
Posts: 2731
Joined: Wed Sep 17, 2014 11:21
In-game: Linuxdirk
Location: Germany
Contact:

Re: What's the deal with the forums lately?

by Linuxdirk » Post

Hume2 wrote:This might help :D
The chart looks funny but is actually pretty useless because HTTP response codes are not “measurable“ and the x axis has no legend. A timeline would be much more useful.

Assign a color to the HTTP response codes and horizontally or vertically stack by date/time.

Running this command every X minutes gives a nicely parsable CSV (time,duration,response) as result.

Code: Select all

LC_ALL=C curl -s -o /dev/null -I -w "$(date --iso-8601=minutes),%{time_total},%{http_code}\n" https://forum.minetest.net >> mt-status
Could be done in bash by simply putting this in an infinite loop followed by a sleep of the desired amount of seconds.

Currently the forum works so I can’t test but if the server properly returns the HTTP response code as header on errors then this should be logged with this command.

User avatar
runs
Member
Posts: 2147
Joined: Sat Oct 27, 2018 08:32
GitHub: runsy

Re: What's the deal with the forums lately?

by runs » Post

Yes, the forum now is a damn hell :-D
🤑 Patreon |Minetest Chat | 👧 Samantha | ⛏️ Juanchi Game | 🐱 Petz

User avatar
Linuxdirk
Member
Posts: 2731
Joined: Wed Sep 17, 2014 11:21
In-game: Linuxdirk
Location: Germany
Contact:

Re: What's the deal with the forums lately?

by Linuxdirk » Post

I took my idea in the field and actually measured roughly 12 hours of server availability using the method I described.

Image

Orientation

Duration: From 12:11 pm German time (UTC+2) to 11:30 pm
Date: April 9, 2020
Direction is from 12:11 pm to 11:30 pm from left to right
Resolution: 1 minute between calls (end of previous call + 60 seconds)
Top: HTTP status code
Bottom: Response time from curl call to response from server

HTTP status code

Gray: no data due to curl reason
Green: 200 (OK, response was fine)
Red: Any kind of error returned from the server

Response time

Green: below 1.5 seconds
Dark green: 1.5-3 seconds
Yellow: 3-6 seconds
Dark red: 6-10 seconds
Red: more than 10 seconds
Attachments
raw_data.zip
as zip because csv is not allowed
(4.55 KiB) Downloaded 8 times
timeline.png
(5.74 KiB) Not downloaded yet

User avatar
Hume2
Member
Posts: 631
Joined: Tue Jun 19, 2018 08:24
GitHub: Hume2
In-game: Hume2
Location: Czech Republic

Re: What's the deal with the forums lately?

by Hume2 » Post

I didn't mean it that seriously but OK. Your data is way more valuable.
If you lack the reality, go on a trip or find a job.

BlueTangs Rock
Member
Posts: 159
Joined: Sun Jul 10, 2016 05:00
Location: Under Le' Sea

Re: What's the deal with the forums lately?

by BlueTangs Rock » Post

A couple days ago, even the MineTest block and item Wiki (I check those web pages daily when I'm bored) was having loading speed and temporary crashing issues, and those websites seemed to not have the crashing and connection issues that the forums had or at least they were much less effected by the issues for quite a while.
Look at that, a signiture box! To bad I have nothing to put in i-... Wait...

User avatar
paramat
Developer
Posts: 3700
Joined: Sun Oct 28, 2012 00:05
GitHub: paramat
IRC: paramat
Location: UK

Re: What's the deal with the forums lately?

by paramat » Post

Celeron55 needs more donations to cover his MT expenses, so you can donate to improve forum speed.
As is often the case the answer is: It is a free game.

User avatar
rubenwardy
Moderator
Posts: 6424
Joined: Tue Jun 12, 2012 18:11
GitHub: rubenwardy
IRC: rubenwardy
In-game: rubenwardy
Location: United Kingdom
Contact:

Re: What's the deal with the forums lately?

by rubenwardy » Post

celeron55 is currently migrating the forums to a new machine. This needs to be done with scratch, and is being done with more up to date methods that will make it easier in the future

User avatar
Linuxdirk
Member
Posts: 2731
Joined: Wed Sep 17, 2014 11:21
In-game: Linuxdirk
Location: Germany
Contact:

Re: What's the deal with the forums lately?

by Linuxdirk » Post

Since I’m a data and statistics nerd here’s the final result. How this can be used to track down issues or help raising donations for a better server? I have no idea. I am just the messenger here :)

Meta

Monitoring duration was from April 9, 12:11pm (2020-04-09T12:11+02:00) to April 17, 12:03am (2020-04-17T00:03+02:00)

Same test setup as before, regarding orientation, HTTP status code colors and response time colors. Tests were performed from location Germany using a 100 Mbit/s VDSL2 connection (ITU G.993.5) with SNR of 10 dB (Rx and Tx) with a median connection speed to DSLAM of 110 Mbit/s Rx and 45 Mbit/s Tx.

Machine used for testing was a “mini PC” running on Arch Linux with Kernel 5.5.13 having an Intel Celeron J3455 CPU running at 1.5 GHz. Test was performed with the following command running in a tmux session.

Code: Select all

while true; do
    LC_ALL=C curl -s -o /dev/null -I \
        -w "$(date --iso-8601=minutes),%{time_total},%{http_code}\n" \
        https://forum.minetest.net \
        >> mt-status
    sleep 60
done
See resulting data source file in zip attachment.

Image

(You might want to open the timeline in a new tab and zoom to 100% and scroll sideways)

Orientation

Previous orientation applies with following addition: each one pixel wide line represents one call and the lines horizontal pixel position directly relates to the Nth line in the data source file.

HTTP response code counter

000 (curl error): 228
200 (OK): 7947
500 (Internal Server Error): 72
502 (Bad Gateway): 46
503 (Service Unavailable): 36
504 (Gateway Timeout): 475


Response time counter

< 1.5 seconds: 3738
>= 1.5 seconds: 473
>= 3 seconds: 542
>= 6 seconds: 544
>= 10 seconds: 3507

Availability

8804 calls in total
228 curl errors resulting in no response code
8576 successful requests (got a response code)
629 various server errors

~92.7% availability based on HTTP response codes

8804 calls in total
3507 requests above 10 seconds

~60.2% availability based on bad response times

8804 calls in total
481 requests took over 60 seconds

~94.5% availability based on requests above 60 seconds
Attachments
final_timeline_with_annotations.png
(15.79 KiB) Not downloaded yet
all_sources.zip
(87.22 KiB) Downloaded 5 times

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests