Creative mode for singleplayer

User avatar
Micro_Steve
Member
 
Posts: 12
Joined: Wed Mar 19, 2014 13:46
Location: Alabama, U.S.A.

Creative mode for singleplayer

by Micro_Steve » Sat Mar 22, 2014 00:33

Is there any way to enable fly mode for creative purposes only. I just finished a 3 story house and it was a royal pain scaffolding the house. I realize this is probably a minor gripe but it would encourage others as well to build bigger and larger projects.

Yes I am also a Minecraft player and this is truly an asset for builds.
 

twoelk
Member
 
Posts: 1332
Joined: Fri Apr 19, 2013 16:19
Location: northern Germany
GitHub: twoelk
IRC: twoelk
In-game: twoelk

by twoelk » Sat Mar 22, 2014 00:39

type
Code: Select all
/grant singleplayer all
in chat to be god
 

User avatar
Micro_Steve
Member
 
Posts: 12
Joined: Wed Mar 19, 2014 13:46
Location: Alabama, U.S.A.

by Micro_Steve » Sat Mar 22, 2014 00:46

twoelk wrote:type
Code: Select all
/grant singleplayer all
in chat to be god


Thanks. Only one small problem..lol How do I get down!

No worries. Found it! Thanks for the help!
Last edited by Micro_Steve on Sat Mar 22, 2014 00:59, edited 1 time in total.
 

User avatar
John1
Member
 
Posts: 36
Joined: Mon Mar 10, 2014 01:21
Location: USA

by John1 » Sat Mar 22, 2014 00:59

Micro_Steve wrote:Thanks. Only one small problem..lol How do I get down!


shift key
 

User avatar
Micro_Steve
Member
 
Posts: 12
Joined: Wed Mar 19, 2014 13:46
Location: Alabama, U.S.A.

by Micro_Steve » Sat Mar 22, 2014 01:00

John1 wrote:
Micro_Steve wrote:Thanks. Only one small problem..lol How do I get down!


shift key


Shift key wasn't working for me. It was the "I" key.
 

User avatar
John1
Member
 
Posts: 36
Joined: Mon Mar 10, 2014 01:21
Location: USA

by John1 » Sat Mar 22, 2014 01:14

Micro_Steve wrote:Shift key wasn't working for me. It was the "I" key.


The default is shift to go down and "I" to bring up inventory. The settings must have been changed.
 

twoelk
Member
 
Posts: 1332
Joined: Fri Apr 19, 2013 16:19
Location: northern Germany
GitHub: twoelk
IRC: twoelk
In-game: twoelk

by twoelk » Sat Mar 22, 2014 01:23

I have my Inventory open with the E key, sound familiar?
and have mapped the "special1" previously E to F for fast.
Less finger acrobatic for me that way.
 

User avatar
onpon4
Member
 
Posts: 517
Joined: Thu Mar 21, 2013 01:54

by onpon4 » Sat Mar 22, 2014 01:49

Probably you checked the "'Use' = climb down" checkbox. The "use" key is E by default, so either it switched it to I for you when you made E the inventory key, or you did so without thinking about it.

What version of Minetest do you have, by the way? I'm not sure what "special1" is, the menu doesn't call anything that in 0.4.9.
 

twoelk
Member
 
Posts: 1332
Joined: Fri Apr 19, 2013 16:19
Location: northern Germany
GitHub: twoelk
IRC: twoelk
In-game: twoelk

by twoelk » Sat Mar 22, 2014 01:59

default key of "special1" is the key "E" = "use"
minetest.conf.example wrote:
Code: Select all
...
#keymap_inventory = KEY_KEY_I
# Go down ladder / go down in fly mode / go fast in fast mode
#keymap_special1 = KEY_KEY_E
#keymap_chat = KEY_KEY_T
#keymap_cmd = /
#keyman_console = KEY_F10
#keymap_rangeselect = KEY_KEY_R
#keymap_freemove = KEY_KEY_K
#keymap_fastmove = KEY_KEY_J
#keymap_screenshot = KEY_F12
# If true, keymap_special1 instead of keymap_sneak is used for climbing down and descending
#aux1_descends = false
...
Last edited by twoelk on Sat Mar 22, 2014 02:05, edited 1 time in total.
 


Return to General Discussion



Who is online

Users browsing this forum: Skamiz Kazzarch and 3 guests