[Windows] sfan5's builds: 32-bit & 64-bit, LevelDB, LuaJIT

User avatar
rnd
Member
 
Posts: 168
Joined: Sun Dec 28, 2014 12:24
IRC: ac_minetest
In-game: rnd

Re: [Windows] sfan5's builds: 32-bit & 64-bit, LevelDB, LuaJ

by rnd » Mon Oct 30, 2017 21:03

I just tried latest win32 build minetest-0.5.0-65c5539-win32 (from https://gitlab.com/minetest/minetest/-/ ... s/download) and it works. So something must be wrong with build process i think. Would be nice to know what, for "educational" purposes.
 

User avatar
sfan5
Moderator
 
Posts: 3706
Joined: Wed Aug 24, 2011 09:44
Location: Germany
GitHub: sfan5
IRC: sfan5

Minetest 0.5.0-fc9747e

by sfan5 » Wed Nov 08, 2017 15:49

+ 22 commits

Download: minetest-0.5.0-fc9747e
Mods: Mesecons | WorldEdit | Nuke & Minetest builds for Windows (32-bit & 64-bit)
 

User avatar
Inocudom
Member
 
Posts: 2946
Joined: Sat Sep 29, 2012 01:14
IRC: Inocudom
In-game: Inocudom

Re: [Windows] sfan5's builds: 32-bit & 64-bit, LevelDB, LuaJ

by Inocudom » Wed Nov 08, 2017 17:37

Calinou seems to be very busy these days, so could you supply a script that compiles Minetest 0.5 Dev on Linux Mint 17.3/Ubuntu 14.04? It would probably help out a good number of people (like me.)
 

User avatar
azekill_DIABLO
Member
 
Posts: 6548
Joined: Wed Oct 29, 2014 20:05
Location: Inside the Box
GitHub: azekillDIABLO
In-game: azekill_DIABLO

Re: [Windows] sfan5's builds: 32-bit & 64-bit, LevelDB, LuaJ

by azekill_DIABLO » Thu Nov 09, 2017 17:42

Inocudom wrote:Calinou seems to be very busy these days, so could you supply a script that compiles Minetest 0.5 Dev on Linux Mint 17.3/Ubuntu 14.04? It would probably help out a good number of people (like me.)

ACtually compiling recent version of minetest are pretty easy... the readme should show you everything you need to know! normally, it's matter of a few command lines...
 

User avatar
Inocudom
Member
 
Posts: 2946
Joined: Sat Sep 29, 2012 01:14
IRC: Inocudom
In-game: Inocudom

Re: [Windows] sfan5's builds: 32-bit & 64-bit, LevelDB, LuaJ

by Inocudom » Thu Nov 09, 2017 19:10

azekill_DIABLO wrote:
Inocudom wrote:Calinou seems to be very busy these days, so could you supply a script that compiles Minetest 0.5 Dev on Linux Mint 17.3/Ubuntu 14.04? It would probably help out a good number of people (like me.)

ACtually compiling recent version of minetest are pretty easy... the readme should show you everything you need to know! normally, it's matter of a few command lines...

It is now:
Inocudom wrote:
Code: Select all
[ 57%] Building CXX object src/CMakeFiles/minetest.dir/util/srp.cpp.o
In file included from /usr/include/x86_64-linux-gnu/gmp.h:51:0,
                 from /home/derek/minetest/src/util/srp.cpp:46:
/usr/include/c++/4.9/cstddef:51:11: error: ‘::max_align_t’ has not been declared
   using ::max_align_t;
           ^
make[2]: *** [src/CMakeFiles/minetest.dir/util/srp.cpp.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[1]: *** [src/CMakeFiles/minetest.dir/all] Error 2
make: *** [all] Error 2
[  0%] Built target jsoncpp
-- *** Detected Git version 0.5.0-dev-c60abb2 ***
[  0%] Built target GenerateVersion
[  1%] Building CXX object src/CMakeFiles/minetest.dir/util/srp.cpp.o
In file included from /usr/include/x86_64-linux-gnu/gmp.h:51:0,
                 from /home/derek/minetest/src/util/srp.cpp:46:
/usr/include/c++/4.9/cstddef:51:11: error: ‘::max_align_t’ has not been declared
   using ::max_align_t;
           ^
make[2]: *** [src/CMakeFiles/minetest.dir/util/srp.cpp.o] Error 1
make[1]: *** [src/CMakeFiles/minetest.dir/all] Error 2
make: *** [all] Error 2
The program 'minetest' is currently not installed. You can install it by typing:
sudo apt-get install minetest


You can run Minetest again by typing "minetest" in a terminal or selecting it in an applications menu.
You can install mods in ~/.minetest/mods, too.

The scripts create this error (the ones in the first post of this topic.) I used to be able to compile Minetest on Linux Mint using these scripts. What happened?

Thanks to the kind folks in irc, I came to the conclusion that I needed to update my cmake, clang, and gcc installations. However, getting Linux Mint 17.3 to actually use the newly installed gcc version proved to be a pain. Luckily, I came across the following instructions on the internet after using DuckDuckGo:
https://askubuntu.com/questions/26498/choose-gcc-and-g-version
Thanks to those instructions, Calinou's compiling scripts no longer give any fatal errors and are now able to compile Minetest 0.5 Dev.
 

User avatar
sfan5
Moderator
 
Posts: 3706
Joined: Wed Aug 24, 2011 09:44
Location: Germany
GitHub: sfan5
IRC: sfan5

Minetest 0.5.0-20a85d7

by sfan5 » Fri Nov 10, 2017 22:06

Upgraded to gcc 7.2, new build just to test this (and whether it fixes the 32-bit problem).
+ 1 commit

Download: minetest-0.5.0-20a85d7

Edit: 32-bit problem still not fixed.. :(
Mods: Mesecons | WorldEdit | Nuke & Minetest builds for Windows (32-bit & 64-bit)
 

Previous

Return to Builds



Who is online

Users browsing this forum: No registered users and 1 guest