Page 16 of 29

Re:

PostPosted: Wed Apr 23, 2014 07:18
by sfan5
New Build
+ 15 commits

Download: minetest-0.4.9-127f354-win32.7z

Minetest 0.4.9-d315347

PostPosted: Sun Apr 27, 2014 19:10
by sfan5
New Build
+ 7 commits

Download: minetest-0.4.9-d315347

Minetest 0.4.9-88b18da

PostPosted: Tue Apr 29, 2014 15:24
by sfan5
New Build
+ 3 commits

Download: minetest-0.4.9-88b18da

Re: Minetest 0.4.9-88b18da

PostPosted: Wed Apr 30, 2014 14:28
by Krock
sfan5 wrote:New Build
+ 3 commits

Download: minetest-0.4.9-88b18da

Nice, but the leveldb support broke, I can't create and/or join leveldb worlds anymore.
Image
I also tested that with the previous versions (d315347, 127f354) and there it's broken too. Help?

EDIT: has been solved, thanks, sfan5.

Minetest 0.4.9-b44d359

PostPosted: Wed Apr 30, 2014 17:30
by sfan5
New Build
+ 3 commits

I only made this build because the win32 build had a broken LevelDB DLL.
Download: minetest-0.4.9-b44d359

Re: sfan5's Windows builds: 32-bit & 64-bit, LevelDB, LuaJIT

PostPosted: Fri May 02, 2014 08:21
by Krock
Since that "libleveldb.dll" exists, it seems to corrupt leveldb worlds like sqlite3.

I tested this on my server and the last "well" working version was 5 or 4 days old - without the libleveldb.dll file.

So, this re-generation bug is very easy to reproduce. Anyone else having those problems?

Minetest 0.4.9-b44d359

PostPosted: Sun May 04, 2014 16:22
by sfan5
New Build
+ 2 commits

Download: minetest-0.4.9-b44d359

Re: sfan5's Windows builds: 32-bit & 64-bit, LevelDB, LuaJIT

PostPosted: Mon May 05, 2014 15:18
by Krock
Nice but I still can reproduce the as-already-told generation bug on my server. It keeps regnerating ~1 chunk out of 4.

Minetest 0.4.9-ef2729f

PostPosted: Fri May 09, 2014 19:42
by sfan5
New Build
+ 3 commits

Download: minetest-0.4.9-ef2729f
If you look closely you will be able to see that my builds now include Carbone. Hooray! \o/

Minetest 0.4.9-c37e89f

PostPosted: Tue May 13, 2014 17:24
by sfan5
New Build with a lot of bugfixes
+ 8 commits

Download: minetest-0.4.9-c37e89f

Re: sfan5's Windows builds: 32-bit & 64-bit, LevelDB, LuaJIT

PostPosted: Wed May 14, 2014 13:30
by Krock
EDIT 2014-05-18

~every 3rd server crash is caused by this:
+ "German error message alert"

Minetest 0.4.9-3e5bc9c

PostPosted: Thu May 22, 2014 07:07
by sfan5
New Build
+ 8 commits

Download: minetest-0.4.9-3e5bc9c

Re: Minetest 0.4.9-bc65b40

PostPosted: Thu May 22, 2014 10:25
by cHyper
sfan5 wrote:New Build
+ 8 commits

Download: minetest-0.4.9-bc65b40


The requested URL /minetest-builds/minetest/minetest-0.4.9-bc65b40-win32.7z was not found on this server.

Re: Minetest 0.4.9-bc65b40

PostPosted: Thu May 22, 2014 11:06
by sfan5
cHyper wrote:
sfan5 wrote:New Build
+ 8 commits

Download: minetest-0.4.9-bc65b40


The requested URL /minetest-builds/minetest/minetest-0.4.9-bc65b40-win32.7z was not found on this server.

Fixed, use then new download link (same post)

Re: sfan5's Windows builds: 32-bit & 64-bit, LevelDB, LuaJIT

PostPosted: Thu May 22, 2014 11:10
by cHyper
Not Found!?

Re: sfan5's Windows builds: 32-bit & 64-bit, LevelDB, LuaJIT

PostPosted: Thu May 22, 2014 11:40
by sfan5
cHyper wrote:Not Found!?

Argh.. The upload failed again. It should be working now.

Minetest 0.4.9-60e6368

PostPosted: Sat May 24, 2014 19:30
by sfan5
New Build
+ 9 commits

Download: minetest-0.4.9-60e6368

Minetest 0.4.9-a7d49da

PostPosted: Mon Jun 02, 2014 15:05
by sfan5
New Build
+ 10 commits

Download: minetest-0.4.9-a7d49da

Minetest 0.4.9-9675d9e

PostPosted: Wed Jun 11, 2014 15:16
by sfan5
New Build
+ 6 commits

Download: minetest-0.4.9-9675d9e

Minetest 0.4.9-cb3b42e

PostPosted: Tue Jun 17, 2014 18:31
by sfan5
New Build with bugfixes and grahical improvements.
+ 13 commits

Download: minetest-0.4.9-cb3b42e

Minetest 0.4.9-5fb8778

PostPosted: Mon Jun 23, 2014 13:23
by sfan5
New Build with bugfixes and grahical improvements.
+ 29 commits

Download: minetest-0.4.9-5fb8778

Re: sfan5's Windows builds: 32-bit & 64-bit, LevelDB, LuaJIT

PostPosted: Fri Jun 27, 2014 12:49
by twoelk
It seems I have problems with the sounds in your builds. Somewhere between 15th April and 30th April it seems I can not activate sound on your win32 builds anymore.

minetest-0.4.9-8b02a01-20140415(sfan)sound
minetest-0.4.9-dev20140425(blockmen) sound

minetest-0.4.9-b44d359-20140430(sfan)nosound
minetest-0.4.9-dev20140517(blockmen) sound
minetest-0.4.9-c37e89f-20140513(sfan)nosound
minetest-0.4.9-3e5bc9c-20140522(sfan)nosound
minetest-0.4.9-dev20140618(blockmen) sound
minetest-0.4.9-5fb8778-20140623(sfan)nosound

While the builds by blockmen seem to work those by Krock do not. It might be, I am missing some simple default setting but I have found none. I have tried this on two seperate windows machines running vista and win7 with the same results. Sorry I didn't notice earlier but I usually run the game without sounds. I was experimenting with new background music when I noticed this while I was copying my old sound folders to the newer builds.

Minetest 0.4.9-13517fb

PostPosted: Fri Jun 27, 2014 15:37
by sfan5
I was able to repduce your sounds problem, but I don't have a clue why the sounds might not be working.

Anyway, here, have a new build :3
+ 12 commits

Download: minetest-0.4.9-13517fb

Re: sfan5's Windows builds: 32-bit & 64-bit, LevelDB, LuaJIT

PostPosted: Sat Jun 28, 2014 14:46
by trainwrecktony
I've been using your x64 buiilds for a month flawlessly as client and server but seems like commits since 5fb8778 are causing issues.

I can reproduce a crash without debug info that occurs on client when joining a server that plays a sound on join. Carbone git game has this feature, i commented it out on my server and now no crash but i know of another server that has join sound and instant crash on join sound. Other in game sounds work fine.

13517fb has some interesting changes to player files, on my server it will create a running copy of the player file logged in and name it playername.~mt. If the player disconnects and logs back in it loads the original copy so differences in last inventory and position are obvious. I can manually fix this by move/delete the original playerfile and removing the .~mt extension from running copy

Re: sfan5's Windows builds: 32-bit & 64-bit, LevelDB, LuaJIT

PostPosted: Sat Jun 28, 2014 15:34
by sfan5
trainwrecktony wrote:I can reproduce a crash without debug info that occurs on client when joining a server that plays a sound on join. Carbone git game has this feature, i commented it out on my server and now no crash but i know of another server that has join sound and instant crash on join sound. Other in game sounds work fine.

This was already fixed, I'll make a new build soon.
trainwrecktony wrote:13517fb has some interesting changes to player files, on my server it will create a running copy of the player file logged in and name it playername.~mt. If the player disconnects and logs back in it loads the original copy so differences in last inventory and position are obvious. I can manually fix this by move/delete the original playerfile and removing the .~mt extension from running copy

This is already a known bug and in the process of getting fixed.