A need to clearify Minetest Version

User avatar
Don
Member
 
Posts: 1643
Joined: Sat May 17, 2014 18:40
GitHub: DonBatman
IRC: Batman
In-game: Batman

A need to clearify Minetest Version

by Don » Sat Dec 13, 2014 17:36

I have noticed that people are having troubles with mods because of the version of Minetest they are using. Is there a way we can note the minimum version needed. An example of this would be mesh nodes. As it stands the official release does not support it. If someone was to try to use a mod like christmastrees it would not work.
If there was a way to tag them or even simply add version to title it would redude confusion.
Many of my mods are now a part of Minetest-mods. A place where you know they are maintained!

A list of my mods can be found here
 

User avatar
Krock
Developer
 
Posts: 4469
Joined: Thu Oct 03, 2013 07:48
Location: Switzerland
GitHub: SmallJoker

Re: A need to clearify Minetest Version

by Krock » Sat Dec 13, 2014 17:45

Don't worry. Just use 0.4.10-dev as minimal version.
0.4.11 gets released soon.
Look, I programmed a bug for you. >> Mod Search Engine << - Mods by Krock - DuckDuckGo mod search bang: !mtmod <keyword here>
 

User avatar
Don
Member
 
Posts: 1643
Joined: Sat May 17, 2014 18:40
GitHub: DonBatman
IRC: Batman
In-game: Batman

Re: A need to clearify Minetest Version

by Don » Sat Dec 13, 2014 17:48

Krock wrote:Don't worry. Just use 0.4.10-dev as minimal version.
0.4.11 gets released soon.

This does not help new comers. I know I can download and compile the latest but someone new to minetest has no idea that some mods won't work because they use features only available in the dev version.
Many of my mods are now a part of Minetest-mods. A place where you know they are maintained!

A list of my mods can be found here
 

User avatar
Napiophelios
Member
 
Posts: 988
Joined: Mon Jul 07, 2014 01:14
GitHub: Napiophelios
IRC: Nappi
In-game: Nappi

Re: A need to clearify Minetest Version

by Napiophelios » Sat Dec 13, 2014 18:40

Its already in the mod release guide lines. The mod developer is supposed to provide such information in the release.
 

User avatar
Don
Member
 
Posts: 1643
Joined: Sat May 17, 2014 18:40
GitHub: DonBatman
IRC: Batman
In-game: Batman

Re: A need to clearify Minetest Version

by Don » Sat Dec 13, 2014 19:24

Napiophelios wrote:Its already in the mod release guide lines. The mod developer is supposed to provide such information in the release.

My apologies. I missed that.
Many of my mods are now a part of Minetest-mods. A place where you know they are maintained!

A list of my mods can be found here
 

User avatar
Don
Member
 
Posts: 1643
Joined: Sat May 17, 2014 18:40
GitHub: DonBatman
IRC: Batman
In-game: Batman

Re: A need to clearify Minetest Version

by Don » Sun Dec 14, 2014 15:15

I looked over this page https://forum.minetest.net/viewtopic.php?f=11&t=1271 and found nothing about the minetest version. Does this page need updated or is the version not a requirement?
Many of my mods are now a part of Minetest-mods. A place where you know they are maintained!

A list of my mods can be found here
 

User avatar
Napiophelios
Member
 
Posts: 988
Joined: Mon Jul 07, 2014 01:14
GitHub: Napiophelios
IRC: Nappi
In-game: Nappi

Re: A need to clearify Minetest Version

by Napiophelios » Sun Dec 14, 2014 16:03

Don wrote:I looked over this page https://forum.minetest.net/viewtopic.php?f=11&t=1271 and found nothing about the minetest version. Does this page need updated or is the version not a requirement?



Its inferred information;
If your mod requires a certain build of Minetest to function properly,
then the build version should be listed as a Mod dependency
 

User avatar
Don
Member
 
Posts: 1643
Joined: Sat May 17, 2014 18:40
GitHub: DonBatman
IRC: Batman
In-game: Batman

Re: A need to clearify Minetest Version

by Don » Sun Dec 14, 2014 16:40

Napiophelios wrote:
Don wrote:I looked over this page https://forum.minetest.net/viewtopic.php?f=11&t=1271 and found nothing about the minetest version. Does this page need updated or is the version not a requirement?



Its inferred information;
If your mod requires a certain build of Minetest to function properly,
then the build version should be listed as a Mod dependency

This is not a requirement though. It leaves it up to the modder to decide if they want to or not. The reason I bring this up is because I have helped a few people install Minetest. They like the game but don't understand why things don't work.
An example is homedecor. It is listed in the Mods section but uses mesh nodes. This will only work on the dev version. If someone decides to try minetest they would go to the website and download it. That version is minetest 0.4.10. Then they install mods like homedecor which will not work properly. The solution is get the dev version from github. Only a very small percentage of the population knows how to download and compile the game. Most don't even know what a terminal is.
Thinking of new or non technical players, if the have the latest stable version they should be able to use the mods that are in the Mods section.
Many of my mods are now a part of Minetest-mods. A place where you know they are maintained!

A list of my mods can be found here
 


Return to Modding Discussion



Who is online

Users browsing this forum: No registered users and 3 guests