Using set_attach function

amadin
Member
 
Posts: 544
Joined: Tue Jun 16, 2015 16:23

Using set_attach function

by amadin » Sun Feb 07, 2016 20:31

In multiplayer, then the player is attached to an object (eg, a horse) with using set_attach function, and the object is out of sight of another player (as well as the second player logged later than the first was attached), then the second player lost the first player model. It's look like a horse without player but player is on the horse. How to fix this?
 

User avatar
stu
Member
 
Posts: 923
Joined: Sat Feb 02, 2013 02:51
Location: United Kingdom
GitHub: stujones11

Re: Using set_attach function

by stu » Tue Feb 09, 2016 18:53

amadin wrote:In multiplayer, then the player is attached to an object (eg, a horse) with using set_attach function, and the object is out of sight of another player (as well as the second player logged later than the first was attached), then the second player lost the first player model. It's look like a horse without player but player is on the horse. How to fix this?

This is a long-standing engine bug and there is not much you can do other than detach then re-attach the invisible player. Not sure if there is an open issue for this but you could try asking on IRC.

PS. There is no need to double-post, someone will usually reply if they know the answer.
 

amadin
Member
 
Posts: 544
Joined: Tue Jun 16, 2015 16:23
 


Return to Modding Discussion



Who is online

Users browsing this forum: No registered users and 1 guest