Object doesn't show "inside" textures

schnico
New member
 
Posts: 6
Joined: Fri Jan 08, 2016 21:13
In-game: schnico

Object doesn't show "inside" textures

by schnico » Thu Feb 18, 2016 23:22

Hi everyone,

I'm trying to make my own boat mod (based on minetest boat) and created a model with blender for it. Sadly it doesn't show the textures completely:
screenshot_20160219_001419.png
(534.92 KiB) Not downloaded yet

screenshot_20160219_001403.png
(564.25 KiB) Not downloaded yet


It shows only the texture from outside, but not inside.

My Code:
Code: Select all
local boat = {
       
   physical = true,
   collisionbox = {-0.5, -0.35, -0.5, 0.5, 0.3, 0.5},
   visual = "mesh",
   mesh = "simple.obj",
   textures = {"simply.png"},
        visual_size = {x=10, y=10},
   driver = nil,
   v = 0,
   last_v = 0,
   removed = false,
        seats = {
                [1] = {
                        pos=nil,
                        player=nil,
                    },
                [2] = {
                        pos=nil,
                        player=nil,
                    },
                [3] = {
                        pos=nil,
                        player=nil,
                    },
                [4] = {
                        pos=nil,
                        player=nil,
                    },
        }
       
}

Did you get an idea? Thank's a lot! :)

cheers
schnico
 

User avatar
Nathan.S
Member
 
Posts: 920
Joined: Wed Sep 24, 2014 17:47
Location: Bigsby Texas
GitHub: NathanSalapat
IRC: NathanS21
In-game: NathanS21

Re: Object doesn't show "inside" textures

by Nathan.S » Fri Feb 19, 2016 02:08

It could be two things, either your walls are just a single face, which is probably the case, the face normal points outward which is why from the outside the texture is visible from the inside minetest doesn't draw anything, a simple way to check would be to flip the normal on your model and see if it is visible from the inside or the outside. If that ends up being the case you just need to create an inner wall, which can probably be accomplished by duplicating the mesh, flipping the normals, and scaling it down a teeny bit, so the faces don't exist in the same space which will result in flickering.

The other thing could be a problem with backface culling, which I don't know how to fix, as I seem to recall it being discussed on Github as a problem with the engine right now, though I believe RBA was working on a fix for it.
I record Minetest videos, Mod reviews, Modding tutorials, and Lets plays.
Check out my website, and brand new Minetest Modding Course
 

schnico
New member
 
Posts: 6
Joined: Fri Jan 08, 2016 21:13
In-game: schnico

Re: Object doesn't show "inside" textures

by schnico » Sun Feb 21, 2016 12:17

Thank you really much!
My model got only 1 face and I didn't thought about, that minetest (as a voxel world) needs 3 dimensions instead of 2 ^^.

Now I got another problem, but that will be the matter of another thread.

cheers schnico
 


Return to Modding Discussion



Who is online

Users browsing this forum: No registered users and 2 guests