How to disable "smooth lighting"?

User avatar
sorcerykid
Member
 
Posts: 273
Joined: Fri Aug 26, 2016 15:36
Location: Illinois, USA
In-game: Nemo

How to disable "smooth lighting"?

by sorcerykid » Sat Apr 15, 2017 11:56

I do not like the new "smooth lighting" algorithm. I get a headache playing Minetest just due to eye strain it's causing. Frankly, I think the light mapping curve in 0.4.15 looks ridiculous. I see patches of roadway with ghost shadows in broad daylight. I see bridges where the entire superstructure is illuminated by a single torch. The entire scenery looks anything but realistic, just a messy patchwork of dark blobs and glowing spotlights at nighttime as well as in caves and mines.

Surely there has to be some way to disable this horrible new feature?
 

User avatar
Sergey
Member
 
Posts: 665
Joined: Wed Jan 11, 2017 13:28
Location: Russia

Re: How to disable "smooth lighting"?

by Sergey » Sat Apr 15, 2017 12:42

It is problem with lighting in MT itself. Not because of smoothing feature.
Use mapfix mod to fix lighting.
I am Russian. I am Atheist. I am Homophobe. I am Communist.
In other words, I am an ordinary Soviet man.
 

User avatar
sorcerykid
Member
 
Posts: 273
Joined: Fri Aug 26, 2016 15:36
Location: Illinois, USA
In-game: Nemo

Re: How to disable "smooth lighting"?

by sorcerykid » Sat Apr 15, 2017 15:26

Everything looks fine when i join my server in Minetest 0.4.14. So it is not the map, it is the client.
 

paramat
Developer
 
Posts: 2780
Joined: Sun Oct 28, 2012 00:05
Location: UK
GitHub: paramat
IRC: paramat

Re: How to disable "smooth lighting"?

by paramat » Sat Apr 15, 2017 17:10

This is not due to official 'smooth lighting' or lighting bugs, it's the new light curve that makes light spread further from light sources, making light sources effectively brighter. We have reduced the light level of torches by 1 in MTGame to compensate and create a difference between torch (12), fire/lava (13) and meselamp/growlamp (14). Light nodes in mods may need to reduce their light levels to work better wth the new light curve.

The light curve can only be changed in engine code but maybe you could open an issue to make it configurable?
 

Fixerol
Member
 
Posts: 683
Joined: Sun Jul 31, 2011 11:23
Location: Ukraine
IRC: Fixer
In-game: Fixer

Re: How to disable "smooth lighting"?

by Fixerol » Sat Apr 15, 2017 23:20

You can adjust display_gamma option, may help.
 

User avatar
Wuzzy
Member
 
Posts: 2373
Joined: Mon Sep 24, 2012 15:01
GitHub: Wuzzy2
IRC: Wuzzy
In-game: Wuzzy

The first real answer

by Wuzzy » Tue Apr 18, 2017 14:53

How to disable "smooth lighting"?


To disable smooth lighting, untick the checkbox labelled “Smooth Lighting” in the settings menu (top left).
I'm creating MineClone 2, a Minecraft clone for Minetest.
I made the Help modpack, adding in-game help to Minetest.
 

User avatar
sorcerykid
Member
 
Posts: 273
Joined: Fri Aug 26, 2016 15:36
Location: Illinois, USA
In-game: Nemo

Re: How to disable "smooth lighting"?

by sorcerykid » Tue Apr 18, 2017 18:24

I am referring to the lighting curve (which Fixer has termed smooth lighting in the change log post), not the "smooth lighting" setting which is something completely different.
 

User avatar
Wuzzy
Member
 
Posts: 2373
Joined: Mon Sep 24, 2012 15:01
GitHub: Wuzzy2
IRC: Wuzzy
In-game: Wuzzy

Re: How to disable "smooth lighting"?

by Wuzzy » Wed Apr 19, 2017 13:34

Correct answer, wrong question?! xD
I'm creating MineClone 2, a Minecraft clone for Minetest.
I made the Help modpack, adding in-game help to Minetest.
 

User avatar
azekill_DIABLO
Member
 
Posts: 4850
Joined: Wed Oct 29, 2014 20:05
Location: Pixelator
GitHub: azekillDIABLO
In-game: azekill_DIABLO

Re: The first real answer

by azekill_DIABLO » Sun Apr 23, 2017 12:26

Wuzzy wrote:
How to disable "smooth lighting"?


To disable smooth lighting, untick the checkbox labelled “Smooth Lighting” in the settings menu (top left).


oh damn it looks awful without it! and while i'm here, i liked a lot old versions of lightning, i'm mt-c55
Code: Select all
Hi, my username is azekill_DIABLO and i'm an exelent bug-maker(yeah...i know...i have a bad reputation)

azekill_DIABLO said: Mineyoshi+ABJ+Baggins= TOPIC HIJACKED.
My Mods and Stuff | Voxellar | VoxBox on GITHUB | M.I.L.A Monster engine
Check my awesome website and give feedback!
 

User avatar
sorcerykid
Member
 
Posts: 273
Joined: Fri Aug 26, 2016 15:36
Location: Illinois, USA
In-game: Nemo

Re: How to disable "smooth lighting"?

by sorcerykid » Sat Jun 10, 2017 15:42

Yes, it would be wonderful if the light curve could be configurable to some degree, or even just an option to revert to the old lighting algorithm. It's been putting a noticeable strain on my eyes.

Ever since upgrading to 0.4.15, I've started getting headaches after playing for long periods. esp. mining where the effects are most severe since the pinspot-like rendering of torches on a dark backdrop makes it very hard to focus.
Last edited by sorcerykid on Sat Jun 10, 2017 15:49, edited 2 times in total.
 

User avatar
azekill_DIABLO
Member
 
Posts: 4850
Joined: Wed Oct 29, 2014 20:05
Location: Pixelator
GitHub: azekillDIABLO
In-game: azekill_DIABLO

Re: How to disable "smooth lighting"?

by azekill_DIABLO » Sat Jun 10, 2017 15:44

i won't talk you of the nyan cat glowing. i got blind on a server because of it.
Code: Select all
Hi, my username is azekill_DIABLO and i'm an exelent bug-maker(yeah...i know...i have a bad reputation)

azekill_DIABLO said: Mineyoshi+ABJ+Baggins= TOPIC HIJACKED.
My Mods and Stuff | Voxellar | VoxBox on GITHUB | M.I.L.A Monster engine
Check my awesome website and give feedback!
 

Fixerol
Member
 
Posts: 683
Joined: Sun Jul 31, 2011 11:23
Location: Ukraine
IRC: Fixer
In-game: Fixer

Re: How to disable "smooth lighting"?

by Fixerol » Sun Jun 11, 2017 13:49

sorcerykid, are you playing with tone mapping? Try disabling it, or adjusting your gamma.
 

User avatar
azekill_DIABLO
Member
 
Posts: 4850
Joined: Wed Oct 29, 2014 20:05
Location: Pixelator
GitHub: azekillDIABLO
In-game: azekill_DIABLO

Re: How to disable "smooth lighting"?

by azekill_DIABLO » Sun Jun 11, 2017 13:59

actually, the old lightning algorhytm was far nicer
Code: Select all
Hi, my username is azekill_DIABLO and i'm an exelent bug-maker(yeah...i know...i have a bad reputation)

azekill_DIABLO said: Mineyoshi+ABJ+Baggins= TOPIC HIJACKED.
My Mods and Stuff | Voxellar | VoxBox on GITHUB | M.I.L.A Monster engine
Check my awesome website and give feedback!
 

User avatar
MineYoshi
Member
 
Posts: 5187
Joined: Wed Jul 08, 2015 13:20
Location: Colombia

Re: How to disable "smooth lighting"?

by MineYoshi » Mon Jun 12, 2017 15:18

azekill_DIABLO wrote:actually, the old lightning algorhytm was far nicer

+1
People talk about freedom of speech, so i'll say that G-d exists.
 


Return to Bugs and Problems



Who is online

Users browsing this forum: No registered users and 5 guests