Problem with complete

User avatar
Andrey01
Member
 
Posts: 1912
Joined: Wed Oct 19, 2016 15:18
Location: Russia, Moscow
GitHub: Andrey2470T
In-game: Andrey01

Problem with complete

by Andrey01 » Sat Jul 08, 2017 09:51

Why when i close the game (server) it is completing very long time? Maybe for plenty of mods that i use?
DL9Eh7xVBw7DXwLAMX1lStE21bSD2XUQ
 

User avatar
Andrey01
Member
 
Posts: 1912
Joined: Wed Oct 19, 2016 15:18
Location: Russia, Moscow
GitHub: Andrey2470T
In-game: Andrey01

Re: Problem with complete

by Andrey01 » Thu Jul 13, 2017 13:36

Hmm... the community does not reply me. It means it does not know what to do with it, either! Before 0.4.16 so problem wasn`t. Maybe should i redownload some mods that i have?
DL9Eh7xVBw7DXwLAMX1lStE21bSD2XUQ
 

User avatar
MineYoshi
Member
 
Posts: 5339
Joined: Wed Jul 08, 2015 13:20

Re: Problem with complete

by MineYoshi » Thu Jul 13, 2017 21:31

When i close my game it instantly crashes without going to the menu.
To be honest the only thing that matters is that "it runs" and "it does most of its function".
la mandra sempre hi és aquí; l'avorriment no té pietat.
 

User avatar
duane
Member
 
Posts: 1258
Joined: Wed Aug 19, 2015 19:11
Location: Oklahoma City
GitHub: duane-r

Re: Problem with complete

by duane » Fri Jul 14, 2017 06:16

Andrey01 wrote:Why when i close the game (server) it is completing very long time? Maybe for plenty of mods that i use?


Does it do that when you don't run mods?
Believe in people and you don't need to believe anything else.
 

User avatar
sorcerykid
Member
 
Posts: 737
Joined: Fri Aug 26, 2016 15:36
Location: Illinois, USA
In-game: Nemo

Re: Problem with complete

by sorcerykid » Sat Jul 15, 2017 02:55

Check to see if one (or more) mods has a registered shutdown callback that is interfering with the normal shutdown process. In Linux, you can just issue a recursive grep from within the mods subdirectory, as so:

Code: Select all
grep on_shutdown -R .
 

User avatar
Andrey01
Member
 
Posts: 1912
Joined: Wed Oct 19, 2016 15:18
Location: Russia, Moscow
GitHub: Andrey2470T
In-game: Andrey01

Re: Problem with complete

by Andrey01 » Sat Jul 15, 2017 11:27

duane wrote:
Andrey01 wrote:Why when i close the game (server) it is completing very long time? Maybe for plenty of mods that i use?


Does it do that when you don't run mods?

I have already tried. Now all works fine.
sorcerykid wrote:Check to see if one (or more) mods has a registered shutdown callback that is interfering with the normal shutdown process. In Linux, you can just issue a recursive grep from within the mods subdirectory, as so:

Code: Select all
grep on_shutdown -R .

Thanks. With helping that command i have found the mod "snow" that do it.
DL9Eh7xVBw7DXwLAMX1lStE21bSD2XUQ
 

User avatar
Linuxdirk
Member
 
Posts: 1464
Joined: Wed Sep 17, 2014 11:21
Location: Germany
In-game: Linuxdirk

Re: Problem with complete

by Linuxdirk » Sat Jul 15, 2017 15:39

Andrey01 wrote:Hmm... the community does not reply me. It means it does not know what to do with it, either!

Or maybe because they have you (and the three other shitposters) on ignore. Or maybe because your post lacks a proper error description. Or because you missed naming your OS and MT version. Or because there is no debug.txt dump. Or because it is not even clear what the issue is.

There are multiple reasons here. Accept the first one and work on the others by editing your post.
 

User avatar
rubenwardy
Moderator
 
Posts: 5306
Joined: Tue Jun 12, 2012 18:11
Location: United Kingdom
GitHub: rubenwardy
IRC: rubenwardy
In-game: rubenwardy

Re: Problem with complete

by rubenwardy » Sat Jul 15, 2017 20:24

It takes a while to close as the game needs to wait for any loaded map blocks to save, and for the emerge threads (map generation and loading) to close.
Core Developer | Donate | My Twitter | Mods | Mods 4 Android | Node Box Editor | Minetest Modding Book

Hello profile reader

LgiOxMFYXOqtqVqMPhbw1Bn3oNRvEC7j
 

User avatar
Andrey01
Member
 
Posts: 1912
Joined: Wed Oct 19, 2016 15:18
Location: Russia, Moscow
GitHub: Andrey2470T
In-game: Andrey01

Re: Problem with complete

by Andrey01 » Mon Jul 17, 2017 13:41

Linuxdirk wrote:
Andrey01 wrote:Hmm... the community does not reply me. It means it does not know what to do with it, either!

Or maybe because they have you (and the three other shitposters) on ignore. Or maybe because your post lacks a proper error description. Or because you missed naming your OS and MT version. Or because there is no debug.txt dump. Or because it is not even clear what the issue is.

There are multiple reasons here. Accept the first one and work on the others by editing your post.

Really is this shitpost? Forget about Just test topic where i did it (although it is not true). Really have i written first post incorrect? I don`t see nothing so. I think many people know i use Linux. A version was written in first post. Generally i think many people have not still had a time to reply me.
DL9Eh7xVBw7DXwLAMX1lStE21bSD2XUQ
 


Return to Problems



Who is online

Users browsing this forum: No registered users and 2 guests