Saplings

User avatar
scottwolff
Member
 
Posts: 124
Joined: Sat Apr 30, 2016 06:15
Location: Central Illinois
In-game: scottwolff or some variant of iasiney

Saplings

by scottwolff » Wed Feb 14, 2018 22:04

0.4.16 Version, Ubuntu 16.04

I wonder if this has to do with Ethereal.

Keep getting this error and server crashes:

2018-02-14 20:26:59: ACTION[Server]: 13310 places node default:cobble at (754,28,1002)
2018-02-14 20:27:01: ACTION[Server]: lara places node default:acacia_bush_leaves at (755,33,997)
2018-02-14 20:27:05: ACTION[Server]: 13310 places node default:cobble at (754,28,1001)
2018-02-14 20:27:06: ACTION[Server]: loli digs cblocks:wood_cyan at (858,7,880)
2018-02-14 20:27:06: ACTION[Server]: 13310 places node default:cobble at (754,29,1001)
2018-02-14 20:27:07: ACTION[Server]: 13310 places node default:cobble at (754,30,1001)
2018-02-14 20:27:07: ACTION[Server]: 13310 leaves game. List of players:
2018-02-14 20:27:07: ACTION[Server]: lara leaves game. List of players:
2018-02-14 20:27:07: ACTION[Server]: loli leaves game. List of players:
2018-02-14 20:27:08: ERROR[Main]: ServerError: AsyncErr: ServerThread::run Lua: Runtime error from mod '' in callback item_OnPlace(): ...st/bin/../games/minetest_game/mods/default/trees.lua:493: a$
2018-02-14 20:27:08: ERROR[Main]: stack traceback:
2018-02-14 20:27:08: ERROR[Main]: ...st/bin/../games/minetest_game/mods/default/trees.lua:493: in function 'sapling_on_place'
2018-02-14 20:27:08: ERROR[Main]: ...st/bin/../games/minetest_game/mods/default/nodes.lua:1561: in function <...st/bin/../games/minetest_game/mods/default/nodes.lua:1560>
 

User avatar
scottwolff
Member
 
Posts: 124
Joined: Sat Apr 30, 2016 06:15
Location: Central Illinois
In-game: scottwolff or some variant of iasiney

Re: Saplings

by scottwolff » Fri Feb 16, 2018 21:57

scottwolff wrote:0.4.16 Version, Ubuntu 16.04

I wonder if this has to do with Ethereal.

Keep getting this error and server crashes:

2018-02-14 20:26:59: ACTION[Server]: 13310 places node default:cobble at (754,28,1002)
2018-02-14 20:27:01: ACTION[Server]: lara places node default:acacia_bush_leaves at (755,33,997)
2018-02-14 20:27:05: ACTION[Server]: 13310 places node default:cobble at (754,28,1001)
2018-02-14 20:27:06: ACTION[Server]: loli digs cblocks:wood_cyan at (858,7,880)
2018-02-14 20:27:06: ACTION[Server]: 13310 places node default:cobble at (754,29,1001)
2018-02-14 20:27:07: ACTION[Server]: 13310 places node default:cobble at (754,30,1001)
2018-02-14 20:27:07: ACTION[Server]: 13310 leaves game. List of players:
2018-02-14 20:27:07: ACTION[Server]: lara leaves game. List of players:
2018-02-14 20:27:07: ACTION[Server]: loli leaves game. List of players:
2018-02-14 20:27:08: ERROR[Main]: ServerError: AsyncErr: ServerThread::run Lua: Runtime error from mod '' in callback item_OnPlace(): ...st/bin/../games/minetest_game/mods/default/trees.lua:493: a$
2018-02-14 20:27:08: ERROR[Main]: stack traceback:
2018-02-14 20:27:08: ERROR[Main]: ...st/bin/../games/minetest_game/mods/default/trees.lua:493: in function 'sapling_on_place'
2018-02-14 20:27:08: ERROR[Main]: ...st/bin/../games/minetest_game/mods/default/nodes.lua:1561: in function <...st/bin/../games/minetest_game/mods/default/nodes.lua:1560>


Update: No, this does not have anything to do with ethereal so to speak

So far I've determined that, turning off other world gen mods such as nether and bedrock and a few other non world gen mods doesn't seem to affect the crash issue. In fact, I turned off ethereal and reloaded the default_game and placing the apple tree sapling still crashes the server.

Update 2:

I have turned off all mods but placing the default:sapling on default:dirt_with_grass still crashes the server.

I made a singleplayer server world v7 4.16 and turned on ethereal and placed the sapling and it did not crash the game for me. So, again, what was done appears to be done at this point.

So, yes, I am basically out of ideas.
 

User avatar
scottwolff
Member
 
Posts: 124
Joined: Sat Apr 30, 2016 06:15
Location: Central Illinois
In-game: scottwolff or some variant of iasiney

[Resolved] Re: Saplings

by scottwolff » Fri Feb 16, 2018 23:07

scottwolff wrote:
scottwolff wrote:0.4.16 Version, Ubuntu 16.04

I wonder if this has to do with Ethereal.

Keep getting this error and server crashes:

2018-02-14 20:26:59: ACTION[Server]: 13310 places node default:cobble at (754,28,1002)
2018-02-14 20:27:01: ACTION[Server]: lara places node default:acacia_bush_leaves at (755,33,997)
2018-02-14 20:27:05: ACTION[Server]: 13310 places node default:cobble at (754,28,1001)
2018-02-14 20:27:06: ACTION[Server]: loli digs cblocks:wood_cyan at (858,7,880)
2018-02-14 20:27:06: ACTION[Server]: 13310 places node default:cobble at (754,29,1001)
2018-02-14 20:27:07: ACTION[Server]: 13310 places node default:cobble at (754,30,1001)
2018-02-14 20:27:07: ACTION[Server]: 13310 leaves game. List of players:
2018-02-14 20:27:07: ACTION[Server]: lara leaves game. List of players:
2018-02-14 20:27:07: ACTION[Server]: loli leaves game. List of players:
2018-02-14 20:27:08: ERROR[Main]: ServerError: AsyncErr: ServerThread::run Lua: Runtime error from mod '' in callback item_OnPlace(): ...st/bin/../games/minetest_game/mods/default/trees.lua:493: a$
2018-02-14 20:27:08: ERROR[Main]: stack traceback:
2018-02-14 20:27:08: ERROR[Main]: ...st/bin/../games/minetest_game/mods/default/trees.lua:493: in function 'sapling_on_place'
2018-02-14 20:27:08: ERROR[Main]: ...st/bin/../games/minetest_game/mods/default/nodes.lua:1561: in function <...st/bin/../games/minetest_game/mods/default/nodes.lua:1560>


Update: No, this does not have anything to do with ethereal so to speak

So far I've determined that, turning off other world gen mods such as nether and bedrock and a few other non world gen mods doesn't seem to affect the crash issue. In fact, I turned off ethereal and reloaded the default_game and placing the apple tree sapling still crashes the server.

Update 2:

I have turned off all mods but placing the default:sapling on default:dirt_with_grass still crashes the server.

I made a singleplayer server world v7 4.16 and turned on ethereal and placed the sapling and it did not crash the game for me. So, again, what was done appears to be done at this point.

So, yes, I am basically out of ideas.


My bad, I was not using 0.4.16 stable minetest_game. It doesn't crash the server now. Probably should see some general improvement since I was using the wrong once since day on.
 

User avatar
TumeniNodes
Member
 
Posts: 2461
Joined: Fri Feb 26, 2016 19:49
Location: in the dark recesses of the mind
GitHub: TumeniNodes
IRC: tumeninodes
In-game: TumeniNodes

Re: Saplings

by TumeniNodes » Fri Feb 16, 2018 23:32

maybe there needs to be a notice on the main page for Minetest regarding versions (mostly for those who get it via their package manager on Linux distros)

but this seems to be happening more frequently lately with newer users.
My brain, is AES256 encrypted, even I don't know wth I'm thinking...
 


Return to Problems



Who is online

Users browsing this forum: No registered users and 2 guests

cron