Display glitch?

Post Reply
Enkidu
Member
Posts: 17
Joined: Sun Apr 17, 2016 22:52
In-game: Enkidu

Display glitch?

by Enkidu » Post

Minetest-5.6.0-dev-ec9f157 (server)
Minetest-5.6.0-dev-ec9f157 (client)
Running on Ubuntu 22.04

So, I'm deep (>1024) in a large cavern. In the distance, across the cavern there are lighted areas, blue in colour, like I can see the sky! When it is night outside I can see the stars. I can see the moon pass across a lighted area. These lighted areas seem to be openings to further reaches of the cavern.

In addition, when I look into a nearby dark or dimly lit area I see little sparkles.

This seems to have come on fairly recently, but doesn't seem to be related to any particular update. (I update and compile every week or so.) Does anyone know what is going on here? I'll try to attach a couple of screenshots, but I'm unsure if that will work.
Attachments
screenshot_20220514_133354.png
screenshot_20220514_133354.png (315.76 KiB) Viewed 147 times
screenshot_20220514_143713.png
screenshot_20220514_143713.png (99.46 KiB) Viewed 147 times

User avatar
GayJesus
Member
Posts: 175
Joined: Wed Jul 17, 2019 22:29

Re: Display glitch?

by GayJesus » Post

same problem i've had for a long time. can be used as a cheat if you turn your view distance down to see players through stuff far away on PVP.
cdb_18da7b1c212d

User avatar
Festus1965
Member
Posts: 2957
Joined: Sun Jan 03, 2016 11:58
In-game: Festus1965 Thomas Thailand Explorer
Location: Thailand ChiangMai
Contact:

Re: Display glitch?

by Festus1965 » Post

yes, you see the sky, as your client has (still) not loaded further other solid rock, and so can't show it = show sky behind. normal ...
Human has no future (climate change)
If urgend, you find me in Roblox (as CNXThomas)

Enkidu
Member
Posts: 17
Joined: Sun Apr 17, 2016 22:52
In-game: Enkidu

Re: Display glitch?

by Enkidu » Post

@Festus1965 It was not always this way. At one time I would see a bright grey-white patch which would fade away. It doesn't fase away now. Are you saying that there is no solution?

User avatar
TenPlus1
Member
Posts: 3217
Joined: Mon Jul 29, 2013 13:38
GitHub: tenplus1

Re: Display glitch?

by TenPlus1 » Post

I change the skybox to black when below -100 so this doesnt happen.

Enkidu
Member
Posts: 17
Joined: Sun Apr 17, 2016 22:52
In-game: Enkidu

Re: Display glitch?

by Enkidu » Post

TenPlus1 wrote:
Sat May 14, 2022 05:40
I change the skybox to black when below -100 so this doesnt happen.
I see. Where do I set that? I don't know much about the innards of MT. Thanks

User avatar
TenPlus1
Member
Posts: 3217
Joined: Mon Jul 29, 2013 13:38
GitHub: tenplus1

Re: Display glitch?

by TenPlus1 » Post

You could use Sofar's SkyBox mod to create and set an underground skybox for when you are digging: https://content.minetest.net/packages/sofar/skybox/

..or..

The Other Worlds mod adds an asteroid layer which uses it's own skyboxes and the underground one is already set to black for you: https://notabug.org/TenPlus1/other_worlds

Enkidu
Member
Posts: 17
Joined: Sun Apr 17, 2016 22:52
In-game: Enkidu

Re: Display glitch?

by Enkidu » Post

TenPlus1 wrote:
Sat May 14, 2022 12:34
You could use Sofar's SkyBox mod to create and set an underground skybox for when you are digging: https://content.minetest.net/packages/sofar/skybox/
Thanks. I'll look into that.

What puzzles me is why this has suddenly started happening. These bright areas used to disappear after a second or two, but now they stay there for ever.

I checked the git log for the last week or so, but nothing sticks out.

Enkidu
Member
Posts: 17
Joined: Sun Apr 17, 2016 22:52
In-game: Enkidu

Re: Display glitch?

by Enkidu » Post

Update:

I discovered that my Minetest server script was not bringing the server down. Having fixed that, so that the server and client are at exactly the same version, the problem seems to have been ameliorated. It hasn't been completely fixed, though. The version were never very different, so it's a bit odd.

I'll continue to update the server and the client every week or so, and hope that the issue goes away completely. If I find out what is causing this I will update this topic.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest