Can't connect to servers

marzin
Member
 
Posts: 34
Joined: Sun Jun 26, 2011 12:07

Can't connect to servers

by marzin » Tue Feb 14, 2012 21:44

Hi. When I'm try to connect it can't download content (is always 0%) and crash,

Here is fro out from console:

Code: Select all
Irrlicht Engine version 1.7.2
Linux 3.0.0-16-generic #28-Ubuntu SMP Fri Jan 27 17:50:54 UTC 2012 i686
Creating X window...
Visual chosen: : 39
Using renderer: OpenGL 2.1.2
GeForce 7300 SE/7200 GS/PCI/SSE2: NVIDIA Corporation
OpenGL driver version is 1.2 or better.
GLSL version: 1.2
Loaded texture: /home/marzin/celeron55-minetest-cb05a28/data/clienttextures/menubg.png
Loaded texture: /home/marzin/celeron55-minetest-cb05a28/data/clienttextures/menulogo.png
locale has been set to:pl_PL.UTF-8
locale has been set to:C
locale has been set to:pl_PL.UTF-8
locale has been set to:C
locale has been set to:pl_PL.UTF-8
locale has been set to:C
22:37:51: ERROR[main]: Timed out.
22:37:51: ERROR[main]: error_message = Connection timed out.
locale has been set to:pl_PL.UTF-8
locale has been set to:C
locale has been set to:pl_PL.UTF-8
locale has been set to:C
locale has been set to:pl_PL.UTF-8
locale has been set to:C
locale has been set to:pl_PL.UTF-8
locale has been set to:C
22:38:09: ERROR[main]: generate_image(): Could not load image
 

User avatar
Lunarhiro
Member
 
Posts: 121
Joined: Fri Feb 10, 2012 23:13

by Lunarhiro » Tue Feb 14, 2012 21:56

My sister's does that too when she tries to connect to mine...and I use mods so I thought it might be cuz of that :o. Honestly no idea though :/
 

jn
Member
 
Posts: 106
Joined: Tue Jan 03, 2012 19:15

by jn » Wed Feb 15, 2012 00:15

marzin wrote:[...] Connection timed out. [...]

That's the issue.
Does it work with fast servers, or a server standing in the same room?
 

marzin
Member
 
Posts: 34
Joined: Sun Jun 26, 2011 12:07

by marzin » Wed Feb 15, 2012 09:23

No, it is not issue.

Not always it show "connection time out". Here is log without it:

Code: Select all
Irrlicht Engine version 1.7.2
Linux 3.0.0-16-generic #28-Ubuntu SMP Fri Jan 27 17:50:54 UTC 2012 i686
Creating X window...
Visual chosen: : 39
Using renderer: OpenGL 2.1.2
GeForce 7300 SE/7200 GS/PCI/SSE2: NVIDIA Corporation
OpenGL driver version is 1.2 or better.
GLSL version: 1.2
Loaded texture: /home/marzin/celeron55-minetest-cb05a28/data/clienttextures/menubg.png
Loaded texture: /home/marzin/celeron55-minetest-cb05a28/data/clienttextures/menulogo.png
locale has been set to:pl_PL.UTF-8
locale has been set to:C
locale has been set to:pl_PL.UTF-8
locale has been set to:C
locale has been set to:pl_PL.UTF-8
locale has been set to:C
10:20:26: ERROR[main]: generate_image(): Could not load image "rat.png" while building texture
10:20:26: ERROR[main]: generate_image(): Creating a dummy image for "rat.png"

In thread b78e16f0:
/home/marzin/celeron55-minetest-cb05a28/src/client.cpp:2175: void Client::afterContentReceived(): Assertion 'm_itemdef_received' failed.
Debug stacks:
DEBUG STACK FOR THREAD b78e16f0:
#0  int main(int, char**)
(Leftover data: #1  void Client::step(float))
(Leftover data: #2  virtual void ClientEnvironment::step(float))
(Leftover data: #3  void Client::Receive())
(Leftover data: #4  void Client::ProcessData(irr::u8*, irr::u32, irr::u16))
(Leftover data: #5  void MeshUpdateQueue::addBlock(v3s16, MeshMakeData*, bool))
 

jn
Member
 
Posts: 106
Joined: Tue Jan 03, 2012 19:15

by jn » Wed Feb 15, 2012 15:53

marzin wrote:
Code: Select all
[...] Assertion 'm_itemdef_received' failed. [...]

This can also be due to the server sending data to slowly upon connecting.
It should show a nice warning in this case, instead of just crashing, that's a bug.
 


Return to Problems



Who is online

Users browsing this forum: No registered users and 1 guest