Poor performance when shaders are ENABLED

User avatar
Fixer
Member
 
Posts: 895
Joined: Sun Jul 31, 2011 11:23
Location: Ukraine
IRC: Fixer
In-game: Fixer

Poor performance when shaders are ENABLED

by Fixer » Mon Dec 21, 2015 00:11

Hardware: Core i3-2120, AMD/ATI Radeon HD6870, OpenGL 4.5, Windows 7 sp1, ATI Driver Crimson Ed 15.12 beta, resolution ~1280*978, 120 nodes fixed view, map disabled, chat and interface is on
Minetest: 0.4.13-dev krock's 32 bit build, 15 DEC 2015
Config with shaders off:
+ Spoiler

Config with shaders on:
+ Spoiler

Config with shaders on / effects off (default shader settings in MT):
+ Spoiler

Results:
Test 1) Just Test 0.4.12-dev, position: -77.5 1.5 -101, yaw = 0.0, standing without moves
shaders off: 52 fps
shaders on: 24 fps (2.1 x slower)
shaders on / effects off*: 34 fps (1.5 x slower) <--- default

Test 2) LinuxGaming 2 0.4.13-dev, position: 445.0 40.5 756.5, yaw = 0.0, standing without moves
shaders off: 34 fps
shaders on: 19 fps (1.8 x slower)
shaders on / effects off*: 24 fps (1.4 x slower) <--- default

By default in MT enable_shaders is true, that means that default performance could be boosted up to +50% if you disable shaders by default, this can increase fps more into comfort range (if you have fixed view range) or increase view range while keeping fps above 30(when default autorange finder is enabled).

Interesting in doing some tests? I advise developers to look at that issue and disable shaders by default or fix them (if something is wrong). Disabling shaders helped me a lot to improve minetest performance in multiplayer (gaining 30-60 fps with 120 nodes view), singleplayer was capable of 240 nodes @ >60fps (but with very big stutters, that's the other unsolved problem).

* effects are: bump mapping, normal maps, paralax occlusion, waving water.. leaves.. plants
 

User avatar
benrob0329
Member
 
Posts: 1319
Joined: Thu Aug 06, 2015 22:39
Location: Michigan
GitHub: Benrob0329
IRC: benrob0329
In-game: benrob03

Re: Poor performance when shaders are ENABLED

by benrob0329 » Mon Dec 21, 2015 01:25

If you set the wanted_fps and max_fps settings, you can get 50+ fps with shaders.
Social: YouTube Peertube Matrix Room: #minetest:matrix.org | Games: The Infinite IKEA
 

User avatar
Calinou
Moderator
 
Posts: 3162
Joined: Mon Aug 01, 2011 14:26
Location: Troyes, France
GitHub: Calinou
IRC: Calinou
In-game: Calinou

Re: Poor performance when shaders are ENABLED

by Calinou » Mon Dec 21, 2015 11:22

benrob0329 wrote:If you set the wanted_fps and max_fps settings, you can get 50+ fps with shaders.


What's wrong with the default values? wanted_fps is used mostly for the range autotuner, whereas fps_max's default value is set to something that prevents generating useless heat (the only reason to increase it is for benchmarking, as well as using a 120/144 Hz screen).
 

User avatar
Fixer
Member
 
Posts: 895
Joined: Sun Jul 31, 2011 11:23
Location: Ukraine
IRC: Fixer
In-game: Fixer

Re: Poor performance when shaders are ENABLED

by Fixer » Mon Dec 21, 2015 11:43

benrob0329 wrote:If you set the wanted_fps and max_fps settings, you can get 50+ fps with shaders.


max_fps settings was set to 0, no fps limit, with fixed view it will show as high fps, as possible, wanted_fps is for view range finder iirc, which is disabled here.
 

User avatar
paramat
Developer
 
Posts: 3580
Joined: Sun Oct 28, 2012 00:05
Location: UK
GitHub: paramat
IRC: paramat

Re: Poor performance when shaders are ENABLED

by paramat » Mon Dec 21, 2015 13:58

Ohh ... all this time i thought there was no difference between 'shaders off' and 'shaders on, no effects' =}
 

User avatar
PilzAdam
Member
 
Posts: 4026
Joined: Fri Jul 20, 2012 16:19
Location: Germany
GitHub: PilzAdam
IRC: PilzAdam

Re: Poor performance when shaders are ENABLED

by PilzAdam » Wed Dec 23, 2015 11:58

Fixerol wrote:By default in MT enable_shaders is true, that means that default performance could be boosted up to +50% if you disable shaders by default, this can increase fps more into comfort range (if you have fixed view range) or increase view range while keeping fps above 30(when default autorange finder is enabled).


The results of this highly depend on your setup. For me, I have almost no difference in performance with shaders enabled compared to shaders disabled.

You can't say that performance would be better for everyone if we disable shaders by default. Everyone has to test it for their specific setup.
 

User avatar
Fixer
Member
 
Posts: 895
Joined: Sun Jul 31, 2011 11:23
Location: Ukraine
IRC: Fixer
In-game: Fixer

Re: Poor performance when shaders are ENABLED

by Fixer » Wed Dec 23, 2015 20:13

Everyone has to test it for their specific setup.


That's why I'm asking everybody to test on their setups.
 

User avatar
kaadmy
Member
 
Posts: 706
Joined: Thu Aug 27, 2015 23:07
GitHub: kaadmy
IRC: KaadmY
In-game: KaadmY kaadmy NeD

Re: Poor performance when shaders are ENABLED

by kaadmy » Wed Dec 23, 2015 21:49

Shaders are way too slow for me, reduces performance by 5-10 FPS.
Also, shaders have a bug with fog, but it's probably my problem.

+ Screenshots
Attachments
screenshot_20151223_134728.png
(497.86 KiB) Not downloaded yet
screenshot_20151223_134720.png
(254.72 KiB) Not downloaded yet
screenshot_20151223_134657.png
(551.51 KiB) Not downloaded yet
Never paint white stripes on roads near Zebra crossings.

Pixture
 

User avatar
benrob0329
Member
 
Posts: 1319
Joined: Thu Aug 06, 2015 22:39
Location: Michigan
GitHub: Benrob0329
IRC: benrob0329
In-game: benrob03

Re: Poor performance when shaders are ENABLED

by benrob0329 » Thu Dec 24, 2015 01:25

Did you set wanted_fps and max_fps?

@Fixerol if its not set the FPS is really unstable and bounces all over the place, setting it gives me a constant FPS around what I set it to.
Social: YouTube Peertube Matrix Room: #minetest:matrix.org | Games: The Infinite IKEA
 

User avatar
kaadmy
Member
 
Posts: 706
Joined: Thu Aug 27, 2015 23:07
GitHub: kaadmy
IRC: KaadmY
In-game: KaadmY kaadmy NeD

Re: Poor performance when shaders are ENABLED

by kaadmy » Thu Dec 24, 2015 14:24

My config uses a fixed viewing range.
Never paint white stripes on roads near Zebra crossings.

Pixture
 


Return to Problems



Who is online

Users browsing this forum: No registered users and 1 guest