Japanese characters appear as blanks

Byakuren
Member
 
Posts: 816
Joined: Tue Apr 14, 2015 01:59
GitHub: raymoo
IRC: Hijiri
In-game: Raymoo + Clownpiece

Japanese characters appear as blanks

by Byakuren » Fri Jun 17, 2016 18:28

I am able to display some unicode text, but japanese text turns into blanks. I used this test code:
Code: Select all
minetest.register_on_joinplayer(function(player)
        minetest.chat_send_all("test")
        minetest.chat_send_all("lambda> λ") -- Non-japanese unicode
        minetest.chat_send_all("a> あ")
end)


I am running Debian Stretch.

This was the output:
debugoutputscreen.png
(29.64 KiB) Not downloaded yet


EDIT: works after changing font to one that supports the characters.
Every time a mod API is left undocumented, a koala dies.
 

User avatar
srifqi
Member
 
Posts: 557
Joined: Sat Jun 28, 2014 04:31
Location: Indonesia
GitHub: srifqi
IRC: srifqi
In-game: srifqi

Re: Japanese characters appear as blanks

by srifqi » Mon Jun 20, 2016 18:09

What version of Minetest do you have? I think this already fixed (#2891). Turkish character was getting same behavior (#2847).
Saya dari Indonesia! · Terjemahkan Minetest! · my mods · My nickname in IPA: /es.rif.qi/
 

Byakuren
Member
 
Posts: 816
Joined: Tue Apr 14, 2015 01:59
GitHub: raymoo
IRC: Hijiri
In-game: Raymoo + Clownpiece

Re: Japanese characters appear as blanks

by Byakuren » Mon Jun 20, 2016 21:28

srifqi wrote:What version of Minetest do you have? I think this already fixed (#2891). Turkish character was getting same behavior (#2847).


Yeah, I already edited the OP to say that it was just an issue that my font didn't have the characters.
Every time a mod API is left undocumented, a koala dies.
 


Return to Problems



Who is online

Users browsing this forum: No registered users and 4 guests