boat stuttering

Robsoie
Member
 
Posts: 98
Joined: Fri Apr 29, 2016 16:22

boat stuttering

by Robsoie » Tue Jan 24, 2017 03:22

Something i noticed since i play is that boats are problematic , when you're on them each 5/6 seconds there's some kind of "hickup", you seem to move forward then backward, basically a stutter.

At first i thought it was new chunks loading that may disturb some slow lua script, but after experimenting and navigating in chunks that have been loaded already, it is still happening.
What's odd is that even flying in fast speed in such already loaded region is fast and smooth without any kind of stutter, but those much slower boats are stuttering.
The recently added carts does not exhibit that problem too, and they can move way faster on the powered rails.

Is there any solution to those stuttering boat ? as it's always fun to use some boat instead of simply swimming or cheat flying over rivers, but in this state they're more annoying than relaxing.
 

User avatar
paramat
Developer
 
Posts: 3474
Joined: Sun Oct 28, 2012 00:05
Location: UK
GitHub: paramat
IRC: paramat

Re: boat stuttering

by paramat » Tue Jan 24, 2017 05:33

That's simply Lua lag caused by other intensive mods running (what mods are you using?). If you have any Lua mapgen mods running generate new world before using the boat. Carts experience this too but the player has to build track before using the cart, so new world is not being generated when you use a cart.
 

Robsoie
Member
 
Posts: 98
Joined: Fri Apr 29, 2016 16:22

Re: boat stuttering

by Robsoie » Tue Jan 24, 2017 13:44

That must be it, as i have a few mods that seems to work with mapgen too.
A pity then to not be able to use boats without that stutter as without additional mods to enhance it, the world is much less interesting.
 

User avatar
paramat
Developer
 
Posts: 3474
Joined: Sun Oct 28, 2012 00:05
Location: UK
GitHub: paramat
IRC: paramat

Re: boat stuttering

by paramat » Wed Jan 25, 2017 04:30

Boats should be fairly smooth in previously-generated world, if not, check for overly-intensive non-mapgen mods.
 

tinoesroho
Member
 
Posts: 570
Joined: Fri Feb 17, 2012 21:55
Location: Canada

Re: boat stuttering

by tinoesroho » Sat Jan 28, 2017 20:51

paramat wrote:That's simply Lua lag caused by other intensive mods running (what mods are you using?). If you have any Lua mapgen mods running generate new world before using the boat. Carts experience this too but the player has to build track before using the cart, so new world is not being generated when you use a cart.


Entity attachment is a terrible method. May I suggest using model replacement in the boat mod - one that changes player speed and prevents sinking? One way to dismount would be to use the sneak key, for example.
We are what we create.

I tinker and occasionally make (lousy) mods. Currently building an MMO subgame and updating mods. Pirate Party of Canada member. Sporadic author. 21 years old.

My github:
https://github.com/tinoesroho/
 

Robsoie
Member
 
Posts: 98
Joined: Fri Apr 29, 2016 16:22

Re: boat stuttering

by Robsoie » Tue Jan 31, 2017 02:16

That sounds like a great idea, as it would get rid of the attach tracking function that add more calculation to do and when there's already lots of calculation/chunk stuff being done result only in visual stuttering.

Though is it actually possible to transform the player model into another model like a boat with a character sitting in it (and also switch the physics from player character to boat-like to change how navigation is done) during gameplay with the Minetest code ?

If it would work, it would be great to improve the performance of any kind of other vehicles.
 


Return to Problems



Who is online

Users browsing this forum: No registered users and 2 guests