[Bug] strange line

Post Reply
User avatar
Fishkilleur
Member
Posts: 29
Joined: Wed Apr 20, 2011 11:57
Location: France

[Bug] strange line

by Fishkilleur » Post

Hello, I have a strange bug on Ubuntu 10.10 with the stable ppa :

Image

Image

I have a Nvidia graphic card.
This bug is only on this computer, not on my netbook with Ubuntu 10.10.
There is this bug with the official and non-official texture.

Thanks.
Last edited by Fishkilleur on Sat Apr 30, 2011 19:44, edited 1 time in total.

User avatar
James
New member
Posts: 3
Joined: Tue Apr 19, 2011 16:54

by James » Post

May be a driver problem, I've seen something similar in Minetest and other games.

On mine, the 4-5 blocks closest to the player in any direction render fine, but then some faces are missing from other blocks. I've not looked at the code, but perhaps it is to do with scaling the textures that are far from the camera.

User avatar
Evrim
Member
Posts: 42
Joined: Fri May 06, 2011 16:45

by Evrim » Post

Turn auto antialiasing off at your nVidia driver settings, this option causes bugs with opengl also on Minecraft

User avatar
Fishkilleur
Member
Posts: 29
Joined: Wed Apr 20, 2011 11:57
Location: France

by Fishkilleur » Post

Since my uprage to 11.04, I haven't this bug.

User avatar
Evrim
Member
Posts: 42
Joined: Fri May 06, 2011 16:45

by Evrim » Post

That's due to Natty's new openGL library usage or your drivers were updated to close anti-aliasing off

Glad you got it fixed

User avatar
adiblol
New member
Posts: 4
Joined: Sat May 07, 2011 18:14

by adiblol » Post

James wrote: On mine, the 4-5 blocks closest to the player in any direction render fine, but then some faces are missing from other blocks. I've not looked at the code, but perhaps it is to do with scaling the textures that are far from the camera.
The same on my Intel 82865/855GM graphics chip and Debian sid.

User avatar
adiblol
New member
Posts: 4
Joined: Sat May 07, 2011 18:14

by adiblol » Post

Friend told me that these problems are caused by Z buffer (AKA depth buffer). You should increase its resolution, I don't know how to do this from xorg.conf (if it is possible outside the game...).

Z buffer resolution can be chosen when requesting the GLX visual when initializing OpenGL - I don't know if Irrlicht interfaces the selection mechanism, if it does the issue probably could be fixed.

User avatar
adiblol
New member
Posts: 4
Joined: Sat May 07, 2011 18:14

by adiblol » Post

It is not Z buffer problem, but mipmaps problem.
Patch: http://pastebin.com/vFxYfAaK
Use only if you experience graphic glitches, it reduces video quality otherwise.
Last edited by adiblol on Thu Aug 04, 2011 14:47, edited 1 time in total.

User avatar
Calinou
Moderator
Posts: 3164
Joined: Mon Aug 01, 2011 14:26
GitHub: Calinou
IRC: Calinou
In-game: Calinou
Location: Troyes, France
Contact:

by Calinou » Post

Do not use antialiasing and/or anistropic filtering from your GPU's control panel.

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 3 guests