Page 1 of 1

what()= Access violation

PostPosted: Fri May 11, 2012 23:27
by gabrielomega
Well... First things first.
Hi. I'm new here, but I've played Minetest a lot.

Well... Here's the problem.

When I'm am Playing Minetest 0.4, the game stops and shows this message:
Code: Select all
Some exception, what()= Access violation


And, when I see the MS-DOS that helps to write the -debug.txt- there's another message:
Code: Select all
18:36:05: VERBOSE[main]: error_message = Some exception, what()= Access violation


Can somebody help me? I know that this is a great game, and I want to know the actual version (0.4)

thanks,
Gabriel R.

PostPosted: Sat May 12, 2012 06:35
by Calinou
Does it always happen, or only when you're doing something specific? What Windows version are you using?

PostPosted: Sat May 12, 2012 10:51
by Jordach
Must be using Direct3d.

PostPosted: Sat May 12, 2012 21:22
by gabrielomega
Calinou wrote:Does it always happen, or only when you're doing something specific? What Windows version are you using?


I am using Windows XP Professional Service Pack 2

PostPosted: Sat May 12, 2012 21:23
by gabrielomega
Jordach wrote:Must be using Direct3d.


Maybe. The renderer is Direct3d...

PostPosted: Sat May 12, 2012 21:40
by Jordach
That's why it does that.

PostPosted: Sat May 12, 2012 23:55
by gabrielomega
Jordach wrote:That's why it does that.


So... what should I do?

PostPosted: Sun May 13, 2012 08:30
by Jordach
in the minetest.conf there should be a line called

video_driver = direct3d9

change it so it says

video_driver = opengl

hope this helps.

PostPosted: Sun May 13, 2012 11:22
by gabrielomega
Jordach wrote:in the minetest.conf there should be a line called

video_driver = direct3d9

change it so it says

video_driver = opengl

hope this helps.


Erm... Thanks, the problem disappeared... but now are only white and black textures... I'll update the opengl.

Thanks

PostPosted: Sun May 13, 2012 12:36
by Jordach
Direct3D generally is the cause for that bug: get your self a nice GPU (ebuyer) and then play. Hope that helped.

PostPosted: Sun Aug 05, 2012 10:13
by marcweiler
help i cant find it it is a config file by me!
and i have the same when i build happens some exception, what()="Access violation"
guys i did the opengl thing but the wood planks look like water but in direct3d9 it looks all normal like it should

PostPosted: Wed Sep 19, 2012 13:08
by breinzter11
my friend got this problem
then i tell him to use open gl and it's work
he got no problem anymore