Can't activate mod (mac OS 10.11.6 / Minetest 0.4.16)

moustiquaire
New member
 
Posts: 3
Joined: Thu Nov 30, 2017 19:35

Can't activate mod (mac OS 10.11.6 / Minetest 0.4.16)

by moustiquaire » Thu Nov 30, 2017 19:44

Hi, I can't figure out how to activate mods.
Here's what I do :
1) from the welcome screen, I select a world then click on "configure"
2) a new screen appears, with mods on the right. I can either "activate" or "deactivate all", and "save".
3) no matter what I do, nothings seems to happen.

Precision 1 : I do not play myself but my kids have been asking for monsters, so that's why I'm trying to install mods
Precision 2 : I'm french so some quotations may differ from your actual screen

Thanks for any clue !
 

User avatar
Krock
Developer
 
Posts: 3920
Joined: Thu Oct 03, 2013 07:48
Location: Switzerland
GitHub: SmallJoker

Re: Can't activate mod (mac OS 10.11.6 / Minetest 0.4.16)

by Krock » Fri Dec 01, 2017 13:41

Pay attention to which mods are required by each you enable:
Image
The red circled mod, "biome_lib" as example here, must be enabled in order to make "moretrees" work, as it depends on that mod.
Mods like default, vessels are already bundled in minetest_game, as seen in the blue listed mods from the subgame in the bottom picture.

Of course, if you enable the optional depending mods too, you'll perhaps have a few more features.
Mod Search Engine - Mods by Krock - DuckDuckGo mod search bang: !mtmod <keyword here>
 

moustiquaire
New member
 
Posts: 3
Joined: Thu Nov 30, 2017 19:35

Re: Can't activate mod (mac OS 10.11.6 / Minetest 0.4.16)

by moustiquaire » Fri Dec 01, 2017 18:47

Mods like default, vessels are already bundled in minetest_game, as seen in the blue listed mods from the subgame in the bottom picture.


Well I'm not sure my Minetest behaves the right way :
1) I do not have any "enabled" tickbox
2) I have only blue subgame mods and nothing else

Capture d’écran 2017-12-01 à 19.46.22.png
(37.56 KiB) Not downloaded yet
 

moustiquaire
New member
 
Posts: 3
Joined: Thu Nov 30, 2017 19:35

Re: Can't activate mod (mac OS 10.11.6 / Minetest 0.4.16)

by moustiquaire » Fri Dec 01, 2017 19:20

Well, I don't really understand what's happening there, but lots of sheep, zombies have spawned and my kids seem just happy :-)
Though I still don't know which mods are activated and which aren't.
 

User avatar
Krock
Developer
 
Posts: 3920
Joined: Thu Oct 03, 2013 07:48
Location: Switzerland
GitHub: SmallJoker

Re: Can't activate mod (mac OS 10.11.6 / Minetest 0.4.16)

by Krock » Sat Dec 02, 2017 10:04

You installed the mods to the wrong directory. They belong into ~/.minetest/mods/ (or similar personal directory for the gobal installation) - NOT into */games/minetest_game/mods/, which is the place for subgames.
Sure, some mods may work this way, as long their dependencies are satisfied. However, you'll make your life hard by not moving them, as you
1) can't see the dependencies in the GUI
and 2) you can't disable the mods for a new world, they'll be activated everywhere.

How to install mods: http://dev.minetest.net/Installing_Mods
What's a subgame: http://dev.minetest.net/Subgames
Mod Search Engine - Mods by Krock - DuckDuckGo mod search bang: !mtmod <keyword here>
 


Return to Problems



Who is online

Users browsing this forum: No registered users and 3 guests