Protocol version mismatch?

Sailorman
Member
 
Posts: 11
Joined: Fri Dec 08, 2017 09:13
In-game: Sailorman

Protocol version mismatch?

by Sailorman » Fri Dec 08, 2017 09:18

I am having an error when trying to log into most minetest servers. The error reads: "Protocol version mismatch. Server supports protocol versions between 24 and 32. We only support protocol version 36."

Any help with this issue will be greatly appreciated :).
 

User avatar
sfan5
Moderator
 
Posts: 3725
Joined: Wed Aug 24, 2011 09:44
Location: Germany
GitHub: sfan5
IRC: sfan5

Re: Protocol version mismatch?

by sfan5 » Fri Dec 08, 2017 12:13

Download a stable 0.4.16 build, do not use 0.5.0-dev as a regular player.
Mods: Mesecons | WorldEdit | Nuke & Minetest builds for Windows (32-bit & 64-bit)
 

User avatar
rubenwardy
Moderator
 
Posts: 4962
Joined: Tue Jun 12, 2012 18:11
Location: United Kingdom
GitHub: rubenwardy
IRC: rubenwardy
In-game: rubenwardy

Re: Protocol version mismatch?

by rubenwardy » Fri Dec 08, 2017 15:28

sfan5 wrote:do not use 0.5.0-dev as a regular player.


To clarify: you can use 0.5.0-dev as a player if you're willing to accept a buggier game, however you won't find many servers to connect to. You also can't use any 0.5.0-dev worlds in 0.4.x, and we may break compatiblity between 0.5.0-dev commits without warning
 

Sailorman
Member
 
Posts: 11
Joined: Fri Dec 08, 2017 09:13
In-game: Sailorman

Re: Protocol version mismatch?

by Sailorman » Sat Dec 09, 2017 00:32

Ok. How will I install minetest 0.4.16? I am on ubuntu 16.04.1. I installed 0.5 using aptitude in the terminal.
 

User avatar
Krock
Developer
 
Posts: 3780
Joined: Thu Oct 03, 2013 07:48
Location: Switzerland
GitHub: SmallJoker

Re: Protocol version mismatch?

by Krock » Sat Dec 09, 2017 14:30

Sailorman wrote:Ok. How will I install minetest 0.4.16?

You can use the PPA to get the latest stable version: (installation instructions are there too)
https://launchpad.net/~minetestdevs/+ar ... ntu/stable
Or compile it yourself by checking out the git branch "stable-0.4" before running "make".

EDIT: I see you already found an outdated PPA.. viewtopic.php?f=6&t=18961
Mod Search Engine - Mods by Krock - DuckDuckGo mod search bang: !mtmod <keyword here>
 


Return to Bugs and Problems



Who is online

Users browsing this forum: No registered users and 4 guests