Weird Mouse Glitch

Aeonian
Member
 
Posts: 15
Joined: Sat Dec 02, 2017 17:53
In-game: Aeonian

Weird Mouse Glitch

by Aeonian » Sat Dec 09, 2017 17:23

I noticed that on windows, your mouse sort of drifts after you stop moving your mouse. This is really annoying for building and just moving around in general.

Is there a way to fix this?
 

User avatar
Krock
Developer
 
Posts: 4141
Joined: Thu Oct 03, 2013 07:48
Location: Switzerland
GitHub: SmallJoker

Re: Weird Mouse Glitch

by Krock » Sat Dec 09, 2017 19:07

This issue was already reported here, here and here.
Fixed in https://github.com/minetest/minetest/pull/4701 (November, 5 months after 0.4.16 stable release)

Either wait for 0.4.17 or get a 0.5.0-dev build from the Builds subforum. Note that you can't play with the latter on most of the servers.

Also, please DON'T post your issue everywhere, wait for an answer. If it's urgent, feel free to join #minetest on the Freenode IRC server and ask for help there.
Mod Search Engine - Mods by Krock - DuckDuckGo mod search bang: !mtmod <keyword here>
 

Aeonian
Member
 
Posts: 15
Joined: Sat Dec 02, 2017 17:53
In-game: Aeonian

Re: Weird Mouse Glitch

by Aeonian » Sat Dec 09, 2017 19:19

Well, I just realized that this one existed. So, yes, I re-posted here because it was more active and I didn't want to wait an entire day for a single response. I only reposted once and did not repost "everywhere". By the way thanks for not responding on my other thread, that just proves my point further. Also the last here just refers back to this thread, so really you have only two instances in completely different places.

I could not find anything online, and I'm really not sure how you did. I also did not know there was a freenode IRC or that the github was active whatsoever.

I'm also extremely new to this forum, and I don't know where everything is; therefore, I thank you for informing me on these resources and alternative forums.
 

User avatar
Otter
Member
 
Posts: 143
Joined: Fri May 12, 2017 21:17

Re: Weird Mouse Glitch

by Otter » Mon Jun 04, 2018 02:47

I am now getting the mouse drift error. It was not there yesterday and I have swapped mice to test. This is while using Minetest 0.5.0-22ebbe1 and 0.417-3d0617c. Both windows 64 bit builds. I am using a E-3LUE Cobra mouse. The drift does not occur before starting a game, in other software or when I am in inventory or chat mode. It happens online or playing locally.
 

User avatar
Otter
Member
 
Posts: 143
Joined: Fri May 12, 2017 21:17

Re: Weird Mouse Glitch

by Otter » Mon Jun 04, 2018 05:53

Fixed it by opening the settings for my shortcut and going to the compatibility tab. Selecting Override high DPI scaling behavior and setting the scaling to be performed by the application fixed the problem.

Image
Attachments
Clipboard01.jpg
(51.49 KiB) Not downloaded yet
 


Return to Problems



Who is online

Users browsing this forum: No registered users and 1 guest