No text rendered in main menu (bad locale settings)

aemstuz
New member
 
Posts: 1
Joined: Fri Feb 16, 2018 19:21

No text rendered in main menu (bad locale settings)

by aemstuz » Fri Feb 16, 2018 20:27

Hello everyone,

I have installed Minetest 0.4.16 from Kubuntu 17.10 repo (no mods, just this package with required dependencies: https://packages.ubuntu.com/artful/minetest). Each time I launch the game main menu looks like this:

Image

I have tried to run minetest in terminal but the output seems not to indicate any error related to fonts/text rendering:

Code: Select all
Cannot connect to server socket err = Nie ma takiego pliku ani katalogu
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for 4294967295, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for 4294967295, skipping unlock
Loaded texture: /usr/share/games/minetest/games/minetest_game/menu/header.png
Loaded texture: /usr/share/games/minetest/games/minetest_game/menu/icon.png
Loaded texture: /usr/share/games/minetest/games/minimal/menu/icon.png



I have also tried to set
Code: Select all
debug_log_level = verbose
in ~/.minetest/minetest.conf and check debug.txt, however it also does not say much:

Code: Select all

-------------
  Separator
-------------

2018-02-16 20:38:31: VERBOSE[Main]: httpfetch_init: parallel_limit=8
2018-02-16 20:38:31: INFO[Main]: Message locale is now set to: LC_CTYPE=pl_PL.UTF-8;LC_NUMERIC=C;LC_TIME=pl_PL.UTF-8;LC_COLLATE=pl_PL.UTF-8;LC_MONETARY=pl_PL.UTF-8;LC_MESSAGES=pl_PL.UTF-8;LC_PAPER=pl_PL.UTF-8;LC_NAME=pl_PL.UTF-8;LC_ADDRESS=pl_PL.UTF-8;LC_TELEPHONE=pl_PL.UTF-8;LC_MEASUREM
2018-02-16 20:38:31: INFO[Main]: NT=pl_PL.UTF-8;LC_IDENTIFICATION=pl_PL.UTF-8
2018-02-16 20:38:31: VERBOSE[Main]: Determining world path
2018-02-16 20:38:31: INFO[Main]: Searching worlds...
2018-02-16 20:38:31: INFO[Main]:   In /home/mateusz/.minetest/worlds:
2018-02-16 20:38:31: INFO[Main]: 0 found.
2018-02-16 20:38:31: INFO[Main]: Creating default world at [/home/mateusz/.minetest/worlds/world]
2018-02-16 20:38:31: VERBOSE[Main]: Determining gameid/gamespec
2018-02-16 20:38:31: INFO[Main]: Using default gameid [minetest]
2018-02-16 20:38:31: INFO[Main]: Using commanded world path [/home/mateusz/.minetest/worlds/world]
2018-02-16 20:38:31: INFO[Main]: Irrlicht: Irrlicht Engine version 1.8.4
2018-02-16 20:38:31: INFO[Main]: Irrlicht: Linux 4.13.0-32-generic #35-Ubuntu SMP Thu Jan 25 09:13:46 UTC 2018 x86_64
2018-02-16 20:38:31: INFO[Main]: Irrlicht: Using renderer: OpenGL 4.6.0
2018-02-16 20:38:31: INFO[Main]: Irrlicht: GeForce 940MX/PCIe/SSE2: NVIDIA Corporation
2018-02-16 20:38:31: INFO[Main]: Irrlicht: OpenGL driver version is 1.2 or better.
2018-02-16 20:38:31: INFO[Main]: Irrlicht: GLSL version: 4.6
2018-02-16 20:38:31: INFO[Main]: text_height=10
2018-02-16 20:38:31: INFO[Main]: Waiting for other menus
2018-02-16 20:38:31: INFO[Main]: Waited for other menus
2018-02-16 20:38:31: INFO[Main]: Audio: Initializing...
2018-02-16 20:38:31: INFO[Main]: Audio: Initialized: OpenAL 1.1 ALSOFT 1.17.2, using OpenAL Soft
2018-02-16 20:38:31: INFO[Main]: GUIEngine: Initializing Lua
2018-02-16 20:38:31: VERBOSE[AsyncWorker-0]: Loading and running script from /usr/share/games/minetest/builtin/init.lua
2018-02-16 20:38:31: INFO[AsyncWorker-0]: Initializing Asynchronous environment
2018-02-16 20:38:31: VERBOSE[AsyncWorker-1]: Loading and running script from /usr/share/games/minetest/builtin/init.lua
2018-02-16 20:38:31: INFO[AsyncWorker-1]: Initializing Asynchronous environment
2018-02-16 20:38:31: VERBOSE[AsyncWorker-2]: Loading and running script from /usr/share/games/minetest/builtin/init.lua
2018-02-16 20:38:31: INFO[AsyncWorker-2]: Initializing Asynchronous environment
2018-02-16 20:38:31: VERBOSE[AsyncWorker-3]: Loading and running script from /usr/share/games/minetest/builtin/init.lua
2018-02-16 20:38:31: INFO[AsyncWorker-3]: Initializing Asynchronous environment
2018-02-16 20:38:31: INFO[Main]: SCRIPTAPI: Initialized main menu modules
2018-02-16 20:38:31: VERBOSE[Main]: Loading and running script from /usr/share/games/minetest/builtin/init.lua
2018-02-16 20:38:31: INFO[Main]: Searching worlds...
2018-02-16 20:38:31: INFO[Main]:   In /home/mateusz/.minetest/worlds:
2018-02-16 20:38:31: INFO[Main]: 0 found.
2018-02-16 20:38:31: VERBOSE[Main]: OpenALSoundManager::maintain(): 0 playing sounds, 0 sound names loaded
2018-02-16 20:38:31: INFO[Main]: Audio: Error opening /home/mateusz/.minetest/sounds/main_menu.0.ogg for decoding
2018-02-16 20:38:31: INFO[Main]: Audio: Error opening /home/mateusz/.minetest/sounds/main_menu.1.ogg for decoding
2018-02-16 20:38:31: INFO[Main]: Audio: Error opening /home/mateusz/.minetest/sounds/main_menu.2.ogg for decoding
2018-02-16 20:38:31: INFO[Main]: Audio: Error opening /home/mateusz/.minetest/sounds/main_menu.3.ogg for decoding
2018-02-16 20:38:31: INFO[Main]: Audio: Error opening /home/mateusz/.minetest/sounds/main_menu.4.ogg for decoding
2018-02-16 20:38:31: INFO[Main]: Audio: Error opening /home/mateusz/.minetest/sounds/main_menu.5.ogg for decoding
2018-02-16 20:38:31: INFO[Main]: Audio: Error opening /home/mateusz/.minetest/sounds/main_menu.6.ogg for decoding
2018-02-16 20:38:31: INFO[Main]: Audio: Error opening /home/mateusz/.minetest/sounds/main_menu.7.ogg for decoding
2018-02-16 20:38:31: INFO[Main]: Audio: Error opening /home/mateusz/.minetest/sounds/main_menu.8.ogg for decoding
2018-02-16 20:38:31: INFO[Main]: Audio: Error opening /home/mateusz/.minetest/sounds/main_menu.9.ogg for decoding
2018-02-16 20:38:31: INFO[Main]: Audio: Error opening /home/mateusz/.minetest/sounds/main_menu.ogg for decoding
2018-02-16 20:38:31: INFO[Main]: Audio: Error opening /usr/share/games/minetest/sounds/main_menu.0.ogg for decoding
2018-02-16 20:38:31: INFO[Main]: Audio: Error opening /usr/share/games/minetest/sounds/main_menu.1.ogg for decoding
2018-02-16 20:38:31: INFO[Main]: Audio: Error opening /usr/share/games/minetest/sounds/main_menu.2.ogg for decoding
2018-02-16 20:38:31: INFO[Main]: Audio: Error opening /usr/share/games/minetest/sounds/main_menu.3.ogg for decoding
2018-02-16 20:38:31: INFO[Main]: Audio: Error opening /usr/share/games/minetest/sounds/main_menu.4.ogg for decoding
2018-02-16 20:38:31: INFO[Main]: Audio: Error opening /usr/share/games/minetest/sounds/main_menu.5.ogg for decoding
2018-02-16 20:38:31: INFO[Main]: Audio: Error opening /usr/share/games/minetest/sounds/main_menu.6.ogg for decoding
2018-02-16 20:38:31: INFO[Main]: Audio: Error opening /usr/share/games/minetest/sounds/main_menu.7.ogg for decoding
2018-02-16 20:38:31: INFO[Main]: Audio: Error opening /usr/share/games/minetest/sounds/main_menu.8.ogg for decoding
2018-02-16 20:38:31: INFO[Main]: Audio: Error opening /usr/share/games/minetest/sounds/main_menu.9.ogg for decoding
2018-02-16 20:38:31: INFO[Main]: Audio: Error opening /usr/share/games/minetest/sounds/main_menu.ogg for decoding
2018-02-16 20:38:31: INFO[Main]: OpenALSoundManager: "main_menu" not found.


Minetest version:

Code: Select all
$ minetest --version
Minetest 0.4.16 (Linux)
Using Irrlicht 1.8.4
Build info: VER=0.4.16 BUILD_TYPE=None RUN_IN_PLACE=0 USE_GETTEXT=1 USE_SOUND=1 USE_CURL=1 USE_FREETYPE=1 USE_LUAJIT=1 STATIC_SHAREDIR="/usr/share/games/minetest"


OpenGL:

Code: Select all
$ glxinfo |grep "OpenGL version"
OpenGL version string: 4.6.0 NVIDIA 387.34


GPU:

Code: Select all
$ lspci -nn | grep '\[03'
00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:591b] (rev 04)
02:00.0 3D controller [0302]: NVIDIA Corporation GM108M [GeForce 940MX] [10de:134d] (rev a2)


I have also tried it on Intel GPUs but it does not helped.

Please, post solution or just ideas where to find what is happening (maybe I should check some other logs?).

EDIT:

I have found workaround. Running minetest from terminal with temporarily changed locale settings makes GUI text appears:

Code: Select all
$ export LANG=en_US.UTF-8
$ minetest


although I believe that it should work on every locale. Is there a way to set locale in minetest.conf?
 

Kris
New member
 
Posts: 2
Joined: Tue Feb 20, 2018 15:16

Re: No text rendered in main menu (bad locale settings)

by Kris » Tue Feb 20, 2018 16:02

The problem is not the language setting, but the FontDroidFallbakcFull font is missing in Ubuntu 17.10 and derivatives.

The easiest way is to add at the end of the minetest.conf file in the user's directory.

language = pl
fallback_font_path = /usr/share/games/minetest/fonts/Cousine-Regular.ttf
screenH = 1029
screenW = 1920
main_menu_technical_settings = true
font_size = 14
mono_font_size = 14
fallback_font_size = 14

I chose this font because it is in the main game directory, but it may be different.

Settings can be changed after starting the game in Settings -> Advanced Settings, in the search field enter lang and correct entries
 


Return to Problems



Who is online

Users browsing this forum: No registered users and 1 guest