Multiple errors

User avatar
Phoenixflo44
Member
 
Posts: 576
Joined: Fri Jul 28, 2017 15:01
Location: Behind my PC, in Germany
In-game: Phoenixflo44

Multiple errors

by Phoenixflo44 » Wed Aug 01, 2018 19:00

The first error is when I go to the Texture Pack tab in the main menu.
Code: Select all
2018-08-01 19:26:39: WARNING[Main]: info.txt is deprecated. description.txt should be used instead.
2018-08-01 19:26:39: ERROR[Main]: Main menu error: Runtime error from mod '' in callback handleMainMenuButtons(): Runtime error from mod '??' in callback ??(): info.txt is deprecated. description.txt should be used instead.
2018-08-01 19:26:39: ERROR[Main]: stack traceback:
2018-08-01 19:26:39: ERROR[Main]:    [C]: in function 'log'
2018-08-01 19:26:39: ERROR[Main]:    ...are/games/minetest/builtin/mainmenu/tab_texturepacks.lua:76: in function 'get_formspec'
2018-08-01 19:26:39: ERROR[Main]:    /usr/share/games/minetest/builtin/fstk/tabview.lua:74: in function 'get_formspec'
2018-08-01 19:26:39: ERROR[Main]:    /usr/share/games/minetest/builtin/fstk/ui.lua:107: in function 'update'
2018-08-01 19:26:39: ERROR[Main]:    /usr/share/games/minetest/builtin/fstk/ui.lua:151: in function 'handle_buttons'
2018-08-01 19:26:39: ERROR[Main]:    /usr/share/games/minetest/builtin/fstk/ui.lua:192: in function </usr/share/games/minetest/builtin/fstk/ui.lua:178>


The second mistake is if I want to go to my city. This problem also comes with other worlds.
Code: Select all
2018-08-01 19:30:14: WARNING[Main]: NodeDefManager: Ignoring CONTENT_IGNORE redefinition
2018-08-01 19:30:14: WARNING[Main]: Field "maxwear" is deprecated; replace with uses=1/maxwear
2018-08-01 19:30:14: WARNING[Main]: Field "maxwear" is deprecated; replace with uses=1/maxwear
2018-08-01 19:30:14: WARNING[Main]: Field "maxwear" is deprecated; replace with uses=1/maxwear
2018-08-01 19:30:14: WARNING[Main]: WARNING: minetest.setting_* functions are deprecated.  Use methods on the minetest.settings object.
2018-08-01 19:30:14: ERROR[Main]: ModError: Failed to load and run script from /home/spike/.minetest/mods/worldedit/init.lua:
2018-08-01 19:30:14: ERROR[Main]: Runtime error from mod '??' in callback ??(): WARNING: minetest.setting_* functions are deprecated.  Use methods on the minetest.settings object.
2018-08-01 19:30:14: ERROR[Main]: stack traceback:
2018-08-01 19:30:14: ERROR[Main]:    [C]: in function 'log'
2018-08-01 19:30:14: ERROR[Main]:    /usr/share/games/minetest/builtin/game/deprecated.lua:61: in function 'setting_getbool'
2018-08-01 19:30:14: ERROR[Main]:    /home/spike/.minetest/mods/worldedit/init.lua:43: in main chunk
2018-08-01 19:30:14: ERROR[Main]: Siehe debug.txt für Details.


And the third problem is @Solars when he tries to go to my city.
Code: Select all
ERROR[Main]: The following mods could not be found: "quartz" "wool" "xfences" "xtraores" "xtraores_armor"
ERROR[Main]: mod "farming_food" has unsatisfied dependencies:  "hud"
ERROR[Main]: mod "bushes_classic" has unsatisfied dependencies:  "biome_lib" "plantlife_i18n"
ERROR[Main]: mod "doc_items" has unsatisfied dependencies:  "doc"
ERROR[Main]: mod "drawers" has unsatisfied dependencies:  "mcl_core"
ERROR[Main]: mod "hud" has unsatisfied dependencies:  "bushes_classic"
ERROR[Main]: mod "mcl_core" has unsatisfied dependencies:  "doc_items"
ERROR[Main]: mod "mcl_end" has unsatisfied dependencies:  "doc_items" "mcl_throwing"
ERROR[Main]: mod "mcl_walls" has unsatisfied dependencies:  "mcl_core"
ERROR[Main]: mod "mobs_mc" has unsatisfied dependencies:  "doc_items"
ERROR[Main]: mod "molehills" has unsatisfied dependencies:  "biome_lib" "plantlife_i18n"
...
ERROR[Main]: ModError: Failed to load and run script from minetest/bin/../worlds/Mountain City/worldmods/scifi_nodes/init.lua:
ERROR[Main]: ...e/minetest/minetest/bin/../builtin/game/register.lua:130: attempt to compare number with string
ERROR[Main]: stack traceback:
ERROR[Main]:    ...e/minetest/minetest/bin/../builtin/game/register.lua:130: in function 'register_item'
ERROR[Main]:    ...e/minetest/minetest/bin/../builtin/game/register.lua:206: in function 'really_register_node'
ERROR[Main]:    .../Mountain City/worldmods/technic_worldgen/crafts.lua:167: in function 'register_node'
ERROR[Main]:    .../worlds/Mountain City/worldmods/scifi_nodes/init.lua:352: in main chunk
ERROR[Main]: Siehe debug.txt für Details.

Code: Select all
WARNING[Main]: Undeclared global variable "hw_utils" accessed at ...orlds/Mountain City/worldmods/weather_pack/utils.lua:9
WARNING[Main]: [mpd] Misformatted song entry in songs.txt: #Name         Time   Gain
WARNING[Main]: Undeclared global variable "mg_name" accessed at .../../worlds/Mountain City/worldmods/mcl_init/init.lua:13
[Main]: [inventory_plus]: Wait a minute. This isn't the real inventory_plus ...
WARNING[Main]: Assignment to undeclared global "lines" inside a function at ...bin/../worlds/Mountain City/worldmods/skins/init.lua:53.
WARNING[Main]: Field "tile_images": Deprecated; new name is "tiles".
WARNING[Main]: Node 'light_source' value exceeds maximum, limiting to maximum: default:glowstone
WARNING[Main]: Undeclared global variable "wheat_seed_drop" accessed at ...orlds/Mountain City/worldmods/default/craftitems.lua:308
WARNING[Main]: Not registering alias, item with same name is already defined: default:mese -> default:mese_block
You can't see it here. I'm doing everything wrong anyway.
 

User avatar
Krock
Developer
 
Posts: 4114
Joined: Thu Oct 03, 2013 07:48
Location: Switzerland
GitHub: SmallJoker

Re: Multiple errors

by Krock » Wed Aug 01, 2018 19:46

First two issues: open your minetest.conf file and change this setting to the following line: (was set to "error" in your configuration)
Code: Select all
deprecated_lua_api_handling = log


The third one indicates missing mods. Ensure that you and solars are using the very same, unmodified (clean) game to run the world. MineClone 2 seems to be involved there. The error about the scifi_nodes mod belong into its forum topic so that the author can fix it.

The last (fourth) one is not an error.
Mod Search Engine - Mods by Krock - DuckDuckGo mod search bang: !mtmod <keyword here>
 

User avatar
Phoenixflo44
Member
 
Posts: 576
Joined: Fri Jul 28, 2017 15:01
Location: Behind my PC, in Germany
In-game: Phoenixflo44

Re: Multiple errors

by Phoenixflo44 » Wed Aug 01, 2018 20:13

The mods which are supposedly missing but are then available. And this is the normal minetest game, but I have copied a few MCL mods so my default is running again. and the SciFi mod: When I join my city, he doesn't make any mistakes with me. Only for Solars.
You can't see it here. I'm doing everything wrong anyway.
 

User avatar
Festus1965
Member
 
Posts: 309
Joined: Sun Jan 03, 2016 11:58
Location: Thailand - Chiang Mai (+5-6h to MEZ)
In-game: Thomas Explorer

Re: Multiple errors

by Festus1965 » Wed Aug 01, 2018 22:37

never ever activate more then one mod at one time, and check it for a view days first ... before activate the next one ...

so maybe take all of them out again (false), check if server runs, and then one by one get them back in ...

so much easier to find out which one does it ...
 

User avatar
Phoenixflo44
Member
 
Posts: 576
Joined: Fri Jul 28, 2017 15:01
Location: Behind my PC, in Germany
In-game: Phoenixflo44

Re: Multiple errors

by Phoenixflo44 » Sun Aug 12, 2018 17:33

The good solars has a new problem. I'm not getting along with this stuff.

Code: Select all
ERROR[Main]: ModError: Failed to load and run script from minetest/alt/minetest/bin/../mods/worldedit/init.lua:
ERROR[Main]: invalid key to 'next'
ERROR[Main]: stack traceback:
ERROR[Main]:    [C]: in function 'register_item_raw'
ERROR[Main]:    ...netest/alt/minetest/bin/../builtin/game/register.lua:180: in function 'register_item'
ERROR[Main]:    ...netest/alt/minetest/bin/../builtin/game/register.lua:257: in function 'register_tool'
ERROR[Main]:    ...minetest/alt/minetest/bin/../mods/worldedit/wand.lua:1: in main chunk
ERROR[Main]:    [C]: in function 'dofile'
ERROR[Main]:    ...minetest/alt/minetest/bin/../mods/worldedit/init.lua:29: in function 'load_module'
ERROR[Main]:    ...minetest/alt/minetest/bin/../mods/worldedit/init.lua:39: in main chunk
ERROR[Main]: Siehe debug.txt für Details.
You can't see it here. I'm doing everything wrong anyway.
 

User avatar
Andrey01
Member
 
Posts: 2154
Joined: Wed Oct 19, 2016 15:18
Location: Russia, Moscow
GitHub: Andrey2470T
In-game: Andrey01

Re: Multiple errors

by Andrey01 » Fri Aug 24, 2018 16:51

Phoenixflo44 wrote:The good solars has a new problem. I'm not getting along with this stuff.

Code: Select all
ERROR[Main]: ModError: Failed to load and run script from minetest/alt/minetest/bin/../mods/worldedit/init.lua:
ERROR[Main]: invalid key to 'next'
ERROR[Main]: stack traceback:
ERROR[Main]:    [C]: in function 'register_item_raw'
ERROR[Main]:    ...netest/alt/minetest/bin/../builtin/game/register.lua:180: in function 'register_item'
ERROR[Main]:    ...netest/alt/minetest/bin/../builtin/game/register.lua:257: in function 'register_tool'
ERROR[Main]:    ...minetest/alt/minetest/bin/../mods/worldedit/wand.lua:1: in main chunk
ERROR[Main]:    [C]: in function 'dofile'
ERROR[Main]:    ...minetest/alt/minetest/bin/../mods/worldedit/init.lua:29: in function 'load_module'
ERROR[Main]:    ...minetest/alt/minetest/bin/../mods/worldedit/init.lua:39: in main chunk
ERROR[Main]: Siehe debug.txt für Details.

It means the value that was passed in pairs() is invalid. That is it may be nil, string, numbers instead necessary table. Can you show init.lua file to see what does it do wrong?
DL9Eh7xVBw7DXwLAMX1lStE21bSD2XUQ
 

User avatar
Phoenixflo44
Member
 
Posts: 576
Joined: Fri Jul 28, 2017 15:01
Location: Behind my PC, in Germany
In-game: Phoenixflo44

Re: Multiple errors

by Phoenixflo44 » Mon Aug 27, 2018 15:50

Andrey01 wrote:
Phoenixflo44 wrote:The good solars has a new problem. I'm not getting along with this stuff.

Code: Select all
ERROR[Main]: ModError: Failed to load and run script from minetest/alt/minetest/bin/../mods/worldedit/init.lua:
ERROR[Main]: invalid key to 'next'
ERROR[Main]: stack traceback:
ERROR[Main]:    [C]: in function 'register_item_raw'
ERROR[Main]:    ...netest/alt/minetest/bin/../builtin/game/register.lua:180: in function 'register_item'
ERROR[Main]:    ...netest/alt/minetest/bin/../builtin/game/register.lua:257: in function 'register_tool'
ERROR[Main]:    ...minetest/alt/minetest/bin/../mods/worldedit/wand.lua:1: in main chunk
ERROR[Main]:    [C]: in function 'dofile'
ERROR[Main]:    ...minetest/alt/minetest/bin/../mods/worldedit/init.lua:29: in function 'load_module'
ERROR[Main]:    ...minetest/alt/minetest/bin/../mods/worldedit/init.lua:39: in main chunk
ERROR[Main]: Siehe debug.txt für Details.

It means the value that was passed in pairs() is invalid. That is it may be nil, string, numbers instead necessary table. Can you show init.lua file to see what does it do wrong?


Worldedit:
Code: Select all
local function load_module(path)
   local file = io.open(path, "r")
   if not file then return end
   file:close()
   return dofile(path)
end


Worldedit wand:
Code: Select all
minetest.register_tool("worldedit:wand", {
   description = "WorldEdit wand tool. Left-click to set the 1st position, Right-click to set the 2nd position.",
   groups = {},
   inventory_image = "worldedit_wand.png",
   wield_image = "",
   wield_scale = {x=1,y=1,z=1},
   stack_max = 1, -- there is no need to have more than one
   liquids_pointable = true, -- ground with only water on can be selected as well
   -- the tool_capabilities are completely irrelevant here - no need to dig
   tool_capabilities = {
      full_punch_interval = 1.0,
      max_drop_level=0,
      groupcaps={
         fleshy={times={[2]=0.80, [3]=0.40}, maxwear=0.05, maxlevel=1},
         snappy={times={[2]=0.80, [3]=0.40}, maxwear=0.05, maxlevel=1},
         choppy={times={[3]=0.90}, maxwear=0.05, maxlevel=0}
      }
   },
   node_placement_prediction = nil,
You can't see it here. I'm doing everything wrong anyway.
 

User avatar
Andrey01
Member
 
Posts: 2154
Joined: Wed Oct 19, 2016 15:18
Location: Russia, Moscow
GitHub: Andrey2470T
In-game: Andrey01

Re: Multiple errors

by Andrey01 » Mon Aug 27, 2018 18:20

Show the init.lua entirely. You showed only 6 lines, but it says an error on 29 line. Or if you took a snippet of the code near where the error happened then point at corresponding line.
DL9Eh7xVBw7DXwLAMX1lStE21bSD2XUQ
 

User avatar
Phoenixflo44
Member
 
Posts: 576
Joined: Fri Jul 28, 2017 15:01
Location: Behind my PC, in Germany
In-game: Phoenixflo44

Re: Multiple errors

by Phoenixflo44 » Mon Aug 27, 2018 18:29

Code: Select all
--- Worldedit.
-- @module worldedit
-- @release 1.1
-- @copyright 2013 sfan5, Anthony Zhang (Uberi/Temperest), and Brett O'Donnell (cornernote).
-- @license GNU Affero General Public License version 3 (AGPLv3)
-- @author sfan5
-- @author Anthony Zang (Uberi/Temperest)
-- @author Bret O'Donnel (cornernote)
-- @author ShadowNinja

worldedit = {}
worldedit.version = {1, 1, major=1, minor=1}
worldedit.version_string = table.concat(worldedit.version, ".")

if not minetest.get_voxel_manip then
   local err_msg = "This version of WorldEdit requires Minetest 0.4.8 or later!  You have an old version."
   minetest.log("error", string.rep("#", 128))
   minetest.log("error", err_msg)
   minetest.log("error", string.rep("#", 128))
   error(err_msg)
end

local path = minetest.get_modpath(minetest.get_current_modname())

local function load_module(path)
   local file = io.open(path, "r")
   if not file then return end
   file:close()
   return dofile(path)
end

dofile(path .. "/common.lua")
load_module(path .. "/manipulations.lua")
load_module(path .. "/primitives.lua")
load_module(path .. "/visualization.lua")
load_module(path .. "/serialization.lua")
load_module(path .. "/code.lua")
load_module(path .. "/compatibility.lua")
load_module(path .. "/wand.lua")
load_module(path .. "/cuboid.lua")


if minetest.setting_getbool("log_mods") then
   print("[WorldEdit] Loaded!")
end


Code: Select all
minetest.register_tool("worldedit:wand", {
   description = "WorldEdit wand tool. Left-click to set the 1st position, Right-click to set the 2nd position.",
   groups = {},
   inventory_image = "worldedit_wand.png",
   wield_image = "",
   wield_scale = {x=1,y=1,z=1},
   stack_max = 1, -- there is no need to have more than one
   liquids_pointable = true, -- ground with only water on can be selected as well
   -- the tool_capabilities are completely irrelevant here - no need to dig
   tool_capabilities = {
      full_punch_interval = 1.0,
      max_drop_level=0,
      groupcaps={
         fleshy={times={[2]=0.80, [3]=0.40}, maxwear=0.05, maxlevel=1},
         snappy={times={[2]=0.80, [3]=0.40}, maxwear=0.05, maxlevel=1},
         choppy={times={[3]=0.90}, maxwear=0.05, maxlevel=0}
      }
   },
   node_placement_prediction = nil,

   on_use = function(itemstack, placer, pointed_thing)
      if placer ~= nil and pointed_thing ~= nil then
        local name = placer:get_player_name()
        local pos  = minetest.get_pointed_thing_position( pointed_thing, false ) -- not above

        if not pos then
          return itemstack
        end

        worldedit.pos1[name] = pos
        worldedit.mark_pos1(name)

      end
      return itemstack -- nothing consumed, nothing changed
   end,

   on_place = function(itemstack, placer, pointed_thing) -- Left Click
      if placer ~= nil and pointed_thing ~= nil then
        local name = placer:get_player_name()
        local pos  = minetest.get_pointed_thing_position( pointed_thing, false ) -- not above

        if not pos then
          return itemstack
        end

        worldedit.pos2[name] = pos
        worldedit.mark_pos2(name)
      end
      return itemstack -- nothing consumed, nothing changed
   end,
})
You can't see it here. I'm doing everything wrong anyway.
 


Return to Problems



Who is online

Users browsing this forum: No registered users and 2 guests